/[packages]/cauldron/invokebinder/current/SPECS/invokebinder.spec
ViewVC logotype

Contents of /cauldron/invokebinder/current/SPECS/invokebinder.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 560832 - (show annotations) (download)
Thu Dec 26 17:01:28 2013 UTC (10 years, 3 months ago) by dmorgan
File size: 2060 byte(s)
imported package invokebinder
1 Name: invokebinder
2 Version: 1.1
3 Release: %mkrel 4
4 Summary: A Java DSL for binding method handles forward, rather than backward
5 Group: Development/Java
6 License: ASL 2.0
7 URL: http://github.com/headius/%{name}/
8 Source0: https://github.com/headius/%{name}/archive/%{name}-%{version}.tar.gz
9 BuildArch: noarch
10
11 BuildRequires: java-devel
12 BuildRequires: jpackage-utils
13
14 BuildRequires: maven-local
15 BuildRequires: maven-compiler-plugin
16 BuildRequires: maven-install-plugin
17 BuildRequires: maven-jar-plugin
18 BuildRequires: maven-javadoc-plugin
19 BuildRequires: maven-surefire-plugin
20 BuildRequires: maven-surefire-provider-junit4
21
22 Requires: java
23 Requires: jpackage-utils
24
25 %description
26 This library hopes to provide a more friendly DSL for binding method handles.
27 Unlike the normal MethodHandle API, handles are bound forward from a source
28 MethodType and eventually adapted to a final target MethodHandle. Along the
29 way the transformations are pushed onto a stack and eventually applied in
30 reverse order, as the standard API demands.
31
32 %package javadoc
33 Summary: Javadocs for %{name}
34 Group: Documentation
35 Requires: jpackage-utils
36
37 %description javadoc
38 This package contains the API documentation for %{name}.
39
40 %prep
41 %setup -q -n %{name}-%{name}-%{version}
42 find ./ -name '*.jar' -exec rm -f '{}' \;
43 find ./ -name '*.class' -exec rm -f '{}' \;
44
45 %build
46 mvn-rpmbuild install javadoc:aggregate
47
48 %install
49 mkdir -p $RPM_BUILD_ROOT%{_javadir}
50 cp -p target/%{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
51
52 mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}
53 cp -rp target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
54
55 install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
56 install -pm 644 pom.xml \
57 $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{name}.pom
58
59 %add_maven_depmap JPP-%{name}.pom %{name}.jar
60
61 %files
62 %doc LICENSE
63 %{_mavenpomdir}/JPP-%{name}.pom
64 %{_mavendepmapfragdir}/%{name}
65 %{_javadir}/%{name}.jar
66
67 %files javadoc
68 %doc LICENSE
69 %{_javadocdir}/%{name}
70

  ViewVC Help
Powered by ViewVC 1.1.30