/[packages]/cauldron/libapreq2/current/SPECS/libapreq2.spec
ViewVC logotype

Contents of /cauldron/libapreq2/current/SPECS/libapreq2.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 251949 - (show annotations) (download)
Thu May 31 00:57:18 2012 UTC (11 years, 10 months ago) by fwang
File size: 6379 byte(s)
rebuild for new perl
1 #Module-Specific definitions
2 %define rversion 2.13
3 %define revision r376644
4
5 %define mod_name mod_apreq
6 %define mod_conf 76_%{mod_name}2.conf
7 %define mod_so %{mod_name}2.so
8
9 %define apache_version 2.2.0
10
11 %define major 3
12 %define libname %mklibname apreq2_ %{major}
13 %define develname %mklibname apreq -d
14
15 Summary: Apache Request Library
16 Name: libapreq2
17 Version: %perl_convert_version %{rversion}
18 Release: %mkrel 8
19 License: Apache License
20 Group: System/Libraries
21 URL: http://httpd.apache.org/apreq/
22 #Source0: libapreq2-%{rversion}-%{revision}.tar.bz2
23 Source0: http://people.apache.org/~issac/libapreq2-%{rversion}.tar.gz
24 Source1: http://people.apache.org/~issac/libapreq2-%{rversion}.tar.gz.asc
25 Source2: 76_mod_apreq2.conf
26 Patch0: libapreq2-2.03-dev-version_check_fix.diff
27 Patch1: libapreq2-2.08-autoconf260.diff
28 BuildRequires: autoconf2.5
29 BuildRequires: automake
30 BuildRequires: libtool
31 BuildRequires: chrpath
32 BuildRequires: perl-devel
33 BuildRequires: perl-doc
34 BuildRequires: perl-Pod-Tests
35 BuildRequires: perl-Apache-Test
36 BuildRequires: perl-Template-Toolkit
37 BuildRequires: perl-Tie-IxHash
38 BuildRequires: perl-ExtUtils-XSBuilder
39 BuildRequires: perl-Parse-RecDescent
40 BuildRequires: perl-libwww-perl
41 BuildRequires: apache-mod_perl-devel
42 BuildRequires: apache-devel >= %{apache_version}
43 BuildRequires: apache-source >= %{apache_version}
44 #BuildRequires: apache-mod_ssl >= %{apache_version}
45
46 %description
47 libapreq is a safe, standards-compliant, high-performance library used for
48 parsing HTTP cookies, query-strings and POST data. The original version
49 (libapreq-1.X) was designed by Lincoln Stein and Doug MacEachern. The perl
50 APIs Apache::Request and Apache::Cookie are the lightweight mod_perl analogs of
51 the CGI and CGI::Cookie perl modules.
52
53 This package contains the shared libraries for %{name}
54
55 %package -n %{libname}
56 Summary: Apache Request Library
57 Group: System/Libraries
58 Obsoletes: %{_lib}apreq2 < 2.130.0-5
59
60 %description -n %{libname}
61 libapreq is a safe, standards-compliant, high-performance library used for
62 parsing HTTP cookies, query-strings and POST data. The original version
63 (libapreq-1.X) was designed by Lincoln Stein and Doug MacEachern. The perl
64 APIs Apache::Request and Apache::Cookie are the lightweight mod_perl analogs of
65 the CGI and CGI::Cookie perl modules.
66
67 This package contains the shared libraries for %{name}
68
69 %package -n %{develname}
70 Summary: Development library and header files for the Apache Request Library
71 Group: Development/C
72 Requires: %{libname} = %{version}
73 Provides: libapreq-devel = %{version}
74 Obsoletes: %{mklibname apreq 0 -d}
75
76 %description -n %{develname}
77 libapreq is a safe, standards-compliant, high-performance library used for
78 parsing HTTP cookies, query-strings and POST data. The original version
79 (libapreq-1.X) was designed by Lincoln Stein and Doug MacEachern. The perl
80 APIs Apache::Request and Apache::Cookie are the lightweight mod_perl analogs of
81 the CGI and CGI::Cookie perl modules.
82
83 This package contains the development library and its header files.
84
85 %package -n perl-libapreq2
86 Summary: Apache Request Library Perl Glue
87 Group: System/Servers
88 Requires: apache-mod_perl
89 Requires: apache-mod_apreq >= %{version}
90 Provides: perl-libapreq
91 Obsoletes: perl-libapreq
92
93 %description -n perl-libapreq2
94 libapreq is a safe, standards-compliant, high-performance library used for
95 parsing HTTP cookies, query-strings and POST data. The original version
96 (libapreq-1.X) was designed by Lincoln Stein and Doug MacEachern. The perl
97 APIs Apache::Request and Apache::Cookie are the lightweight mod_perl analogs of
98 the CGI and CGI::Cookie perl modules.
99
100 %package -n apache-%{mod_name}
101 Summary: DSO module for the apache Web server
102 Group: System/Servers
103 Requires(pre): rpm-helper
104 Requires(postun): rpm-helper
105 Requires(pre): apache >= 2.2.0
106 Requires(pre): apache >= %{apache_version}
107 Requires: apache >= 2.2.0
108 Requires: apache >= %{apache_version}
109 Requires: perl-libapreq2 >= %{version}
110
111 %description -n apache-%{mod_name}
112 Mod_%{name} is a DSO module for the apache Web server.
113
114 %prep
115 %setup -q -n libapreq2-%{rversion}
116 %patch0 -p0
117 %patch1 -p0
118
119 # got the idea why this wasn't working from debian, thanks guys!
120 # P0 combined with this hack fixes it all...
121 perl -pi -e "s|_APACHE2_REAL_VERSION_|%{apache_version}|g" build/version_check.pl
122
123 cp %{SOURCE2} %{mod_conf}
124
125 %build
126 export WANT_AUTOCONF_2_5=1
127 #libtoolize --copy --force && aclocal && autoconf && autoheader && automake -a -c
128
129 export AUTOMAKE="automake"
130 export ACLOCAL="aclocal"
131
132 sh ./buildconf
133
134 %configure2_5x \
135 --disable-static \
136 --with-perl=%{_bindir}/perl \
137 --enable-perl-glue \
138 --with-mm-opts=INSTALLDIRS=vendor \
139 --with-apache2-apxs=%{_sbindir}/apxs \
140 --with-apr-config=%{_bindir}/apr-1-config \
141 --with-apu-config=%{_bindir}/apu-1-config
142
143 %make
144
145 # Build the perl modules
146 #pushd glue/perl
147 # %{__perl} ../../build/xsbuilder.pl run
148 # CFLAGS="%{optflags}" %{__perl} Makefile.PL -apxs %{_sbindir}/apxs INSTALLDIRS=vendor
149 # %make
150 # mv Makefile Makefile.xx
151 #popd
152
153 #make test
154
155 %install
156 %makeinstall_std
157
158 # move the module in place
159 mv %{buildroot}%{_libdir}/apache %{buildroot}%{_libdir}/apache-extramodules
160
161 # install module conf files for the "conf.d" dir loading structure
162 install -d %{buildroot}%{_sysconfdir}/httpd/modules.d
163 install -m0644 %{mod_conf} %{buildroot}%{_sysconfdir}/httpd/modules.d/
164
165 # install one extra devel file
166 install -m0755 apreq*-config %{buildroot}%{_bindir}/
167
168 # install the perl stuff
169 #pushd glue/perl
170 #cp Makefile.xx Makefile
171 #%makeinstall_std
172 #popd
173
174 # nuke rpath
175 find %{buildroot}%{perl_vendorlib} -name "*.so" | xargs chrpath -d
176
177 # cleanup
178 find %{buildroot} -name '*.la' -delete
179
180 %files -n %{libname}
181 %defattr(-,root,root)
182 %doc CHANGES INSTALL README
183 %{_libdir}/libapreq2.so.%{major}
184 %{_libdir}/libapreq2.so.%{major}.*
185
186 %files -n %{develname}
187 %defattr(-,root,root)
188 %doc CHANGES INSTALL README
189 %{_bindir}/apreq*-config
190 %{_libdir}/libapreq*.so
191 %{_includedir}/apreq*
192 %{_includedir}/apache/apreq*
193
194 %files -n apache-%{mod_name}
195 %defattr(-,root,root)
196 %doc CHANGES INSTALL README
197 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/httpd/modules.d/%{mod_conf}
198 %attr(0755,root,root) %{_libdir}/apache-extramodules/%{mod_so}
199
200 %files -n perl-libapreq2
201 %defattr(-,root,root)
202 %doc CHANGES INSTALL README
203 %{perl_vendorlib}/*/auto/APR/Request/*
204 %{perl_vendorlib}/*/Apache2/*
205 %{perl_vendorlib}/*/APR/*
206 %{_mandir}/man3/*

  ViewVC Help
Powered by ViewVC 1.1.30