/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Annotation of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 357359 - (hide annotations) (download)
Sat Jan 12 12:20:05 2013 UTC (11 years, 3 months ago) by umeabot
File size: 3889 byte(s)
Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
1 remmy 232282 %bcond_without python
2     %bcond_without sharp
3 ahmad 35921
4 wally 134735 %define major 4
5     %define libname %mklibname gpod %{major}
6     %define libnamedev %mklibname -d gpod
7     %define api 1.0
8    
9     Summary: Library to access an iPod audio player
10     Name: libgpod
11     Version: 0.8.2
12 umeabot 357359 Release: %mkrel 4
13 wally 134735 Source0: http://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
14     License: LGPLv2+
15     Group: System/Libraries
16     Url: http://www.gtkpod.org/
17     BuildRequires: gtk+2-devel
18     BuildRequires: udev-devel
19     BuildRequires: dbus-glib-devel
20    
21     BuildRequires: libsgutils-devel
22     BuildRequires: taglib-devel
23     BuildRequires: libxml2-devel
24     BuildRequires: libsqlite3-devel
25     BuildRequires: libusb1-devel
26     BuildRequires: libimobiledevice-devel
27     BuildRequires: gtk-doc
28     BuildRequires: eject
29     BuildRequires: intltool
30    
31 ahmad 35828 %description
32     libgpod is a library meant to abstract access to an iPod content. It
33     provides an easy to use API to retrieve the list of files and playlist
34     stored on an iPod, to modify them and to save them back to the iPod.
35    
36 wally 134735 %package -n %{libname}
37     Group: System/Libraries
38     Summary: Library to access an iPod audio player
39     Requires: eject
40     Requires: %{name} >= %{version}-%{release}
41 ahmad 35828
42 wally 134735 %description -n %{libname}
43 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
44     provides an easy to use API to retrieve the list of files and playlist
45     stored on an iPod, to modify them and to save them back to the iPod.
46    
47 wally 134735 %package -n %{libnamedev}
48     Group: Development/C
49     Summary: Library to access an iPod audio player
50     Requires: %{libname} = %{version}-%{release}
51 remmy 232282 Suggests: %{name}-sharp = %{version}-%{release}
52 wally 134735 Provides: %{name}-devel = %{version}-%{release}
53     Obsoletes: %mklibname -d gpod 2
54 ahmad 35828
55 wally 134735 %description -n %{libnamedev}
56 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
57     provides an easy to use API to retrieve the list of files and playlist
58     stored on an iPod, to modify them and to save them back to the iPod.
59    
60 remmy 232282 %if %{with python}
61 ahmad 35828 %package -n python-gpod
62 wally 134735 Group: Development/Python
63     Summary: Python module for iPod access
64     BuildRequires: python-gobject-devel
65     BuildRequires: python-devel
66     BuildRequires: mutagen
67     BuildRequires: swig
68     Requires: mutagen
69     Requires: %{libname} = %{version}-%{release}
70 ahmad 35828
71     %description -n python-gpod
72     libgpod is a library meant to abstract access to an iPod content. It
73     provides an easy to use API to retrieve the list of files and playlist
74     stored on an iPod, to modify them and to save them back to the iPod.
75    
76     This is a Python binding for libgpod.
77 remmy 232282 %endif
78 ahmad 35828
79 remmy 232282 %if %{with sharp}
80 ahmad 35828 %package sharp
81 wally 134735 Group: Development/Other
82     Summary: Mono binding to libgpod for iPod access
83     BuildRequires: mono-devel
84     BuildRequires: gtk-sharp2
85     BuildRequires: gtk-sharp2-devel
86     Requires: %libname = %{version}-%{release}
87 ahmad 35828
88     %description sharp
89     libgpod is a library meant to abstract access to an iPod content. It
90     provides an easy to use API to retrieve the list of files and playlist
91     stored on an iPod, to modify them and to save them back to the iPod.
92    
93     This is a Mono binding for libgpod.
94 remmy 232282 %endif
95 ahmad 35828
96     %prep
97 wally 134735 %setup -q
98 ahmad 35828 %apply_patches
99    
100     %build
101 wally 134735 %configure2_5x \
102     --disable-static \
103     --enable-udev \
104     --without-hal
105 ahmad 35828
106     %make
107    
108     %install
109     %makeinstall_std
110 ahmad 35921
111 wally 134735 #we don't want these
112     find %{buildroot} -name "*.la" -delete
113 wally 279838
114 remmy 232282 %if !%{with sharp}
115     rm -f %{buildroot}/%{_libdir}/pkgconfig/%{name}-sharp.pc
116     %endif
117 ahmad 35828
118 wally 134735 %find_lang %{name}
119    
120     %files -f %{name}.lang
121 ahmad 35828 %doc README* AUTHORS
122 wally 134735 %{_bindir}/ipod-read-sysinfo-extended
123 ahmad 35828 /lib/udev/iphone-set-info
124     /lib/udev/ipod-set-info
125     /lib/udev/rules.d/90-libgpod.rules
126 wally 134735
127     %files -n %{libname}
128     %{_libdir}/%{name}.so.%{major}*
129 ahmad 35828
130 wally 134735 %files -n %{libnamedev}
131 ahmad 35828 %doc ChangeLog
132 wally 134735 %doc %{_datadir}/gtk-doc/html/%{name}
133     %{_libdir}/%{name}.so
134     %{_libdir}/pkgconfig/%{name}-%{api}.pc
135     %{_libdir}/pkgconfig/%{name}-sharp.pc
136     %{_includedir}/gpod-%{api}/
137 ahmad 35828
138 remmy 232282 %if %{with python}
139 ahmad 35828 %files -n python-gpod
140 wally 134735 %{py_platsitedir}/gpod/
141 remmy 232282 %endif
142 ahmad 35828
143 remmy 232282 %if %{with sharp}
144 ahmad 35828 %files sharp
145 remmy 232282 %{_libdir}/pkgconfig/%{name}-sharp.pc
146 wally 134735 %dir %{_libdir}/%{name}
147     %{_libdir}/%{name}/%{name}-sharp*
148 remmy 232282 %endif

  ViewVC Help
Powered by ViewVC 1.1.30