/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Annotation of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 35921 - (hide annotations) (download)
Mon Jan 24 01:33:39 2011 UTC (13 years, 2 months ago) by ahmad
File size: 3981 byte(s)
- drop old/unneeded scriptlets
1 ahmad 35828 %define name libgpod
2     %define version 0.8.0
3     %define git 20100829
4 ahmad 35921 %define release %mkrel 3
5 ahmad 35828 %define major 4
6     %define libname %mklibname gpod %major
7     %define libnamedev %mklibname -d gpod
8     %define api 1.0
9     %define build_hal 0
10 ahmad 35921
11 ahmad 35828 Summary: Library to access an iPod audio player
12     Name: %{name}
13     Version: %{version}
14     Release: %{release}
15     Source0: http://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
16     License: LGPLv2+
17     Group: System/Libraries
18     Url: http://www.gtkpod.org/
19     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
20     BuildRequires: gtk+2-devel
21     BuildRequires: udev-devel dbus-glib-devel
22     %if %build_hal
23     BuildRequires: hal-devel
24     %endif
25     BuildRequires: libsgutils-devel
26     BuildRequires: taglib-devel
27     BuildRequires: libxml2-devel
28     BuildRequires: libsqlite3-devel
29     BuildRequires: libusb1-devel
30     BuildRequires: libimobiledevice-devel
31     BuildRequires: gtk-doc
32     BuildRequires: eject
33     BuildRequires: intltool
34    
35     %description
36     libgpod is a library meant to abstract access to an iPod content. It
37     provides an easy to use API to retrieve the list of files and playlist
38     stored on an iPod, to modify them and to save them back to the iPod.
39    
40     %package -n %libname
41     Group: System/Libraries
42     Summary: Library to access an iPod audio player
43     Requires: eject
44     Requires: %name >= %version-release
45    
46     %description -n %libname
47     libgpod is a library meant to abstract access to an iPod content. It
48     provides an easy to use API to retrieve the list of files and playlist
49     stored on an iPod, to modify them and to save them back to the iPod.
50    
51     %package -n %libnamedev
52     Group: Development/C
53     Summary: Library to access an iPod audio player
54     Requires: %libname = %version-%release
55     Requires: %name-sharp = %version-%release
56     Provides: %name-devel = %version-%release
57     Obsoletes: %mklibname -d gpod 2
58    
59     %description -n %libnamedev
60     libgpod is a library meant to abstract access to an iPod content. It
61     provides an easy to use API to retrieve the list of files and playlist
62     stored on an iPod, to modify them and to save them back to the iPod.
63    
64     %package -n python-gpod
65     Group: Development/Python
66     Summary: Python module for iPod access
67     BuildRequires: python-gobject-devel
68     %py_requires -d
69     BuildRequires: mutagen
70     BuildRequires: swig
71     Requires: mutagen
72     Requires: %libname = %version-%release
73    
74     %description -n python-gpod
75     libgpod is a library meant to abstract access to an iPod content. It
76     provides an easy to use API to retrieve the list of files and playlist
77     stored on an iPod, to modify them and to save them back to the iPod.
78    
79     This is a Python binding for libgpod.
80    
81     %package sharp
82     Group: Development/Other
83     Summary: Mono binding to libgpod for iPod access
84     BuildRequires: mono-devel
85     BuildRequires: gtk-sharp2
86     BuildRequires: gtk-sharp2-devel
87     Requires: %libname = %version-%release
88    
89     %description sharp
90     libgpod is a library meant to abstract access to an iPod content. It
91     provides an easy to use API to retrieve the list of files and playlist
92     stored on an iPod, to modify them and to save them back to the iPod.
93    
94     This is a Mono binding for libgpod.
95    
96     %prep
97     %setup -q -n %{name}-%version
98     %apply_patches
99    
100     %build
101     %configure2_5x --enable-gtk-doc --enable-udev \
102     %if !%build_hal
103     --without-hal
104     %endif
105    
106     %make
107    
108     %install
109 ahmad 35921 rm -rf %{buildroot} %name.lang
110    
111 ahmad 35828 %makeinstall_std
112 ahmad 35921
113 ahmad 35828 %find_lang %name
114    
115     %clean
116 ahmad 35921 rm -rf %{buildroot}
117 ahmad 35828
118     %files -f %name.lang
119     %defattr(-,root,root)
120     %doc README* AUTHORS
121     %_bindir/ipod-read-sysinfo-extended
122     /lib/udev/iphone-set-info
123     /lib/udev/ipod-set-info
124     /lib/udev/rules.d/90-libgpod.rules
125     %if %build_hal
126     %_libdir/hal/scripts/*
127     %_datadir/hal/fdi/policy/20thirdparty/*
128     %endif
129    
130     %files -n %libname
131     %defattr(-,root,root)
132     %_libdir/lib*.so.%{major}*
133    
134     %files -n %libnamedev
135     %defattr(-,root,root)
136     %doc ChangeLog
137     %_libdir/lib*.so
138     %attr(644,root,root) %_libdir/lib*a
139     %_libdir/pkgconfig/libgpod-%api.pc
140     %_libdir/pkgconfig/libgpod-sharp.pc
141     %_includedir/gpod-%api/
142     %_datadir/gtk-doc/html/*
143    
144     %files -n python-gpod
145     %defattr(-,root,root)
146     %py_platsitedir/gpod/
147    
148     %files sharp
149     %defattr(-,root,root)
150     %dir %_libdir/%name/
151     %_libdir/%name/libgpod-sharp*
152    
153    

  ViewVC Help
Powered by ViewVC 1.1.30