/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Annotation of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 442336 - (hide annotations) (download)
Thu Jun 13 04:16:07 2013 UTC (10 years, 10 months ago) by fwang
File size: 4020 byte(s)
rebuild for new libimobiledevices
1 remmy 232282 %bcond_without python
2 rtp 401075 %ifnarch %arm %mips
3 remmy 232282 %bcond_without sharp
4 rtp 401075 %endif
5 ahmad 35921
6 wally 134735 %define major 4
7     %define libname %mklibname gpod %{major}
8     %define libnamedev %mklibname -d gpod
9     %define api 1.0
10    
11     Summary: Library to access an iPod audio player
12     Name: libgpod
13     Version: 0.8.2
14 fwang 442336 Release: %mkrel 6
15 wally 134735 Source0: http://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
16     License: LGPLv2+
17     Group: System/Libraries
18     Url: http://www.gtkpod.org/
19     BuildRequires: gtk+2-devel
20     BuildRequires: udev-devel
21     BuildRequires: dbus-glib-devel
22     BuildRequires: libsgutils-devel
23     BuildRequires: taglib-devel
24     BuildRequires: libxml2-devel
25     BuildRequires: libsqlite3-devel
26     BuildRequires: libusb1-devel
27     BuildRequires: libimobiledevice-devel
28     BuildRequires: gtk-doc
29     BuildRequires: eject
30     BuildRequires: intltool
31    
32 ahmad 35828 %description
33     libgpod is a library meant to abstract access to an iPod content. It
34     provides an easy to use API to retrieve the list of files and playlist
35     stored on an iPod, to modify them and to save them back to the iPod.
36    
37 wally 134735 %package -n %{libname}
38     Group: System/Libraries
39     Summary: Library to access an iPod audio player
40     Requires: eject
41     Requires: %{name} >= %{version}-%{release}
42 ahmad 35828
43 wally 134735 %description -n %{libname}
44 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
45     provides an easy to use API to retrieve the list of files and playlist
46     stored on an iPod, to modify them and to save them back to the iPod.
47    
48 wally 134735 %package -n %{libnamedev}
49     Group: Development/C
50     Summary: Library to access an iPod audio player
51     Requires: %{libname} = %{version}-%{release}
52 rtp 401075 %if %{with sharp}
53 remmy 232282 Suggests: %{name}-sharp = %{version}-%{release}
54 rtp 401075 %endif
55 wally 134735 Provides: %{name}-devel = %{version}-%{release}
56     Obsoletes: %mklibname -d gpod 2
57 ahmad 35828
58 wally 134735 %description -n %{libnamedev}
59 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
60     provides an easy to use API to retrieve the list of files and playlist
61     stored on an iPod, to modify them and to save them back to the iPod.
62    
63 remmy 232282 %if %{with python}
64 ahmad 35828 %package -n python-gpod
65 wally 134735 Group: Development/Python
66     Summary: Python module for iPod access
67     BuildRequires: python-gobject-devel
68     BuildRequires: python-devel
69     BuildRequires: mutagen
70     BuildRequires: swig
71     Requires: mutagen
72     Requires: %{libname} = %{version}-%{release}
73 ahmad 35828
74     %description -n python-gpod
75     libgpod is a library meant to abstract access to an iPod content. It
76     provides an easy to use API to retrieve the list of files and playlist
77     stored on an iPod, to modify them and to save them back to the iPod.
78    
79     This is a Python binding for libgpod.
80 remmy 232282 %endif
81 ahmad 35828
82 remmy 232282 %if %{with sharp}
83 ahmad 35828 %package sharp
84 wally 134735 Group: Development/Other
85     Summary: Mono binding to libgpod for iPod access
86     BuildRequires: mono-devel
87     BuildRequires: gtk-sharp2
88     BuildRequires: gtk-sharp2-devel
89     Requires: %libname = %{version}-%{release}
90 ahmad 35828
91     %description sharp
92     libgpod is a library meant to abstract access to an iPod content. It
93     provides an easy to use API to retrieve the list of files and playlist
94     stored on an iPod, to modify them and to save them back to the iPod.
95    
96     This is a Mono binding for libgpod.
97 remmy 232282 %endif
98 ahmad 35828
99     %prep
100 wally 134735 %setup -q
101 ahmad 35828 %apply_patches
102    
103     %build
104 wally 134735 %configure2_5x \
105     --disable-static \
106 fwang 442336 --enable-udev --with-udev-dir=%{_prefix}/lib/udev \
107 wally 134735 --without-hal
108 ahmad 35828
109     %make
110    
111     %install
112     %makeinstall_std
113 ahmad 35921
114 wally 134735 #we don't want these
115     find %{buildroot} -name "*.la" -delete
116 wally 279838
117 remmy 232282 %if !%{with sharp}
118     rm -f %{buildroot}/%{_libdir}/pkgconfig/%{name}-sharp.pc
119     %endif
120 ahmad 35828
121 wally 134735 %find_lang %{name}
122    
123     %files -f %{name}.lang
124 ahmad 35828 %doc README* AUTHORS
125 wally 134735 %{_bindir}/ipod-read-sysinfo-extended
126 fwang 442336 %{_prefix}/lib/udev/iphone-set-info
127     %{_prefix}/lib/udev/ipod-set-info
128     %{_udevrulesdir}/90-libgpod.rules
129 wally 134735
130     %files -n %{libname}
131     %{_libdir}/%{name}.so.%{major}*
132 ahmad 35828
133 wally 134735 %files -n %{libnamedev}
134 ahmad 35828 %doc ChangeLog
135 wally 134735 %doc %{_datadir}/gtk-doc/html/%{name}
136     %{_libdir}/%{name}.so
137     %{_libdir}/pkgconfig/%{name}-%{api}.pc
138 rtp 401075 %if %{with sharp}
139 wally 134735 %{_libdir}/pkgconfig/%{name}-sharp.pc
140 rtp 401075 %endif
141 wally 134735 %{_includedir}/gpod-%{api}/
142 ahmad 35828
143 remmy 232282 %if %{with python}
144 ahmad 35828 %files -n python-gpod
145 wally 134735 %{py_platsitedir}/gpod/
146 remmy 232282 %endif
147 ahmad 35828
148 remmy 232282 %if %{with sharp}
149 ahmad 35828 %files sharp
150 remmy 232282 %{_libdir}/pkgconfig/%{name}-sharp.pc
151 wally 134735 %dir %{_libdir}/%{name}
152     %{_libdir}/%{name}/%{name}-sharp*
153 remmy 232282 %endif

  ViewVC Help
Powered by ViewVC 1.1.30