/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Annotation of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 475274 - (hide annotations) (download)
Thu Sep 5 16:01:59 2013 UTC (10 years, 7 months ago) by luigiwalser
File size: 3884 byte(s)
- 0.8.3
- remove patch0 (fixed upstream)

1 remmy 232282 %bcond_without python
2 rtp 401075 %ifnarch %arm %mips
3 remmy 232282 %bcond_without sharp
4 rtp 401075 %endif
5 ahmad 35921
6 wally 134735 %define major 4
7     %define libname %mklibname gpod %{major}
8     %define libnamedev %mklibname -d gpod
9     %define api 1.0
10    
11     Summary: Library to access an iPod audio player
12     Name: libgpod
13 luigiwalser 475274 Version: 0.8.3
14     Release: %mkrel 1
15 wally 134735 Source0: http://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
16     License: LGPLv2+
17     Group: System/Libraries
18     Url: http://www.gtkpod.org/
19     BuildRequires: gtk+2-devel
20     BuildRequires: udev-devel
21     BuildRequires: dbus-glib-devel
22     BuildRequires: libsgutils-devel
23     BuildRequires: taglib-devel
24     BuildRequires: libxml2-devel
25     BuildRequires: libsqlite3-devel
26     BuildRequires: libusb1-devel
27     BuildRequires: libimobiledevice-devel
28     BuildRequires: gtk-doc
29     BuildRequires: eject
30     BuildRequires: intltool
31    
32 ahmad 35828 %description
33     libgpod is a library meant to abstract access to an iPod content. It
34     provides an easy to use API to retrieve the list of files and playlist
35     stored on an iPod, to modify them and to save them back to the iPod.
36    
37 wally 134735 %package -n %{libname}
38     Group: System/Libraries
39     Summary: Library to access an iPod audio player
40     Requires: eject
41     Requires: %{name} >= %{version}-%{release}
42 ahmad 35828
43 wally 134735 %description -n %{libname}
44 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
45     provides an easy to use API to retrieve the list of files and playlist
46     stored on an iPod, to modify them and to save them back to the iPod.
47    
48 wally 134735 %package -n %{libnamedev}
49     Group: Development/C
50     Summary: Library to access an iPod audio player
51     Requires: %{libname} = %{version}-%{release}
52     Provides: %{name}-devel = %{version}-%{release}
53     Obsoletes: %mklibname -d gpod 2
54 ahmad 35828
55 wally 134735 %description -n %{libnamedev}
56 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
57     provides an easy to use API to retrieve the list of files and playlist
58     stored on an iPod, to modify them and to save them back to the iPod.
59    
60 remmy 232282 %if %{with python}
61 ahmad 35828 %package -n python-gpod
62 wally 134735 Group: Development/Python
63     Summary: Python module for iPod access
64     BuildRequires: python-gobject-devel
65     BuildRequires: python-devel
66     BuildRequires: mutagen
67     BuildRequires: swig
68     Requires: mutagen
69     Requires: %{libname} = %{version}-%{release}
70 ahmad 35828
71     %description -n python-gpod
72     libgpod is a library meant to abstract access to an iPod content. It
73     provides an easy to use API to retrieve the list of files and playlist
74     stored on an iPod, to modify them and to save them back to the iPod.
75    
76     This is a Python binding for libgpod.
77 remmy 232282 %endif
78 ahmad 35828
79 remmy 232282 %if %{with sharp}
80 ahmad 35828 %package sharp
81 wally 134735 Group: Development/Other
82     Summary: Mono binding to libgpod for iPod access
83     BuildRequires: mono-devel
84     BuildRequires: gtk-sharp2
85     BuildRequires: gtk-sharp2-devel
86     Requires: %libname = %{version}-%{release}
87 ahmad 35828
88     %description sharp
89     libgpod is a library meant to abstract access to an iPod content. It
90     provides an easy to use API to retrieve the list of files and playlist
91     stored on an iPod, to modify them and to save them back to the iPod.
92    
93     This is a Mono binding for libgpod.
94 remmy 232282 %endif
95 ahmad 35828
96     %prep
97 wally 134735 %setup -q
98 ahmad 35828 %apply_patches
99    
100     %build
101 wally 134735 %configure2_5x \
102     --disable-static \
103 fwang 442336 --enable-udev --with-udev-dir=%{_prefix}/lib/udev \
104 wally 134735 --without-hal
105 ahmad 35828
106     %make
107    
108     %install
109     %makeinstall_std
110 ahmad 35921
111 wally 134735 #we don't want these
112     find %{buildroot} -name "*.la" -delete
113 wally 279838
114 remmy 232282 %if !%{with sharp}
115     rm -f %{buildroot}/%{_libdir}/pkgconfig/%{name}-sharp.pc
116     %endif
117 ahmad 35828
118 wally 134735 %find_lang %{name}
119    
120     %files -f %{name}.lang
121 ahmad 35828 %doc README* AUTHORS
122 wally 134735 %{_bindir}/ipod-read-sysinfo-extended
123 fwang 442336 %{_prefix}/lib/udev/iphone-set-info
124     %{_prefix}/lib/udev/ipod-set-info
125     %{_udevrulesdir}/90-libgpod.rules
126 wally 134735
127     %files -n %{libname}
128     %{_libdir}/%{name}.so.%{major}*
129 ahmad 35828
130 wally 134735 %files -n %{libnamedev}
131 ahmad 35828 %doc ChangeLog
132 wally 134735 %doc %{_datadir}/gtk-doc/html/%{name}
133     %{_libdir}/%{name}.so
134     %{_libdir}/pkgconfig/%{name}-%{api}.pc
135     %{_includedir}/gpod-%{api}/
136 ahmad 35828
137 remmy 232282 %if %{with python}
138 ahmad 35828 %files -n python-gpod
139 wally 134735 %{py_platsitedir}/gpod/
140 remmy 232282 %endif
141 ahmad 35828
142 remmy 232282 %if %{with sharp}
143 ahmad 35828 %files sharp
144 remmy 232282 %{_libdir}/pkgconfig/%{name}-sharp.pc
145 wally 134735 %dir %{_libdir}/%{name}
146     %{_libdir}/%{name}/%{name}-sharp*
147 remmy 232282 %endif

  ViewVC Help
Powered by ViewVC 1.1.30