/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Annotation of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1982794 - (hide annotations) (download)
Thu Aug 31 20:52:28 2023 UTC (7 months, 2 weeks ago) by daviddavid
File size: 4393 byte(s)
- add support for libplist >= 2.3

1 daviddavid 1444443 %bcond_with python
2 wally 1577621
3 pterjan 985250 %ifnarch %mips
4 remmy 232282 %bcond_without sharp
5 rtp 401075 %endif
6 ahmad 35921
7 wally 134735 %define major 4
8 daviddavid 1597891 %define api 1.0
9 wally 134735 %define libname %mklibname gpod %{major}
10 daviddavid 1597891 %define libnamedev %mklibname gpod -d
11 wally 134735
12     Summary: Library to access an iPod audio player
13     Name: libgpod
14 luigiwalser 475274 Version: 0.8.3
15 daviddavid 1982791 Release: %mkrel 25
16 daviddavid 882256 License: LGPLv2+
17     Group: System/Libraries
18     Url: http://www.gtkpod.org/
19 danf 1778814 Source0: https://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
20 sander85 858677 Patch0: libgpod-fixswig.patch
21 fwang 878904 Patch1: libgpod-0.8.3-mono4.patch
22 fwang 879154 Patch2: libgpod-0.8.3-disable-tests.patch
23 daviddavid 882256 Patch3: libgpod-0.8.3-fix-segfault-and-some-typos.patch
24 daviddavid 1597891 Patch5: 0001-configure.ac-Add-support-for-libplist-2.2.patch
25 daviddavid 1221091 BuildRequires: pkgconfig(gtk+-2.0)
26 tv 643448 BuildRequires: pkgconfig(libudev)
27     BuildRequires: pkgconfig(dbus-glib-1)
28 wally 134735 BuildRequires: libsgutils-devel
29 tv 643448 BuildRequires: pkgconfig(taglib)
30     BuildRequires: pkgconfig(libxml-2.0)
31     BuildRequires: pkgconfig(sqlite3)
32     BuildRequires: pkgconfig(libusb-1.0)
33     BuildRequires: pkgconfig(libimobiledevice-1.0)
34 daviddavid 1597891 BuildRequires: pkgconfig(libplist-2.0) >= 2.2.0
35 wally 134735 BuildRequires: gtk-doc
36     BuildRequires: eject
37     BuildRequires: intltool
38    
39 ahmad 35828 %description
40     libgpod is a library meant to abstract access to an iPod content. It
41     provides an easy to use API to retrieve the list of files and playlist
42     stored on an iPod, to modify them and to save them back to the iPod.
43    
44 wally 134735 %package -n %{libname}
45     Group: System/Libraries
46     Summary: Library to access an iPod audio player
47     Requires: eject
48     Requires: %{name} >= %{version}-%{release}
49 ahmad 35828
50 wally 134735 %description -n %{libname}
51 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
52     provides an easy to use API to retrieve the list of files and playlist
53     stored on an iPod, to modify them and to save them back to the iPod.
54    
55 wally 134735 %package -n %{libnamedev}
56     Group: Development/C
57     Summary: Library to access an iPod audio player
58     Requires: %{libname} = %{version}-%{release}
59     Provides: %{name}-devel = %{version}-%{release}
60 ahmad 35828
61 wally 134735 %description -n %{libnamedev}
62 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
63     provides an easy to use API to retrieve the list of files and playlist
64     stored on an iPod, to modify them and to save them back to the iPod.
65    
66 remmy 232282 %if %{with python}
67 daviddavid 1444443 %package -n python3-gpod
68 wally 134735 Group: Development/Python
69 daviddavid 1444443 Summary: Python 3 module for iPod access
70     BuildRequires: pkgconfig(pygobject-3.0)
71     BuildRequires: pkgconfig(python3)
72     BuildRequires: python3dist(mutagen)
73 wally 134735 BuildRequires: swig
74 daviddavid 1444443 Requires: python3dist(mutagen)
75 wally 134735 Requires: %{libname} = %{version}-%{release}
76 ahmad 35828
77 daviddavid 1221091 Provides: python-gpod = %{version}-%{release}
78    
79 daviddavid 1444443 %description -n python3-gpod
80 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
81     provides an easy to use API to retrieve the list of files and playlist
82     stored on an iPod, to modify them and to save them back to the iPod.
83    
84 daviddavid 1444443 This is a Python 3 binding for libgpod.
85 remmy 232282 %endif
86 ahmad 35828
87 remmy 232282 %if %{with sharp}
88 ahmad 35828 %package sharp
89 wally 134735 Group: Development/Other
90     Summary: Mono binding to libgpod for iPod access
91 tv 643448 BuildRequires: pkgconfig(mono)
92 wally 134735 BuildRequires: gtk-sharp2
93 tv 643448 BuildRequires: pkgconfig(gapi-2.0)
94 daviddavid 882256 Requires: %{libname} = %{version}-%{release}
95 ahmad 35828
96     %description sharp
97     libgpod is a library meant to abstract access to an iPod content. It
98     provides an easy to use API to retrieve the list of files and playlist
99     stored on an iPod, to modify them and to save them back to the iPod.
100    
101     This is a Mono binding for libgpod.
102 remmy 232282 %endif
103 ahmad 35828
104 daviddavid 1444443 %prep
105 daviddavid 1982794 %autosetup -p1
106 ahmad 35828
107 daviddavid 1982794 # support libplist 2.3
108     sed -e 's|plist_dict_insert_item|plist_dict_set_item|' -i tools/ipod-lockdown.c
109    
110 ahmad 35828 %build
111 fwang 878905 autoreconf -fi
112 wally 1479455 %configure \
113 wally 134735 --disable-static \
114 daviddavid 882256 --enable-udev \
115     --with-udev-dir=%{_prefix}/lib/udev \
116 daviddavid 1221091 --without-hal
117 ahmad 35828
118 kekepower 1215767 %make_build
119 ahmad 35828
120     %install
121 kekepower 1215767 %make_install
122 ahmad 35921
123 wally 134735 #we don't want these
124     find %{buildroot} -name "*.la" -delete
125 wally 279838
126 remmy 232282 %if !%{with sharp}
127     rm -f %{buildroot}/%{_libdir}/pkgconfig/%{name}-sharp.pc
128     %endif
129 ahmad 35828
130 wally 134735 %find_lang %{name}
131    
132     %files -f %{name}.lang
133 ahmad 35828 %doc README* AUTHORS
134 wally 134735 %{_bindir}/ipod-read-sysinfo-extended
135 fwang 442336 %{_prefix}/lib/udev/iphone-set-info
136     %{_prefix}/lib/udev/ipod-set-info
137     %{_udevrulesdir}/90-libgpod.rules
138 wally 134735
139     %files -n %{libname}
140 ovitters 876806 %{_libdir}/%{name}.so.%{major}{,.*}
141 ahmad 35828
142 wally 134735 %files -n %{libnamedev}
143 ahmad 35828 %doc ChangeLog
144 wally 134735 %doc %{_datadir}/gtk-doc/html/%{name}
145     %{_libdir}/%{name}.so
146     %{_libdir}/pkgconfig/%{name}-%{api}.pc
147     %{_includedir}/gpod-%{api}/
148 ahmad 35828
149 remmy 232282 %if %{with python}
150 daviddavid 1444443 %files -n python3-gpod
151     %{python3_sitearch}/gpod/
152 remmy 232282 %endif
153 ahmad 35828
154 remmy 232282 %if %{with sharp}
155 ahmad 35828 %files sharp
156 remmy 232282 %{_libdir}/pkgconfig/%{name}-sharp.pc
157 wally 134735 %dir %{_libdir}/%{name}
158     %{_libdir}/%{name}/%{name}-sharp*
159 remmy 232282 %endif

  ViewVC Help
Powered by ViewVC 1.1.30