/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Contents of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 442336 - (show annotations) (download)
Thu Jun 13 04:16:07 2013 UTC (10 years, 9 months ago) by fwang
File size: 4020 byte(s)
rebuild for new libimobiledevices
1 %bcond_without python
2 %ifnarch %arm %mips
3 %bcond_without sharp
4 %endif
5
6 %define major 4
7 %define libname %mklibname gpod %{major}
8 %define libnamedev %mklibname -d gpod
9 %define api 1.0
10
11 Summary: Library to access an iPod audio player
12 Name: libgpod
13 Version: 0.8.2
14 Release: %mkrel 6
15 Source0: http://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
16 License: LGPLv2+
17 Group: System/Libraries
18 Url: http://www.gtkpod.org/
19 BuildRequires: gtk+2-devel
20 BuildRequires: udev-devel
21 BuildRequires: dbus-glib-devel
22 BuildRequires: libsgutils-devel
23 BuildRequires: taglib-devel
24 BuildRequires: libxml2-devel
25 BuildRequires: libsqlite3-devel
26 BuildRequires: libusb1-devel
27 BuildRequires: libimobiledevice-devel
28 BuildRequires: gtk-doc
29 BuildRequires: eject
30 BuildRequires: intltool
31
32 %description
33 libgpod is a library meant to abstract access to an iPod content. It
34 provides an easy to use API to retrieve the list of files and playlist
35 stored on an iPod, to modify them and to save them back to the iPod.
36
37 %package -n %{libname}
38 Group: System/Libraries
39 Summary: Library to access an iPod audio player
40 Requires: eject
41 Requires: %{name} >= %{version}-%{release}
42
43 %description -n %{libname}
44 libgpod is a library meant to abstract access to an iPod content. It
45 provides an easy to use API to retrieve the list of files and playlist
46 stored on an iPod, to modify them and to save them back to the iPod.
47
48 %package -n %{libnamedev}
49 Group: Development/C
50 Summary: Library to access an iPod audio player
51 Requires: %{libname} = %{version}-%{release}
52 %if %{with sharp}
53 Suggests: %{name}-sharp = %{version}-%{release}
54 %endif
55 Provides: %{name}-devel = %{version}-%{release}
56 Obsoletes: %mklibname -d gpod 2
57
58 %description -n %{libnamedev}
59 libgpod is a library meant to abstract access to an iPod content. It
60 provides an easy to use API to retrieve the list of files and playlist
61 stored on an iPod, to modify them and to save them back to the iPod.
62
63 %if %{with python}
64 %package -n python-gpod
65 Group: Development/Python
66 Summary: Python module for iPod access
67 BuildRequires: python-gobject-devel
68 BuildRequires: python-devel
69 BuildRequires: mutagen
70 BuildRequires: swig
71 Requires: mutagen
72 Requires: %{libname} = %{version}-%{release}
73
74 %description -n python-gpod
75 libgpod is a library meant to abstract access to an iPod content. It
76 provides an easy to use API to retrieve the list of files and playlist
77 stored on an iPod, to modify them and to save them back to the iPod.
78
79 This is a Python binding for libgpod.
80 %endif
81
82 %if %{with sharp}
83 %package sharp
84 Group: Development/Other
85 Summary: Mono binding to libgpod for iPod access
86 BuildRequires: mono-devel
87 BuildRequires: gtk-sharp2
88 BuildRequires: gtk-sharp2-devel
89 Requires: %libname = %{version}-%{release}
90
91 %description sharp
92 libgpod is a library meant to abstract access to an iPod content. It
93 provides an easy to use API to retrieve the list of files and playlist
94 stored on an iPod, to modify them and to save them back to the iPod.
95
96 This is a Mono binding for libgpod.
97 %endif
98
99 %prep
100 %setup -q
101 %apply_patches
102
103 %build
104 %configure2_5x \
105 --disable-static \
106 --enable-udev --with-udev-dir=%{_prefix}/lib/udev \
107 --without-hal
108
109 %make
110
111 %install
112 %makeinstall_std
113
114 #we don't want these
115 find %{buildroot} -name "*.la" -delete
116
117 %if !%{with sharp}
118 rm -f %{buildroot}/%{_libdir}/pkgconfig/%{name}-sharp.pc
119 %endif
120
121 %find_lang %{name}
122
123 %files -f %{name}.lang
124 %doc README* AUTHORS
125 %{_bindir}/ipod-read-sysinfo-extended
126 %{_prefix}/lib/udev/iphone-set-info
127 %{_prefix}/lib/udev/ipod-set-info
128 %{_udevrulesdir}/90-libgpod.rules
129
130 %files -n %{libname}
131 %{_libdir}/%{name}.so.%{major}*
132
133 %files -n %{libnamedev}
134 %doc ChangeLog
135 %doc %{_datadir}/gtk-doc/html/%{name}
136 %{_libdir}/%{name}.so
137 %{_libdir}/pkgconfig/%{name}-%{api}.pc
138 %if %{with sharp}
139 %{_libdir}/pkgconfig/%{name}-sharp.pc
140 %endif
141 %{_includedir}/gpod-%{api}/
142
143 %if %{with python}
144 %files -n python-gpod
145 %{py_platsitedir}/gpod/
146 %endif
147
148 %if %{with sharp}
149 %files sharp
150 %{_libdir}/pkgconfig/%{name}-sharp.pc
151 %dir %{_libdir}/%{name}
152 %{_libdir}/%{name}/%{name}-sharp*
153 %endif

  ViewVC Help
Powered by ViewVC 1.1.30