/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Contents of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 451546 - (show annotations) (download)
Mon Jul 8 22:00:11 2013 UTC (10 years, 8 months ago) by blino
File size: 4069 byte(s)
update to libimobiledevice new api (from teuf @ Red Hat)
1 %bcond_without python
2 %ifnarch %arm %mips
3 %bcond_without sharp
4 %endif
5
6 %define major 4
7 %define libname %mklibname gpod %{major}
8 %define libnamedev %mklibname -d gpod
9 %define api 1.0
10
11 Summary: Library to access an iPod audio player
12 Name: libgpod
13 Version: 0.8.2
14 Release: %mkrel 7
15 Source0: http://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
16 Patch0: libgpod-0.8.2-imobiledevice-1.1.5.patch
17 License: LGPLv2+
18 Group: System/Libraries
19 Url: http://www.gtkpod.org/
20 BuildRequires: gtk+2-devel
21 BuildRequires: udev-devel
22 BuildRequires: dbus-glib-devel
23 BuildRequires: libsgutils-devel
24 BuildRequires: taglib-devel
25 BuildRequires: libxml2-devel
26 BuildRequires: libsqlite3-devel
27 BuildRequires: libusb1-devel
28 BuildRequires: libimobiledevice-devel
29 BuildRequires: gtk-doc
30 BuildRequires: eject
31 BuildRequires: intltool
32
33 %description
34 libgpod is a library meant to abstract access to an iPod content. It
35 provides an easy to use API to retrieve the list of files and playlist
36 stored on an iPod, to modify them and to save them back to the iPod.
37
38 %package -n %{libname}
39 Group: System/Libraries
40 Summary: Library to access an iPod audio player
41 Requires: eject
42 Requires: %{name} >= %{version}-%{release}
43
44 %description -n %{libname}
45 libgpod is a library meant to abstract access to an iPod content. It
46 provides an easy to use API to retrieve the list of files and playlist
47 stored on an iPod, to modify them and to save them back to the iPod.
48
49 %package -n %{libnamedev}
50 Group: Development/C
51 Summary: Library to access an iPod audio player
52 Requires: %{libname} = %{version}-%{release}
53 %if %{with sharp}
54 Suggests: %{name}-sharp = %{version}-%{release}
55 %endif
56 Provides: %{name}-devel = %{version}-%{release}
57 Obsoletes: %mklibname -d gpod 2
58
59 %description -n %{libnamedev}
60 libgpod is a library meant to abstract access to an iPod content. It
61 provides an easy to use API to retrieve the list of files and playlist
62 stored on an iPod, to modify them and to save them back to the iPod.
63
64 %if %{with python}
65 %package -n python-gpod
66 Group: Development/Python
67 Summary: Python module for iPod access
68 BuildRequires: python-gobject-devel
69 BuildRequires: python-devel
70 BuildRequires: mutagen
71 BuildRequires: swig
72 Requires: mutagen
73 Requires: %{libname} = %{version}-%{release}
74
75 %description -n python-gpod
76 libgpod is a library meant to abstract access to an iPod content. It
77 provides an easy to use API to retrieve the list of files and playlist
78 stored on an iPod, to modify them and to save them back to the iPod.
79
80 This is a Python binding for libgpod.
81 %endif
82
83 %if %{with sharp}
84 %package sharp
85 Group: Development/Other
86 Summary: Mono binding to libgpod for iPod access
87 BuildRequires: mono-devel
88 BuildRequires: gtk-sharp2
89 BuildRequires: gtk-sharp2-devel
90 Requires: %libname = %{version}-%{release}
91
92 %description sharp
93 libgpod is a library meant to abstract access to an iPod content. It
94 provides an easy to use API to retrieve the list of files and playlist
95 stored on an iPod, to modify them and to save them back to the iPod.
96
97 This is a Mono binding for libgpod.
98 %endif
99
100 %prep
101 %setup -q
102 %apply_patches
103
104 %build
105 %configure2_5x \
106 --disable-static \
107 --enable-udev --with-udev-dir=%{_prefix}/lib/udev \
108 --without-hal
109
110 %make
111
112 %install
113 %makeinstall_std
114
115 #we don't want these
116 find %{buildroot} -name "*.la" -delete
117
118 %if !%{with sharp}
119 rm -f %{buildroot}/%{_libdir}/pkgconfig/%{name}-sharp.pc
120 %endif
121
122 %find_lang %{name}
123
124 %files -f %{name}.lang
125 %doc README* AUTHORS
126 %{_bindir}/ipod-read-sysinfo-extended
127 %{_prefix}/lib/udev/iphone-set-info
128 %{_prefix}/lib/udev/ipod-set-info
129 %{_udevrulesdir}/90-libgpod.rules
130
131 %files -n %{libname}
132 %{_libdir}/%{name}.so.%{major}*
133
134 %files -n %{libnamedev}
135 %doc ChangeLog
136 %doc %{_datadir}/gtk-doc/html/%{name}
137 %{_libdir}/%{name}.so
138 %{_libdir}/pkgconfig/%{name}-%{api}.pc
139 %if %{with sharp}
140 %{_libdir}/pkgconfig/%{name}-sharp.pc
141 %endif
142 %{_includedir}/gpod-%{api}/
143
144 %if %{with python}
145 %files -n python-gpod
146 %{py_platsitedir}/gpod/
147 %endif
148
149 %if %{with sharp}
150 %files sharp
151 %{_libdir}/pkgconfig/%{name}-sharp.pc
152 %dir %{_libdir}/%{name}
153 %{_libdir}/%{name}/%{name}-sharp*
154 %endif

  ViewVC Help
Powered by ViewVC 1.1.30