/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Contents of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1982794 - (show annotations) (download)
Thu Aug 31 20:52:28 2023 UTC (7 months, 3 weeks ago) by daviddavid
File size: 4393 byte(s)
- add support for libplist >= 2.3

1 %bcond_with python
2
3 %ifnarch %mips
4 %bcond_without sharp
5 %endif
6
7 %define major 4
8 %define api 1.0
9 %define libname %mklibname gpod %{major}
10 %define libnamedev %mklibname gpod -d
11
12 Summary: Library to access an iPod audio player
13 Name: libgpod
14 Version: 0.8.3
15 Release: %mkrel 25
16 License: LGPLv2+
17 Group: System/Libraries
18 Url: http://www.gtkpod.org/
19 Source0: https://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
20 Patch0: libgpod-fixswig.patch
21 Patch1: libgpod-0.8.3-mono4.patch
22 Patch2: libgpod-0.8.3-disable-tests.patch
23 Patch3: libgpod-0.8.3-fix-segfault-and-some-typos.patch
24 Patch5: 0001-configure.ac-Add-support-for-libplist-2.2.patch
25 BuildRequires: pkgconfig(gtk+-2.0)
26 BuildRequires: pkgconfig(libudev)
27 BuildRequires: pkgconfig(dbus-glib-1)
28 BuildRequires: libsgutils-devel
29 BuildRequires: pkgconfig(taglib)
30 BuildRequires: pkgconfig(libxml-2.0)
31 BuildRequires: pkgconfig(sqlite3)
32 BuildRequires: pkgconfig(libusb-1.0)
33 BuildRequires: pkgconfig(libimobiledevice-1.0)
34 BuildRequires: pkgconfig(libplist-2.0) >= 2.2.0
35 BuildRequires: gtk-doc
36 BuildRequires: eject
37 BuildRequires: intltool
38
39 %description
40 libgpod is a library meant to abstract access to an iPod content. It
41 provides an easy to use API to retrieve the list of files and playlist
42 stored on an iPod, to modify them and to save them back to the iPod.
43
44 %package -n %{libname}
45 Group: System/Libraries
46 Summary: Library to access an iPod audio player
47 Requires: eject
48 Requires: %{name} >= %{version}-%{release}
49
50 %description -n %{libname}
51 libgpod is a library meant to abstract access to an iPod content. It
52 provides an easy to use API to retrieve the list of files and playlist
53 stored on an iPod, to modify them and to save them back to the iPod.
54
55 %package -n %{libnamedev}
56 Group: Development/C
57 Summary: Library to access an iPod audio player
58 Requires: %{libname} = %{version}-%{release}
59 Provides: %{name}-devel = %{version}-%{release}
60
61 %description -n %{libnamedev}
62 libgpod is a library meant to abstract access to an iPod content. It
63 provides an easy to use API to retrieve the list of files and playlist
64 stored on an iPod, to modify them and to save them back to the iPod.
65
66 %if %{with python}
67 %package -n python3-gpod
68 Group: Development/Python
69 Summary: Python 3 module for iPod access
70 BuildRequires: pkgconfig(pygobject-3.0)
71 BuildRequires: pkgconfig(python3)
72 BuildRequires: python3dist(mutagen)
73 BuildRequires: swig
74 Requires: python3dist(mutagen)
75 Requires: %{libname} = %{version}-%{release}
76
77 Provides: python-gpod = %{version}-%{release}
78
79 %description -n python3-gpod
80 libgpod is a library meant to abstract access to an iPod content. It
81 provides an easy to use API to retrieve the list of files and playlist
82 stored on an iPod, to modify them and to save them back to the iPod.
83
84 This is a Python 3 binding for libgpod.
85 %endif
86
87 %if %{with sharp}
88 %package sharp
89 Group: Development/Other
90 Summary: Mono binding to libgpod for iPod access
91 BuildRequires: pkgconfig(mono)
92 BuildRequires: gtk-sharp2
93 BuildRequires: pkgconfig(gapi-2.0)
94 Requires: %{libname} = %{version}-%{release}
95
96 %description sharp
97 libgpod is a library meant to abstract access to an iPod content. It
98 provides an easy to use API to retrieve the list of files and playlist
99 stored on an iPod, to modify them and to save them back to the iPod.
100
101 This is a Mono binding for libgpod.
102 %endif
103
104 %prep
105 %autosetup -p1
106
107 # support libplist 2.3
108 sed -e 's|plist_dict_insert_item|plist_dict_set_item|' -i tools/ipod-lockdown.c
109
110 %build
111 autoreconf -fi
112 %configure \
113 --disable-static \
114 --enable-udev \
115 --with-udev-dir=%{_prefix}/lib/udev \
116 --without-hal
117
118 %make_build
119
120 %install
121 %make_install
122
123 #we don't want these
124 find %{buildroot} -name "*.la" -delete
125
126 %if !%{with sharp}
127 rm -f %{buildroot}/%{_libdir}/pkgconfig/%{name}-sharp.pc
128 %endif
129
130 %find_lang %{name}
131
132 %files -f %{name}.lang
133 %doc README* AUTHORS
134 %{_bindir}/ipod-read-sysinfo-extended
135 %{_prefix}/lib/udev/iphone-set-info
136 %{_prefix}/lib/udev/ipod-set-info
137 %{_udevrulesdir}/90-libgpod.rules
138
139 %files -n %{libname}
140 %{_libdir}/%{name}.so.%{major}{,.*}
141
142 %files -n %{libnamedev}
143 %doc ChangeLog
144 %doc %{_datadir}/gtk-doc/html/%{name}
145 %{_libdir}/%{name}.so
146 %{_libdir}/pkgconfig/%{name}-%{api}.pc
147 %{_includedir}/gpod-%{api}/
148
149 %if %{with python}
150 %files -n python3-gpod
151 %{python3_sitearch}/gpod/
152 %endif
153
154 %if %{with sharp}
155 %files sharp
156 %{_libdir}/pkgconfig/%{name}-sharp.pc
157 %dir %{_libdir}/%{name}
158 %{_libdir}/%{name}/%{name}-sharp*
159 %endif

  ViewVC Help
Powered by ViewVC 1.1.30