/[packages]/cauldron/libjpeg/current/SPECS/libjpeg.spec
ViewVC logotype

Annotation of /cauldron/libjpeg/current/SPECS/libjpeg.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 207937 - (hide annotations) (download)
Sun Feb 12 07:53:43 2012 UTC (12 years, 2 months ago) by fwang
File size: 4619 byte(s)
new version 1.2.0
1 blino 910 %define major 8
2     %define libname %mklibname jpeg %{major}
3     %define develname %mklibname -d jpeg
4     %define staticname %mklibname -s -d jpeg
5    
6 fwang 138027 Summary: A MMX/SSE2 accelerated library for manipulating JPEG image files
7 blino 910 Name: libjpeg
8 fwang 138028 Epoch: 1
9 fwang 207937 Version: 1.2.0
10 fwang 138027 Release: %mkrel 1
11     License: wxWidgets
12 blino 910 Group: System/Libraries
13 fwang 138027 URL: http://sourceforge.net/projects/libjpeg-turbo
14     Source0: http://downloads.sourceforge.net/libjpeg-turbo/libjpeg-turbo-%{version}.tar.gz
15 blino 910 # These two allow automatic lossless rotation of JPEG images from a digital
16     # camera which have orientation markings in the EXIF data. After rotation
17     # the orientation markings are reset to avoid duplicate rotation when
18     # applying these programs again.
19     Source2: http://jpegclub.org/jpegexiforient.c
20     Source3: http://jpegclub.org/exifautotran.txt
21 fwang 138027 BuildRequires: nasm
22 blino 910
23     %description
24     The libjpeg package contains a shared library of functions for loading,
25     manipulating and saving JPEG format image files.
26    
27     Install the libjpeg package if you need to manipulate JPEG files. You
28     should also install the jpeg-progs package.
29    
30     %package -n %{libname}
31 fwang 138027 Summary: A MMX/SSE2 accelerated library for manipulating JPEG image files
32 blino 910 Group: System/Libraries
33 fwang 138027 Provides: %{name} = %{epoch}:%{version}-%{release}
34 blino 910
35     %description -n %{libname}
36     This package contains the library needed to run programs dynamically
37 fwang 138027 linked with libjpeg-turbo.
38 blino 910
39     %package -n %{develname}
40     Summary: Development tools for programs which will use the libjpeg library
41     Group: Development/C
42 fwang 138027 Requires: %{libname} = %{epoch}:%{version}
43     Provides: jpeg-devel = %{epoch}:%{version}-%{release}
44     Provides: jpeg%{major}-devel = %{epoch}:%{version}-%{release}
45     Provides: %{name}-devel = %{epoch}:%{version}-%{release}
46     Obsoletes: %{name}-devel < %{epoch}:%{version}-%{release}
47 blino 910 Conflicts: jpeg6-devel
48     Obsoletes: %{mklibname jpeg 62 -d} < 6b-45
49    
50     %description -n %{develname}
51     The libjpeg-devel package includes the header files necessary for
52     developing programs which will manipulate JPEG files using
53     the libjpeg library.
54    
55     If you are going to develop programs which will manipulate JPEG images,
56     you should install libjpeg-devel. You'll also need to have the libjpeg
57     package installed.
58    
59     %package -n %{staticname}
60     Summary: Static libraries for programs which will use the libjpeg library
61     Group: Development/C
62 fwang 138027 Requires: %{develname} = %{epoch}:%{version}-%{release}
63     Provides: %{name}-static-devel = %{epoch}:%{version}-%{release}
64     Provides: jpeg-static-devel = %{epoch}:%{version}-%{release}
65     Provides: jpeg%{major}-static-devel = %{epoch}:%{version}-%{release}
66 blino 910 Conflicts: jpeg6-static-devel
67     Obsoletes: %{mklibname jpeg 62 -d -s} < 6b-45
68     Obsoletes: %{mklibname jpeg 7 -d -s} < 7-3
69    
70     %description -n %{staticname}
71     The libjpeg-devel package includes the static librariesnecessary for
72     developing programs which will manipulate JPEG files using
73     the libjpeg library.
74    
75     If you are going to develop programs which will manipulate JPEG images,
76     you should install libjpeg-devel. You'll also need to have the libjpeg
77     package installed.
78    
79     %package -n jpeg-progs
80     Summary: Programs for manipulating JPEG format image files
81     Group: Graphics
82 fwang 138027 Requires: %{libname} = %{epoch}:%{version}-%{release}
83     Provides: jpeg-progs = %{epoch}:%{version}-%{release}
84     Provides: libjpeg-progs = %{epoch}:%{version}-%{release}
85 blino 910
86     %description -n jpeg-progs
87     The jpeg-progs package contains simple client programs for accessing
88     the libjpeg functions. Libjpeg client programs include cjpeg, djpeg,
89     jpegtran, rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG
90     format. Djpeg decompresses a JPEG file into a regular image file. Jpegtran
91     can perform various useful transformations on JPEG files. Rdjpgcom displays
92     any text comments included in a JPEG file. Wrjpgcom inserts text
93     comments into a JPEG file.
94    
95     %prep
96 fwang 138027 %setup -qn libjpeg-turbo-%{version}
97 blino 910
98     cp %{SOURCE2} jpegexiforient.c
99     cp %{SOURCE3} exifautotran
100    
101     %build
102     %configure2_5x \
103 fwang 138027 --with-jpeg8 \
104 blino 910 --disable-silent-rules \
105     --enable-shared \
106     --enable-static
107    
108     %make
109    
110     gcc %{optflags} -o jpegexiforient jpegexiforient.c
111    
112     LD_PRELOAD=$PWD/.libs/%{name}.so make test
113    
114     %install
115 fwang 138027 %makeinstall_std
116 blino 910
117 fwang 207937 rm -fr %{buildroot}%{_libdir}/*.la %{buildroot}%{_datadir}/doc
118 fwang 159559
119 blino 910 install -m 755 jpegexiforient %{buildroot}%{_bindir}
120     install -m 755 exifautotran %{buildroot}%{_bindir}
121    
122     %files -n %{libname}
123     %doc README change.log coderules.txt filelist.txt install.txt jconfig.txt libjpeg.txt structure.txt usage.txt wizard.txt
124     %{_libdir}/libjpeg.so.%{major}*
125    
126     %files -n %{develname}
127     %doc example.c
128     %{_libdir}/*.so
129     %{_includedir}/*.h
130    
131     %files -n %{staticname}
132     %{_libdir}/*.a
133    
134     %files -n jpeg-progs
135     %{_bindir}/*
136     %{_mandir}/man1/*

  ViewVC Help
Powered by ViewVC 1.1.30