/[packages]/cauldron/libopenshot/current/SPECS/libopenshot.spec
ViewVC logotype

Contents of /cauldron/libopenshot/current/SPECS/libopenshot.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1379457 - (show annotations) (download)
Thu Mar 21 13:02:15 2019 UTC (5 years ago) by daviddavid
File size: 3108 byte(s)
- new version: 2.4.4
- now libmajor is 17

1 %define major 17
2 %define lib_ver 0.2.3
3 %define libname %mklibname openshot %{major}
4 %define devname %mklibname openshot -d
5
6 %define with_ruby 0
7
8 Name: libopenshot
9 Version: 2.4.4
10 Release: %mkrel 1
11 Summary: Library for creating and editing videos
12 License: LGPLv3+
13 Group: System/Libraries
14 URL: http://www.openshot.org/
15 Source0: https://github.com/OpenShot/libopenshot/archive/v%{version}/%{name}-%{version}.tar.gz
16 Patch1: libopenshot-0.2.2-fix-build-with-imagemagick7.patch
17
18 BuildRequires: cmake
19 BuildRequires: cppzmq-devel
20 BuildRequires: doxygen
21 BuildRequires: swig
22 BuildRequires: ffmpeg-devel
23 %if %{with_ruby}
24 BuildRequires: pkgconfig(ruby)
25 %endif
26 BuildRequires: libopenshot-audio-devel >= 0.1.4
27 BuildRequires: pkgconfig(ImageMagick) >= 7.0
28 BuildRequires: pkgconfig(python3)
29 BuildRequires: pkgconfig(UnitTest++)
30 BuildRequires: pkgconfig(Qt5Core)
31 BuildRequires: pkgconfig(Qt5Gui)
32 BuildRequires: pkgconfig(Qt5Help)
33 BuildRequires: pkgconfig(Qt5Multimedia)
34 BuildRequires: pkgconfig(Qt5MultimediaWidgets)
35
36 %description
37 OpenShot Library (libopenshot) is an open-source project
38 dedicated to delivering high quality video editing, animation,
39 and playback solutions to the world. For more information
40 visit <http://www.openshot.org/>.
41
42 #----------------------------------------------------
43
44 %package -n %{libname}
45 Summary: OpenShot Library
46 Group: System/Libraries
47
48 %description -n %{libname}
49 OpenShot Library (libopenshot) is an open-source project
50 dedicated to delivering high quality video editing, animation,
51 and playback solutions to the world. For more information
52 visit <http://www.openshot.org/>.
53 This package contains library files for %{name}.
54
55 #----------------------------------------------------
56
57 %package -n %{devname}
58 Summary: Development files for %{name}
59 Group: Development/C
60 Requires: %{libname} = %{version}-%{release}
61 Provides: %{name}-devel = %{version}-%{release}
62 Provides: openshot-devel = %{version}-%{release}
63
64 %description -n %{devname}
65 The %{devname} package contains libraries and header files for
66 developing applications that use %{name}.
67
68 #----------------------------------------------------
69
70 %package -n python3-%{name}
71 Summary: Python 3 bindings for %{name}
72 Group: Development/Python
73
74 %description -n python3-%{name}
75 The python3-%{name} package contains python 3 bindings for
76 applications that use %{name}.
77
78 #----------------------------------------------------
79 %if %{with_ruby}
80 %package -n ruby-%{name}
81 Summary: Ruby bindings for %{name}
82 Group: Development/Ruby
83
84 %description -n ruby-%{name}
85 The ruby-%{name} package contains ruby bindings for
86 applications that use %{name}.
87 %endif
88 #----------------------------------------------------
89
90 %prep
91 %setup -q
92 %autopatch -p1
93
94 %build
95 %cmake
96 %make_build
97
98 %install
99 %make_install -C build
100
101 %files -n %{libname}
102 %{_libdir}/libopenshot.so.%{major}
103 %{_libdir}/libopenshot.so.%{lib_ver}
104
105 %files -n %{devname}
106 %doc AUTHORS COPYING README.md
107 %{_includedir}/%{name}/
108 %{_libdir}/libopenshot.so
109
110 %files -n python3-%{name}
111 %doc AUTHORS COPYING README.md
112 %{python3_sitearch}/*
113
114 %if %{with_ruby}
115 %files -n ruby-%{name}
116 %{ruby_vendorarchdir}/*
117 %endif

  ViewVC Help
Powered by ViewVC 1.1.30