/[packages]/cauldron/libssh2/current/SPECS/libssh2.spec
ViewVC logotype

Contents of /cauldron/libssh2/current/SPECS/libssh2.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1378823 - (show annotations) (download)
Tue Mar 19 12:09:03 2019 UTC (5 years, 1 month ago) by daviddavid
File size: 2534 byte(s)
- new version: 1.8.1, fixes CVE-2019-385[5-9] and CVE-2019-386[0-3] (mga#24532)
- disable static lib and drop .la files

1 %define rname libssh2
2
3 %define major 1
4 %define libname %mklibname ssh2_ %{major}
5 %define develname %mklibname ssh2 -d
6
7 Summary: A library implementing the SSH2 protocol
8 Name: %{rname}
9 Version: 1.8.1
10 Release: %mkrel 1
11 Group: System/Libraries
12 License: BSD
13 URL: http://www.libssh2.org/
14 Source0: http://www.libssh2.org/download/%{rname}-%{version}.tar.gz
15 Source1: http://www.libssh2.org/download/%{rname}-%{version}.tar.gz.asc
16 BuildRequires: pkgconfig
17 BuildRequires: pkgconfig(openssl) >= 1.1
18 BuildRequires: pkgconfig(zlib)
19 BuildRequires: libtool
20
21 %description
22 libssh2 is a library implementing the SSH2 protocol as defined by Internet
23 Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25), SECSH-CONNECTION(23),
24 SECSH-ARCH(20), SECSH-FILEXFER(06)*, SECSH-DHGEX(04), and SECSH-NUMBERS(10).
25
26 %package -n %{libname}
27 Summary: A library implementing the SSH2 protocol
28 Group: System/Libraries
29
30 %description -n %{libname}
31 libssh2 is a library implementing the SSH2 protocol as defined by Internet
32 Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25), SECSH-CONNECTION(23),
33 SECSH-ARCH(20), SECSH-FILEXFER(06)*, SECSH-DHGEX(04), and SECSH-NUMBERS(10).
34
35 %package -n %{develname}
36 Summary: Static library and header files for the %{rname} library
37 Group: Development/C
38 Provides: %{rname}-devel = %{version}
39 Provides: libssh-devel = %{version}
40 Provides: libssh2-devel = %{version}
41 Provides: ssh2-devel = %{version}
42 Requires: %{libname} = %{version}
43
44 %description -n %{develname}
45 libssh2 is a library implementing the SSH2 protocol as defined by Internet
46 Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25), SECSH-CONNECTION(23),
47 SECSH-ARCH(20), SECSH-FILEXFER(06)*, SECSH-DHGEX(04), and SECSH-NUMBERS(10).
48
49 This package contains the static %{rname} library and its header files.
50
51 %prep
52 %setup -q -n %{rname}-%{version}
53
54 %build
55 %serverbuild
56 %configure2_5x \
57 --disable-static \
58 --without-libgcrypt-prefix \
59 --with-openssl=%{_prefix} \
60 --with-libz=%{_prefix}
61
62 %make_build
63 # The SSH test will fail if we don't have /dev/tty,
64 if [ ! -c /dev/tty ]; then
65 echo Skipping SSH test due to missing /dev/tty
66 echo "exit 0" > tests/ssh2.sh
67 fi
68 # Apparently it fails in the sparc and arm buildsystems too
69 %ifarch %{arm}
70 echo Skipping SSH test on sparc/arm
71 echo "exit 0" > tests/ssh2.sh
72 %endif
73 make -C tests check
74
75 %install
76 %make_install
77
78 find %{buildroot} -name '*.la' -delete
79
80 %files -n %{libname}
81 %doc COPYING ChangeLog NEWS README
82 %{_libdir}/*.so.%{major}{,.*}
83
84 %files -n %{develname}
85 %{_includedir}/*
86 %{_libdir}/*.so
87 %{_mandir}/man3/*
88 %{_libdir}/pkgconfig/*.pc

  ViewVC Help
Powered by ViewVC 1.1.30