/[packages]/cauldron/mascot/current/SPECS/mascot.spec
ViewVC logotype

Annotation of /cauldron/mascot/current/SPECS/mascot.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 285892 - (hide annotations) (download)
Thu Aug 30 19:23:48 2012 UTC (11 years, 7 months ago) by blue_prawn
File size: 3092 byte(s)
imported package mascot
1 blue_prawn 285892 %define libname ocaml-mascot-lib
2    
3     Name: mascot
4     Version: 1.0beta
5     Release: %mkrel 1
6     Summary: Style-checker for OCaml sources
7     License: GPL v3
8     Group: Development/Other
9     URL: http://mascot.x9c.fr/
10     # The 1.0 version requires ocaml 4.00.0 not yet in cauldron.
11     #Source0: http://forge.ocamlcore.org/frs/download.php/990/mascot-%{version}.tar.gz
12     Source0: http://forge.ocamlcore.org/frs/download.php/651/mascot-1.0-beta.tar.gz
13     BuildRequires: ocaml-findlib
14    
15     %description
16     Mascot is a style-checker for OCaml sources. It provides checks in various
17     categories: code, documentation, interface, metrics, and typography. The
18     goal of the tool is to allow a (team of) developer(s) to enforce style
19     properties over a source codebase for greater coherency and style
20     uniformity. The tool is highly customizable, allowing one to choose the
21     checks to perform, as well as exceptions to those checks in given files.
22     Moreover, a plugin system allows the developer to add its own checks, and
23     output modes.
24    
25     Bundled output modes range from bare text to CheckStyle- and
26     JDepend-compatible XML file in order to allow integration with Jenkins.
27    
28     Help:
29     In order to improve the project, I am primarily looking for testers and bug
30     reporters http://bugs.x9c.fr. Pointing errors in documentation and
31     indicating where it should be enhanced is also very helpful. Of course,
32     aside from bugs, you can also use the tracker to request new features.
33    
34     The darcs repository is http://mascot.x9c.fr/_darcs (read-only, useful to
35     always get the last version).
36    
37     %package -n %{libname}
38     Summary: Development files for %{name}
39     Group: Development/Other
40     Requires: %{name} = %{version}-%{release}
41     Requires: ocaml-compilers
42    
43     %description -n %{libname}
44     This package contains libraries and signature files for developing
45     applications with %{name}.
46    
47     %package -n %{libname}-devel
48     Summary: Development files for %{name}
49     Group: Development/Other
50     Requires: %{libname} = %{version}-%{release}
51    
52     %description -n %{libname}-devel
53     This package contains native libraries files for developing
54     applications with %{name}.
55    
56     %prep
57     #setup -q -n mascot-%{version}
58     %setup -q -n mascot-1.0-beta
59    
60     %build
61     sh configure
62     make all
63     make doc
64    
65     %check
66     make tests
67    
68     %install
69     rm -rf %{buildroot}
70     export DESTDIR=%{buildroot}
71     export OCAMLFIND_DESTDIR=%{buildroot}/%{_libdir}/ocaml
72     mkdir -p $OCAMLFIND_DESTDIR/mascot
73     make install PATH_OCAMLFIND="/usr/bin/ocamlfind"
74    
75     # make an easier command line invocation
76     install -d -m 755 %{buildroot}/%{_bindir}
77     pushd %{buildroot}%{_bindir}/
78     ln -s \
79     %{_libdir}/ocaml/mascot/mascot.native \
80     mascot
81     popd
82    
83     %files
84     %doc README COPYING CHANGES FEATURES VERSION
85     %doc doc/
86     %dir %{_libdir}/ocaml/mascot
87     %{_libdir}/ocaml/mascot/META
88     %{_libdir}/ocaml/mascot/mascot.byte
89     %{_libdir}/ocaml/mascot/mascot.native
90     %{_bindir}/mascot
91    
92     %files -n %{libname}
93     %doc tests/
94     %doc ocamldoc/
95     %{_libdir}/ocaml/mascot/*.cmi
96     %{_libdir}/ocaml/mascot/*.cmo
97    
98     %files -n %{libname}-devel
99     %{_libdir}/ocaml/mascot/*.cmx
100     %{_libdir}/ocaml/mascot/*.o

  ViewVC Help
Powered by ViewVC 1.1.30