/[packages]/cauldron/mascot/current/SPECS/mascot.spec
ViewVC logotype

Annotation of /cauldron/mascot/current/SPECS/mascot.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 285904 - (hide annotations) (download)
Thu Aug 30 20:52:34 2012 UTC (11 years, 7 months ago) by blue_prawn
File size: 3121 byte(s)
build requires camlp4
1 blue_prawn 285892 %define libname ocaml-mascot-lib
2    
3     Name: mascot
4     Version: 1.0beta
5     Release: %mkrel 1
6     Summary: Style-checker for OCaml sources
7     License: GPL v3
8     Group: Development/Other
9     URL: http://mascot.x9c.fr/
10     # The 1.0 version requires ocaml 4.00.0 not yet in cauldron.
11     #Source0: http://forge.ocamlcore.org/frs/download.php/990/mascot-%{version}.tar.gz
12     Source0: http://forge.ocamlcore.org/frs/download.php/651/mascot-1.0-beta.tar.gz
13     BuildRequires: ocaml-findlib
14 blue_prawn 285904 BuildRequires: camlp4-devel
15 blue_prawn 285892
16     %description
17     Mascot is a style-checker for OCaml sources. It provides checks in various
18     categories: code, documentation, interface, metrics, and typography. The
19     goal of the tool is to allow a (team of) developer(s) to enforce style
20     properties over a source codebase for greater coherency and style
21     uniformity. The tool is highly customizable, allowing one to choose the
22     checks to perform, as well as exceptions to those checks in given files.
23     Moreover, a plugin system allows the developer to add its own checks, and
24     output modes.
25    
26     Bundled output modes range from bare text to CheckStyle- and
27     JDepend-compatible XML file in order to allow integration with Jenkins.
28    
29     Help:
30     In order to improve the project, I am primarily looking for testers and bug
31     reporters http://bugs.x9c.fr. Pointing errors in documentation and
32     indicating where it should be enhanced is also very helpful. Of course,
33     aside from bugs, you can also use the tracker to request new features.
34    
35     The darcs repository is http://mascot.x9c.fr/_darcs (read-only, useful to
36     always get the last version).
37    
38     %package -n %{libname}
39     Summary: Development files for %{name}
40     Group: Development/Other
41     Requires: %{name} = %{version}-%{release}
42     Requires: ocaml-compilers
43    
44     %description -n %{libname}
45     This package contains libraries and signature files for developing
46     applications with %{name}.
47    
48     %package -n %{libname}-devel
49     Summary: Development files for %{name}
50     Group: Development/Other
51     Requires: %{libname} = %{version}-%{release}
52    
53     %description -n %{libname}-devel
54     This package contains native libraries files for developing
55     applications with %{name}.
56    
57     %prep
58     #setup -q -n mascot-%{version}
59     %setup -q -n mascot-1.0-beta
60    
61     %build
62     sh configure
63     make all
64     make doc
65    
66     %check
67     make tests
68    
69     %install
70     rm -rf %{buildroot}
71     export DESTDIR=%{buildroot}
72     export OCAMLFIND_DESTDIR=%{buildroot}/%{_libdir}/ocaml
73     mkdir -p $OCAMLFIND_DESTDIR/mascot
74     make install PATH_OCAMLFIND="/usr/bin/ocamlfind"
75    
76     # make an easier command line invocation
77     install -d -m 755 %{buildroot}/%{_bindir}
78     pushd %{buildroot}%{_bindir}/
79     ln -s \
80     %{_libdir}/ocaml/mascot/mascot.native \
81     mascot
82     popd
83    
84     %files
85     %doc README COPYING CHANGES FEATURES VERSION
86     %doc doc/
87     %dir %{_libdir}/ocaml/mascot
88     %{_libdir}/ocaml/mascot/META
89     %{_libdir}/ocaml/mascot/mascot.byte
90     %{_libdir}/ocaml/mascot/mascot.native
91     %{_bindir}/mascot
92    
93     %files -n %{libname}
94     %doc tests/
95     %doc ocamldoc/
96     %{_libdir}/ocaml/mascot/*.cmi
97     %{_libdir}/ocaml/mascot/*.cmo
98    
99     %files -n %{libname}-devel
100     %{_libdir}/ocaml/mascot/*.cmx
101     %{_libdir}/ocaml/mascot/*.o

  ViewVC Help
Powered by ViewVC 1.1.30