/[packages]/cauldron/mate-utils/current/SPECS/mate-utils.spec
ViewVC logotype

Contents of /cauldron/mate-utils/current/SPECS/mate-utils.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2051812 - (show annotations) (download)
Sun Mar 24 16:30:01 2024 UTC (4 weeks, 3 days ago) by wally
File size: 7119 byte(s)
- update BRs (SILENT)
1 %define url_ver %(echo %{version}|cut -d. -f1,2)
2
3 %define major 6
4 %define libname %mklibname matedict %{major}
5 %define develname %mklibname -d matedict
6
7 Summary: MATE utility programs such as file search and calculator
8 Name: mate-utils
9 Version: 1.28.0
10 Release: %mkrel 1
11 Group: Graphical desktop/MATE
12 License: GPLv2+ and LGPLv2+
13 URL: https://mate-desktop.org/
14 Source0: https://pub.mate-desktop.org/releases/%{url_ver}/%{name}-%{version}.tar.xz
15 Source1: mate-system-log.wrapper
16 Source2: org.mageia-mate-system-log.policy.in
17
18 BuildRequires: pkgconfig(mate-desktop-2.0) >= %{url_ver}
19 BuildRequires: pkgconfig(glib-2.0)
20 BuildRequires: pkgconfig(ice)
21 BuildRequires: pkgconfig(libgtop-2.0)
22 BuildRequires: pkgconfig(libmatepanelapplet-4.0) >= %{url_ver}
23 BuildRequires: pkgconfig(sm)
24 BuildRequires: pkgconfig(x11)
25 BuildRequires: pkgconfig(xext)
26 BuildRequires: pkgconfig(xmu)
27 BuildRequires: pkgconfig(popt)
28 BuildRequires: pkgconfig(dri)
29 BuildRequires: pkgconfig(librsvg-2.0)
30 BuildRequires: yelp-tools
31 BuildRequires: intltool
32 BuildRequires: itstool
33 BuildRequires: inkscape
34 BuildRequires: librsvg
35 BuildRequires: pkgconfig(gtk+-3.0)
36 BuildRequires: pkgconfig(libcanberra-gtk3)
37 BuildRequires: pkgconfig(udisks2)
38
39 Requires: mate-dictionary = %{version}-%{release}
40 Requires: mate-screenshot = %{version}-%{release}
41 Requires: mate-search-tool = %{version}-%{release}
42 Requires: mate-system-log = %{version}-%{release}
43 Requires: mate-disk-usage-analyzer = %{version}-%{release}
44 Requires: mate-utils-common = %{version}-%{release}
45 Requires: polkit
46
47 %description
48 MATE Desktop utilities is a collection of small applications
49 all there to make your day just that little bit brighter
50 - System Log Viewer, Search Tool, Dictionary.
51
52 %package common
53 Summary: Common files for %{name}
54 BuildArch: noarch
55 Requires: mate-desktop-schemas
56
57 %description common
58 MATE Desktop utilities is a collection of small applications
59 all there to make your day just that little bit brighter
60 - System Log Viewer, Search Tool, Dictionary.
61
62 This package provides common files for Mate Desktop utilities.
63
64 %package -n mate-system-log
65 Summary: A log file viewer for the MATE desktop
66 Requires: %{name}-common = %{version}-%{release}
67
68 %description -n mate-system-log
69 An application that lets you view various system log files.
70
71 %package -n mate-screenshot
72 Summary: A utility to take a screen-shot of the desktop
73 Requires: %{name}-common = %{version}-%{release}
74
75 %description -n mate-screenshot
76 An application that let you take a screen-shot of your desktop.
77
78 %package -n mate-dictionary
79 Summary: A dictionary for MATE Desktop
80 Requires: %{name}-common = %{version}-%{release}
81 Requires: %{libname} = %{version}-%{release}
82
83 %description -n mate-dictionary
84 A dictionary application for MATE Desktop.
85
86 %package -n mate-search-tool
87 Summary: A file searching tool for MATE Desktop
88 Requires: %{name}-common = %{version}-%{release}
89
90 %description -n mate-search-tool
91 An application to search for files on your computer.
92
93 %package -n mate-disk-usage-analyzer
94 Summary: A disk usage analyzing tool for MATE Desktop
95 Requires: %{name}-common = %{version}-%{release}
96
97 %description -n mate-disk-usage-analyzer
98 An application to help analyze disk usage.
99
100 %package -n mate-disk-image-mounter
101 Summary: A disk image mounter for MATE Desktop
102 Requires: %{name}-common = %{version}-%{release}
103
104 %description -n mate-disk-image-mounter
105 An application to mount images.
106
107 %package -n %{libname}
108 Group: System/Libraries
109 Summary:MATE dictionary shared library
110
111 %description -n %{libname}
112 This is the shared library required by the MATE Dictionary.
113
114 %package -n %{develname}
115 Group: Development/C
116 Summary: MATE dictionary library development files
117 Requires: %{libname} = %{version}-%{release}
118 Provides: %{name}-devel = %{version}-%{release}
119
120 %description -n %{develname}
121 Shared library required by the MATE Dictionary.
122
123 %prep
124 %autosetup
125
126 %build
127 %configure \
128 --disable-static \
129 --disable-schemas-compile \
130 --enable-gdict-applet \
131 --enable-ipv6=yes \
132 --with-x
133
134 %make_build
135
136 %install
137 %make_install
138
139 # make mate-system-log use polkit:
140 mkdir -p %{buildroot}%{_libexecdir}
141 mv %{buildroot}%{_bindir}/mate-system-log %{buildroot}%{_libexecdir}
142 install -m 755 %{_sourcedir}/mate-system-log.wrapper %{buildroot}%{_bindir}/mate-system-log
143 install -m 644 -D %{_sourcedir}/org.mageia-mate-system-log.policy.in %{buildroot}%{_datadir}/polkit-1/actions/org.mageia.mate-system-log.policy
144
145 %find_lang %{name} --with-gnome
146 %find_lang mate-disk-usage-analyzer --with-gnome
147 %find_lang mate-dictionary --with-gnome
148 %find_lang mate-search-tool --with-gnome
149 %find_lang mate-system-log --with-gnome
150
151 %files
152
153 %files common -f %{name}.lang
154 %license COPYING COPYING.libs
155 %doc NEWS README*
156
157 %files -n mate-system-log -f mate-system-log.lang
158 %{_bindir}/mate-system-log
159 %{_libexecdir}/mate-system-log
160 %{_datadir}/polkit-1/actions/org.mageia.mate-system-log.policy
161 %{_datadir}/glib-2.0/schemas/org.mate.system-log.gschema.xml
162 %{_datadir}/applications/mate-system-log.desktop
163 %{_datadir}/icons/hicolor/*/apps/mate-system-log.png
164 %{_datadir}/icons/hicolor/scalable/apps/mate-system-log-symbolic.svg
165 %{_mandir}/man1/mate-system-log.1.*
166
167 %files -n mate-screenshot
168 %{_bindir}/mate-screenshot
169 %{_bindir}/mate-panel-screenshot
170 %{_datadir}/applications/mate-screenshot.desktop
171 %{_mandir}/man1/mate-screenshot.1.*
172 %{_mandir}/man1/mate-panel-screenshot.1.*
173 %{_datadir}/glib-2.0/schemas/org.mate.screenshot.gschema.xml
174 %{_datadir}/metainfo/mate-screenshot.appdata.xml
175
176 %files -n mate-dictionary -f mate-dictionary.lang
177 %doc mate-dictionary/AUTHORS
178 %doc mate-dictionary/README*
179 %{_bindir}/mate-dictionary
180 %{_datadir}/applications/mate-dictionary.desktop
181 %{_datadir}/mate-dict/
182 %{_datadir}/mate-dictionary/
183 %{_libexecdir}/mate-dictionary-applet
184 %{_mandir}/man1/mate-dictionary.1.*
185 %{_datadir}/glib-2.0/schemas/org.mate.dictionary.gschema.xml
186 %{_datadir}/mate-panel/applets/org.mate.DictionaryApplet.mate-panel-applet
187 %{_datadir}/dbus-1/services/org.mate.panel.applet.DictionaryAppletFactory.service
188 %{_datadir}/gtk-doc/html/mate-dict
189 %{_datadir}/metainfo/mate-dictionary.appdata.xml
190
191 %files -n mate-search-tool -f mate-search-tool.lang
192 %{_bindir}/mate-search-tool
193 %{_datadir}/applications/mate-search-tool.desktop
194 %{_mandir}/man1/mate-search-tool.1.*
195 %{_datadir}/glib-2.0/schemas/org.mate.search-tool.gschema.xml
196 %{_datadir}/pixmaps/mate-search-tool/
197 %{_datadir}/metainfo/mate-search-tool.appdata.xml
198
199 %files -n mate-disk-usage-analyzer -f mate-disk-usage-analyzer.lang
200 %doc baobab/AUTHORS
201 %doc baobab/README*
202 %{_bindir}/mate-disk-usage-analyzer
203 %{_datadir}/applications/mate-disk-usage-analyzer.desktop
204 %{_mandir}/man1/mate-disk-usage-analyzer.1.*
205 %{_datadir}/glib-2.0/schemas/org.mate.disk-usage-analyzer.gschema.xml
206 %{_datadir}/icons/hicolor/*/apps/mate-disk-usage-analyzer.*
207 %{_datadir}/metainfo/mate-disk-usage-analyzer.appdata.xml
208
209 %files -n mate-disk-image-mounter
210 %{_bindir}/mate-disk-image-mounter
211 %{_datadir}/applications/mate-disk-image-mounter.desktop
212
213 %files -n %{libname}
214 %_libdir/libmatedict.so.%{major}*
215
216 %files -n %{develname}
217 %{_libdir}/libmatedict.so
218 %{_libdir}/pkgconfig/mate-dict*.pc
219 %{_includedir}/mate-dict

  ViewVC Help
Powered by ViewVC 1.1.30