/[packages]/cauldron/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /cauldron/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1174481 - (hide annotations) (download)
Sat Oct 28 18:19:49 2017 UTC (6 years, 5 months ago) by cjw
File size: 20869 byte(s)
- disable x86-specific gallium driver svga for arm builds

1 tv 135155 %if "%distro_section" == "tainted"
2     %global build_plf 1
3     %else
4     %global build_plf 0
5     %endif
6    
7 pterjan 5340 # (cg) Cheater...
8     %define Werror_cflags %nil
9    
10     # (aco) Needed for the dri drivers
11     %define _disable_ld_no_undefined 1
12    
13 ghibo 1066639 # https://cgit.freedesktop.org/mesa/mesa/commit/?h=13.0&id=3bb0415ab96f74183f7aa58c1a543448653ccb3e
14 tmb 400079 %define git 0
15 tmb 1104553 %define git_branch 17.1
16 mikala 112356
17 ghibo 1066639 %define opengl_ver 4.5
18 blino 289598
19 tmb 922766 # define version, RC & release
20 tv 1172771 %define main_version 17.2.3
21 tv 1151285 #define relc 5
22 cjw 1174481 %define rel 4
23 pterjan 5340
24 tv 1140191 %define release %mkrel %{?relc:0.rc%{relc}.}%{rel}
25 pterjan 5340
26     %if %{git}
27 ghibo 1066639 %if %{?relc:1}%{!?relc:0}
28 tv 799294 %define release %mkrel 1~rc%{relc}.1.git%{git}.%{rel}
29 pterjan 5340 %else
30 ghibo 1066639 %define release 1.git%{git}.%{rel}
31 pterjan 5340 %endif
32     %endif
33    
34     %define makedepend %{_bindir}/gccmakedep
35    
36 tv 812143 %define d3dname d3d
37 pterjan 5340 %define eglname mesaegl
38     %define glname mesagl
39     %define glwname mesaglw
40 tv 88442 %define glesv1name mesaglesv1
41     %define glesv2name mesaglesv2
42 mikala 112356 %define glapiname glapi
43 blino 215979 %define gbmname gbm
44     %define waylandeglname wayland-egl
45 tv 634669 %define xaname xatracker
46 akien 1041911 %define vulkanname vulkan
47 tv 88442
48 tv 812143 %define d3dmajor 1
49 pterjan 5340 %define eglmajor 1
50     %define glmajor 1
51     %define glwmajor 1
52 tv 88442 %define glesv1major 1
53     %define glesv2major 2
54 mikala 112356 %define glapimajor 0
55 blino 215979 %define gbmmajor 1
56     %define waylandeglmajor 1
57 blino 289617 %define osmesamajor 8
58 tv 634669 %define xamajor 2
59 tv 88442
60 tv 812143 %define libd3dname %mklibname %{d3dname} %{d3dmajor}
61 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
62     %define libglname %mklibname %{glname} %{glmajor}
63     %define libglwname %mklibname %{glwname} %{glwmajor}
64 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
65     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
66 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
67 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
68     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
69 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
70 tv 634669 %define libxaname %mklibname %{xaname} %{xamajor}
71 akien 1041911 %define libvulkanname %mklibname %{vulkanname}
72 pterjan 5340
73     %define dridrivers %mklibname dri-drivers
74    
75 anssi 278008 %define osmesadevel %mklibname osmesa -d
76    
77 pterjan 5340 # Architecture-independent Virtual provides:
78 tv 812143 %define libd3dname_virt lib%{d3dname}
79 pterjan 5340 %define libeglname_virt lib%{eglname}
80     %define libglname_virt lib%{glname}
81     %define libglwname_virt lib%{glwname}
82 tv 88442 %define libglesv1name_virt lib%{glesv1name}
83     %define libglesv2name_virt lib%{glesv2name}
84 mikala 112356 %define libglapiname_virt lib%{glapiname}
85 blino 215979 %define libgbmname_virt lib%{gbmname}
86     %define libwaylandeglname_virt lib%{waylandeglname}
87 tv 634669 %define libxaname_virt lib%{xaname}
88 pterjan 5340
89     %define oldlibglname %mklibname MesaGL 1
90    
91     %define mesasrcdir %{_prefix}/src/Mesa/
92    
93 akien 1041911 # (akien) Not adding on arm as it would break the build there
94     %define enable_vulkan 0
95     %ifarch %{ix86} x86_64
96     %define enable_vulkan 1
97     %endif
98    
99 tv 1051613 %define base_drivers swrast,nouveau,radeon,r200
100     %ifarch %{ix86} x86_64
101     %define platform_drivers ,i915,i965
102 cjw 1174481 %define gallium_platform_drivers ,svga
103 tv 1051613 %endif
104     %define dri_drivers --with-dri-drivers=%{?base_drivers}%{?platform_drivers}
105 pterjan 5340
106 ovitters 645737 Name: mesa
107 tmb 1039883 Version: %{main_version}
108 pterjan 5340 Release: %{release}
109 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
110 pterjan 5340 Group: System/Libraries
111    
112 tmb 1095010 # temp force new gcc
113     BuildRequires: gcc >= 5.4.0-2
114    
115 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
116 tv 585816 BuildRequires: pkgconfig(xshmfence)
117 mikala 127466 BuildRequires: pkgconfig(xt) >= 1.0.5
118     BuildRequires: pkgconfig(xmu) >= 1.0.3
119     BuildRequires: pkgconfig(x11) >= 1.3.3
120     BuildRequires: pkgconfig(xdamage) >= 1.1.1
121 ovitters 1145130 BuildRequires: pkgconfig(expat) >= 2.0.1
122 pterjan 5340 BuildRequires: gccmakedep
123     BuildRequires: x11-proto-devel >= 7.3
124 tmb 837893 BuildRequires: pkgconfig(libdrm) >= 2.4.60
125 tv 585825 BuildRequires: pkgconfig(xcb-dri3)
126 blino 659717 BuildRequires: pkgconfig(xcb-present) >= 1.11
127 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
128     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
129     BuildRequires: pkgconfig(xi) >= 1.3
130     BuildRequires: pkgconfig(talloc)
131 tv 88443 BuildRequires: libxml2-python
132 tmb 920659 BuildRequires: python-mako
133 tmb 35532 BuildRequires: makedepend
134 tmb 920659 BuildRequires: bison
135 ovitters 645737 BuildRequires: flex
136 ovitters 1145130 BuildRequires: pkgconfig(libelf)
137 tmb 1095010 BuildRequires: llvm-devel >= 3.9.1-5
138 mikala 127466 BuildRequires: pkgconfig(libudev)
139 tv 812142 BuildRequires: pkgconfig(libva)
140 blino 270761 BuildRequires: pkgconfig(vdpau)
141 blino 215979 BuildRequires: wayland-devel
142 tmb 1041913 %if %{enable_vulkan}
143     BuildRequires: libgcrypt-devel
144     %endif
145 ovitters 1145130 BuildRequires: pkgconfig(wayland-protocols) >= 1.8
146 pterjan 5340
147     URL: http://www.mesa3d.org
148     %if %{git}
149 ghibo 1066639 #Source0: %{name}-%{git}.tar.bz2
150     # (blino) snapshot of 13.0 branch
151     Source0: %{name}-%{git_branch}-%{git}.tar.xz
152 pterjan 5340 %else
153 tmb 1107908 Source0: https://mesa.freedesktop.org/archive/mesa-%{main_version}%{?relc:-rc%{relc}}.tar.xz
154 pterjan 5340 %endif
155     Source3: make-git-snapshot.sh
156    
157     # Instructions to setup your repository clone
158     # git://git.freedesktop.org/git/mesa/mesa
159     # git checkout mesa_7_5_branch
160     # git branch mdv-cherry-picks
161     # git am ../02??-*.patch
162     # git branch mdv-redhat
163     # git am ../03??-*.patch
164     # git branch mdv-patches
165     # git am ../09??-*.patch
166     # In order to update to the branch via patches, issue this command:
167     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
168    
169     # Cherry picks
170     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
171 tmb 411326
172 tv 88247 # Patches "liberated" from Fedora:
173 tv 1051664 # http://pkgs.fedoraproject.org/cgit/rpms/mesa.git/
174 pterjan 5340 # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
175    
176 tv 1173701 # https://cgit.freedesktop.org/~ajax/mesa/log/?h=mesa-17.2-s3tc
177     Patch0: 0001-mesa-Squash-merge-of-S3TC-support.patch
178    
179 blino 278732 # Patches from ChromiumOS
180     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
181    
182 blino 271493 # Mageia/Mandriva patches
183 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
184    
185 tv 88440 #------------------------------------------------------------------------------
186    
187     # package mesa
188 pterjan 5340 License: MIT
189     Requires: %{libglname} = %{version}-%{release}
190     Provides: hackMesa = %{version}
191     Obsoletes: hackMesa <= %{version}
192     Provides: Mesa = %{version}
193     Obsoletes: Mesa < %{version}
194    
195     %package -n %{libglname}
196     Summary: Files for Mesa (GL and GLX libs)
197     Group: System/Libraries
198 tv 88247 Obsoletes: %{oldlibglname} < 6.4
199 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
200     Provides: %{libglname_virt} = %{version}-%{release}
201     Requires: %{dridrivers} >= %{version}-%{release}
202    
203     # (anssi) Forces the upgrade of x11-server-common to happen before
204     # alternatives removal, which allows x11-server-common to grab the symlink.
205     Conflicts: x11-server-common < 1.3.0.0-17
206    
207     %package -n %{dridrivers}
208     Summary: Mesa DRI drivers
209     Group: System/Libraries
210 blino 274132 # do not require exact release to avoid conflicts when having
211     # x86_64 dri drivers from tainted and i586 dri drivers from core
212     Requires: mesa = %{version}
213 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
214 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
215     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
216 pterjan 5340
217 tv 812143 %package -n %{libd3dname}
218     Summary: Mesa Direct3D9 state tracker
219     Group: System/Libraries
220     Provides: %{libd3dname_virt} = %{version}-%{release}
221    
222     %package -n %{libd3dname}-devel
223     Summary: Development files for Mesa Direct3D9 state tracker
224     Group: Development/C
225     Requires: %{libd3dname} = %{version}-%{release}
226     Provides: lib%{d3dname}-devel
227     Provides: %{d3dname}-devel
228     Provides: libd3d-devel
229    
230 pterjan 5340 %package -n %{libglname}-devel
231     Summary: Development files for Mesa (OpenGL compatible 3D lib)
232     Group: Development/C
233 tv 88237 Requires: %{libglname} = %{version}-%{release}
234 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
235     Provides: %{glname}-devel = %{version}-%{release}
236     Provides: GL-devel
237     Obsoletes: %{oldlibglname}-devel < 6.4
238     Provides: %{oldlibglname}-devel = %{version}-%{release}
239     Provides: libMesaGL-devel = %{version}-%{release}
240     Provides: MesaGL-devel = %{version}-%{release}
241 tv 88438 Provides: libgl-devel
242 pterjan 5340
243 tv 88433 %package -n %{libeglname}
244     Summary: Files for Mesa (EGL libs)
245     Group: System/Libraries
246     Provides: %{libeglname_virt} = %{version}-%{release}
247    
248     %package -n %{libeglname}-devel
249     Summary: Development files for Mesa (EGL libs)
250     Group: Development/C
251 tv 88439 Requires: %{libeglname} = %{version}-%{release}
252 tv 88433 Provides: EGL-devel
253 tv 88438 Provides: lib%{eglname}-devel
254     Provides: %{eglname}-devel
255     Provides: libegl-devel
256 tv 88433
257 anssi 278008 %package -n %{libosmesaname}
258     Summary: Mesa offscreen rendering library
259     Group: System/Libraries
260    
261     %package -n %{osmesadevel}
262     Summary: Development files for libosmesa
263     Group: Development/C
264     Requires: %{libosmesaname} = %{version}-%{release}
265     Provides: osmesa-devel = %{version}-%{release}
266     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
267    
268 mikala 112356 %package -n %{libglapiname}
269     Summary: Files for mesa (glapi libs)
270     Group: System/Libraries
271     Provides: %{libglapiname_virt} = %{version}-%{release}
272 tv 88442
273 mikala 112356 %package -n %{libglapiname}-devel
274     Summary: Development files for glapi libs
275     Group: Development/C
276     Requires: %{libglapiname_virt} = %{version}-%{release}
277     Provides: lib%{glapiname}-devel
278     Provides: %{libglapiname}-devel
279    
280 tv 88442 %package -n %{libglesv1name}
281     Summary: Files for Mesa (glesv1 libs)
282     Group: System/Libraries
283     Provides: %{libglesv1name_virt} = %{version}-%{release}
284    
285     %package -n %{libglesv1name}-devel
286     Summary: Development files for glesv1 libs
287     Group: Development/C
288     Requires: %{libglesv1name} = %{version}-%{release}
289     Provides: lib%{glesv1name}-devel
290     Provides: %{glesv1name}-devel
291     Provides: libglesv1-devel
292    
293     %package -n %{libglesv2name}
294     Summary: Files for Mesa (glesv2 libs)
295     Group: System/Libraries
296     Provides: %{libglesv2name_virt} = %{version}-%{release}
297    
298     %package -n %{libglesv2name}-devel
299     Summary: Development files for glesv2 libs
300     Group: Development/C
301     Requires: %{libglesv2name} = %{version}-%{release}
302 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
303 tv 88442 Provides: lib%{glesv2name}-devel
304     Provides: %{glesv2name}-devel
305     Provides: libglesv2-devel
306    
307 blino 215979 %package -n %{libgbmname}
308     Summary: Files for Mesa (gbm libs)
309     Group: System/Libraries
310     Provides: %{libgbmname_virt} = %{version}-%{release}
311    
312     %package -n %{libgbmname}-devel
313     Summary: Development files for Mesa (gbm libs)
314     Group: Development/C
315     Requires: %{libgbmname} = %{version}-%{release}
316     Provides: lib%{gbmname}-devel
317     Provides: %{gbmname}-devel
318    
319     %package -n %{libwaylandeglname}
320     Summary: Files for Mesa (Wayland EGL libs)
321     Group: System/Libraries
322     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
323    
324     %package -n %{libwaylandeglname}-devel
325     Summary: Development files for Mesa (Wayland EGL libs)
326     Group: Development/C
327     Requires: %{libwaylandeglname} = %{version}-%{release}
328     Provides: lib%{waylandeglname}-devel
329     Provides: %{waylandeglname}-devel
330    
331 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
332 blino 270761 Summary: VDPAU plugin for nouveau driver
333 blino 300616 Group: System/Libraries
334 tv 302568 # temporary:
335     %rename vdpau-driver-nouveau
336 blino 270761
337 tv 799259 %package -n %{_lib}vdpau-driver-r300
338     Summary: VDPAU plugin for r300 driver
339     Group: System/Libraries
340     # temporary:
341     %rename vdpau-driver-r300
342    
343 tv 301233 %package -n %{_lib}vdpau-driver-r600
344 blino 270761 Summary: VDPAU plugin for r600 driver
345 blino 300616 Group: System/Libraries
346 tv 302568 # temporary:
347     %rename vdpau-driver-r600
348 blino 270761
349 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
350 blino 289282 Summary: VDPAU plugin for radeonsi driver
351     Group: System/Libraries
352 tv 302568 # temporary:
353     %rename vdpau-driver-radeonsi
354 blino 289282
355 tv 634669 %package -n %{libxaname}
356     Summary: Files for Mesa XA state tracker
357     Group: System/Libraries
358     Provides: %{libxaname_virt} = %{version}-%{release}
359    
360     %package -n %{libxaname}-devel
361     Summary: Development files for XA libs
362     Group: Development/C
363     Requires: %{libxaname_virt} = %{version}-%{release}
364     Provides: lib%{xaname}-devel
365     Provides: %{libxaname}-devel
366    
367 akien 1041911 %if %{enable_vulkan}
368     %package -n %{libvulkanname}_intel
369     Summary: Mesa vulkan driver for Intel GPU
370     Group: System/Libraries
371    
372 akien 1099595 %package -n %{libvulkanname}_radeon
373     Summary: Mesa vulkan driver for Radeon GPU
374     Group: System/Libraries
375    
376 akien 1041911 %package -n %{libvulkanname}-devel
377     Summary: Mesa's Vulkan development files
378     Group: Development/C
379     Requires: %{libvulkanname}_intel = %{version}-%{release}
380     Provides: libvulkan-devel
381     Provides: libvulkan_intel-devel
382     %endif
383    
384 pterjan 5340 %package common-devel
385     Summary: Meta package for mesa devel
386     Group: Development/C
387 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
388 pterjan 5340 Provides: hackMesa-common-devel = %{version}
389 tv 88247 Obsoletes: Mesa-common-devel < %{version}
390 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
391     Requires: %{libglname}-devel = %{version}
392 blino 289355 Requires: mesaglu-devel
393 tv 135156 Requires: freeglut-devel
394 tv 88442 Requires: %{libeglname}-devel = %{version}
395     Requires: %{libglesv1name}-devel = %{version}
396     Requires: %{libglesv2name}-devel = %{version}
397 pterjan 5340
398 tv 88440 #------------------------------------------------------------------------------
399 pterjan 5340
400     %description
401 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
402 pterjan 5340
403     %description common-devel
404     Mesa common metapackage devel
405    
406     %description -n %{libeglname}
407 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
408 pterjan 5340 EGL parts.
409    
410     %description -n %{libeglname}-devel
411 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
412 pterjan 5340 EGL development parts.
413    
414     %description -n %{libglname}
415 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
416 pterjan 5340 GL and GLX parts.
417    
418     %description -n %{dridrivers}
419 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
420 pterjan 5340 DRI drivers.
421    
422     %description -n %{libglname}-devel
423 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
424 pterjan 5340
425     This package contains the headers needed to compile Mesa programs.
426    
427 tv 88442 %description -n %{libglesv1name}
428     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
429     well-defined subset profiles of OpenGL.
430    
431     This package provides the OpenGL ES library version 1.
432    
433 anssi 278008 %description -n %{libosmesaname}
434     Mesa offscreen rendering libraries for rendering OpenGL into
435     application-allocated blocks of memory.
436    
437     %description -n %{osmesadevel}
438     This package contains the headers needed to compile programs against
439     the Mesa offscreen rendering library.
440    
441 mikala 112356 %description -n %{libglapiname}
442     This packages provides the glapi shared library used by gallium.
443    
444     %description -n %{libglapiname}-devel
445     This package contains the headers needed to compile programes against glapi shared library.
446    
447 tv 88442 %description -n %{libglesv1name}-devel
448     This package contains the headers needed to compile OpenGL ES 1 programs.
449    
450 tv 812143 %description -n %{libd3dname}
451     Mesa Direct3D9 state tracker.
452    
453     %description -n %{libd3dname}-devel
454     Mesa Direct3D9 state tracker development package.
455    
456 tv 88442 %description -n %{libglesv2name}
457     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
458     well-defined subset profiles of OpenGL.
459    
460     This package provides the OpenGL ES library version 2.
461    
462     %description -n %{libglesv2name}-devel
463     This package contains the headers needed to compile OpenGL ES 2 programs.
464    
465 blino 215979 %description -n %{libgbmname}
466 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
467 blino 215979 GBM (Graphics Buffer Manager) parts.
468    
469     %description -n %{libgbmname}-devel
470 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
471 blino 215979 GBM (Graphics Buffer Manager) development parts.
472    
473     %description -n %{libwaylandeglname}
474 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
475 blino 215979 Wayland EGL platform parts.
476    
477     %description -n %{libwaylandeglname}-devel
478 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
479 blino 215979 Wayland EGL platform development parts.
480    
481 tv 634669 %description -n %{libxaname}
482     This packages provides the xa shared library used by gallium.
483    
484     %description -n %{libxaname}-devel
485     This package contains the headers needed to compile programes against xa shared library.
486    
487 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
488 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
489     with the nouveau driver.
490    
491 tv 799259 %description -n %{_lib}vdpau-driver-r300
492     This packages provides a VPDAU plugin to enable video acceleration
493     with the r300 driver.
494    
495 tv 301233 %description -n %{_lib}vdpau-driver-r600
496 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
497     with the r600 driver.
498    
499 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
500 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
501     with the radeonsi driver.
502    
503 akien 1041911 %if %{enable_vulkan}
504     %description -n %{libvulkanname}_intel
505     This package contains the Vulkan parts for Mesa's Intel driver.
506    
507 akien 1099595 %description -n %{libvulkanname}_radeon
508     This package contains the Vulkan parts for Mesa's Radeon driver.
509    
510 akien 1041911 %description -n %{libvulkanname}-devel
511     This package contains the development files for Mesa's Vulkan implementation.
512     %endif
513    
514 tv 88440 #------------------------------------------------------------------------------
515    
516 pterjan 5340 %prep
517 akien 1099119 %autosetup -n %{name}-%{version}%{?relc:-rc%{relc}} -p1
518 pterjan 5340
519 tv 1173701 # this is a hack for S3TC support. r200_screen.c is symlinked to
520     # radeon_screen.c in git, but is its own file in the tarball.
521     cp -f src/mesa/drivers/dri/{radeon,r200}/radeon_screen.c
522    
523 pterjan 5340 %build
524 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
525     autoreconf -vfi
526    
527 tv 551068 # for bin/test-driver:
528     automake --add-missing
529    
530 tv 1051650 %configure2_5x \
531 akien 1041911 %if %{enable_vulkan}
532 akien 1099595 --with-vulkan-drivers=intel,radeon \
533 akien 1041911 %endif
534 tv 1051646 --enable-gallium-osmesa \
535 tv 1051650 --with-dri-driverdir=%{_libdir}/dri \
536 pterjan 5340 --enable-egl \
537 tv 88442 --enable-gles1 \
538     --enable-gles2 \
539 blino 270761 --disable-xvmc \
540     --enable-vdpau \
541 tv 1051650 --enable-va \
542 tv 1140192 --with-platforms=x11,wayland,drm \
543 tv 1051650 --enable-shared-glapi \
544     --enable-gbm \
545     --enable-glx \
546     --enable-glx-tls \
547     --enable-texture-float=yes \
548 tv 1140192 --enable-llvm \
549 tv 1051650 --enable-dri \
550 tv 634669 --enable-xa \
551 blino 897332 --enable-nine \
552 cjw 1174481 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast,virgl%{?gallium_platform_drivers} \
553 tv 1051613 %{?dri_drivers}
554 blino 270723 # end of configure options
555 pterjan 5340
556 anssi 332631
557 anssi 165988 %make
558 pterjan 5340
559     %install
560 tv 1051611 %make_install
561 pterjan 5340
562 blino 216556 # FIXME: strip will likely break the hardlink
563 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
564     # to prevent proprietary driver installers from removing them
565     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
566     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
567     for l in ../libGL.so.*; do cp -a $l .; done
568     popd
569    
570     %ifarch %{x86_64}
571     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
572     %endif
573    
574 tv 1051623 # libvdpau opens the versioned name, don't bother including the unversioned
575     rm -f %{buildroot}%{_libdir}/vdpau/*.so
576 blino 270761
577 tv 1051625 # strip out useless headers
578     rm -f %{buildroot}%{_includedir}/GL/w*.h
579    
580 tv 1051622 # remove .la files
581 tv 881746 find %{buildroot} -name '*.la' -delete
582 blino 271144
583 tv 88440 #------------------------------------------------------------------------------
584    
585 pterjan 5340 %files
586 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
587 pterjan 5340
588     %files -n %{dridrivers}
589     %dir %{_libdir}/dri
590     %{_libdir}/dri/*_dri.so
591 tv 812142 %{_libdir}/dri/*_drv*.so
592 pterjan 5340
593 tv 88433 %files -n %{libglname}
594     %{_libdir}/libGL.so.*
595     %dir %{_libdir}/mesa
596 ovitters 877635 %{_libdir}/mesa/libGL.so.%{glmajor}{,.*}
597 tv 88433
598     %files -n %{libeglname}
599 ovitters 877635 %{_libdir}/libEGL.so.%{eglmajor}{,.*}
600 tv 88433
601 anssi 278008 %files -n %{libosmesaname}
602 ovitters 877635 %{_libdir}/libOSMesa.so.%{osmesamajor}{,.*}
603 anssi 278008
604 mikala 112356 %files -n %{libglapiname}
605 ovitters 877635 %{_libdir}/libglapi.so.%{glapimajor}{,.*}
606 mikala 112356
607 tv 88442 %files -n %{libglesv1name}
608 ovitters 877635 %{_libdir}/libGLESv1_CM.so.%{glesv1major}{,.*}
609 tv 88442
610 tv 812143 %files -n %{libd3dname}
611     %{_libdir}/d3d/*.so.*
612    
613 tv 88442 %files -n %{libglesv2name}
614 ovitters 877635 %{_libdir}/libGLESv2.so.%{glesv2major}{,.*}
615 tv 88442
616 blino 215979 %files -n %{libgbmname}
617     %{_libdir}/libgbm.so.%{gbmmajor}
618 ovitters 878590 %{_libdir}/libgbm.so.%{gbmmajor}.*
619 tv 88445
620 blino 215979 %files -n %{libwaylandeglname}
621     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
622 ovitters 878590 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
623 blino 215979
624 tv 634669 %files -n %{libxaname}
625 ovitters 877635 %{_libdir}/libxatracker.so.%{xamajor}{,.*}
626 blino 215979
627 pterjan 5340 %files -n %{libglname}-devel
628 anssi 278008 %dir %{_includedir}/GL
629 pterjan 5340 %{_includedir}/GL/gl.h
630 tv 1051618 %{_includedir}/GL/gl_mangle.h
631 pterjan 5340 %{_includedir}/GL/glext.h
632     %{_includedir}/GL/glx.h
633 tv 1051618 %{_includedir}/GL/glx_mangle.h
634 pterjan 5340 %{_includedir}/GL/glxext.h
635 tv 1051618 %{_includedir}/GL/glcorearb.h
636     %dir %{_includedir}/GL/internal
637     %{_includedir}/GL/internal/dri_interface.h
638     %{_libdir}/pkgconfig/dri.pc
639 pterjan 5340 %{_libdir}/libGL.so
640 tv 88436 %{_libdir}/pkgconfig/gl.pc
641 pterjan 5340
642     %files common-devel
643 tv 1051614
644 tv 88433 %files -n %{libeglname}-devel
645 tv 88442 %{_includedir}/EGL
646     %{_includedir}/KHR
647 tv 88433 %{_libdir}/libEGL.so
648 tv 88436 %{_libdir}/pkgconfig/egl.pc
649 pterjan 5340
650 anssi 278008 %files -n %{osmesadevel}
651     %dir %{_includedir}/GL
652     %{_includedir}/GL/osmesa.h
653     %{_libdir}/libOSMesa.so
654     %{_libdir}/pkgconfig/osmesa.pc
655    
656 mikala 112356 %files -n %{libglapiname}-devel
657     %{_libdir}/libglapi.so
658 pterjan 5340
659 tv 88442 %files -n %{libglesv1name}-devel
660     %{_includedir}/GLES
661     %{_libdir}/libGLESv1_CM.so
662     %{_libdir}/pkgconfig/glesv1_cm.pc
663 tv 88433
664 tv 88442 %files -n %{libglesv2name}-devel
665     %{_includedir}/GLES2
666 cjw 336175 %{_includedir}/GLES3
667 tv 88442 %{_libdir}/libGLESv2.so
668     %{_libdir}/pkgconfig/glesv2.pc
669 tv 88445
670 tv 812143 %files -n %{libd3dname}-devel
671     %{_includedir}/d3dadapter
672     %{_libdir}/d3d/*.so
673     %{_libdir}/pkgconfig/d3d.pc
674    
675 blino 215979 %files -n %{libgbmname}-devel
676 tv 1051618 %{_libdir}/libgbm.so
677 blino 215979 %{_includedir}/gbm.h
678     %{_libdir}/pkgconfig/gbm.pc
679    
680     %files -n %{libwaylandeglname}-devel
681     %{_libdir}/libwayland-egl.so
682     %{_libdir}/pkgconfig/wayland-egl.pc
683 blino 270761
684 tv 634669 %files -n %{libxaname}-devel
685     %{_libdir}/libxatracker.so
686     %{_includedir}/xa_tracker.h
687     %{_includedir}/xa_composite.h
688     %{_includedir}/xa_context.h
689     %{_libdir}/pkgconfig/xatracker.pc
690    
691 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
692 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
693    
694 tv 799259 %files -n %{_lib}vdpau-driver-r300
695     %{_libdir}/vdpau/libvdpau_r300.so.*
696    
697 tv 301233 %files -n %{_lib}vdpau-driver-r600
698 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
699    
700 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
701 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
702 akien 1041911
703     %if %{enable_vulkan}
704     %files -n %{libvulkanname}_intel
705     %dir %{_datadir}/vulkan
706     %dir %{_datadir}/vulkan/icd.d
707 ghibo 1065537 %{_datadir}/vulkan/icd.d/intel_icd*.json
708 akien 1041911 # (akien) No lib major?
709     %{_libdir}/libvulkan_intel.so
710    
711 akien 1099595 %files -n %{libvulkanname}_radeon
712     %dir %{_datadir}/vulkan
713     %dir %{_datadir}/vulkan/icd.d
714     %{_datadir}/vulkan/icd.d/radeon_icd*.json
715     # (akien) No lib major?
716     %{_libdir}/libvulkan_radeon.so
717    
718 akien 1041911 %files -n %{libvulkanname}-devel
719     %{_includedir}/vulkan/
720     %endif

  ViewVC Help
Powered by ViewVC 1.1.30