/[packages]/cauldron/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /cauldron/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1333396 - (hide annotations) (download)
Thu Nov 22 20:09:55 2018 UTC (5 years, 5 months ago) by tmb
File size: 20450 byte(s)
update to 18.3.0-rc4
1 pterjan 5340 # (cg) Cheater...
2     %define Werror_cflags %nil
3    
4     # (aco) Needed for the dri drivers
5     %define _disable_ld_no_undefined 1
6    
7 ghibo 1066639 # https://cgit.freedesktop.org/mesa/mesa/commit/?h=13.0&id=3bb0415ab96f74183f7aa58c1a543448653ccb3e
8 tmb 400079 %define git 0
9 tv 1198003 %define git_branch 18.0
10 mikala 112356
11 ghibo 1066639 %define opengl_ver 4.5
12 blino 289598
13 tmb 922766 # define version, RC & release
14 tv 1328786 %define main_version 18.3.0
15 tmb 1333396 %define relc 4
16 tmb 1317962 %define rel 1
17 pterjan 5340
18 tv 1140191 %define release %mkrel %{?relc:0.rc%{relc}.}%{rel}
19 pterjan 5340
20     %if %{git}
21 ghibo 1066639 %if %{?relc:1}%{!?relc:0}
22 tv 799294 %define release %mkrel 1~rc%{relc}.1.git%{git}.%{rel}
23 pterjan 5340 %else
24 ghibo 1066639 %define release 1.git%{git}.%{rel}
25 pterjan 5340 %endif
26     %endif
27    
28     %define makedepend %{_bindir}/gccmakedep
29    
30 tv 812143 %define d3dname d3d
31 pterjan 5340 %define eglname mesaegl
32     %define glname mesagl
33     %define glwname mesaglw
34 tv 88442 %define glesv1name mesaglesv1
35     %define glesv2name mesaglesv2
36 mikala 112356 %define glapiname glapi
37 blino 215979 %define gbmname gbm
38     %define waylandeglname wayland-egl
39 tv 634669 %define xaname xatracker
40 akien 1041911 %define vulkanname vulkan
41 tv 88442
42 tv 812143 %define d3dmajor 1
43 pterjan 5340 %define eglmajor 1
44     %define glmajor 1
45     %define glwmajor 1
46 tv 88442 %define glesv1major 1
47     %define glesv2major 2
48 mikala 112356 %define glapimajor 0
49 blino 215979 %define gbmmajor 1
50     %define waylandeglmajor 1
51 blino 289617 %define osmesamajor 8
52 tv 634669 %define xamajor 2
53 tv 88442
54 tv 812143 %define libd3dname %mklibname %{d3dname} %{d3dmajor}
55 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
56     %define libglname %mklibname %{glname} %{glmajor}
57     %define libglwname %mklibname %{glwname} %{glwmajor}
58 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
59     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
60 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
61 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
62     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
63 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
64 tv 634669 %define libxaname %mklibname %{xaname} %{xamajor}
65 akien 1041911 %define libvulkanname %mklibname %{vulkanname}
66 pterjan 5340
67     %define dridrivers %mklibname dri-drivers
68    
69 anssi 278008 %define osmesadevel %mklibname osmesa -d
70    
71 pterjan 5340 # Architecture-independent Virtual provides:
72 tv 812143 %define libd3dname_virt lib%{d3dname}
73 pterjan 5340 %define libeglname_virt lib%{eglname}
74     %define libglname_virt lib%{glname}
75     %define libglwname_virt lib%{glwname}
76 tv 88442 %define libglesv1name_virt lib%{glesv1name}
77     %define libglesv2name_virt lib%{glesv2name}
78 mikala 112356 %define libglapiname_virt lib%{glapiname}
79 blino 215979 %define libgbmname_virt lib%{gbmname}
80     %define libwaylandeglname_virt lib%{waylandeglname}
81 tv 634669 %define libxaname_virt lib%{xaname}
82 pterjan 5340
83     %define oldlibglname %mklibname MesaGL 1
84    
85     %define mesasrcdir %{_prefix}/src/Mesa/
86    
87 tv 1217642 %define with_vaapi 1
88 tv 1217640
89 akien 1041911 # (akien) Not adding on arm as it would break the build there
90     %define enable_vulkan 0
91     %ifarch %{ix86} x86_64
92     %define enable_vulkan 1
93     %endif
94    
95 neoclust 1216966
96     %ifarch %{arm} aarch64
97     %define with_etnaviv 1
98     %define with_freedreno 1
99     %define with_vc4 1
100     %endif
101    
102 tv 1051613 %define base_drivers swrast,nouveau,radeon,r200
103     %ifarch %{ix86} x86_64
104     %define platform_drivers ,i915,i965
105 cjw 1174481 %define gallium_platform_drivers ,svga
106 tv 1051613 %endif
107 tv 1219406
108     %define with_wayland_egl 0
109    
110 tv 1051613 %define dri_drivers --with-dri-drivers=%{?base_drivers}%{?platform_drivers}
111 pterjan 5340
112 ovitters 645737 Name: mesa
113 tmb 1039883 Version: %{main_version}
114 pterjan 5340 Release: %{release}
115 blino 289598 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
116 pterjan 5340 Group: System/Libraries
117    
118 tmb 1095010 # temp force new gcc
119     BuildRequires: gcc >= 5.4.0-2
120    
121 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
122 tv 585816 BuildRequires: pkgconfig(xshmfence)
123 mikala 127466 BuildRequires: pkgconfig(xt) >= 1.0.5
124     BuildRequires: pkgconfig(xmu) >= 1.0.3
125     BuildRequires: pkgconfig(x11) >= 1.3.3
126     BuildRequires: pkgconfig(xdamage) >= 1.1.1
127 ovitters 1145130 BuildRequires: pkgconfig(expat) >= 2.0.1
128 pterjan 5340 BuildRequires: gccmakedep
129     BuildRequires: x11-proto-devel >= 7.3
130 tmb 1211143 BuildRequires: pkgconfig(libdrm) >= 2.4.91
131 tv 585825 BuildRequires: pkgconfig(xcb-dri3)
132 blino 659717 BuildRequires: pkgconfig(xcb-present) >= 1.11
133 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
134     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
135     BuildRequires: pkgconfig(xi) >= 1.3
136 tv 1253321 BuildRequires: pkgconfig(xrandr)
137 mikala 127466 BuildRequires: pkgconfig(talloc)
138 tv 1224299 BuildRequires: python2-libxml2
139     BuildRequires: python2-mako
140 tv 1213070 BuildRequires: python3-libxml2
141     BuildRequires: python3-mako
142 tmb 35532 BuildRequires: makedepend
143 tmb 920659 BuildRequires: bison
144 ovitters 645737 BuildRequires: flex
145 ovitters 1145130 BuildRequires: pkgconfig(libelf)
146 tmb 1095010 BuildRequires: llvm-devel >= 3.9.1-5
147 mikala 127466 BuildRequires: pkgconfig(libudev)
148 tv 1217640 %if 0%{?with_vaapi}
149 tv 812142 BuildRequires: pkgconfig(libva)
150 tv 1217640 %endif
151 blino 270761 BuildRequires: pkgconfig(vdpau)
152 tv 1214970 BuildRequires: pkgconfig(wayland-client)
153     BuildRequires: pkgconfig(wayland-server)
154     BuildRequires: pkgconfig(wayland-protocols)
155 tmb 1041913 %if %{enable_vulkan}
156     BuildRequires: libgcrypt-devel
157     %endif
158 ovitters 1145130 BuildRequires: pkgconfig(wayland-protocols) >= 1.8
159 pterjan 5340
160     URL: http://www.mesa3d.org
161     %if %{git}
162 ghibo 1066639 #Source0: %{name}-%{git}.tar.bz2
163     # (blino) snapshot of 13.0 branch
164     Source0: %{name}-%{git_branch}-%{git}.tar.xz
165 pterjan 5340 %else
166 tmb 1107908 Source0: https://mesa.freedesktop.org/archive/mesa-%{main_version}%{?relc:-rc%{relc}}.tar.xz
167 pterjan 5340 %endif
168     Source3: make-git-snapshot.sh
169    
170 tv 1329069 Patch0: fix-linking.patch
171    
172 tmb 1257897 # mesa staging/18.2 branch from 1
173 pterjan 5340
174 tmb 1257893 # mesa master branch from 101
175 tmb 411326
176 pterjan 5340
177 tv 88440 #------------------------------------------------------------------------------
178    
179     # package mesa
180 pterjan 5340 License: MIT
181     Requires: %{libglname} = %{version}-%{release}
182     Provides: hackMesa = %{version}
183     Obsoletes: hackMesa <= %{version}
184     Provides: Mesa = %{version}
185     Obsoletes: Mesa < %{version}
186    
187     %package -n %{libglname}
188     Summary: Files for Mesa (GL and GLX libs)
189     Group: System/Libraries
190 tv 88247 Obsoletes: %{oldlibglname} < 6.4
191 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
192     Provides: %{libglname_virt} = %{version}-%{release}
193     Requires: %{dridrivers} >= %{version}-%{release}
194    
195     # (anssi) Forces the upgrade of x11-server-common to happen before
196     # alternatives removal, which allows x11-server-common to grab the symlink.
197     Conflicts: x11-server-common < 1.3.0.0-17
198    
199     %package -n %{dridrivers}
200     Summary: Mesa DRI drivers
201     Group: System/Libraries
202 blino 274132 # do not require exact release to avoid conflicts when having
203     # x86_64 dri drivers from tainted and i586 dri drivers from core
204     Requires: mesa = %{version}
205 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
206 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
207     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
208 pterjan 5340
209 tv 812143 %package -n %{libd3dname}
210     Summary: Mesa Direct3D9 state tracker
211     Group: System/Libraries
212     Provides: %{libd3dname_virt} = %{version}-%{release}
213    
214     %package -n %{libd3dname}-devel
215     Summary: Development files for Mesa Direct3D9 state tracker
216     Group: Development/C
217     Requires: %{libd3dname} = %{version}-%{release}
218     Provides: lib%{d3dname}-devel
219     Provides: %{d3dname}-devel
220     Provides: libd3d-devel
221    
222 pterjan 5340 %package -n %{libglname}-devel
223     Summary: Development files for Mesa (OpenGL compatible 3D lib)
224     Group: Development/C
225 tv 88237 Requires: %{libglname} = %{version}-%{release}
226 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
227     Provides: %{glname}-devel = %{version}-%{release}
228     Provides: GL-devel
229     Obsoletes: %{oldlibglname}-devel < 6.4
230     Provides: %{oldlibglname}-devel = %{version}-%{release}
231     Provides: libMesaGL-devel = %{version}-%{release}
232     Provides: MesaGL-devel = %{version}-%{release}
233 tv 88438 Provides: libgl-devel
234 pterjan 5340
235 tv 88433 %package -n %{libeglname}
236     Summary: Files for Mesa (EGL libs)
237     Group: System/Libraries
238     Provides: %{libeglname_virt} = %{version}-%{release}
239    
240     %package -n %{libeglname}-devel
241     Summary: Development files for Mesa (EGL libs)
242     Group: Development/C
243 tv 88439 Requires: %{libeglname} = %{version}-%{release}
244 tv 88433 Provides: EGL-devel
245 tv 88438 Provides: lib%{eglname}-devel
246     Provides: %{eglname}-devel
247     Provides: libegl-devel
248 tv 88433
249 anssi 278008 %package -n %{libosmesaname}
250     Summary: Mesa offscreen rendering library
251     Group: System/Libraries
252    
253     %package -n %{osmesadevel}
254     Summary: Development files for libosmesa
255     Group: Development/C
256     Requires: %{libosmesaname} = %{version}-%{release}
257     Provides: osmesa-devel = %{version}-%{release}
258     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
259    
260 mikala 112356 %package -n %{libglapiname}
261     Summary: Files for mesa (glapi libs)
262     Group: System/Libraries
263     Provides: %{libglapiname_virt} = %{version}-%{release}
264 tv 88442
265 mikala 112356 %package -n %{libglapiname}-devel
266     Summary: Development files for glapi libs
267     Group: Development/C
268     Requires: %{libglapiname_virt} = %{version}-%{release}
269     Provides: lib%{glapiname}-devel
270     Provides: %{libglapiname}-devel
271    
272 tv 88442 %package -n %{libglesv1name}
273     Summary: Files for Mesa (glesv1 libs)
274     Group: System/Libraries
275     Provides: %{libglesv1name_virt} = %{version}-%{release}
276    
277     %package -n %{libglesv1name}-devel
278     Summary: Development files for glesv1 libs
279     Group: Development/C
280     Requires: %{libglesv1name} = %{version}-%{release}
281     Provides: lib%{glesv1name}-devel
282     Provides: %{glesv1name}-devel
283     Provides: libglesv1-devel
284    
285     %package -n %{libglesv2name}
286     Summary: Files for Mesa (glesv2 libs)
287     Group: System/Libraries
288     Provides: %{libglesv2name_virt} = %{version}-%{release}
289    
290     %package -n %{libglesv2name}-devel
291     Summary: Development files for glesv2 libs
292     Group: Development/C
293     Requires: %{libglesv2name} = %{version}-%{release}
294 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
295 tv 88442 Provides: lib%{glesv2name}-devel
296     Provides: %{glesv2name}-devel
297     Provides: libglesv2-devel
298    
299 blino 215979 %package -n %{libgbmname}
300     Summary: Files for Mesa (gbm libs)
301     Group: System/Libraries
302     Provides: %{libgbmname_virt} = %{version}-%{release}
303    
304     %package -n %{libgbmname}-devel
305     Summary: Development files for Mesa (gbm libs)
306     Group: Development/C
307     Requires: %{libgbmname} = %{version}-%{release}
308     Provides: lib%{gbmname}-devel
309     Provides: %{gbmname}-devel
310    
311 tv 1219406 %if %{?with_wayland_egl}
312 blino 215979 %package -n %{libwaylandeglname}
313     Summary: Files for Mesa (Wayland EGL libs)
314     Group: System/Libraries
315     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
316    
317     %package -n %{libwaylandeglname}-devel
318     Summary: Development files for Mesa (Wayland EGL libs)
319     Group: Development/C
320     Requires: %{libwaylandeglname} = %{version}-%{release}
321     Provides: lib%{waylandeglname}-devel
322     Provides: %{waylandeglname}-devel
323 tv 1214970 %endif
324 blino 215979
325 tv 301233 %package -n %{_lib}vdpau-driver-nouveau
326 blino 270761 Summary: VDPAU plugin for nouveau driver
327 blino 300616 Group: System/Libraries
328 tv 302568 # temporary:
329     %rename vdpau-driver-nouveau
330 blino 270761
331 tv 799259 %package -n %{_lib}vdpau-driver-r300
332     Summary: VDPAU plugin for r300 driver
333     Group: System/Libraries
334     # temporary:
335     %rename vdpau-driver-r300
336    
337 tv 301233 %package -n %{_lib}vdpau-driver-r600
338 blino 270761 Summary: VDPAU plugin for r600 driver
339 blino 300616 Group: System/Libraries
340 tv 302568 # temporary:
341     %rename vdpau-driver-r600
342 blino 270761
343 tv 301233 %package -n %{_lib}vdpau-driver-radeonsi
344 blino 289282 Summary: VDPAU plugin for radeonsi driver
345     Group: System/Libraries
346 tv 302568 # temporary:
347     %rename vdpau-driver-radeonsi
348 blino 289282
349 tv 634669 %package -n %{libxaname}
350     Summary: Files for Mesa XA state tracker
351     Group: System/Libraries
352     Provides: %{libxaname_virt} = %{version}-%{release}
353    
354     %package -n %{libxaname}-devel
355     Summary: Development files for XA libs
356     Group: Development/C
357     Requires: %{libxaname_virt} = %{version}-%{release}
358     Provides: lib%{xaname}-devel
359     Provides: %{libxaname}-devel
360    
361 akien 1041911 %if %{enable_vulkan}
362     %package -n %{libvulkanname}_intel
363     Summary: Mesa vulkan driver for Intel GPU
364     Group: System/Libraries
365    
366 akien 1099595 %package -n %{libvulkanname}_radeon
367     Summary: Mesa vulkan driver for Radeon GPU
368     Group: System/Libraries
369    
370 akien 1041911 %package -n %{libvulkanname}-devel
371     Summary: Mesa's Vulkan development files
372     Group: Development/C
373     Requires: %{libvulkanname}_intel = %{version}-%{release}
374     Provides: libvulkan-devel
375     Provides: libvulkan_intel-devel
376     %endif
377    
378 pterjan 5340 %package common-devel
379     Summary: Meta package for mesa devel
380     Group: Development/C
381 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
382 pterjan 5340 Provides: hackMesa-common-devel = %{version}
383 tv 88247 Obsoletes: Mesa-common-devel < %{version}
384 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
385     Requires: %{libglname}-devel = %{version}
386 blino 289355 Requires: mesaglu-devel
387 tv 135156 Requires: freeglut-devel
388 tv 88442 Requires: %{libeglname}-devel = %{version}
389     Requires: %{libglesv1name}-devel = %{version}
390     Requires: %{libglesv2name}-devel = %{version}
391 pterjan 5340
392 tv 88440 #------------------------------------------------------------------------------
393 pterjan 5340
394     %description
395 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
396 pterjan 5340
397     %description common-devel
398     Mesa common metapackage devel
399    
400     %description -n %{libeglname}
401 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
402 pterjan 5340 EGL parts.
403    
404     %description -n %{libeglname}-devel
405 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
406 pterjan 5340 EGL development parts.
407    
408     %description -n %{libglname}
409 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
410 pterjan 5340 GL and GLX parts.
411    
412     %description -n %{dridrivers}
413 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
414 pterjan 5340 DRI drivers.
415    
416     %description -n %{libglname}-devel
417 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
418 pterjan 5340
419     This package contains the headers needed to compile Mesa programs.
420    
421 tv 88442 %description -n %{libglesv1name}
422     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
423     well-defined subset profiles of OpenGL.
424    
425     This package provides the OpenGL ES library version 1.
426    
427 anssi 278008 %description -n %{libosmesaname}
428     Mesa offscreen rendering libraries for rendering OpenGL into
429     application-allocated blocks of memory.
430    
431     %description -n %{osmesadevel}
432     This package contains the headers needed to compile programs against
433     the Mesa offscreen rendering library.
434    
435 mikala 112356 %description -n %{libglapiname}
436     This packages provides the glapi shared library used by gallium.
437    
438     %description -n %{libglapiname}-devel
439     This package contains the headers needed to compile programes against glapi shared library.
440    
441 tv 88442 %description -n %{libglesv1name}-devel
442     This package contains the headers needed to compile OpenGL ES 1 programs.
443    
444 tv 812143 %description -n %{libd3dname}
445     Mesa Direct3D9 state tracker.
446    
447     %description -n %{libd3dname}-devel
448     Mesa Direct3D9 state tracker development package.
449    
450 tv 88442 %description -n %{libglesv2name}
451     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
452     well-defined subset profiles of OpenGL.
453    
454     This package provides the OpenGL ES library version 2.
455    
456     %description -n %{libglesv2name}-devel
457     This package contains the headers needed to compile OpenGL ES 2 programs.
458    
459 blino 215979 %description -n %{libgbmname}
460 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
461 blino 215979 GBM (Graphics Buffer Manager) parts.
462    
463     %description -n %{libgbmname}-devel
464 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
465 blino 215979 GBM (Graphics Buffer Manager) development parts.
466    
467 tv 1219406 %if %{?with_wayland_egl}
468 blino 215979 %description -n %{libwaylandeglname}
469 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
470 blino 215979 Wayland EGL platform parts.
471    
472     %description -n %{libwaylandeglname}-devel
473 blino 289598 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
474 blino 215979 Wayland EGL platform development parts.
475 tv 1214970 %endif
476 blino 215979
477 tv 634669 %description -n %{libxaname}
478     This packages provides the xa shared library used by gallium.
479    
480     %description -n %{libxaname}-devel
481     This package contains the headers needed to compile programes against xa shared library.
482    
483 tv 301233 %description -n %{_lib}vdpau-driver-nouveau
484 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
485     with the nouveau driver.
486    
487 tv 799259 %description -n %{_lib}vdpau-driver-r300
488     This packages provides a VPDAU plugin to enable video acceleration
489     with the r300 driver.
490    
491 tv 301233 %description -n %{_lib}vdpau-driver-r600
492 blino 270761 This packages provides a VPDAU plugin to enable video acceleration
493     with the r600 driver.
494    
495 tv 301233 %description -n %{_lib}vdpau-driver-radeonsi
496 blino 289282 This packages provides a VPDAU plugin to enable video acceleration
497     with the radeonsi driver.
498    
499 akien 1041911 %if %{enable_vulkan}
500     %description -n %{libvulkanname}_intel
501     This package contains the Vulkan parts for Mesa's Intel driver.
502    
503 akien 1099595 %description -n %{libvulkanname}_radeon
504     This package contains the Vulkan parts for Mesa's Radeon driver.
505    
506 akien 1041911 %description -n %{libvulkanname}-devel
507     This package contains the development files for Mesa's Vulkan implementation.
508     %endif
509    
510 tv 88440 #------------------------------------------------------------------------------
511    
512 pterjan 5340 %prep
513 akien 1099119 %autosetup -n %{name}-%{version}%{?relc:-rc%{relc}} -p1
514 pterjan 5340
515     %build
516 cjw 336175 # (re)generate auto* generated files using our autotools and libtoolize
517     autoreconf -vfi
518    
519 tv 551068 # for bin/test-driver:
520     automake --add-missing
521    
522 tv 1051650 %configure2_5x \
523 akien 1041911 %if %{enable_vulkan}
524 akien 1099595 --with-vulkan-drivers=intel,radeon \
525 akien 1041911 %endif
526 tv 1051646 --enable-gallium-osmesa \
527 tv 1051650 --with-dri-driverdir=%{_libdir}/dri \
528 pterjan 5340 --enable-egl \
529 tv 88442 --enable-gles1 \
530     --enable-gles2 \
531 blino 270761 --disable-xvmc \
532     --enable-vdpau \
533 tv 1217640 %{?with_vaapi:--enable-va} \
534 tv 1219406 --with-platforms=x11,drm,surfaceless,wayland \
535 tv 1051650 --enable-shared-glapi \
536     --enable-gbm \
537     --enable-glx \
538     --enable-glx-tls \
539     --enable-texture-float=yes \
540 tv 1140192 --enable-llvm \
541 tv 1051650 --enable-dri \
542 tv 634669 --enable-xa \
543 blino 897332 --enable-nine \
544 neoclust 1216966 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast,%{?with_freedreno:freedreno,}%{?with_etnaviv:etnaviv,imx,}%{?with_vc4:vc4,}virgl%{?gallium_platform_drivers} \
545 tv 1051613 %{?dri_drivers}
546 blino 270723 # end of configure options
547 pterjan 5340
548 anssi 332631
549 anssi 165988 %make
550 pterjan 5340
551     %install
552 tv 1051611 %make_install
553 pterjan 5340
554 blino 216556 # FIXME: strip will likely break the hardlink
555 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
556     # to prevent proprietary driver installers from removing them
557     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
558     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
559     for l in ../libGL.so.*; do cp -a $l .; done
560     popd
561    
562     %ifarch %{x86_64}
563     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
564     %endif
565    
566 tv 1051623 # libvdpau opens the versioned name, don't bother including the unversioned
567     rm -f %{buildroot}%{_libdir}/vdpau/*.so
568 blino 270761
569 tv 1051625 # strip out useless headers
570     rm -f %{buildroot}%{_includedir}/GL/w*.h
571    
572 tv 1051622 # remove .la files
573 tv 881746 find %{buildroot} -name '*.la' -delete
574 blino 271144
575 tv 1219406 # remove libwayland-egl on F28+ where it's built as part of wayland source package
576     %if !%{?with_wayland_egl}
577     rm -f %{buildroot}%{_libdir}/libwayland-egl.so*
578     rm -f %{buildroot}%{_libdir}/pkgconfig/wayland-egl.pc
579     %endif
580    
581 tv 88440 #------------------------------------------------------------------------------
582    
583 pterjan 5340 %files
584 tv 1328786 /usr/share/drirc.d/
585 pterjan 5340
586     %files -n %{dridrivers}
587     %dir %{_libdir}/dri
588     %{_libdir}/dri/*_dri.so
589 tv 812142 %{_libdir}/dri/*_drv*.so
590 pterjan 5340
591 tv 88433 %files -n %{libglname}
592     %{_libdir}/libGL.so.*
593     %dir %{_libdir}/mesa
594 ovitters 877635 %{_libdir}/mesa/libGL.so.%{glmajor}{,.*}
595 tv 88433
596     %files -n %{libeglname}
597 ovitters 877635 %{_libdir}/libEGL.so.%{eglmajor}{,.*}
598 tv 88433
599 anssi 278008 %files -n %{libosmesaname}
600 ovitters 877635 %{_libdir}/libOSMesa.so.%{osmesamajor}{,.*}
601 anssi 278008
602 mikala 112356 %files -n %{libglapiname}
603 ovitters 877635 %{_libdir}/libglapi.so.%{glapimajor}{,.*}
604 mikala 112356
605 tv 88442 %files -n %{libglesv1name}
606 ovitters 877635 %{_libdir}/libGLESv1_CM.so.%{glesv1major}{,.*}
607 tv 88442
608 tv 812143 %files -n %{libd3dname}
609     %{_libdir}/d3d/*.so.*
610    
611 tv 88442 %files -n %{libglesv2name}
612 ovitters 877635 %{_libdir}/libGLESv2.so.%{glesv2major}{,.*}
613 tv 88442
614 blino 215979 %files -n %{libgbmname}
615     %{_libdir}/libgbm.so.%{gbmmajor}
616 ovitters 878590 %{_libdir}/libgbm.so.%{gbmmajor}.*
617 tv 88445
618 tv 1219406 %if %{?with_wayland_egl}
619 blino 215979 %files -n %{libwaylandeglname}
620     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
621 ovitters 878590 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
622 tv 1214970 %endif
623 blino 215979
624 tv 634669 %files -n %{libxaname}
625 ovitters 877635 %{_libdir}/libxatracker.so.%{xamajor}{,.*}
626 blino 215979
627 pterjan 5340 %files -n %{libglname}-devel
628 anssi 278008 %dir %{_includedir}/GL
629 pterjan 5340 %{_includedir}/GL/gl.h
630 tv 1051618 %{_includedir}/GL/gl_mangle.h
631 pterjan 5340 %{_includedir}/GL/glext.h
632     %{_includedir}/GL/glx.h
633 tv 1051618 %{_includedir}/GL/glx_mangle.h
634 pterjan 5340 %{_includedir}/GL/glxext.h
635 tv 1051618 %{_includedir}/GL/glcorearb.h
636     %dir %{_includedir}/GL/internal
637     %{_includedir}/GL/internal/dri_interface.h
638     %{_libdir}/pkgconfig/dri.pc
639 pterjan 5340 %{_libdir}/libGL.so
640 tv 88436 %{_libdir}/pkgconfig/gl.pc
641 pterjan 5340
642     %files common-devel
643 tv 1051614
644 tv 88433 %files -n %{libeglname}-devel
645 tv 88442 %{_includedir}/EGL
646     %{_includedir}/KHR
647 tv 88433 %{_libdir}/libEGL.so
648 tv 88436 %{_libdir}/pkgconfig/egl.pc
649 pterjan 5340
650 anssi 278008 %files -n %{osmesadevel}
651     %dir %{_includedir}/GL
652     %{_includedir}/GL/osmesa.h
653     %{_libdir}/libOSMesa.so
654     %{_libdir}/pkgconfig/osmesa.pc
655    
656 mikala 112356 %files -n %{libglapiname}-devel
657     %{_libdir}/libglapi.so
658 pterjan 5340
659 tv 88442 %files -n %{libglesv1name}-devel
660     %{_includedir}/GLES
661     %{_libdir}/libGLESv1_CM.so
662     %{_libdir}/pkgconfig/glesv1_cm.pc
663 tv 88433
664 tv 88442 %files -n %{libglesv2name}-devel
665     %{_includedir}/GLES2
666 cjw 336175 %{_includedir}/GLES3
667 tv 88442 %{_libdir}/libGLESv2.so
668     %{_libdir}/pkgconfig/glesv2.pc
669 tv 88445
670 tv 812143 %files -n %{libd3dname}-devel
671     %{_includedir}/d3dadapter
672     %{_libdir}/d3d/*.so
673     %{_libdir}/pkgconfig/d3d.pc
674    
675 blino 215979 %files -n %{libgbmname}-devel
676 tv 1051618 %{_libdir}/libgbm.so
677 blino 215979 %{_includedir}/gbm.h
678     %{_libdir}/pkgconfig/gbm.pc
679    
680 tv 1219406 %if %{?with_wayland_egl}
681 blino 215979 %files -n %{libwaylandeglname}-devel
682     %{_libdir}/libwayland-egl.so
683     %{_libdir}/pkgconfig/wayland-egl.pc
684 tv 1214970 %endif
685 blino 270761
686 tv 634669 %files -n %{libxaname}-devel
687     %{_libdir}/libxatracker.so
688     %{_includedir}/xa_tracker.h
689     %{_includedir}/xa_composite.h
690     %{_includedir}/xa_context.h
691     %{_libdir}/pkgconfig/xatracker.pc
692    
693 tv 301233 %files -n %{_lib}vdpau-driver-nouveau
694 blino 270761 %{_libdir}/vdpau/libvdpau_nouveau.so.*
695    
696 tv 799259 %files -n %{_lib}vdpau-driver-r300
697     %{_libdir}/vdpau/libvdpau_r300.so.*
698    
699 tv 301233 %files -n %{_lib}vdpau-driver-r600
700 blino 270761 %{_libdir}/vdpau/libvdpau_r600.so.*
701    
702 tv 301233 %files -n %{_lib}vdpau-driver-radeonsi
703 blino 289282 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
704 akien 1041911
705     %if %{enable_vulkan}
706     %files -n %{libvulkanname}_intel
707     %dir %{_datadir}/vulkan
708     %dir %{_datadir}/vulkan/icd.d
709 ghibo 1065537 %{_datadir}/vulkan/icd.d/intel_icd*.json
710 akien 1041911 # (akien) No lib major?
711     %{_libdir}/libvulkan_intel.so
712    
713 akien 1099595 %files -n %{libvulkanname}_radeon
714     %dir %{_datadir}/vulkan
715     %dir %{_datadir}/vulkan/icd.d
716     %{_datadir}/vulkan/icd.d/radeon_icd*.json
717     # (akien) No lib major?
718     %{_libdir}/libvulkan_radeon.so
719    
720 akien 1041911 %files -n %{libvulkanname}-devel
721     %{_includedir}/vulkan/
722     %endif

  ViewVC Help
Powered by ViewVC 1.1.30