/[packages]/cauldron/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /cauldron/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 271144 - (hide annotations) (download)
Sun Jul 15 21:50:23 2012 UTC (11 years, 9 months ago) by blino
File size: 21948 byte(s)
remove la files since they are not needed by mesa (prepare for mesa 8.1)
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 tv 88231
18 mikala 127466 %define git 0
19 mikala 112356 %define with_hardware 1
20    
21 tv 131211 %define relc 0
22 pterjan 5340 %define name mesa
23 anssi 269296 %define version 8.0.4
24 blino 270761 %define rel 2
25 pterjan 5340
26     %define release %mkrel %{rel}
27     %define src_type tar.bz2
28 tv 173693 #define vsuffix %{expand:}
29     %define vsuffix %nil
30 pterjan 5340
31     %if %{relc}
32     %define release %mkrel 0.rc%{relc}.%{rel}
33     %define vsuffix -rc%{relc}
34     %define src_type tar.bz2
35     %endif
36    
37     %if %{git}
38     %if %{relc}
39 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
40 pterjan 5340 %else
41     %define release %mkrel 0.git%{git}.%{rel}
42     %endif
43     %endif
44    
45     %define makedepend %{_bindir}/gccmakedep
46    
47     %define eglname mesaegl
48     %define glname mesagl
49     %define gluname mesaglu
50     %define glwname mesaglw
51 tv 88442 %define glesv1name mesaglesv1
52     %define glesv2name mesaglesv2
53 tv 88445 %define openvgname mesaopenvg
54 mikala 112356 %define glapiname glapi
55 blino 215979 %define gbmname gbm
56     %define waylandeglname wayland-egl
57 tv 88442
58 pterjan 5340 %define eglmajor 1
59     %define glmajor 1
60     %define glumajor 1
61     %define glwmajor 1
62 tv 88442 %define glesv1major 1
63     %define glesv2major 2
64 tv 88445 %define openvgmajor 1
65 mikala 112356 %define glapimajor 0
66 blino 215979 %define gbmmajor 1
67     %define waylandeglmajor 1
68 tv 88442
69 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
70     %define libglname %mklibname %{glname} %{glmajor}
71     %define libgluname %mklibname %{gluname} %{glumajor}
72     %define libglwname %mklibname %{glwname} %{glwmajor}
73 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
74     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
75 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
76 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
77 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
78     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
79 pterjan 5340
80     %define dridrivers %mklibname dri-drivers
81    
82     # Architecture-independent Virtual provides:
83     %define libeglname_virt lib%{eglname}
84     %define libglname_virt lib%{glname}
85     %define libgluname_virt lib%{gluname}
86     %define libglwname_virt lib%{glwname}
87 tv 88442 %define libglesv1name_virt lib%{glesv1name}
88     %define libglesv2name_virt lib%{glesv2name}
89 tv 88445 %define libopenvgname_virt lib%{openvgname}
90 mikala 112356 %define libglapiname_virt lib%{glapiname}
91 blino 215979 %define libgbmname_virt lib%{gbmname}
92     %define libwaylandeglname_virt lib%{waylandeglname}
93 pterjan 5340
94     %define oldlibglname %mklibname MesaGL 1
95     %define oldlibgluname %mklibname MesaGLU 1
96    
97     %define mesasrcdir %{_prefix}/src/Mesa/
98     %define driver_dir %{_libdir}/dri
99    
100 tv 88451 %define enable_egl 1
101 blino 215979 %define enable_wayland 1
102 pterjan 5340
103     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
104     #FIXME: (for >=i586) disable sse
105     # SSE seems to have problem on some apps (gtulpas) for probing.
106 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
107 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
108 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
109 pterjan 5340 %define dri_drivers_ppc64 ""
110 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
111     %define dri_drivers_alpha "r200,radeon,swrast"
112     %define dri_drivers_sparc "ffb,radeon,swrast"
113     %define dri_drivers_mipsel "r200,radeon,swrast"
114 rtp 18133 %define dri_drivers_arm "swrast"
115 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
116    
117     Name: %{name}
118     Version: %{version}
119     Release: %{release}
120     Summary: OpenGL 2.1 compatible 3D graphics library
121     Group: System/Libraries
122    
123 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
124     BuildRequires: pkgconfig(xt) >= 1.0.5
125     BuildRequires: pkgconfig(xmu) >= 1.0.3
126     BuildRequires: pkgconfig(x11) >= 1.3.3
127     BuildRequires: pkgconfig(xdamage) >= 1.1.1
128 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
129     BuildRequires: gccmakedep
130     BuildRequires: x11-proto-devel >= 7.3
131 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
132 pterjan 5340
133 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
134     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
135     BuildRequires: pkgconfig(xi) >= 1.3
136     BuildRequires: pkgconfig(talloc)
137 tv 88443 BuildRequires: libxml2-python
138 tmb 35532 BuildRequires: makedepend
139 dmorgan 106004 BuildRequires: bison flex
140 blino 230504 BuildRequires: llvm-devel
141 mikala 127466 BuildRequires: pkgconfig(libudev)
142 blino 270761 BuildRequires: pkgconfig(vdpau)
143 blino 215979 %if %{enable_wayland}
144     BuildRequires: wayland-devel
145     %endif
146 pterjan 5340
147     URL: http://www.mesa3d.org
148     %if %{git}
149     # (cg) Current commit ref: origin/mesa_7_5_branch
150     Source0: %{name}-%{git}.tar.bz2
151     %else
152     Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{version}%{vsuffix}.%{src_type}
153     %endif
154     Source3: make-git-snapshot.sh
155     Source5: mesa-driver-install
156    
157    
158     # Instructions to setup your repository clone
159     # git://git.freedesktop.org/git/mesa/mesa
160     # git checkout mesa_7_5_branch
161     # git branch mdv-cherry-picks
162     # git am ../02??-*.patch
163     # git branch mdv-redhat
164     # git am ../03??-*.patch
165     # git branch mdv-patches
166     # git am ../09??-*.patch
167    
168     # In order to update to the branch via patches, issue this command:
169     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
170    
171     # Cherry picks
172     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
173     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
174    
175 tv 88247 # Patches "liberated" from Fedora:
176 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
177     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
178    
179 anssi 269296 # Backport nouveau commits to enable build with libdrm_nouveau-2 (Anssi)
180     Patch401: 0401-dri-nouveau-don-t-use-nested-functions.patch
181     Patch402: 0402-nouveau-vieux-switch-to-libdrm_nouveau-2.0.patch
182     Patch403: 0403-nouveau-rework-and-simplify-nv04-nv05-driver-a-bit.patch
183     Patch404: 0404-nvfx-completely-remove-this-driver-GeForce-FX-6-7.patch
184     Patch405: 0405-nouveau-remove-automatic-buffer-migration-heuristics.patch
185     Patch406: 0406-nvc0-remove-obsolete-nvc0_push2.c.patch
186     Patch407: 0407-nouveau-switch-to-libdrm_nouveau-2.0.patch
187     Patch408: 0408-nv30-import-new-driver-for-GeForce-FX-6-7-chipsets-a.patch
188     Patch409: 0409-nvc0-remove-include-of-old-libdrm_nouveau-s-nouveau_.patch
189     Patch410: 0410-targets-egl-static-gbm-further-clean-up-the-nvfx-rem.patch
190     Patch411: 0411-xorg-nouveau-switch-to-libdrm_nouveau-2.0.patch
191     Patch412: 0412-nv50-nvc0-hold-references-to-the-framebuffer-surface.patch
192     Patch413: 0413-nvc0-only-force-early-fragment-tests-if-requested-by.patch
193     Patch414: 0414-nouveau-add-new-shared-scratch-buffers.patch
194     Patch415: 0415-nv50-nvc0-use-new-scratch-buffers-code.patch
195     Patch416: 0416-nvc0-track-texture-dirty-state-individually.patch
196     Patch417: 0417-nvc0-improve-vertex-state-validation.patch
197     Patch418: 0418-nvc0-replace-VERTEX_DATA-push-mode-with-translate-to.patch
198     Patch419: 0419-nvc0-prefix-all-macro-methods-with-MACRO.patch
199     Patch420: 0420-nv50-nvc0-fix-handling-of-user-vbufs-with-stride-acc.patch
200     Patch421: 0421-nouveau-fix-nv30-build-with-mesa-8.0.patch
201    
202 pterjan 5340 # Mandriva patches
203     # git format-patch --start-number 900 mdv-redhat..mdv-patches
204    
205    
206 tv 88440 #------------------------------------------------------------------------------
207    
208     # package mesa
209 pterjan 5340 License: MIT
210     Requires: %{libglname} = %{version}-%{release}
211     Provides: hackMesa = %{version}
212     Obsoletes: hackMesa <= %{version}
213     Provides: Mesa = %{version}
214     Obsoletes: Mesa < %{version}
215    
216     %package -n %{libglname}
217     Summary: Files for Mesa (GL and GLX libs)
218     Group: System/Libraries
219 tv 88247 Obsoletes: %{oldlibglname} < 6.4
220 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
221     Provides: %{libglname_virt} = %{version}-%{release}
222     Requires: %{dridrivers} >= %{version}-%{release}
223 tv 135172 %if %{build_plf}
224     Requires: %mklibname txc-dxtn
225     %endif
226 pterjan 5340
227     # (anssi) Forces the upgrade of x11-server-common to happen before
228     # alternatives removal, which allows x11-server-common to grab the symlink.
229     Conflicts: x11-server-common < 1.3.0.0-17
230    
231     %package -n %{dridrivers}
232     Summary: Mesa DRI drivers
233     Group: System/Libraries
234     Conflicts: %{_lib}MesaGL1 < 7.7-5
235 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
236     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
237 pterjan 5340
238     %package -n %{libglname}-devel
239     Summary: Development files for Mesa (OpenGL compatible 3D lib)
240     Group: Development/C
241 tv 88237 Requires: %{libglname} = %{version}-%{release}
242 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
243     Provides: %{glname}-devel = %{version}-%{release}
244     Provides: GL-devel
245     Obsoletes: %{oldlibglname}-devel < 6.4
246     Provides: %{oldlibglname}-devel = %{version}-%{release}
247     Provides: libMesaGL-devel = %{version}-%{release}
248     Provides: MesaGL-devel = %{version}-%{release}
249 tv 88438 Provides: libgl-devel
250 pterjan 5340
251     %package -n %{libgluname}
252     Summary: Files for Mesa (GLU libs)
253     Group: System/Libraries
254     Obsoletes: %{oldlibgluname} < 6.4
255     Provides: %{oldlibgluname} = %{version}-%{release}
256     Provides: %{libgluname_virt} = %{version}-%{release}
257    
258     %package -n %{libgluname}-devel
259     Summary: Development files for GLU libs
260     Group: Development/C
261     Requires: %{libgluname} = %{version}-%{release}
262     Provides: lib%{gluname}-devel = %{version}-%{release}
263     Provides: %{gluname}-devel = %{version}-%{release}
264     Obsoletes: %{oldlibgluname}-devel < 6.4
265     Provides: %{oldlibgluname}-devel = %{version}-%{release}
266     Provides: libMesaGLU-devel = %{version}-%{release}
267 tv 88247 Provides: MesaGLU-devel = %{version}-%{release}
268 tv 88438 Provides: libglu-devel
269 tv 88436 # pkgconfig files moved from libgl-devel:
270     Conflicts: %{libglname}-devel < 7.10.2-4
271 pterjan 5340
272 tv 88433 %if %{enable_egl}
273     %package -n %{libeglname}
274     Summary: Files for Mesa (EGL libs)
275     Group: System/Libraries
276     Provides: %{libeglname_virt} = %{version}-%{release}
277    
278     %package -n %{libeglname}-devel
279     Summary: Development files for Mesa (EGL libs)
280     Group: Development/C
281 tv 88439 Requires: %{libeglname} = %{version}-%{release}
282 tv 88433 Provides: EGL-devel
283 tv 88438 Provides: lib%{eglname}-devel
284     Provides: %{eglname}-devel
285     Provides: libegl-devel
286 tv 88433 %endif
287    
288 mikala 112356 %package -n %{libglapiname}
289     Summary: Files for mesa (glapi libs)
290     Group: System/Libraries
291     Provides: %{libglapiname_virt} = %{version}-%{release}
292 tv 88442
293 mikala 112356 %package -n %{libglapiname}-devel
294     Summary: Development files for glapi libs
295     Group: Development/C
296     Requires: %{libglapiname_virt} = %{version}-%{release}
297     Provides: lib%{glapiname}-devel
298     Provides: %{libglapiname}-devel
299    
300 tv 88442 %package -n %{libglesv1name}
301     Summary: Files for Mesa (glesv1 libs)
302     Group: System/Libraries
303     Provides: %{libglesv1name_virt} = %{version}-%{release}
304    
305     %package -n %{libglesv1name}-devel
306     Summary: Development files for glesv1 libs
307     Group: Development/C
308     Requires: %{libglesv1name} = %{version}-%{release}
309     Provides: lib%{glesv1name}-devel
310     Provides: %{glesv1name}-devel
311     Provides: libglesv1-devel
312    
313     %package -n %{libglesv2name}
314     Summary: Files for Mesa (glesv2 libs)
315     Group: System/Libraries
316     Provides: %{libglesv2name_virt} = %{version}-%{release}
317    
318     %package -n %{libglesv2name}-devel
319     Summary: Development files for glesv2 libs
320     Group: Development/C
321     Requires: %{libglesv2name} = %{version}-%{release}
322 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
323 tv 88442 Provides: lib%{glesv2name}-devel
324     Provides: %{glesv2name}-devel
325     Provides: libglesv2-devel
326    
327 tv 88445 %package -n %{libopenvgname}
328     Summary: Files for MESA (OpenVG libs)
329     Group: System/Libraries
330     Provides: %{libopenvgname_virt} = %{version}-%{release}
331    
332     %package -n %{libopenvgname}-devel
333     Summary: Development files vor OpenVG libs
334     Group: Development/C
335     Requires: %{libopenvgname} = %{version}-%{release}
336     Provides: lib%{openvgname}-devel
337     Provides: %{openvgname}-devel
338     Provides: libopenvg-devel
339    
340 blino 215979 %if %{enable_wayland}
341     %package -n %{libgbmname}
342     Summary: Files for Mesa (gbm libs)
343     Group: System/Libraries
344     Provides: %{libgbmname_virt} = %{version}-%{release}
345    
346     %package -n %{libgbmname}-devel
347     Summary: Development files for Mesa (gbm libs)
348     Group: Development/C
349     Requires: %{libgbmname} = %{version}-%{release}
350     Provides: lib%{gbmname}-devel
351     Provides: %{gbmname}-devel
352    
353     %package -n %{libwaylandeglname}
354     Summary: Files for Mesa (Wayland EGL libs)
355     Group: System/Libraries
356     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
357    
358     %package -n %{libwaylandeglname}-devel
359     Summary: Development files for Mesa (Wayland EGL libs)
360     Group: Development/C
361     Requires: %{libwaylandeglname} = %{version}-%{release}
362     Provides: lib%{waylandeglname}-devel
363     Provides: %{waylandeglname}-devel
364     %endif
365    
366 blino 270761 %package -n vdpau-driver-nouveau
367     Summary: VDPAU plugin for nouveau driver
368     Group: System/Libraries
369    
370     %package -n vdpau-driver-r300
371     Summary: VDPAU plugin for r300 driver
372     Group: System/Libraries
373    
374     %package -n vdpau-driver-r600
375     Summary: VDPAU plugin for r600 driver
376     Group: System/Libraries
377    
378     %package -n vdpau-driver-softpipe
379     Summary: VDPAU plugin for softpipe driver
380     Group: System/Libraries
381    
382 pterjan 5340 %package common-devel
383     Summary: Meta package for mesa devel
384     Group: Development/C
385 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
386 pterjan 5340 Provides: hackMesa-common-devel = %{version}
387 tv 88247 Obsoletes: Mesa-common-devel < %{version}
388 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
389     Requires: %{libglname}-devel = %{version}
390     Requires: %{libgluname}-devel = %{version}
391 tv 135156 Requires: freeglut-devel
392 tv 88442 Requires: %{libeglname}-devel = %{version}
393     Requires: %{libglesv1name}-devel = %{version}
394     Requires: %{libglesv2name}-devel = %{version}
395 pterjan 5340
396 tv 88440 #------------------------------------------------------------------------------
397 pterjan 5340
398     %description
399     Mesa is an OpenGL 2.1 compatible 3D graphics library.
400 tv 135173 %if %{build_plf}
401 pterjan 5340
402 tv 135173 This package is in the "tainted" section because it enables some
403     OpenGL extentions that are covered by software patents.
404     %endif
405    
406 pterjan 5340 %description common-devel
407     Mesa common metapackage devel
408    
409     %if %{enable_egl}
410     %description -n %{libeglname}
411     Mesa is an OpenGL 2.1 compatible 3D graphics library.
412     EGL parts.
413    
414     %description -n %{libeglname}-devel
415     Mesa is an OpenGL 2.1 compatible 3D graphics library.
416     EGL development parts.
417     %endif
418    
419     %description -n %{libglname}
420     Mesa is an OpenGL 2.1 compatible 3D graphics library.
421     GL and GLX parts.
422    
423 tv 135155 %if %{build_plf}
424     This package is in the "tainted" section because it enables some
425     OpenGL extentions that are covered by software patents.
426     %endif
427    
428 pterjan 5340 %description -n %{dridrivers}
429     Mesa is an OpenGL 2.1 compatible 3D graphics library.
430     DRI drivers.
431    
432     %description -n %{libglname}-devel
433     Mesa is an OpenGL 2.1 compatible 3D graphics library.
434    
435     This package contains the headers needed to compile Mesa programs.
436    
437     %description -n %{libgluname}
438     GLU is the OpenGL Utility Library.
439     It provides a number of functions upon the base OpenGL library to provide
440     higher-level drawing routines from the more primitive routines provided by
441     OpenGL.
442    
443     %description -n %{libgluname}-devel
444     This package contains the headers needed to compile programs with GLU.
445    
446 tv 88442 %description -n %{libglesv1name}
447     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
448     well-defined subset profiles of OpenGL.
449    
450     This package provides the OpenGL ES library version 1.
451    
452 mikala 112356 %description -n %{libglapiname}
453     This packages provides the glapi shared library used by gallium.
454    
455     %description -n %{libglapiname}-devel
456     This package contains the headers needed to compile programes against glapi shared library.
457    
458 tv 88442 %description -n %{libglesv1name}-devel
459     This package contains the headers needed to compile OpenGL ES 1 programs.
460    
461     %description -n %{libglesv2name}
462     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
463     well-defined subset profiles of OpenGL.
464    
465     This package provides the OpenGL ES library version 2.
466    
467     %description -n %{libglesv2name}-devel
468     This package contains the headers needed to compile OpenGL ES 2 programs.
469    
470 tv 88445 %description -n %{libopenvgname}
471     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
472     acceleration interface for vector graphics libraries such as Flash and SVG.
473    
474     %description -n %{libopenvgname}-devel
475     Development files for OpenVG library.
476    
477 blino 215979 %if %{enable_wayland}
478     %description -n %{libgbmname}
479     Mesa is an OpenGL 2.1 compatible 3D graphics library.
480     GBM (Graphics Buffer Manager) parts.
481    
482     %description -n %{libgbmname}-devel
483     Mesa is an OpenGL 2.1 compatible 3D graphics library.
484     GBM (Graphics Buffer Manager) development parts.
485    
486     %description -n %{libwaylandeglname}
487     Mesa is an OpenGL 2.1 compatible 3D graphics library.
488     Wayland EGL platform parts.
489    
490     %description -n %{libwaylandeglname}-devel
491     Mesa is an OpenGL 2.1 compatible 3D graphics library.
492     Wayland EGL platform development parts.
493     %endif
494    
495 blino 270761 %description -n vdpau-driver-nouveau
496     This packages provides a VPDAU plugin to enable video acceleration
497     with the nouveau driver.
498    
499     %description -n vdpau-driver-r300
500     This packages provides a VPDAU plugin to enable video acceleration
501     with the r300 driver.
502    
503     %description -n vdpau-driver-r600
504     This packages provides a VPDAU plugin to enable video acceleration
505     with the r600 driver.
506    
507     %description -n vdpau-driver-softpipe
508     This packages provides a VPDAU plugin to enable video acceleration
509     with the softpipe driver.
510    
511 tv 88440 #------------------------------------------------------------------------------
512    
513 pterjan 5340 %prep
514     %if %{git}
515     %setup -q -n mesa-%{git}
516     %else
517 tv 207029 %setup -q -n Mesa-%{version}%{vsuffix}
518 pterjan 5340 %endif
519    
520     %patch201 -p1
521    
522 anssi 269296 %patch401 -p1
523     %patch402 -p1
524     %patch403 -p1
525     %patch404 -p1
526     %patch405 -p1
527     %patch406 -p1
528     %patch407 -p1
529     %patch408 -p1
530     %patch409 -p1
531     %patch410 -p1
532     %patch411 -p1
533     %patch412 -p1
534     %patch413 -p1
535     %patch414 -p1
536     %patch415 -p1
537     %patch416 -p1
538     %patch417 -p1
539     %patch418 -p1
540     %patch419 -p1
541     %patch420 -p1
542     %patch421 -p1
543    
544 pterjan 5340 chmod +x %{SOURCE5}
545    
546     %build
547     autoreconf -vfi
548     %configure2_5x --with-driver=dri \
549     --with-dri-driverdir=%{driver_dir} \
550     --with-dri-drivers="%{dri_drivers}" \
551 anssi 165988 --enable-shared-dricore \
552 pterjan 5340 %if %{enable_egl}
553     --enable-egl \
554     %else
555     --disable-egl \
556     %endif
557 blino 215979 %if %{enable_wayland}
558     --with-egl-platforms=x11,wayland,drm \
559     --enable-gbm \
560     --enable-shared-glapi \
561     %endif
562 tv 88442 --enable-gles1 \
563     --enable-gles2 \
564 tv 88445 --enable-openvg \
565 mikala 112356 --enable-gallium-egl \
566 blino 270761 --enable-gallium-g3dvl \
567     --disable-xvmc \
568     --enable-vdpau \
569     --disable-va \
570 mikala 112356 %if %{with_hardware}
571     --with-gallium-drivers=r300,r600,nouveau,swrast \
572     --enable-gallium-llvm \
573     %else
574     --disable-gallium-llvm \
575     --with-gallium-drivers=swrast \
576     %endif
577 tv 135155 %if %{build_plf}
578     --enable-texture-float \
579     %endif
580 blino 270723 # end of configure options
581 pterjan 5340
582 anssi 165988 %make
583 pterjan 5340
584     %install
585 tv 88249 %makeinstall_std
586 pterjan 5340
587 blino 216556 # FIXME: strip will likely break the hardlink
588 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
589     # to prevent proprietary driver installers from removing them
590     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
591     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
592     for l in ../libGL.so.*; do cp -a $l .; done
593     popd
594    
595     %ifarch %{x86_64}
596     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
597     %endif
598    
599 tv 88231 rm -f %{buildroot}/%{_includedir}/GL/glut.h
600     rm -f %{buildroot}/%{_includedir}/GL/glutf90.h
601    
602 blino 270761 # .so files are not needed by vdpau
603     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
604    
605 blino 271144 # .la files are not needed by mesa
606     find %{buildroot} -name '*.la' -exec rm {} \;
607    
608 anssi 181478 # use swrastg if built (Anssi 12/2011)
609     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
610    
611 tv 88440 #------------------------------------------------------------------------------
612    
613 pterjan 5340 %files
614     %defattr(-,root,root)
615     %doc docs/COPYING docs/README.*
616    
617     %files -n %{dridrivers}
618     %defattr(-,root,root)
619     %doc docs/COPYING
620     %ifnarch ppc64
621     %dir %{_libdir}/dri
622 anssi 165988 %{_libdir}/dri/libdricore.so
623     %{_libdir}/dri/libglsl.so
624 pterjan 5340 %{_libdir}/dri/*_dri.so
625     %endif
626    
627 tv 88433 %files -n %{libglname}
628     %defattr(-,root,root)
629     %doc docs/COPYING
630     %{_libdir}/libGL.so.*
631     %dir %{_libdir}/mesa
632 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
633 tv 88433
634 tv 88437 %files -n %{libgluname}
635 tv 88433 %defattr(-,root,root)
636     %doc docs/COPYING
637 tv 88434 %{_libdir}/libGLU.so.%{glumajor}*
638 tv 88433
639     %if %{enable_egl}
640     %files -n %{libeglname}
641     %defattr(-,root,root)
642 tv 88442 %doc docs/COPYING
643 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
644 tv 88442 %dir %{_libdir}/egl
645 blino 215979 %if !%{enable_wayland}
646     # st_GL, built only when shared glapi is not enabled
647 mikala 112356 %{_libdir}/egl/st_GL.so
648 blino 215979 %endif
649 mikala 127466 %{_libdir}/egl/egl_gallium.so
650 tv 88441 %endif
651 tv 88433
652 mikala 112356 %files -n %{libglapiname}
653     %defattr(-,root,root)
654     %{_libdir}/libglapi.so.%{glapimajor}*
655    
656 tv 88442 %files -n %{libglesv1name}
657     %defattr(-,root,root)
658     %doc docs/COPYING
659     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
660    
661     %files -n %{libglesv2name}
662     %defattr(-,root,root)
663     %doc docs/COPYING
664     %{_libdir}/libGLESv2.so.%{glesv2major}*
665    
666 tv 88445 %files -n %{libopenvgname}
667     %defattr(-,root,root)
668     %doc docs/COPYING
669     %{_libdir}/libOpenVG.so.%{openvgmajor}*
670    
671 blino 215979 %if %{enable_wayland}
672     %files -n %{libgbmname}
673     %{_libdir}/libgbm.so.%{gbmmajor}
674 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
675 blino 215979 %{_libdir}/gbm/gbm_*.so
676     %{_libdir}/gbm/pipe_*.so
677 tv 88445
678 blino 215979 %files -n %{libwaylandeglname}
679     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
680 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
681 blino 215979 %endif
682    
683    
684 pterjan 5340 %files -n %{libglname}-devel
685     %defattr(-,root,root)
686     %doc docs/COPYING
687     %{_includedir}/GL/gl.h
688     %{_includedir}/GL/glext.h
689     %{_includedir}/GL/gl_mangle.h
690     %{_includedir}/GL/osmesa.h
691     %{_includedir}/GL/wglext.h
692     %{_includedir}/GL/glx.h
693     %{_includedir}/GL/glxext.h
694     %{_includedir}/GL/glx_mangle.h
695     %{_libdir}/libGL.so
696 tv 88436 %{_libdir}/pkgconfig/gl.pc
697     %{_libdir}/pkgconfig/dri.pc
698 pterjan 5340
699     #FIXME: check those headers
700     %{_includedir}/GL/vms_x_fix.h
701     %{_includedir}/GL/wmesa.h
702     %dir %{_includedir}/GL/internal
703     %{_includedir}/GL/internal/dri_interface.h
704    
705     %files -n %{libgluname}-devel
706     %defattr(-,root,root)
707     %doc docs/COPYING
708     %{_includedir}/GL/glu.h
709     %{_includedir}/GL/glu_mangle.h
710     %{_libdir}/libGLU.so
711 tv 88436 %{_libdir}/pkgconfig/glu.pc
712 pterjan 5340
713     %files common-devel
714     %defattr(-,root,root)
715    
716 tv 88441 %if %{enable_egl}
717 tv 88433 %files -n %{libeglname}-devel
718     %defattr(-,root,root)
719 tv 88442 %doc docs/COPYING
720     %{_includedir}/EGL
721     %{_includedir}/KHR
722 tv 88433 %{_libdir}/libEGL.so
723 tv 88436 %{_libdir}/pkgconfig/egl.pc
724 tv 88433 %endif
725 pterjan 5340
726 mikala 112356 %files -n %{libglapiname}-devel
727     %defattr(-,root,root)
728     %{_libdir}/libglapi.so
729 pterjan 5340
730 tv 88442 %files -n %{libglesv1name}-devel
731     %defattr(-,root,root)
732     %{_includedir}/GLES
733     %{_libdir}/libGLESv1_CM.so
734     %{_libdir}/pkgconfig/glesv1_cm.pc
735 tv 88433
736 tv 88442 %files -n %{libglesv2name}-devel
737     %defattr(-,root,root)
738     %{_includedir}/GLES2
739     %{_libdir}/libGLESv2.so
740     %{_libdir}/pkgconfig/glesv2.pc
741 tv 88445
742     %files -n %{libopenvgname}-devel
743     %defattr(-,root,root)
744     %{_includedir}/VG
745     %{_libdir}/libOpenVG.so
746     %{_libdir}/pkgconfig/vg.pc
747 blino 215979
748     %if %{enable_wayland}
749     %files -n %{libgbmname}-devel
750     %{_includedir}/gbm.h
751     %{_libdir}/libgbm.so
752     %{_libdir}/pkgconfig/gbm.pc
753    
754     %files -n %{libwaylandeglname}-devel
755     %{_libdir}/libwayland-egl.so
756     %{_libdir}/pkgconfig/wayland-egl.pc
757     %endif
758 blino 270761
759     %files -n vdpau-driver-nouveau
760     %{_libdir}/vdpau/libvdpau_nouveau.so.*
761    
762     %files -n vdpau-driver-r300
763     %{_libdir}/vdpau/libvdpau_r300.so.*
764    
765     %files -n vdpau-driver-r600
766     %{_libdir}/vdpau/libvdpau_r600.so.*
767    
768     %files -n vdpau-driver-softpipe
769     %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30