/[packages]/cauldron/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /cauldron/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 271500 - (hide annotations) (download)
Mon Jul 16 20:19:17 2012 UTC (11 years, 9 months ago) by blino
File size: 20427 byte(s)
package new /etc/drirc in the mesa package and make dri drivers require it
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 tv 88231
18 blino 271483 %define git 20120715
19 mikala 112356 %define with_hardware 1
20    
21 tv 131211 %define relc 0
22 pterjan 5340 %define name mesa
23 blino 271483 %define version 8.1.0
24     %define rel 1
25 pterjan 5340
26     %define release %mkrel %{rel}
27     %define src_type tar.bz2
28 tv 173693 #define vsuffix %{expand:}
29     %define vsuffix %nil
30 pterjan 5340
31     %if %{relc}
32     %define release %mkrel 0.rc%{relc}.%{rel}
33     %define vsuffix -rc%{relc}
34     %define src_type tar.bz2
35     %endif
36    
37     %if %{git}
38     %if %{relc}
39 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
40 pterjan 5340 %else
41     %define release %mkrel 0.git%{git}.%{rel}
42     %endif
43     %endif
44    
45     %define makedepend %{_bindir}/gccmakedep
46    
47     %define eglname mesaegl
48     %define glname mesagl
49     %define gluname mesaglu
50     %define glwname mesaglw
51 tv 88442 %define glesv1name mesaglesv1
52     %define glesv2name mesaglesv2
53 tv 88445 %define openvgname mesaopenvg
54 mikala 112356 %define glapiname glapi
55 blino 215979 %define gbmname gbm
56     %define waylandeglname wayland-egl
57 tv 88442
58 pterjan 5340 %define eglmajor 1
59     %define glmajor 1
60     %define glumajor 1
61     %define glwmajor 1
62 tv 88442 %define glesv1major 1
63     %define glesv2major 2
64 tv 88445 %define openvgmajor 1
65 mikala 112356 %define glapimajor 0
66 blino 215979 %define gbmmajor 1
67     %define waylandeglmajor 1
68 tv 88442
69 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
70     %define libglname %mklibname %{glname} %{glmajor}
71     %define libgluname %mklibname %{gluname} %{glumajor}
72     %define libglwname %mklibname %{glwname} %{glwmajor}
73 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
74     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
75 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
76 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
77 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
78     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
79 pterjan 5340
80     %define dridrivers %mklibname dri-drivers
81    
82     # Architecture-independent Virtual provides:
83     %define libeglname_virt lib%{eglname}
84     %define libglname_virt lib%{glname}
85     %define libgluname_virt lib%{gluname}
86     %define libglwname_virt lib%{glwname}
87 tv 88442 %define libglesv1name_virt lib%{glesv1name}
88     %define libglesv2name_virt lib%{glesv2name}
89 tv 88445 %define libopenvgname_virt lib%{openvgname}
90 mikala 112356 %define libglapiname_virt lib%{glapiname}
91 blino 215979 %define libgbmname_virt lib%{gbmname}
92     %define libwaylandeglname_virt lib%{waylandeglname}
93 pterjan 5340
94     %define oldlibglname %mklibname MesaGL 1
95     %define oldlibgluname %mklibname MesaGLU 1
96    
97     %define mesasrcdir %{_prefix}/src/Mesa/
98     %define driver_dir %{_libdir}/dri
99    
100 tv 88451 %define enable_egl 1
101 blino 215979 %define enable_wayland 1
102 pterjan 5340
103     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
104     #FIXME: (for >=i586) disable sse
105     # SSE seems to have problem on some apps (gtulpas) for probing.
106 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
107 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
108 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
109 pterjan 5340 %define dri_drivers_ppc64 ""
110 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
111     %define dri_drivers_alpha "r200,radeon,swrast"
112     %define dri_drivers_sparc "ffb,radeon,swrast"
113     %define dri_drivers_mipsel "r200,radeon,swrast"
114 rtp 18133 %define dri_drivers_arm "swrast"
115 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
116    
117     Name: %{name}
118     Version: %{version}
119     Release: %{release}
120     Summary: OpenGL 2.1 compatible 3D graphics library
121     Group: System/Libraries
122    
123 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
124     BuildRequires: pkgconfig(xt) >= 1.0.5
125     BuildRequires: pkgconfig(xmu) >= 1.0.3
126     BuildRequires: pkgconfig(x11) >= 1.3.3
127     BuildRequires: pkgconfig(xdamage) >= 1.1.1
128 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
129     BuildRequires: gccmakedep
130     BuildRequires: x11-proto-devel >= 7.3
131 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
132 pterjan 5340
133 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
134     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
135     BuildRequires: pkgconfig(xi) >= 1.3
136     BuildRequires: pkgconfig(talloc)
137 tv 88443 BuildRequires: libxml2-python
138 tmb 35532 BuildRequires: makedepend
139 dmorgan 106004 BuildRequires: bison flex
140 blino 230504 BuildRequires: llvm-devel
141 mikala 127466 BuildRequires: pkgconfig(libudev)
142 blino 270761 BuildRequires: pkgconfig(vdpau)
143 blino 215979 %if %{enable_wayland}
144     BuildRequires: wayland-devel
145     %endif
146 pterjan 5340
147     URL: http://www.mesa3d.org
148     %if %{git}
149     # (cg) Current commit ref: origin/mesa_7_5_branch
150     Source0: %{name}-%{git}.tar.bz2
151     %else
152     Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{version}%{vsuffix}.%{src_type}
153     %endif
154     Source3: make-git-snapshot.sh
155    
156     # Instructions to setup your repository clone
157     # git://git.freedesktop.org/git/mesa/mesa
158     # git checkout mesa_7_5_branch
159     # git branch mdv-cherry-picks
160     # git am ../02??-*.patch
161     # git branch mdv-redhat
162     # git am ../03??-*.patch
163     # git branch mdv-patches
164     # git am ../09??-*.patch
165    
166     # In order to update to the branch via patches, issue this command:
167     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
168    
169     # Cherry picks
170     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
171     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
172    
173 tv 88247 # Patches "liberated" from Fedora:
174 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
175     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
176    
177 blino 271493 # Mageia/Mandriva patches
178 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
179 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
180     Patch901: 0901-llvmpipe-ldl.patch
181 pterjan 5340
182    
183 tv 88440 #------------------------------------------------------------------------------
184    
185     # package mesa
186 pterjan 5340 License: MIT
187     Requires: %{libglname} = %{version}-%{release}
188     Provides: hackMesa = %{version}
189     Obsoletes: hackMesa <= %{version}
190     Provides: Mesa = %{version}
191     Obsoletes: Mesa < %{version}
192    
193     %package -n %{libglname}
194     Summary: Files for Mesa (GL and GLX libs)
195     Group: System/Libraries
196 tv 88247 Obsoletes: %{oldlibglname} < 6.4
197 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
198     Provides: %{libglname_virt} = %{version}-%{release}
199     Requires: %{dridrivers} >= %{version}-%{release}
200 tv 135172 %if %{build_plf}
201     Requires: %mklibname txc-dxtn
202     %endif
203 pterjan 5340
204     # (anssi) Forces the upgrade of x11-server-common to happen before
205     # alternatives removal, which allows x11-server-common to grab the symlink.
206     Conflicts: x11-server-common < 1.3.0.0-17
207    
208     %package -n %{dridrivers}
209     Summary: Mesa DRI drivers
210     Group: System/Libraries
211 blino 271500 Requires: mesa = %{version}-%{release}
212 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
213 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
214     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
215 pterjan 5340
216     %package -n %{libglname}-devel
217     Summary: Development files for Mesa (OpenGL compatible 3D lib)
218     Group: Development/C
219 tv 88237 Requires: %{libglname} = %{version}-%{release}
220 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
221     Provides: %{glname}-devel = %{version}-%{release}
222     Provides: GL-devel
223     Obsoletes: %{oldlibglname}-devel < 6.4
224     Provides: %{oldlibglname}-devel = %{version}-%{release}
225     Provides: libMesaGL-devel = %{version}-%{release}
226     Provides: MesaGL-devel = %{version}-%{release}
227 tv 88438 Provides: libgl-devel
228 pterjan 5340
229     %package -n %{libgluname}
230     Summary: Files for Mesa (GLU libs)
231     Group: System/Libraries
232     Obsoletes: %{oldlibgluname} < 6.4
233     Provides: %{oldlibgluname} = %{version}-%{release}
234     Provides: %{libgluname_virt} = %{version}-%{release}
235    
236     %package -n %{libgluname}-devel
237     Summary: Development files for GLU libs
238     Group: Development/C
239     Requires: %{libgluname} = %{version}-%{release}
240     Provides: lib%{gluname}-devel = %{version}-%{release}
241     Provides: %{gluname}-devel = %{version}-%{release}
242     Obsoletes: %{oldlibgluname}-devel < 6.4
243     Provides: %{oldlibgluname}-devel = %{version}-%{release}
244     Provides: libMesaGLU-devel = %{version}-%{release}
245 tv 88247 Provides: MesaGLU-devel = %{version}-%{release}
246 tv 88438 Provides: libglu-devel
247 tv 88436 # pkgconfig files moved from libgl-devel:
248     Conflicts: %{libglname}-devel < 7.10.2-4
249 pterjan 5340
250 tv 88433 %if %{enable_egl}
251     %package -n %{libeglname}
252     Summary: Files for Mesa (EGL libs)
253     Group: System/Libraries
254     Provides: %{libeglname_virt} = %{version}-%{release}
255    
256     %package -n %{libeglname}-devel
257     Summary: Development files for Mesa (EGL libs)
258     Group: Development/C
259 tv 88439 Requires: %{libeglname} = %{version}-%{release}
260 tv 88433 Provides: EGL-devel
261 tv 88438 Provides: lib%{eglname}-devel
262     Provides: %{eglname}-devel
263     Provides: libegl-devel
264 tv 88433 %endif
265    
266 mikala 112356 %package -n %{libglapiname}
267     Summary: Files for mesa (glapi libs)
268     Group: System/Libraries
269     Provides: %{libglapiname_virt} = %{version}-%{release}
270 tv 88442
271 mikala 112356 %package -n %{libglapiname}-devel
272     Summary: Development files for glapi libs
273     Group: Development/C
274     Requires: %{libglapiname_virt} = %{version}-%{release}
275     Provides: lib%{glapiname}-devel
276     Provides: %{libglapiname}-devel
277    
278 tv 88442 %package -n %{libglesv1name}
279     Summary: Files for Mesa (glesv1 libs)
280     Group: System/Libraries
281     Provides: %{libglesv1name_virt} = %{version}-%{release}
282    
283     %package -n %{libglesv1name}-devel
284     Summary: Development files for glesv1 libs
285     Group: Development/C
286     Requires: %{libglesv1name} = %{version}-%{release}
287     Provides: lib%{glesv1name}-devel
288     Provides: %{glesv1name}-devel
289     Provides: libglesv1-devel
290    
291     %package -n %{libglesv2name}
292     Summary: Files for Mesa (glesv2 libs)
293     Group: System/Libraries
294     Provides: %{libglesv2name_virt} = %{version}-%{release}
295    
296     %package -n %{libglesv2name}-devel
297     Summary: Development files for glesv2 libs
298     Group: Development/C
299     Requires: %{libglesv2name} = %{version}-%{release}
300 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
301 tv 88442 Provides: lib%{glesv2name}-devel
302     Provides: %{glesv2name}-devel
303     Provides: libglesv2-devel
304    
305 tv 88445 %package -n %{libopenvgname}
306     Summary: Files for MESA (OpenVG libs)
307     Group: System/Libraries
308     Provides: %{libopenvgname_virt} = %{version}-%{release}
309    
310     %package -n %{libopenvgname}-devel
311     Summary: Development files vor OpenVG libs
312     Group: Development/C
313     Requires: %{libopenvgname} = %{version}-%{release}
314     Provides: lib%{openvgname}-devel
315     Provides: %{openvgname}-devel
316     Provides: libopenvg-devel
317    
318 blino 215979 %if %{enable_wayland}
319     %package -n %{libgbmname}
320     Summary: Files for Mesa (gbm libs)
321     Group: System/Libraries
322     Provides: %{libgbmname_virt} = %{version}-%{release}
323    
324     %package -n %{libgbmname}-devel
325     Summary: Development files for Mesa (gbm libs)
326     Group: Development/C
327     Requires: %{libgbmname} = %{version}-%{release}
328     Provides: lib%{gbmname}-devel
329     Provides: %{gbmname}-devel
330    
331     %package -n %{libwaylandeglname}
332     Summary: Files for Mesa (Wayland EGL libs)
333     Group: System/Libraries
334     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
335    
336     %package -n %{libwaylandeglname}-devel
337     Summary: Development files for Mesa (Wayland EGL libs)
338     Group: Development/C
339     Requires: %{libwaylandeglname} = %{version}-%{release}
340     Provides: lib%{waylandeglname}-devel
341     Provides: %{waylandeglname}-devel
342     %endif
343    
344 blino 270761 %package -n vdpau-driver-nouveau
345     Summary: VDPAU plugin for nouveau driver
346     Group: System/Libraries
347    
348     %package -n vdpau-driver-r300
349     Summary: VDPAU plugin for r300 driver
350     Group: System/Libraries
351    
352     %package -n vdpau-driver-r600
353     Summary: VDPAU plugin for r600 driver
354     Group: System/Libraries
355    
356     %package -n vdpau-driver-softpipe
357     Summary: VDPAU plugin for softpipe driver
358     Group: System/Libraries
359    
360 pterjan 5340 %package common-devel
361     Summary: Meta package for mesa devel
362     Group: Development/C
363 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
364 pterjan 5340 Provides: hackMesa-common-devel = %{version}
365 tv 88247 Obsoletes: Mesa-common-devel < %{version}
366 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
367     Requires: %{libglname}-devel = %{version}
368     Requires: %{libgluname}-devel = %{version}
369 tv 135156 Requires: freeglut-devel
370 tv 88442 Requires: %{libeglname}-devel = %{version}
371     Requires: %{libglesv1name}-devel = %{version}
372     Requires: %{libglesv2name}-devel = %{version}
373 pterjan 5340
374 tv 88440 #------------------------------------------------------------------------------
375 pterjan 5340
376     %description
377     Mesa is an OpenGL 2.1 compatible 3D graphics library.
378 tv 135173 %if %{build_plf}
379 pterjan 5340
380 tv 135173 This package is in the "tainted" section because it enables some
381     OpenGL extentions that are covered by software patents.
382     %endif
383    
384 pterjan 5340 %description common-devel
385     Mesa common metapackage devel
386    
387     %if %{enable_egl}
388     %description -n %{libeglname}
389     Mesa is an OpenGL 2.1 compatible 3D graphics library.
390     EGL parts.
391    
392     %description -n %{libeglname}-devel
393     Mesa is an OpenGL 2.1 compatible 3D graphics library.
394     EGL development parts.
395     %endif
396    
397     %description -n %{libglname}
398     Mesa is an OpenGL 2.1 compatible 3D graphics library.
399     GL and GLX parts.
400    
401 tv 135155 %if %{build_plf}
402     This package is in the "tainted" section because it enables some
403     OpenGL extentions that are covered by software patents.
404     %endif
405    
406 pterjan 5340 %description -n %{dridrivers}
407     Mesa is an OpenGL 2.1 compatible 3D graphics library.
408     DRI drivers.
409    
410     %description -n %{libglname}-devel
411     Mesa is an OpenGL 2.1 compatible 3D graphics library.
412    
413     This package contains the headers needed to compile Mesa programs.
414    
415     %description -n %{libgluname}
416     GLU is the OpenGL Utility Library.
417     It provides a number of functions upon the base OpenGL library to provide
418     higher-level drawing routines from the more primitive routines provided by
419     OpenGL.
420    
421     %description -n %{libgluname}-devel
422     This package contains the headers needed to compile programs with GLU.
423    
424 tv 88442 %description -n %{libglesv1name}
425     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
426     well-defined subset profiles of OpenGL.
427    
428     This package provides the OpenGL ES library version 1.
429    
430 mikala 112356 %description -n %{libglapiname}
431     This packages provides the glapi shared library used by gallium.
432    
433     %description -n %{libglapiname}-devel
434     This package contains the headers needed to compile programes against glapi shared library.
435    
436 tv 88442 %description -n %{libglesv1name}-devel
437     This package contains the headers needed to compile OpenGL ES 1 programs.
438    
439     %description -n %{libglesv2name}
440     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
441     well-defined subset profiles of OpenGL.
442    
443     This package provides the OpenGL ES library version 2.
444    
445     %description -n %{libglesv2name}-devel
446     This package contains the headers needed to compile OpenGL ES 2 programs.
447    
448 tv 88445 %description -n %{libopenvgname}
449     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
450     acceleration interface for vector graphics libraries such as Flash and SVG.
451    
452     %description -n %{libopenvgname}-devel
453     Development files for OpenVG library.
454    
455 blino 215979 %if %{enable_wayland}
456     %description -n %{libgbmname}
457     Mesa is an OpenGL 2.1 compatible 3D graphics library.
458     GBM (Graphics Buffer Manager) parts.
459    
460     %description -n %{libgbmname}-devel
461     Mesa is an OpenGL 2.1 compatible 3D graphics library.
462     GBM (Graphics Buffer Manager) development parts.
463    
464     %description -n %{libwaylandeglname}
465     Mesa is an OpenGL 2.1 compatible 3D graphics library.
466     Wayland EGL platform parts.
467    
468     %description -n %{libwaylandeglname}-devel
469     Mesa is an OpenGL 2.1 compatible 3D graphics library.
470     Wayland EGL platform development parts.
471     %endif
472    
473 blino 270761 %description -n vdpau-driver-nouveau
474     This packages provides a VPDAU plugin to enable video acceleration
475     with the nouveau driver.
476    
477     %description -n vdpau-driver-r300
478     This packages provides a VPDAU plugin to enable video acceleration
479     with the r300 driver.
480    
481     %description -n vdpau-driver-r600
482     This packages provides a VPDAU plugin to enable video acceleration
483     with the r600 driver.
484    
485     %description -n vdpau-driver-softpipe
486     This packages provides a VPDAU plugin to enable video acceleration
487     with the softpipe driver.
488    
489 tv 88440 #------------------------------------------------------------------------------
490    
491 pterjan 5340 %prep
492     %if %{git}
493     %setup -q -n mesa-%{git}
494     %else
495 tv 207029 %setup -q -n Mesa-%{version}%{vsuffix}
496 pterjan 5340 %endif
497    
498     %patch201 -p1
499 blino 271493 %patch901 -p1
500 pterjan 5340
501     %build
502     autoreconf -vfi
503     %configure2_5x --with-driver=dri \
504     --with-dri-driverdir=%{driver_dir} \
505     --with-dri-drivers="%{dri_drivers}" \
506 anssi 165988 --enable-shared-dricore \
507 pterjan 5340 %if %{enable_egl}
508     --enable-egl \
509     %else
510     --disable-egl \
511     %endif
512 blino 215979 %if %{enable_wayland}
513     --with-egl-platforms=x11,wayland,drm \
514     --enable-gbm \
515     --enable-shared-glapi \
516     %endif
517 tv 88442 --enable-gles1 \
518     --enable-gles2 \
519 tv 88445 --enable-openvg \
520 mikala 112356 --enable-gallium-egl \
521 blino 270761 --enable-gallium-g3dvl \
522     --disable-xvmc \
523     --enable-vdpau \
524     --disable-va \
525 mikala 112356 %if %{with_hardware}
526     --with-gallium-drivers=r300,r600,nouveau,swrast \
527     --enable-gallium-llvm \
528     %else
529     --disable-gallium-llvm \
530     --with-gallium-drivers=swrast \
531     %endif
532 tv 135155 %if %{build_plf}
533     --enable-texture-float \
534     %endif
535 blino 270723 # end of configure options
536 pterjan 5340
537 anssi 165988 %make
538 pterjan 5340
539     %install
540 tv 88249 %makeinstall_std
541 pterjan 5340
542 blino 216556 # FIXME: strip will likely break the hardlink
543 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
544     # to prevent proprietary driver installers from removing them
545     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
546     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
547     for l in ../libGL.so.*; do cp -a $l .; done
548     popd
549    
550     %ifarch %{x86_64}
551     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
552     %endif
553    
554 tv 88231 rm -f %{buildroot}/%{_includedir}/GL/glut.h
555     rm -f %{buildroot}/%{_includedir}/GL/glutf90.h
556    
557 blino 270761 # .so files are not needed by vdpau
558     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
559    
560 blino 271144 # .la files are not needed by mesa
561     find %{buildroot} -name '*.la' -exec rm {} \;
562    
563 anssi 181478 # use swrastg if built (Anssi 12/2011)
564     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
565    
566 tv 88440 #------------------------------------------------------------------------------
567    
568 pterjan 5340 %files
569     %defattr(-,root,root)
570 blino 271481 %doc docs/COPYING
571 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
572 pterjan 5340
573     %files -n %{dridrivers}
574     %defattr(-,root,root)
575     %doc docs/COPYING
576     %ifnarch ppc64
577     %dir %{_libdir}/dri
578 anssi 165988 %{_libdir}/dri/libdricore.so
579 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
580     #%{_libdir}/dri/libglsl.so
581 pterjan 5340 %{_libdir}/dri/*_dri.so
582     %endif
583    
584 tv 88433 %files -n %{libglname}
585     %defattr(-,root,root)
586     %doc docs/COPYING
587     %{_libdir}/libGL.so.*
588     %dir %{_libdir}/mesa
589 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
590 tv 88433
591 tv 88437 %files -n %{libgluname}
592 tv 88433 %defattr(-,root,root)
593     %doc docs/COPYING
594 tv 88434 %{_libdir}/libGLU.so.%{glumajor}*
595 tv 88433
596     %if %{enable_egl}
597     %files -n %{libeglname}
598     %defattr(-,root,root)
599 tv 88442 %doc docs/COPYING
600 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
601 tv 88442 %dir %{_libdir}/egl
602 blino 215979 %if !%{enable_wayland}
603     # st_GL, built only when shared glapi is not enabled
604 mikala 112356 %{_libdir}/egl/st_GL.so
605 blino 215979 %endif
606 mikala 127466 %{_libdir}/egl/egl_gallium.so
607 tv 88441 %endif
608 tv 88433
609 mikala 112356 %files -n %{libglapiname}
610     %defattr(-,root,root)
611     %{_libdir}/libglapi.so.%{glapimajor}*
612    
613 tv 88442 %files -n %{libglesv1name}
614     %defattr(-,root,root)
615     %doc docs/COPYING
616     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
617    
618     %files -n %{libglesv2name}
619     %defattr(-,root,root)
620     %doc docs/COPYING
621     %{_libdir}/libGLESv2.so.%{glesv2major}*
622    
623 tv 88445 %files -n %{libopenvgname}
624     %defattr(-,root,root)
625     %doc docs/COPYING
626     %{_libdir}/libOpenVG.so.%{openvgmajor}*
627    
628 blino 215979 %if %{enable_wayland}
629     %files -n %{libgbmname}
630     %{_libdir}/libgbm.so.%{gbmmajor}
631 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
632 blino 215979 %{_libdir}/gbm/gbm_*.so
633     %{_libdir}/gbm/pipe_*.so
634 tv 88445
635 blino 215979 %files -n %{libwaylandeglname}
636     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
637 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
638 blino 215979 %endif
639    
640    
641 pterjan 5340 %files -n %{libglname}-devel
642     %defattr(-,root,root)
643     %doc docs/COPYING
644     %{_includedir}/GL/gl.h
645     %{_includedir}/GL/glext.h
646     %{_includedir}/GL/gl_mangle.h
647     %{_includedir}/GL/osmesa.h
648     %{_includedir}/GL/wglext.h
649     %{_includedir}/GL/glx.h
650     %{_includedir}/GL/glxext.h
651     %{_includedir}/GL/glx_mangle.h
652     %{_libdir}/libGL.so
653 tv 88436 %{_libdir}/pkgconfig/gl.pc
654     %{_libdir}/pkgconfig/dri.pc
655 pterjan 5340
656     #FIXME: check those headers
657     %{_includedir}/GL/vms_x_fix.h
658     %{_includedir}/GL/wmesa.h
659     %dir %{_includedir}/GL/internal
660     %{_includedir}/GL/internal/dri_interface.h
661    
662     %files -n %{libgluname}-devel
663     %defattr(-,root,root)
664     %doc docs/COPYING
665     %{_includedir}/GL/glu.h
666     %{_includedir}/GL/glu_mangle.h
667     %{_libdir}/libGLU.so
668 tv 88436 %{_libdir}/pkgconfig/glu.pc
669 pterjan 5340
670     %files common-devel
671     %defattr(-,root,root)
672    
673 tv 88441 %if %{enable_egl}
674 tv 88433 %files -n %{libeglname}-devel
675     %defattr(-,root,root)
676 tv 88442 %doc docs/COPYING
677     %{_includedir}/EGL
678     %{_includedir}/KHR
679 tv 88433 %{_libdir}/libEGL.so
680 tv 88436 %{_libdir}/pkgconfig/egl.pc
681 tv 88433 %endif
682 pterjan 5340
683 mikala 112356 %files -n %{libglapiname}-devel
684     %defattr(-,root,root)
685     %{_libdir}/libglapi.so
686 pterjan 5340
687 tv 88442 %files -n %{libglesv1name}-devel
688     %defattr(-,root,root)
689     %{_includedir}/GLES
690     %{_libdir}/libGLESv1_CM.so
691     %{_libdir}/pkgconfig/glesv1_cm.pc
692 tv 88433
693 tv 88442 %files -n %{libglesv2name}-devel
694     %defattr(-,root,root)
695     %{_includedir}/GLES2
696     %{_libdir}/libGLESv2.so
697     %{_libdir}/pkgconfig/glesv2.pc
698 tv 88445
699     %files -n %{libopenvgname}-devel
700     %defattr(-,root,root)
701     %{_includedir}/VG
702     %{_libdir}/libOpenVG.so
703     %{_libdir}/pkgconfig/vg.pc
704 blino 215979
705     %if %{enable_wayland}
706     %files -n %{libgbmname}-devel
707     %{_includedir}/gbm.h
708     %{_libdir}/libgbm.so
709     %{_libdir}/pkgconfig/gbm.pc
710    
711     %files -n %{libwaylandeglname}-devel
712     %{_libdir}/libwayland-egl.so
713     %{_libdir}/pkgconfig/wayland-egl.pc
714     %endif
715 blino 270761
716     %files -n vdpau-driver-nouveau
717     %{_libdir}/vdpau/libvdpau_nouveau.so.*
718    
719     %files -n vdpau-driver-r300
720     %{_libdir}/vdpau/libvdpau_r300.so.*
721    
722     %files -n vdpau-driver-r600
723     %{_libdir}/vdpau/libvdpau_r600.so.*
724    
725     %files -n vdpau-driver-softpipe
726     %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30