/[packages]/cauldron/mesa/current/SPECS/mesa.spec
ViewVC logotype

Annotation of /cauldron/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 289282 - (hide annotations) (download)
Fri Sep 7 11:03:21 2012 UTC (11 years, 6 months ago) by blino
File size: 23423 byte(s)
enable again radeonsi now that upstream fixed symbol conflicts with r600g
1 rtp 18133 %define bootstrap 0
2     %{?_without_bootstrap: %global bootstrap 0}
3     %{?_with_bootstrap: %global bootstrap 1}
4    
5 tv 135155 %if "%distro_section" == "tainted"
6     %global build_plf 1
7     %else
8     %global build_plf 0
9     %endif
10    
11 pterjan 5340 # (cg) Cheater...
12     %define Werror_cflags %nil
13    
14     # (aco) Needed for the dri drivers
15     %define _disable_ld_no_undefined 1
16    
17 tv 88231
18 blino 289278 %define git 20120906
19     %define git_branch 9.0
20 mikala 112356 %define with_hardware 1
21    
22 tv 131211 %define relc 0
23 pterjan 5340 %define name mesa
24 blino 289278 %define version 9.0.0
25     %define rel 1
26 pterjan 5340
27     %define release %mkrel %{rel}
28     %define src_type tar.bz2
29 tv 173693 #define vsuffix %{expand:}
30     %define vsuffix %nil
31 pterjan 5340
32     %if %{relc}
33     %define release %mkrel 0.rc%{relc}.%{rel}
34     %define vsuffix -rc%{relc}
35     %define src_type tar.bz2
36     %endif
37    
38     %if %{git}
39     %if %{relc}
40 mikala 123310 %define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel}
41 pterjan 5340 %else
42     %define release %mkrel 0.git%{git}.%{rel}
43     %endif
44     %endif
45    
46     %define makedepend %{_bindir}/gccmakedep
47    
48 blino 271501 %define dricorename dricore
49 pterjan 5340 %define eglname mesaegl
50     %define glname mesagl
51     %define gluname mesaglu
52     %define glwname mesaglw
53 tv 88442 %define glesv1name mesaglesv1
54     %define glesv2name mesaglesv2
55 tv 88445 %define openvgname mesaopenvg
56 mikala 112356 %define glapiname glapi
57 blino 215979 %define gbmname gbm
58     %define waylandeglname wayland-egl
59 tv 88442
60 blino 271501 %define dricoremajor 1
61 pterjan 5340 %define eglmajor 1
62     %define glmajor 1
63     %define glumajor 1
64     %define glwmajor 1
65 tv 88442 %define glesv1major 1
66     %define glesv2major 2
67 tv 88445 %define openvgmajor 1
68 mikala 112356 %define glapimajor 0
69 blino 215979 %define gbmmajor 1
70     %define waylandeglmajor 1
71 anssi 278008 %define osmesamajor 8
72 tv 88442
73 blino 271501 %define libdricorename %mklibname %{dricorename} %{dricoremajor}
74 pterjan 5340 %define libeglname %mklibname %{eglname} %{eglmajor}
75     %define libglname %mklibname %{glname} %{glmajor}
76     %define libgluname %mklibname %{gluname} %{glumajor}
77     %define libglwname %mklibname %{glwname} %{glwmajor}
78 tv 88442 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
79     %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
80 tv 88445 %define libopenvgname %mklibname %{openvgname} %{openvgmajor}
81 mikala 112356 %define libglapiname %mklibname %{glapiname} %{glapimajor}
82 blino 215979 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
83     %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
84 anssi 278008 %define libosmesaname %mklibname osmesa %{osmesamajor}
85 pterjan 5340
86     %define dridrivers %mklibname dri-drivers
87    
88 anssi 278008 %define osmesadevel %mklibname osmesa -d
89    
90 pterjan 5340 # Architecture-independent Virtual provides:
91 blino 271501 %define libdricorename_virt lib%{dricorename}
92 pterjan 5340 %define libeglname_virt lib%{eglname}
93     %define libglname_virt lib%{glname}
94     %define libgluname_virt lib%{gluname}
95     %define libglwname_virt lib%{glwname}
96 tv 88442 %define libglesv1name_virt lib%{glesv1name}
97     %define libglesv2name_virt lib%{glesv2name}
98 tv 88445 %define libopenvgname_virt lib%{openvgname}
99 mikala 112356 %define libglapiname_virt lib%{glapiname}
100 blino 215979 %define libgbmname_virt lib%{gbmname}
101     %define libwaylandeglname_virt lib%{waylandeglname}
102 pterjan 5340
103     %define oldlibglname %mklibname MesaGL 1
104     %define oldlibgluname %mklibname MesaGLU 1
105    
106     %define mesasrcdir %{_prefix}/src/Mesa/
107     %define driver_dir %{_libdir}/dri
108    
109 tv 88451 %define enable_egl 1
110 blino 215979 %define enable_wayland 1
111 pterjan 5340
112     #FIXME: (for 386/485) unset SSE, MMX and 3dnow flags
113     #FIXME: (for >=i586) disable sse
114     # SSE seems to have problem on some apps (gtulpas) for probing.
115 tv 207029 %define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast"
116 pterjan 5340 %define dri_drivers_x86_64 %{dri_drivers_i386}
117 tv 207029 %define dri_drivers_ppc "r200,radeon,swrast"
118 pterjan 5340 %define dri_drivers_ppc64 ""
119 tv 207029 %define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast"
120     %define dri_drivers_alpha "r200,radeon,swrast"
121     %define dri_drivers_sparc "ffb,radeon,swrast"
122     %define dri_drivers_mipsel "r200,radeon,swrast"
123 rtp 18133 %define dri_drivers_arm "swrast"
124 pterjan 5340 %define dri_drivers %{expand:%{dri_drivers_%{_arch}}}
125    
126     Name: %{name}
127     Version: %{version}
128     Release: %{release}
129     Summary: OpenGL 2.1 compatible 3D graphics library
130     Group: System/Libraries
131    
132 mikala 127466 BuildRequires: pkgconfig(xfixes) >= 4.0.3
133     BuildRequires: pkgconfig(xt) >= 1.0.5
134     BuildRequires: pkgconfig(xmu) >= 1.0.3
135     BuildRequires: pkgconfig(x11) >= 1.3.3
136     BuildRequires: pkgconfig(xdamage) >= 1.1.1
137 pterjan 5340 BuildRequires: libexpat-devel >= 2.0.1
138     BuildRequires: gccmakedep
139     BuildRequires: x11-proto-devel >= 7.3
140 mikala 127466 BuildRequires: pkgconfig(libdrm) >= 2.4.21
141 pterjan 5340
142 mikala 127466 BuildRequires: pkgconfig(xext) >= 1.1.1
143     BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
144     BuildRequires: pkgconfig(xi) >= 1.3
145     BuildRequires: pkgconfig(talloc)
146 tv 88443 BuildRequires: libxml2-python
147 tmb 35532 BuildRequires: makedepend
148 dmorgan 106004 BuildRequires: bison flex
149 blino 289282 BuildRequires: llvm-devel >= 3.1
150 mikala 127466 BuildRequires: pkgconfig(libudev)
151 blino 270761 BuildRequires: pkgconfig(vdpau)
152 blino 215979 %if %{enable_wayland}
153     BuildRequires: wayland-devel
154     %endif
155 pterjan 5340
156     URL: http://www.mesa3d.org
157     %if %{git}
158 blino 289278 # (blino) snapshot of 9.0 branch
159     Source0: %{name}-%{git_branch}-%{git}.tar.bz2
160 pterjan 5340 %else
161     Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{version}%{vsuffix}.%{src_type}
162     %endif
163     Source3: make-git-snapshot.sh
164    
165     # Instructions to setup your repository clone
166     # git://git.freedesktop.org/git/mesa/mesa
167     # git checkout mesa_7_5_branch
168     # git branch mdv-cherry-picks
169     # git am ../02??-*.patch
170     # git branch mdv-redhat
171     # git am ../03??-*.patch
172     # git branch mdv-patches
173     # git am ../09??-*.patch
174 blino 289281 Patch001: 0001-Fix-undefined-symbols-in-libOSMesa-and-libglapi.patch
175 anssi 278531
176 pterjan 5340 # In order to update to the branch via patches, issue this command:
177     # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
178    
179     # Cherry picks
180     # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
181     Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
182 blino 289280 # (blino) should be pushed to 9.0 branch upstream
183     Patch202: 0202-radeon-llvm-Cleanup-makefile.patch
184 pterjan 5340
185 tv 88247 # Patches "liberated" from Fedora:
186 pterjan 5340 # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
187     # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
188    
189 blino 278732 # Patches from ChromiumOS
190     # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
191    
192 blino 271493 # Mageia/Mandriva patches
193 pterjan 5340 # git format-patch --start-number 900 mdv-redhat..mdv-patches
194 blino 271493 # (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167
195 blino 278333 Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch
196 pterjan 5340
197    
198 tv 88440 #------------------------------------------------------------------------------
199    
200     # package mesa
201 pterjan 5340 License: MIT
202     Requires: %{libglname} = %{version}-%{release}
203     Provides: hackMesa = %{version}
204     Obsoletes: hackMesa <= %{version}
205     Provides: Mesa = %{version}
206     Obsoletes: Mesa < %{version}
207    
208 blino 271501 %package -n %{libdricorename}
209     Summary: Shared library for DRI drivers
210     Group: System/Libraries
211     Provides: %{libdricorename_virt} = %{version}-%{release}
212    
213     %package -n %{libdricorename}-devel
214     Summary: Development files for DRI core
215     Group: Development/C
216     Requires: %{libdricorename} = %{version}-%{release}
217     Provides: lib%{dricorename}-devel = %{version}-%{release}
218     Provides: %{dricorename}-devel = %{version}-%{release}
219    
220 pterjan 5340 %package -n %{libglname}
221     Summary: Files for Mesa (GL and GLX libs)
222     Group: System/Libraries
223 tv 88247 Obsoletes: %{oldlibglname} < 6.4
224 pterjan 5340 Provides: %{oldlibglname} = %{version}-%{release}
225     Provides: %{libglname_virt} = %{version}-%{release}
226     Requires: %{dridrivers} >= %{version}-%{release}
227 tv 135172 %if %{build_plf}
228     Requires: %mklibname txc-dxtn
229     %endif
230 pterjan 5340
231     # (anssi) Forces the upgrade of x11-server-common to happen before
232     # alternatives removal, which allows x11-server-common to grab the symlink.
233     Conflicts: x11-server-common < 1.3.0.0-17
234    
235     %package -n %{dridrivers}
236     Summary: Mesa DRI drivers
237     Group: System/Libraries
238 blino 274132 # do not require exact release to avoid conflicts when having
239     # x86_64 dri drivers from tainted and i586 dri drivers from core
240     Requires: mesa = %{version}
241 pterjan 5340 Conflicts: %{_lib}MesaGL1 < 7.7-5
242 anssi 181478 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
243     Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
244 pterjan 5340
245     %package -n %{libglname}-devel
246     Summary: Development files for Mesa (OpenGL compatible 3D lib)
247     Group: Development/C
248 tv 88237 Requires: %{libglname} = %{version}-%{release}
249 pterjan 5340 Provides: lib%{glname}-devel = %{version}-%{release}
250     Provides: %{glname}-devel = %{version}-%{release}
251     Provides: GL-devel
252     Obsoletes: %{oldlibglname}-devel < 6.4
253     Provides: %{oldlibglname}-devel = %{version}-%{release}
254     Provides: libMesaGL-devel = %{version}-%{release}
255     Provides: MesaGL-devel = %{version}-%{release}
256 tv 88438 Provides: libgl-devel
257 pterjan 5340
258     %package -n %{libgluname}
259     Summary: Files for Mesa (GLU libs)
260     Group: System/Libraries
261     Obsoletes: %{oldlibgluname} < 6.4
262     Provides: %{oldlibgluname} = %{version}-%{release}
263     Provides: %{libgluname_virt} = %{version}-%{release}
264    
265     %package -n %{libgluname}-devel
266     Summary: Development files for GLU libs
267     Group: Development/C
268     Requires: %{libgluname} = %{version}-%{release}
269     Provides: lib%{gluname}-devel = %{version}-%{release}
270     Provides: %{gluname}-devel = %{version}-%{release}
271     Obsoletes: %{oldlibgluname}-devel < 6.4
272     Provides: %{oldlibgluname}-devel = %{version}-%{release}
273     Provides: libMesaGLU-devel = %{version}-%{release}
274 tv 88247 Provides: MesaGLU-devel = %{version}-%{release}
275 tv 88438 Provides: libglu-devel
276 tv 88436 # pkgconfig files moved from libgl-devel:
277     Conflicts: %{libglname}-devel < 7.10.2-4
278 pterjan 5340
279 tv 88433 %if %{enable_egl}
280     %package -n %{libeglname}
281     Summary: Files for Mesa (EGL libs)
282     Group: System/Libraries
283     Provides: %{libeglname_virt} = %{version}-%{release}
284    
285     %package -n %{libeglname}-devel
286     Summary: Development files for Mesa (EGL libs)
287     Group: Development/C
288 tv 88439 Requires: %{libeglname} = %{version}-%{release}
289 tv 88433 Provides: EGL-devel
290 tv 88438 Provides: lib%{eglname}-devel
291     Provides: %{eglname}-devel
292     Provides: libegl-devel
293 tv 88433 %endif
294    
295 anssi 278008 %package -n %{libosmesaname}
296     Summary: Mesa offscreen rendering library
297     Group: System/Libraries
298    
299     %package -n %{osmesadevel}
300     Summary: Development files for libosmesa
301     Group: Development/C
302     Requires: %{libosmesaname} = %{version}-%{release}
303     Provides: osmesa-devel = %{version}-%{release}
304     Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
305    
306 mikala 112356 %package -n %{libglapiname}
307     Summary: Files for mesa (glapi libs)
308     Group: System/Libraries
309     Provides: %{libglapiname_virt} = %{version}-%{release}
310 tv 88442
311 mikala 112356 %package -n %{libglapiname}-devel
312     Summary: Development files for glapi libs
313     Group: Development/C
314     Requires: %{libglapiname_virt} = %{version}-%{release}
315     Provides: lib%{glapiname}-devel
316     Provides: %{libglapiname}-devel
317    
318 tv 88442 %package -n %{libglesv1name}
319     Summary: Files for Mesa (glesv1 libs)
320     Group: System/Libraries
321     Provides: %{libglesv1name_virt} = %{version}-%{release}
322    
323     %package -n %{libglesv1name}-devel
324     Summary: Development files for glesv1 libs
325     Group: Development/C
326     Requires: %{libglesv1name} = %{version}-%{release}
327     Provides: lib%{glesv1name}-devel
328     Provides: %{glesv1name}-devel
329     Provides: libglesv1-devel
330    
331     %package -n %{libglesv2name}
332     Summary: Files for Mesa (glesv2 libs)
333     Group: System/Libraries
334     Provides: %{libglesv2name_virt} = %{version}-%{release}
335    
336     %package -n %{libglesv2name}-devel
337     Summary: Development files for glesv2 libs
338     Group: Development/C
339     Requires: %{libglesv2name} = %{version}-%{release}
340 blino 216556 Requires: %{libeglname}-devel = %{version}-%{release}
341 tv 88442 Provides: lib%{glesv2name}-devel
342     Provides: %{glesv2name}-devel
343     Provides: libglesv2-devel
344    
345 tv 88445 %package -n %{libopenvgname}
346     Summary: Files for MESA (OpenVG libs)
347     Group: System/Libraries
348     Provides: %{libopenvgname_virt} = %{version}-%{release}
349    
350     %package -n %{libopenvgname}-devel
351     Summary: Development files vor OpenVG libs
352     Group: Development/C
353     Requires: %{libopenvgname} = %{version}-%{release}
354     Provides: lib%{openvgname}-devel
355     Provides: %{openvgname}-devel
356     Provides: libopenvg-devel
357    
358 blino 215979 %if %{enable_wayland}
359     %package -n %{libgbmname}
360     Summary: Files for Mesa (gbm libs)
361     Group: System/Libraries
362     Provides: %{libgbmname_virt} = %{version}-%{release}
363    
364     %package -n %{libgbmname}-devel
365     Summary: Development files for Mesa (gbm libs)
366     Group: Development/C
367     Requires: %{libgbmname} = %{version}-%{release}
368     Provides: lib%{gbmname}-devel
369     Provides: %{gbmname}-devel
370    
371     %package -n %{libwaylandeglname}
372     Summary: Files for Mesa (Wayland EGL libs)
373     Group: System/Libraries
374     Provides: %{libwaylandeglname_virt} = %{version}-%{release}
375    
376     %package -n %{libwaylandeglname}-devel
377     Summary: Development files for Mesa (Wayland EGL libs)
378     Group: Development/C
379     Requires: %{libwaylandeglname} = %{version}-%{release}
380     Provides: lib%{waylandeglname}-devel
381     Provides: %{waylandeglname}-devel
382     %endif
383    
384 blino 270761 %package -n vdpau-driver-nouveau
385     Summary: VDPAU plugin for nouveau driver
386 blino 279553 Group: Video
387 blino 270761
388     %package -n vdpau-driver-r300
389     Summary: VDPAU plugin for r300 driver
390 blino 279553 Group: Video
391 blino 270761
392     %package -n vdpau-driver-r600
393     Summary: VDPAU plugin for r600 driver
394 blino 279553 Group: Video
395 blino 270761
396 blino 289282 %package -n vdpau-driver-radeonsi
397     Summary: VDPAU plugin for radeonsi driver
398     Group: System/Libraries
399    
400 blino 270761 %package -n vdpau-driver-softpipe
401     Summary: VDPAU plugin for softpipe driver
402 blino 279553 Group: Video
403 blino 270761
404 pterjan 5340 %package common-devel
405     Summary: Meta package for mesa devel
406     Group: Development/C
407 tv 88247 Provides: Mesa-common-devel = %{version}-%{release}
408 pterjan 5340 Provides: hackMesa-common-devel = %{version}
409 tv 88247 Obsoletes: Mesa-common-devel < %{version}
410 pterjan 5340 Obsoletes: hackMesa-common-devel < %{version}
411     Requires: %{libglname}-devel = %{version}
412     Requires: %{libgluname}-devel = %{version}
413 tv 135156 Requires: freeglut-devel
414 tv 88442 Requires: %{libeglname}-devel = %{version}
415     Requires: %{libglesv1name}-devel = %{version}
416     Requires: %{libglesv2name}-devel = %{version}
417 pterjan 5340
418 tv 88440 #------------------------------------------------------------------------------
419 pterjan 5340
420     %description
421     Mesa is an OpenGL 2.1 compatible 3D graphics library.
422 tv 135173 %if %{build_plf}
423 pterjan 5340
424 tv 135173 This package is in the "tainted" section because it enables some
425     OpenGL extentions that are covered by software patents.
426     %endif
427    
428 pterjan 5340 %description common-devel
429     Mesa common metapackage devel
430    
431     %if %{enable_egl}
432     %description -n %{libeglname}
433     Mesa is an OpenGL 2.1 compatible 3D graphics library.
434     EGL parts.
435    
436     %description -n %{libeglname}-devel
437     Mesa is an OpenGL 2.1 compatible 3D graphics library.
438     EGL development parts.
439     %endif
440    
441 blino 271501 %description -n %{libdricorename}
442     Mesa is an OpenGL 2.1 compatible 3D graphics library.
443     DRI core part.
444    
445 pterjan 5340 %description -n %{libglname}
446     Mesa is an OpenGL 2.1 compatible 3D graphics library.
447     GL and GLX parts.
448    
449 tv 135155 %if %{build_plf}
450     This package is in the "tainted" section because it enables some
451     OpenGL extentions that are covered by software patents.
452     %endif
453    
454 pterjan 5340 %description -n %{dridrivers}
455     Mesa is an OpenGL 2.1 compatible 3D graphics library.
456     DRI drivers.
457    
458 blino 271501 %description -n %{libdricorename}-devel
459     Mesa is an OpenGL 2.1 compatible 3D graphics library.
460    
461     This package contains the headers needed to compile DRI drivers.
462    
463 pterjan 5340 %description -n %{libglname}-devel
464     Mesa is an OpenGL 2.1 compatible 3D graphics library.
465    
466     This package contains the headers needed to compile Mesa programs.
467    
468     %description -n %{libgluname}
469     GLU is the OpenGL Utility Library.
470     It provides a number of functions upon the base OpenGL library to provide
471     higher-level drawing routines from the more primitive routines provided by
472     OpenGL.
473    
474     %description -n %{libgluname}-devel
475     This package contains the headers needed to compile programs with GLU.
476    
477 tv 88442 %description -n %{libglesv1name}
478     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
479     well-defined subset profiles of OpenGL.
480    
481     This package provides the OpenGL ES library version 1.
482    
483 anssi 278008 %description -n %{libosmesaname}
484     Mesa offscreen rendering libraries for rendering OpenGL into
485     application-allocated blocks of memory.
486    
487     %description -n %{osmesadevel}
488     This package contains the headers needed to compile programs against
489     the Mesa offscreen rendering library.
490    
491 mikala 112356 %description -n %{libglapiname}
492     This packages provides the glapi shared library used by gallium.
493    
494     %description -n %{libglapiname}-devel
495     This package contains the headers needed to compile programes against glapi shared library.
496    
497 tv 88442 %description -n %{libglesv1name}-devel
498     This package contains the headers needed to compile OpenGL ES 1 programs.
499    
500     %description -n %{libglesv2name}
501     OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
502     well-defined subset profiles of OpenGL.
503    
504     This package provides the OpenGL ES library version 2.
505    
506     %description -n %{libglesv2name}-devel
507     This package contains the headers needed to compile OpenGL ES 2 programs.
508    
509 tv 88445 %description -n %{libopenvgname}
510     OpenVG is a royalty-free, cross-platform API that provides a low-level hardware
511     acceleration interface for vector graphics libraries such as Flash and SVG.
512    
513     %description -n %{libopenvgname}-devel
514     Development files for OpenVG library.
515    
516 blino 215979 %if %{enable_wayland}
517     %description -n %{libgbmname}
518     Mesa is an OpenGL 2.1 compatible 3D graphics library.
519     GBM (Graphics Buffer Manager) parts.
520    
521     %description -n %{libgbmname}-devel
522     Mesa is an OpenGL 2.1 compatible 3D graphics library.
523     GBM (Graphics Buffer Manager) development parts.
524    
525     %description -n %{libwaylandeglname}
526     Mesa is an OpenGL 2.1 compatible 3D graphics library.
527     Wayland EGL platform parts.
528    
529     %description -n %{libwaylandeglname}-devel
530     Mesa is an OpenGL 2.1 compatible 3D graphics library.
531     Wayland EGL platform development parts.
532     %endif
533    
534 blino 270761 %description -n vdpau-driver-nouveau
535     This packages provides a VPDAU plugin to enable video acceleration
536     with the nouveau driver.
537    
538     %description -n vdpau-driver-r300
539     This packages provides a VPDAU plugin to enable video acceleration
540     with the r300 driver.
541    
542     %description -n vdpau-driver-r600
543     This packages provides a VPDAU plugin to enable video acceleration
544     with the r600 driver.
545    
546 blino 289282 %description -n vdpau-driver-radeonsi
547     This packages provides a VPDAU plugin to enable video acceleration
548     with the radeonsi driver.
549    
550 blino 270761 %description -n vdpau-driver-softpipe
551     This packages provides a VPDAU plugin to enable video acceleration
552     with the softpipe driver.
553    
554 tv 88440 #------------------------------------------------------------------------------
555    
556 pterjan 5340 %prep
557     %if %{git}
558 blino 289278 %setup -q -n mesa-%{git_branch}-%{git}
559 pterjan 5340 %else
560 tv 207029 %setup -q -n Mesa-%{version}%{vsuffix}
561 pterjan 5340 %endif
562    
563 blino 278731 %apply_patches
564 pterjan 5340
565     %build
566     autoreconf -vfi
567 anssi 278008
568     # fix build - TODO: should this be fixed in llvm somehow, or maybe the library
569     # symlinks should be moved to %{_libdir}? -Anssi 08/2012
570     export LDFLAGS="-L%{_libdir}/llvm"
571    
572     %configure2_5x --enable-dri \
573     --enable-glx \
574 pterjan 5340 --with-dri-driverdir=%{driver_dir} \
575     --with-dri-drivers="%{dri_drivers}" \
576 anssi 165988 --enable-shared-dricore \
577 pterjan 5340 %if %{enable_egl}
578     --enable-egl \
579     %else
580     --disable-egl \
581     %endif
582 blino 215979 %if %{enable_wayland}
583     --with-egl-platforms=x11,wayland,drm \
584     --enable-gbm \
585     --enable-shared-glapi \
586     %endif
587 tv 88442 --enable-gles1 \
588     --enable-gles2 \
589 tv 88445 --enable-openvg \
590 mikala 112356 --enable-gallium-egl \
591 blino 270761 --enable-gallium-g3dvl \
592 anssi 278008 --enable-osmesa \
593 blino 270761 --disable-xvmc \
594     --enable-vdpau \
595     --disable-va \
596 mikala 112356 %if %{with_hardware}
597 blino 289282 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
598 mikala 112356 --enable-gallium-llvm \
599     %else
600     --disable-gallium-llvm \
601     --with-gallium-drivers=swrast \
602     %endif
603 tv 135155 %if %{build_plf}
604     --enable-texture-float \
605     %endif
606 blino 270723 # end of configure options
607 pterjan 5340
608 anssi 165988 %make
609 pterjan 5340
610     %install
611 tv 88249 %makeinstall_std
612 pterjan 5340
613 blino 216556 # FIXME: strip will likely break the hardlink
614 pterjan 5340 # (blino) hardlink libGL files in %{_libdir}/mesa
615     # to prevent proprietary driver installers from removing them
616     mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
617     pushd $RPM_BUILD_ROOT%{_libdir}/mesa
618     for l in ../libGL.so.*; do cp -a $l .; done
619     popd
620    
621     %ifarch %{x86_64}
622     mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
623     %endif
624    
625 tv 88231 rm -f %{buildroot}/%{_includedir}/GL/glut.h
626     rm -f %{buildroot}/%{_includedir}/GL/glutf90.h
627    
628 blino 270761 # .so files are not needed by vdpau
629     rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so
630    
631 blino 271144 # .la files are not needed by mesa
632     find %{buildroot} -name '*.la' -exec rm {} \;
633    
634 anssi 181478 # use swrastg if built (Anssi 12/2011)
635     [ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so
636    
637 tv 88440 #------------------------------------------------------------------------------
638    
639 pterjan 5340 %files
640     %defattr(-,root,root)
641 blino 271481 %doc docs/COPYING
642 blino 271500 %config(noreplace) %{_sysconfdir}/drirc
643 pterjan 5340
644 blino 271501 %files -n %{libdricorename}
645     %{_libdir}/libdricore%{version}.so.%{dricoremajor}
646     %{_libdir}/libdricore%{version}.so.%{dricoremajor}.*
647    
648     %files -n %{libdricorename}-devel
649     %{_libdir}/libdricore%{version}.so
650    
651 pterjan 5340 %files -n %{dridrivers}
652     %defattr(-,root,root)
653     %doc docs/COPYING
654     %ifnarch ppc64
655     %dir %{_libdir}/dri
656 blino 271495 # (blino) new mesa 8.1 build system seems to use a static libglsl
657     #%{_libdir}/dri/libglsl.so
658 pterjan 5340 %{_libdir}/dri/*_dri.so
659     %endif
660    
661 tv 88433 %files -n %{libglname}
662     %defattr(-,root,root)
663     %doc docs/COPYING
664     %{_libdir}/libGL.so.*
665     %dir %{_libdir}/mesa
666 tv 88434 %{_libdir}/mesa/libGL.so.%{glmajor}*
667 tv 88433
668 tv 88437 %files -n %{libgluname}
669 tv 88433 %defattr(-,root,root)
670     %doc docs/COPYING
671 tv 88434 %{_libdir}/libGLU.so.%{glumajor}*
672 tv 88433
673     %if %{enable_egl}
674     %files -n %{libeglname}
675     %defattr(-,root,root)
676 tv 88442 %doc docs/COPYING
677 tv 88434 %{_libdir}/libEGL.so.%{eglmajor}*
678 tv 88442 %dir %{_libdir}/egl
679 blino 215979 %if !%{enable_wayland}
680     # st_GL, built only when shared glapi is not enabled
681 mikala 112356 %{_libdir}/egl/st_GL.so
682 blino 215979 %endif
683 mikala 127466 %{_libdir}/egl/egl_gallium.so
684 tv 88441 %endif
685 tv 88433
686 anssi 278008 %files -n %{libosmesaname}
687     %defattr(-,root,root)
688     %{_libdir}/libOSMesa.so.%{osmesamajor}*
689    
690 mikala 112356 %files -n %{libglapiname}
691     %defattr(-,root,root)
692     %{_libdir}/libglapi.so.%{glapimajor}*
693    
694 tv 88442 %files -n %{libglesv1name}
695     %defattr(-,root,root)
696     %doc docs/COPYING
697     %{_libdir}/libGLESv1_CM.so.%{glesv1major}*
698    
699     %files -n %{libglesv2name}
700     %defattr(-,root,root)
701     %doc docs/COPYING
702     %{_libdir}/libGLESv2.so.%{glesv2major}*
703    
704 tv 88445 %files -n %{libopenvgname}
705     %defattr(-,root,root)
706     %doc docs/COPYING
707     %{_libdir}/libOpenVG.so.%{openvgmajor}*
708    
709 blino 215979 %if %{enable_wayland}
710     %files -n %{libgbmname}
711     %{_libdir}/libgbm.so.%{gbmmajor}
712 blino 271141 %{_libdir}/libgbm.so.%{gbmmajor}.*
713 blino 215979 %{_libdir}/gbm/gbm_*.so
714     %{_libdir}/gbm/pipe_*.so
715 tv 88445
716 blino 215979 %files -n %{libwaylandeglname}
717     %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
718 blino 271141 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
719 blino 215979 %endif
720    
721    
722 pterjan 5340 %files -n %{libglname}-devel
723     %defattr(-,root,root)
724     %doc docs/COPYING
725 anssi 278008 %dir %{_includedir}/GL
726 pterjan 5340 %{_includedir}/GL/gl.h
727     %{_includedir}/GL/glext.h
728     %{_includedir}/GL/gl_mangle.h
729     %{_includedir}/GL/wglext.h
730     %{_includedir}/GL/glx.h
731     %{_includedir}/GL/glxext.h
732     %{_includedir}/GL/glx_mangle.h
733     %{_libdir}/libGL.so
734 tv 88436 %{_libdir}/pkgconfig/gl.pc
735     %{_libdir}/pkgconfig/dri.pc
736 pterjan 5340
737     #FIXME: check those headers
738     %{_includedir}/GL/vms_x_fix.h
739     %{_includedir}/GL/wmesa.h
740     %dir %{_includedir}/GL/internal
741     %{_includedir}/GL/internal/dri_interface.h
742    
743     %files -n %{libgluname}-devel
744     %defattr(-,root,root)
745     %doc docs/COPYING
746 anssi 278008 %dir %{_includedir}/GL
747 pterjan 5340 %{_includedir}/GL/glu.h
748     %{_includedir}/GL/glu_mangle.h
749     %{_libdir}/libGLU.so
750 tv 88436 %{_libdir}/pkgconfig/glu.pc
751 pterjan 5340
752     %files common-devel
753     %defattr(-,root,root)
754    
755 tv 88441 %if %{enable_egl}
756 tv 88433 %files -n %{libeglname}-devel
757     %defattr(-,root,root)
758 tv 88442 %doc docs/COPYING
759     %{_includedir}/EGL
760     %{_includedir}/KHR
761 tv 88433 %{_libdir}/libEGL.so
762 tv 88436 %{_libdir}/pkgconfig/egl.pc
763 tv 88433 %endif
764 pterjan 5340
765 anssi 278008 %files -n %{osmesadevel}
766     %defattr(-,root,root)
767     %dir %{_includedir}/GL
768     %{_includedir}/GL/osmesa.h
769     %{_libdir}/libOSMesa.so
770     %{_libdir}/pkgconfig/osmesa.pc
771    
772 mikala 112356 %files -n %{libglapiname}-devel
773     %defattr(-,root,root)
774     %{_libdir}/libglapi.so
775 pterjan 5340
776 tv 88442 %files -n %{libglesv1name}-devel
777     %defattr(-,root,root)
778     %{_includedir}/GLES
779     %{_libdir}/libGLESv1_CM.so
780     %{_libdir}/pkgconfig/glesv1_cm.pc
781 tv 88433
782 tv 88442 %files -n %{libglesv2name}-devel
783     %defattr(-,root,root)
784     %{_includedir}/GLES2
785     %{_libdir}/libGLESv2.so
786     %{_libdir}/pkgconfig/glesv2.pc
787 tv 88445
788     %files -n %{libopenvgname}-devel
789     %defattr(-,root,root)
790     %{_includedir}/VG
791     %{_libdir}/libOpenVG.so
792     %{_libdir}/pkgconfig/vg.pc
793 blino 215979
794     %if %{enable_wayland}
795     %files -n %{libgbmname}-devel
796     %{_includedir}/gbm.h
797     %{_libdir}/libgbm.so
798     %{_libdir}/pkgconfig/gbm.pc
799    
800     %files -n %{libwaylandeglname}-devel
801     %{_libdir}/libwayland-egl.so
802     %{_libdir}/pkgconfig/wayland-egl.pc
803     %endif
804 blino 270761
805     %files -n vdpau-driver-nouveau
806     %{_libdir}/vdpau/libvdpau_nouveau.so.*
807    
808     %files -n vdpau-driver-r300
809     %{_libdir}/vdpau/libvdpau_r300.so.*
810    
811     %files -n vdpau-driver-r600
812     %{_libdir}/vdpau/libvdpau_r600.so.*
813    
814 blino 289282 %files -n vdpau-driver-radeonsi
815     %{_libdir}/vdpau/libvdpau_radeonsi.so.*
816    
817 blino 270761 %files -n vdpau-driver-softpipe
818     %{_libdir}/vdpau/libvdpau_softpipe.so.*

  ViewVC Help
Powered by ViewVC 1.1.30