/[packages]/cauldron/mesa/current/SPECS/mesa.spec
ViewVC logotype

Diff of /cauldron/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

revision 88246 by tv, Tue Apr 19 10:03:57 2011 UTC revision 88247 by tv, Tue Apr 19 10:05:39 2011 UTC
# Line 143  Source5:       mesa-driver-install Line 143  Source5:       mesa-driver-install
143  Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch  Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch
144  Patch202: 0202-fix-includes-for-latest-libdrm.patch  Patch202: 0202-fix-includes-for-latest-libdrm.patch
145    
146  # Patches "liberated" from Fedora:  # Patches "liberated" from Fedora:
147  # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/  # http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/
148  # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat  # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
149  Patch300: 0300-RH-mesa-7.1-nukeglthread-debug-v1.1.patch  Patch300: 0300-RH-mesa-7.1-nukeglthread-debug-v1.1.patch
# Line 183  Provides:      EGL-devel Line 183  Provides:      EGL-devel
183  %package -n     %{libglname}  %package -n     %{libglname}
184  Summary:        Files for Mesa (GL and GLX libs)  Summary:        Files for Mesa (GL and GLX libs)
185  Group:          System/Libraries  Group:          System/Libraries
186  Obsoletes:      %{oldlibglname} < 6.4  Obsoletes:      %{oldlibglname} < 6.4
187  Provides:       %{oldlibglname} = %{version}-%{release}  Provides:       %{oldlibglname} = %{version}-%{release}
188  Provides:       %{libglname_virt} = %{version}-%{release}  Provides:       %{libglname_virt} = %{version}-%{release}
189  Requires:       %{dridrivers} >= %{version}-%{release}  Requires:       %{dridrivers} >= %{version}-%{release}
# Line 231  Provides:      %{gluname}-devel = %{version}- Line 231  Provides:      %{gluname}-devel = %{version}-
231  Obsoletes:      %{oldlibgluname}-devel < 6.4  Obsoletes:      %{oldlibgluname}-devel < 6.4
232  Provides:       %{oldlibgluname}-devel = %{version}-%{release}  Provides:       %{oldlibgluname}-devel = %{version}-%{release}
233  Provides:       libMesaGLU-devel = %{version}-%{release}  Provides:       libMesaGLU-devel = %{version}-%{release}
234  Provides:       MesaGLU-devel = %{version}-%{release}  Provides:       MesaGLU-devel = %{version}-%{release}
235    
236  %if %{with_mesaglut}  %if %{with_mesaglut}
237  %package -n     %{libglutname}  %package -n     %{libglutname}
# Line 251  Requires:      %{libglutname} = %{version}-%{ Line 251  Requires:      %{libglutname} = %{version}-%{
251  # (gc) /usr/lib/pkgconfig/glut.pc depends on /usr/lib/pkgconfig/{x11,xmu,xi}.pc (Requires.private) and pkg-config --list-all  # (gc) /usr/lib/pkgconfig/glut.pc depends on /usr/lib/pkgconfig/{x11,xmu,xi}.pc (Requires.private) and pkg-config --list-all
252  # goes wild without these deps  # goes wild without these deps
253  Requires:       libx11-devel libxmu-devel libxi-devel  Requires:       libx11-devel libxmu-devel libxi-devel
254  Provides:       lib%{glutname}-devel = %{version}-%{release}  Provides:       lib%{glutname}-devel = %{version}-%{release}
255  Provides:       %{glutname}-devel = %{version}-%{release}  Provides:       %{glutname}-devel = %{version}-%{release}
256  Obsoletes:      %{oldlibglutname}-devel < 6.4  Obsoletes:      %{oldlibglutname}-devel < 6.4
257  Provides:       %{oldlibglutname}-devel = %{version}-%{release}  Provides:       %{oldlibglutname}-devel = %{version}-%{release}
258  Provides:       libMesaGLUT-devel = %{version}-%{release}  Provides:       libMesaGLUT-devel = %{version}-%{release}
# Line 270  Provides:      %{libglwname_virt} = %{version Line 270  Provides:      %{libglwname_virt} = %{version
270  Summary:        Development files for glw libs  Summary:        Development files for glw libs
271  Group:          Development/C  Group:          Development/C
272  Requires:       %{libglwname} = %{version}-%{release}  Requires:       %{libglwname} = %{version}-%{release}
273  Provides:       lib%{glwname}-devel = %{version}-%{release}  Provides:       lib%{glwname}-devel = %{version}-%{release}
274  Provides:       %{glwname}-devel = %{version}-%{release}  Provides:       %{glwname}-devel = %{version}-%{release}
275    
276  %package        common-devel  %package        common-devel
277  Summary:        Meta package for mesa devel  Summary:        Meta package for mesa devel
278  Group:          Development/C  Group:          Development/C
279  Provides:       Mesa-common-devel = %{version}-%{release}  Provides:       Mesa-common-devel = %{version}-%{release}
280  Provides:       hackMesa-common-devel = %{version}  Provides:       hackMesa-common-devel = %{version}
281  Obsoletes:      Mesa-common-devel < %{version}  Obsoletes:      Mesa-common-devel < %{version}
282  Obsoletes:      hackMesa-common-devel < %{version}  Obsoletes:      hackMesa-common-devel < %{version}
283  Requires:       %{libglname}-devel = %{version}  Requires:       %{libglname}-devel = %{version}
284  Requires:       %{libglwname}-devel = %{version}  Requires:       %{libglwname}-devel = %{version}

Legend:
Removed from v.88246  
changed lines
  Added in v.88247

  ViewVC Help
Powered by ViewVC 1.1.26