/[packages]/cauldron/mesa/current/SPECS/mesa.spec
ViewVC logotype

Contents of /cauldron/mesa/current/SPECS/mesa.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1217640 - (show annotations) (download)
Wed Apr 11 20:25:14 2018 UTC (5 years, 11 months ago) by tv
File size: 21070 byte(s)
temporary disable vaapi as libllvm5 was removed too fast
1 %bcond_with wayland
2
3 # (cg) Cheater...
4 %define Werror_cflags %nil
5
6 # (aco) Needed for the dri drivers
7 %define _disable_ld_no_undefined 1
8
9 # https://cgit.freedesktop.org/mesa/mesa/commit/?h=13.0&id=3bb0415ab96f74183f7aa58c1a543448653ccb3e
10 %define git 0
11 %define git_branch 18.0
12
13 %define opengl_ver 4.5
14
15 # define version, RC & release
16 %define main_version 18.0.0
17 #define relc 5
18 %define rel 5
19
20 %define release %mkrel %{?relc:0.rc%{relc}.}%{rel}
21
22 %if %{git}
23 %if %{?relc:1}%{!?relc:0}
24 %define release %mkrel 1~rc%{relc}.1.git%{git}.%{rel}
25 %else
26 %define release 1.git%{git}.%{rel}
27 %endif
28 %endif
29
30 %define makedepend %{_bindir}/gccmakedep
31
32 %define d3dname d3d
33 %define eglname mesaegl
34 %define glname mesagl
35 %define glwname mesaglw
36 %define glesv1name mesaglesv1
37 %define glesv2name mesaglesv2
38 %define glapiname glapi
39 %define gbmname gbm
40 %define waylandeglname wayland-egl
41 %define xaname xatracker
42 %define vulkanname vulkan
43
44 %define d3dmajor 1
45 %define eglmajor 1
46 %define glmajor 1
47 %define glwmajor 1
48 %define glesv1major 1
49 %define glesv2major 2
50 %define glapimajor 0
51 %define gbmmajor 1
52 %define waylandeglmajor 1
53 %define osmesamajor 8
54 %define xamajor 2
55
56 %define libd3dname %mklibname %{d3dname} %{d3dmajor}
57 %define libeglname %mklibname %{eglname} %{eglmajor}
58 %define libglname %mklibname %{glname} %{glmajor}
59 %define libglwname %mklibname %{glwname} %{glwmajor}
60 %define libglesv1name %mklibname %{glesv1name}_ %{glesv1major}
61 %define libglesv2name %mklibname %{glesv2name}_ %{glesv2major}
62 %define libglapiname %mklibname %{glapiname} %{glapimajor}
63 %define libgbmname %mklibname %{gbmname} %{gbmmajor}
64 %define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor}
65 %define libosmesaname %mklibname osmesa %{osmesamajor}
66 %define libxaname %mklibname %{xaname} %{xamajor}
67 %define libvulkanname %mklibname %{vulkanname}
68
69 %define dridrivers %mklibname dri-drivers
70
71 %define osmesadevel %mklibname osmesa -d
72
73 # Architecture-independent Virtual provides:
74 %define libd3dname_virt lib%{d3dname}
75 %define libeglname_virt lib%{eglname}
76 %define libglname_virt lib%{glname}
77 %define libglwname_virt lib%{glwname}
78 %define libglesv1name_virt lib%{glesv1name}
79 %define libglesv2name_virt lib%{glesv2name}
80 %define libglapiname_virt lib%{glapiname}
81 %define libgbmname_virt lib%{gbmname}
82 %define libwaylandeglname_virt lib%{waylandeglname}
83 %define libxaname_virt lib%{xaname}
84
85 %define oldlibglname %mklibname MesaGL 1
86
87 %define mesasrcdir %{_prefix}/src/Mesa/
88
89 %define with_vaapi 0
90
91 # (akien) Not adding on arm as it would break the build there
92 %define enable_vulkan 0
93 %ifarch %{ix86} x86_64
94 %define enable_vulkan 1
95 %endif
96
97
98 %ifarch %{arm} aarch64
99 %define with_etnaviv 1
100 %define with_freedreno 1
101 %define with_vc4 1
102 %endif
103
104 %define base_drivers swrast,nouveau,radeon,r200
105 %ifarch %{ix86} x86_64
106 %define platform_drivers ,i915,i965
107 %define gallium_platform_drivers ,svga
108 %endif
109 %define dri_drivers --with-dri-drivers=%{?base_drivers}%{?platform_drivers}
110
111 Name: mesa
112 Version: %{main_version}
113 Release: %{release}
114 Summary: OpenGL %{opengl_ver} compatible 3D graphics library
115 Group: System/Libraries
116
117 # temp force new gcc
118 BuildRequires: gcc >= 5.4.0-2
119
120 BuildRequires: pkgconfig(xfixes) >= 4.0.3
121 BuildRequires: pkgconfig(xshmfence)
122 BuildRequires: pkgconfig(xt) >= 1.0.5
123 BuildRequires: pkgconfig(xmu) >= 1.0.3
124 BuildRequires: pkgconfig(x11) >= 1.3.3
125 BuildRequires: pkgconfig(xdamage) >= 1.1.1
126 BuildRequires: pkgconfig(expat) >= 2.0.1
127 BuildRequires: gccmakedep
128 BuildRequires: x11-proto-devel >= 7.3
129 BuildRequires: pkgconfig(libdrm) >= 2.4.91
130 BuildRequires: pkgconfig(xcb-dri3)
131 BuildRequires: pkgconfig(xcb-present) >= 1.11
132 BuildRequires: pkgconfig(xext) >= 1.1.1
133 BuildRequires: pkgconfig(xxf86vm) >= 1.1.0
134 BuildRequires: pkgconfig(xi) >= 1.3
135 BuildRequires: pkgconfig(talloc)
136 BuildRequires: python3-libxml2
137 BuildRequires: python3-mako
138 BuildRequires: makedepend
139 BuildRequires: bison
140 BuildRequires: flex
141 BuildRequires: pkgconfig(libelf)
142 BuildRequires: llvm-devel >= 3.9.1-5
143 BuildRequires: pkgconfig(libudev)
144 %if 0%{?with_vaapi}
145 BuildRequires: pkgconfig(libva)
146 %endif
147 BuildRequires: pkgconfig(vdpau)
148 %if %{with wayland}
149 BuildRequires: pkgconfig(wayland-client)
150 BuildRequires: pkgconfig(wayland-server)
151 BuildRequires: pkgconfig(wayland-protocols)
152 %endif
153 %if %{enable_vulkan}
154 BuildRequires: libgcrypt-devel
155 %endif
156 BuildRequires: pkgconfig(wayland-protocols) >= 1.8
157
158 URL: http://www.mesa3d.org
159 %if %{git}
160 #Source0: %{name}-%{git}.tar.bz2
161 # (blino) snapshot of 13.0 branch
162 Source0: %{name}-%{git_branch}-%{git}.tar.xz
163 %else
164 Source0: https://mesa.freedesktop.org/archive/mesa-%{main_version}%{?relc:-rc%{relc}}.tar.xz
165 %endif
166 Source3: make-git-snapshot.sh
167
168 # Instructions to setup your repository clone
169 # git://git.freedesktop.org/git/mesa/mesa
170 # git checkout mesa_7_5_branch
171 # git branch mdv-cherry-picks
172 # git am ../02??-*.patch
173 # git branch mdv-redhat
174 # git am ../03??-*.patch
175 # git branch mdv-patches
176 # git am ../09??-*.patch
177 # In order to update to the branch via patches, issue this command:
178 # git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/'
179
180 # Cherry picks
181 # git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks
182
183 # Patches "liberated" from Fedora:
184 # http://pkgs.fedoraproject.org/cgit/rpms/mesa.git/
185 # git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat
186
187 # https://cgit.freedesktop.org/~ajax/mesa/log/?h=mesa-17.2-s3tc
188
189 # Patches from ChromiumOS
190 # http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD
191
192 # Mageia/Mandriva patches
193 # git format-patch --start-number 900 mdv-redhat..mdv-patches
194
195 #------------------------------------------------------------------------------
196
197 # package mesa
198 License: MIT
199 Requires: %{libglname} = %{version}-%{release}
200 Provides: hackMesa = %{version}
201 Obsoletes: hackMesa <= %{version}
202 Provides: Mesa = %{version}
203 Obsoletes: Mesa < %{version}
204
205 %package -n %{libglname}
206 Summary: Files for Mesa (GL and GLX libs)
207 Group: System/Libraries
208 Obsoletes: %{oldlibglname} < 6.4
209 Provides: %{oldlibglname} = %{version}-%{release}
210 Provides: %{libglname_virt} = %{version}-%{release}
211 Requires: %{dridrivers} >= %{version}-%{release}
212
213 # (anssi) Forces the upgrade of x11-server-common to happen before
214 # alternatives removal, which allows x11-server-common to grab the symlink.
215 Conflicts: x11-server-common < 1.3.0.0-17
216
217 %package -n %{dridrivers}
218 Summary: Mesa DRI drivers
219 Group: System/Libraries
220 # do not require exact release to avoid conflicts when having
221 # x86_64 dri drivers from tainted and i586 dri drivers from core
222 Requires: mesa = %{version}
223 Conflicts: %{_lib}MesaGL1 < 7.7-5
224 Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4
225 Provides: %{_lib}dri-drivers-experimental = %{version}-%{release}
226
227 %package -n %{libd3dname}
228 Summary: Mesa Direct3D9 state tracker
229 Group: System/Libraries
230 Provides: %{libd3dname_virt} = %{version}-%{release}
231
232 %package -n %{libd3dname}-devel
233 Summary: Development files for Mesa Direct3D9 state tracker
234 Group: Development/C
235 Requires: %{libd3dname} = %{version}-%{release}
236 Provides: lib%{d3dname}-devel
237 Provides: %{d3dname}-devel
238 Provides: libd3d-devel
239
240 %package -n %{libglname}-devel
241 Summary: Development files for Mesa (OpenGL compatible 3D lib)
242 Group: Development/C
243 Requires: %{libglname} = %{version}-%{release}
244 Provides: lib%{glname}-devel = %{version}-%{release}
245 Provides: %{glname}-devel = %{version}-%{release}
246 Provides: GL-devel
247 Obsoletes: %{oldlibglname}-devel < 6.4
248 Provides: %{oldlibglname}-devel = %{version}-%{release}
249 Provides: libMesaGL-devel = %{version}-%{release}
250 Provides: MesaGL-devel = %{version}-%{release}
251 Provides: libgl-devel
252
253 %package -n %{libeglname}
254 Summary: Files for Mesa (EGL libs)
255 Group: System/Libraries
256 Provides: %{libeglname_virt} = %{version}-%{release}
257
258 %package -n %{libeglname}-devel
259 Summary: Development files for Mesa (EGL libs)
260 Group: Development/C
261 Requires: %{libeglname} = %{version}-%{release}
262 Provides: EGL-devel
263 Provides: lib%{eglname}-devel
264 Provides: %{eglname}-devel
265 Provides: libegl-devel
266
267 %package -n %{libosmesaname}
268 Summary: Mesa offscreen rendering library
269 Group: System/Libraries
270
271 %package -n %{osmesadevel}
272 Summary: Development files for libosmesa
273 Group: Development/C
274 Requires: %{libosmesaname} = %{version}-%{release}
275 Provides: osmesa-devel = %{version}-%{release}
276 Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3
277
278 %package -n %{libglapiname}
279 Summary: Files for mesa (glapi libs)
280 Group: System/Libraries
281 Provides: %{libglapiname_virt} = %{version}-%{release}
282
283 %package -n %{libglapiname}-devel
284 Summary: Development files for glapi libs
285 Group: Development/C
286 Requires: %{libglapiname_virt} = %{version}-%{release}
287 Provides: lib%{glapiname}-devel
288 Provides: %{libglapiname}-devel
289
290 %package -n %{libglesv1name}
291 Summary: Files for Mesa (glesv1 libs)
292 Group: System/Libraries
293 Provides: %{libglesv1name_virt} = %{version}-%{release}
294
295 %package -n %{libglesv1name}-devel
296 Summary: Development files for glesv1 libs
297 Group: Development/C
298 Requires: %{libglesv1name} = %{version}-%{release}
299 Provides: lib%{glesv1name}-devel
300 Provides: %{glesv1name}-devel
301 Provides: libglesv1-devel
302
303 %package -n %{libglesv2name}
304 Summary: Files for Mesa (glesv2 libs)
305 Group: System/Libraries
306 Provides: %{libglesv2name_virt} = %{version}-%{release}
307
308 %package -n %{libglesv2name}-devel
309 Summary: Development files for glesv2 libs
310 Group: Development/C
311 Requires: %{libglesv2name} = %{version}-%{release}
312 Requires: %{libeglname}-devel = %{version}-%{release}
313 Provides: lib%{glesv2name}-devel
314 Provides: %{glesv2name}-devel
315 Provides: libglesv2-devel
316
317 %package -n %{libgbmname}
318 Summary: Files for Mesa (gbm libs)
319 Group: System/Libraries
320 Provides: %{libgbmname_virt} = %{version}-%{release}
321
322 %package -n %{libgbmname}-devel
323 Summary: Development files for Mesa (gbm libs)
324 Group: Development/C
325 Requires: %{libgbmname} = %{version}-%{release}
326 Provides: lib%{gbmname}-devel
327 Provides: %{gbmname}-devel
328
329 %if %{with wayland}
330 %package -n %{libwaylandeglname}
331 Summary: Files for Mesa (Wayland EGL libs)
332 Group: System/Libraries
333 Provides: %{libwaylandeglname_virt} = %{version}-%{release}
334
335 %package -n %{libwaylandeglname}-devel
336 Summary: Development files for Mesa (Wayland EGL libs)
337 Group: Development/C
338 Requires: %{libwaylandeglname} = %{version}-%{release}
339 Provides: lib%{waylandeglname}-devel
340 Provides: %{waylandeglname}-devel
341 %endif
342
343 %package -n %{_lib}vdpau-driver-nouveau
344 Summary: VDPAU plugin for nouveau driver
345 Group: System/Libraries
346 # temporary:
347 %rename vdpau-driver-nouveau
348
349 %package -n %{_lib}vdpau-driver-r300
350 Summary: VDPAU plugin for r300 driver
351 Group: System/Libraries
352 # temporary:
353 %rename vdpau-driver-r300
354
355 %package -n %{_lib}vdpau-driver-r600
356 Summary: VDPAU plugin for r600 driver
357 Group: System/Libraries
358 # temporary:
359 %rename vdpau-driver-r600
360
361 %package -n %{_lib}vdpau-driver-radeonsi
362 Summary: VDPAU plugin for radeonsi driver
363 Group: System/Libraries
364 # temporary:
365 %rename vdpau-driver-radeonsi
366
367 %package -n %{libxaname}
368 Summary: Files for Mesa XA state tracker
369 Group: System/Libraries
370 Provides: %{libxaname_virt} = %{version}-%{release}
371
372 %package -n %{libxaname}-devel
373 Summary: Development files for XA libs
374 Group: Development/C
375 Requires: %{libxaname_virt} = %{version}-%{release}
376 Provides: lib%{xaname}-devel
377 Provides: %{libxaname}-devel
378
379 %if %{enable_vulkan}
380 %package -n %{libvulkanname}_intel
381 Summary: Mesa vulkan driver for Intel GPU
382 Group: System/Libraries
383
384 %package -n %{libvulkanname}_radeon
385 Summary: Mesa vulkan driver for Radeon GPU
386 Group: System/Libraries
387
388 %package -n %{libvulkanname}-devel
389 Summary: Mesa's Vulkan development files
390 Group: Development/C
391 Requires: %{libvulkanname}_intel = %{version}-%{release}
392 Provides: libvulkan-devel
393 Provides: libvulkan_intel-devel
394 %endif
395
396 %package common-devel
397 Summary: Meta package for mesa devel
398 Group: Development/C
399 Provides: Mesa-common-devel = %{version}-%{release}
400 Provides: hackMesa-common-devel = %{version}
401 Obsoletes: Mesa-common-devel < %{version}
402 Obsoletes: hackMesa-common-devel < %{version}
403 Requires: %{libglname}-devel = %{version}
404 Requires: mesaglu-devel
405 Requires: freeglut-devel
406 Requires: %{libeglname}-devel = %{version}
407 Requires: %{libglesv1name}-devel = %{version}
408 Requires: %{libglesv2name}-devel = %{version}
409
410 #------------------------------------------------------------------------------
411
412 %description
413 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
414
415 %description common-devel
416 Mesa common metapackage devel
417
418 %description -n %{libeglname}
419 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
420 EGL parts.
421
422 %description -n %{libeglname}-devel
423 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
424 EGL development parts.
425
426 %description -n %{libglname}
427 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
428 GL and GLX parts.
429
430 %description -n %{dridrivers}
431 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
432 DRI drivers.
433
434 %description -n %{libglname}-devel
435 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
436
437 This package contains the headers needed to compile Mesa programs.
438
439 %description -n %{libglesv1name}
440 OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
441 well-defined subset profiles of OpenGL.
442
443 This package provides the OpenGL ES library version 1.
444
445 %description -n %{libosmesaname}
446 Mesa offscreen rendering libraries for rendering OpenGL into
447 application-allocated blocks of memory.
448
449 %description -n %{osmesadevel}
450 This package contains the headers needed to compile programs against
451 the Mesa offscreen rendering library.
452
453 %description -n %{libglapiname}
454 This packages provides the glapi shared library used by gallium.
455
456 %description -n %{libglapiname}-devel
457 This package contains the headers needed to compile programes against glapi shared library.
458
459 %description -n %{libglesv1name}-devel
460 This package contains the headers needed to compile OpenGL ES 1 programs.
461
462 %description -n %{libd3dname}
463 Mesa Direct3D9 state tracker.
464
465 %description -n %{libd3dname}-devel
466 Mesa Direct3D9 state tracker development package.
467
468 %description -n %{libglesv2name}
469 OpenGL ES is a low-level, lightweight API for advanced embedded graphics using
470 well-defined subset profiles of OpenGL.
471
472 This package provides the OpenGL ES library version 2.
473
474 %description -n %{libglesv2name}-devel
475 This package contains the headers needed to compile OpenGL ES 2 programs.
476
477 %description -n %{libgbmname}
478 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
479 GBM (Graphics Buffer Manager) parts.
480
481 %description -n %{libgbmname}-devel
482 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
483 GBM (Graphics Buffer Manager) development parts.
484
485 %if %{with wayland}
486 %description -n %{libwaylandeglname}
487 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
488 Wayland EGL platform parts.
489
490 %description -n %{libwaylandeglname}-devel
491 Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library.
492 Wayland EGL platform development parts.
493 %endif
494
495 %description -n %{libxaname}
496 This packages provides the xa shared library used by gallium.
497
498 %description -n %{libxaname}-devel
499 This package contains the headers needed to compile programes against xa shared library.
500
501 %description -n %{_lib}vdpau-driver-nouveau
502 This packages provides a VPDAU plugin to enable video acceleration
503 with the nouveau driver.
504
505 %description -n %{_lib}vdpau-driver-r300
506 This packages provides a VPDAU plugin to enable video acceleration
507 with the r300 driver.
508
509 %description -n %{_lib}vdpau-driver-r600
510 This packages provides a VPDAU plugin to enable video acceleration
511 with the r600 driver.
512
513 %description -n %{_lib}vdpau-driver-radeonsi
514 This packages provides a VPDAU plugin to enable video acceleration
515 with the radeonsi driver.
516
517 %if %{enable_vulkan}
518 %description -n %{libvulkanname}_intel
519 This package contains the Vulkan parts for Mesa's Intel driver.
520
521 %description -n %{libvulkanname}_radeon
522 This package contains the Vulkan parts for Mesa's Radeon driver.
523
524 %description -n %{libvulkanname}-devel
525 This package contains the development files for Mesa's Vulkan implementation.
526 %endif
527
528 #------------------------------------------------------------------------------
529
530 %prep
531 %autosetup -n %{name}-%{version}%{?relc:-rc%{relc}} -p1
532
533 %build
534 # (re)generate auto* generated files using our autotools and libtoolize
535 autoreconf -vfi
536
537 # for bin/test-driver:
538 automake --add-missing
539
540 %configure2_5x \
541 %if %{enable_vulkan}
542 --with-vulkan-drivers=intel,radeon \
543 %endif
544 --enable-gallium-osmesa \
545 --with-dri-driverdir=%{_libdir}/dri \
546 --enable-egl \
547 --enable-gles1 \
548 --enable-gles2 \
549 --disable-xvmc \
550 --enable-vdpau \
551 %{?with_vaapi:--enable-va} \
552 --with-platforms=x11,drm,surfaceless%{?with_wayland:,wayland} \
553 --enable-shared-glapi \
554 --enable-gbm \
555 --enable-glx \
556 --enable-glx-tls \
557 --enable-texture-float=yes \
558 --enable-llvm \
559 --enable-dri \
560 --enable-xa \
561 --enable-nine \
562 --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast,%{?with_freedreno:freedreno,}%{?with_etnaviv:etnaviv,imx,}%{?with_vc4:vc4,}virgl%{?gallium_platform_drivers} \
563 %{?dri_drivers}
564 # end of configure options
565
566
567 %make
568
569 %install
570 %make_install
571
572 # FIXME: strip will likely break the hardlink
573 # (blino) hardlink libGL files in %{_libdir}/mesa
574 # to prevent proprietary driver installers from removing them
575 mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa
576 pushd $RPM_BUILD_ROOT%{_libdir}/mesa
577 for l in ../libGL.so.*; do cp -a $l .; done
578 popd
579
580 %ifarch %{x86_64}
581 mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri
582 %endif
583
584 # libvdpau opens the versioned name, don't bother including the unversioned
585 rm -f %{buildroot}%{_libdir}/vdpau/*.so
586
587 # strip out useless headers
588 rm -f %{buildroot}%{_includedir}/GL/w*.h
589
590 # remove .la files
591 find %{buildroot} -name '*.la' -delete
592
593 #------------------------------------------------------------------------------
594
595 %files
596 %config(noreplace) %{_sysconfdir}/drirc
597
598 %files -n %{dridrivers}
599 %dir %{_libdir}/dri
600 %{_libdir}/dri/*_dri.so
601 %{_libdir}/dri/*_drv*.so
602
603 %files -n %{libglname}
604 %{_libdir}/libGL.so.*
605 %dir %{_libdir}/mesa
606 %{_libdir}/mesa/libGL.so.%{glmajor}{,.*}
607
608 %files -n %{libeglname}
609 %{_libdir}/libEGL.so.%{eglmajor}{,.*}
610
611 %files -n %{libosmesaname}
612 %{_libdir}/libOSMesa.so.%{osmesamajor}{,.*}
613
614 %files -n %{libglapiname}
615 %{_libdir}/libglapi.so.%{glapimajor}{,.*}
616
617 %files -n %{libglesv1name}
618 %{_libdir}/libGLESv1_CM.so.%{glesv1major}{,.*}
619
620 %files -n %{libd3dname}
621 %{_libdir}/d3d/*.so.*
622
623 %files -n %{libglesv2name}
624 %{_libdir}/libGLESv2.so.%{glesv2major}{,.*}
625
626 %files -n %{libgbmname}
627 %{_libdir}/libgbm.so.%{gbmmajor}
628 %{_libdir}/libgbm.so.%{gbmmajor}.*
629
630 %if %{with wayland}
631 %files -n %{libwaylandeglname}
632 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}
633 %{_libdir}/libwayland-egl.so.%{waylandeglmajor}.*
634 %endif
635
636 %files -n %{libxaname}
637 %{_libdir}/libxatracker.so.%{xamajor}{,.*}
638
639 %files -n %{libglname}-devel
640 %dir %{_includedir}/GL
641 %{_includedir}/GL/gl.h
642 %{_includedir}/GL/gl_mangle.h
643 %{_includedir}/GL/glext.h
644 %{_includedir}/GL/glx.h
645 %{_includedir}/GL/glx_mangle.h
646 %{_includedir}/GL/glxext.h
647 %{_includedir}/GL/glcorearb.h
648 %dir %{_includedir}/GL/internal
649 %{_includedir}/GL/internal/dri_interface.h
650 %{_libdir}/pkgconfig/dri.pc
651 %{_libdir}/libGL.so
652 %{_libdir}/pkgconfig/gl.pc
653
654 %files common-devel
655
656 %files -n %{libeglname}-devel
657 %{_includedir}/EGL
658 %{_includedir}/KHR
659 %{_libdir}/libEGL.so
660 %{_libdir}/pkgconfig/egl.pc
661
662 %files -n %{osmesadevel}
663 %dir %{_includedir}/GL
664 %{_includedir}/GL/osmesa.h
665 %{_libdir}/libOSMesa.so
666 %{_libdir}/pkgconfig/osmesa.pc
667
668 %files -n %{libglapiname}-devel
669 %{_libdir}/libglapi.so
670
671 %files -n %{libglesv1name}-devel
672 %{_includedir}/GLES
673 %{_libdir}/libGLESv1_CM.so
674 %{_libdir}/pkgconfig/glesv1_cm.pc
675
676 %files -n %{libglesv2name}-devel
677 %{_includedir}/GLES2
678 %{_includedir}/GLES3
679 %{_libdir}/libGLESv2.so
680 %{_libdir}/pkgconfig/glesv2.pc
681
682 %files -n %{libd3dname}-devel
683 %{_includedir}/d3dadapter
684 %{_libdir}/d3d/*.so
685 %{_libdir}/pkgconfig/d3d.pc
686
687 %files -n %{libgbmname}-devel
688 %{_libdir}/libgbm.so
689 %{_includedir}/gbm.h
690 %{_libdir}/pkgconfig/gbm.pc
691
692 %if %{with wayland}
693 %files -n %{libwaylandeglname}-devel
694 %{_libdir}/libwayland-egl.so
695 %{_libdir}/pkgconfig/wayland-egl.pc
696 %endif
697
698 %files -n %{libxaname}-devel
699 %{_libdir}/libxatracker.so
700 %{_includedir}/xa_tracker.h
701 %{_includedir}/xa_composite.h
702 %{_includedir}/xa_context.h
703 %{_libdir}/pkgconfig/xatracker.pc
704
705 %files -n %{_lib}vdpau-driver-nouveau
706 %{_libdir}/vdpau/libvdpau_nouveau.so.*
707
708 %files -n %{_lib}vdpau-driver-r300
709 %{_libdir}/vdpau/libvdpau_r300.so.*
710
711 %files -n %{_lib}vdpau-driver-r600
712 %{_libdir}/vdpau/libvdpau_r600.so.*
713
714 %files -n %{_lib}vdpau-driver-radeonsi
715 %{_libdir}/vdpau/libvdpau_radeonsi.so.*
716
717 %if %{enable_vulkan}
718 %files -n %{libvulkanname}_intel
719 %dir %{_datadir}/vulkan
720 %dir %{_datadir}/vulkan/icd.d
721 %{_datadir}/vulkan/icd.d/intel_icd*.json
722 # (akien) No lib major?
723 %{_libdir}/libvulkan_intel.so
724
725 %files -n %{libvulkanname}_radeon
726 %dir %{_datadir}/vulkan
727 %dir %{_datadir}/vulkan/icd.d
728 %{_datadir}/vulkan/icd.d/radeon_icd*.json
729 # (akien) No lib major?
730 %{_libdir}/libvulkan_radeon.so
731
732 %files -n %{libvulkanname}-devel
733 %{_includedir}/vulkan/
734 %endif

  ViewVC Help
Powered by ViewVC 1.1.30