/[packages]/cauldron/metacity/current/SPECS/metacity.spec
ViewVC logotype

Contents of /cauldron/metacity/current/SPECS/metacity.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 129664 - (show annotations) (download)
Tue Jul 26 08:23:33 2011 UTC (12 years, 9 months ago) by dmorgan
File size: 4394 byte(s)
Seems ok to push it now
1 %define lib_major 0
2 %define libname %mklibname %{name}-private %{lib_major}
3 %define libnamedev %mklibname -d %{name}-private
4 %define startup_notification_version 0.4
5
6 Summary: Metacity window manager
7 Name: metacity
8 Version: 2.34.1
9 # Do not push metacity for the moment, we need to test to see why gnome-shell doesn't start with it
10 Release: %mkrel 1
11 URL: http://ftp.gnome.org/pub/gnome/sources/metacity/
12 Source0: http://ftp.gnome.org/pub/GNOME/sources/metacity/%{name}-%{version}.tar.xz
13 # (fc) use Ia Ora as default theme
14 Patch2: metacity-2.25.2-defaulttheme.patch
15 # (fc) enable compositor by default
16 Patch4: metacity-enable-compositor.patch
17 Patch5: metacity_low_resources.patch
18 # (fc) ensure text is local encoded for Zenity (GNOME bug #617536)
19 Patch8: metacity-2.30.1-local-encoding-for-zenity.patch
20 # 2.30.3-3.mga1 add patch from upstream to fix gdm-greeter pop-up message at login
21 # this changes warn_about_lame_clients_and_finish_interact() to be called only
22 # when interacting with the window manager in a session save
23 # http://git.gnome.org/browse/metacity/patch/?id=85aba1afe33d973bdea0229b534516c1658a44d5
24 Patch9: metacity-2.30.3-RestartStyleHint-to-RestartIfRunning-when-replaced.patch
25 License: GPLv2+
26 Group: Graphical desktop/GNOME
27 BuildRoot: %{_tmppath}/%{name}-%{version}-root
28 Requires: zenity
29 BuildRequires: libglade2.0-devel
30 BuildRequires: libGConf2-devel >= 1.1.9
31 BuildRequires: startup-notification-devel >= %{startup_notification_version}
32 BuildRequires: libcanberra-devel
33 BuildRequires: libgtop2.0-devel
34 BuildRequires: libxinerama-devel
35 BuildRequires: libxcomposite-devel
36 BuildRequires: libxdamage-devel
37 BuildRequires: libxtst-devel
38 BuildRequires: libmesaglu-devel
39 BuildRequires: GConf2
40 BuildRequires: zenity
41 BuildRequires: intltool
42 BuildRequires: gnome-doc-utils
43 BuildRequires: libcanberra-gtk-devel
44 #gw libtool dep:
45 BuildRequires: dbus-glib-devel
46
47
48 %description
49 Metacity is a simple window manager that integrates nicely with
50 GNOME 2.
51
52 %package -n %{libname}
53 Summary: Libraries for Metacity
54 Group: System/Libraries
55
56 %description -n %{libname}
57 This package contains libraries used by Metacity.
58
59 %package -n %{libnamedev}
60 Summary: Libraries and include files with Metacity
61 Group: Development/GNOME and GTK+
62 Requires: %name = %{version}
63 Requires: %{libname} = %{version}
64 Provides: %{name}-devel = %{version}-%{release}
65 Provides: lib%{name}-private-devel = %{version}-%{release}
66 Obsoletes: %mklibname -d %{name}-private 0
67
68 %description -n %{libnamedev}
69 This package provides the necessary development libraries and include
70 files to allow you to develop with Metacity.
71
72
73 %prep
74 %setup -q
75 #%patch2 -p1 -b .defaulttheme
76 # don't enable compositor by default, too many drivers are buggy currently
77 #%patch4 -p1 -b .enable-compositor
78 %ifarch %mips
79 %patch5 -p1 -b .lowres
80 %endif
81 %patch8 -p1 -b .local-encoding
82 #%patch9 -p1 -b .gdm-greeter
83
84 %build
85
86 %configure2_5x
87 %make
88
89 %install
90 rm -rf $RPM_BUILD_ROOT %name.lang
91 GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 %makeinstall_std
92
93 %find_lang %{name}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %define schemas metacity
99
100 %post
101 if [ ! -d %{_sysconfdir}/gconf/gconf.xml.local-defaults/apps/metacity/general -a "x$META_CLASS" != "x" ]; then
102 case "$META_CLASS" in
103 *server) METACITY_THEME="Ia Ora Gray" ;;
104 *desktop) METACITY_THEME="Ia Ora Steel" ;;
105 *download) METACITY_THEME="Ia Ora Night";;
106 esac
107
108 if [ "x$METACITY_THEME" != "x" ]; then
109 %{_bindir}/gconftool-2 --config-source=xml::/etc/gconf/gconf.xml.local-defaults/ --direct --type=string --set /apps/metacity/general/theme "$METACITY_THEME" > /dev/null
110 fi
111 fi
112
113
114 %preun
115 %preun_uninstall_gconf_schemas %{schemas}
116
117 %files -f %{name}.lang
118 %defattr(-,root,root)
119 %doc README COPYING NEWS HACKING
120 %{_sysconfdir}/gconf/schemas/*
121 %{_bindir}/*
122 %{_datadir}/gnome-control-center/keybindings/50-metacity*.xml
123 %{_datadir}/applications/metacity.desktop
124 %{_datadir}/gnome/wm-properties/metacity-wm.desktop
125 %{_datadir}/metacity
126 %dir %_datadir/gnome/help/creating-metacity-themes
127 %_datadir/gnome/help/creating-metacity-themes/C
128 %_datadir/gnome/help/creating-metacity-themes/de/creating-metacity-themes.xml
129
130 %{_datadir}/themes/*
131 %{_mandir}/man1/*
132
133 %files -n %{libname}
134 %defattr(-,root,root)
135 %{_libdir}/*.so.%{lib_major}*
136
137 %files -n %{libnamedev}
138 %defattr(-,root,root)
139 %doc ChangeLog
140 %{_libdir}/*.so
141 %{_libdir}/*.a
142 %{_libdir}/*.la
143 %{_includedir}/*
144 %{_libdir}/pkgconfig/*
145
146

  ViewVC Help
Powered by ViewVC 1.1.30