/[packages]/cauldron/mplayer/current/SPECS/mplayer.spec
ViewVC logotype

Annotation of /cauldron/mplayer/current/SPECS/mplayer.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 226412 - (hide annotations) (download)
Sun Mar 25 17:05:54 2012 UTC (12 years ago) by luigiwalser
File size: 21214 byte(s)
SILENT: add RGBA from r34589
1 blino 24858 %define build_3264bit 0
2     %{?_with_3264bit: %{expand: %%global build_3264bit 1}}
3     %{?_without_3264bit: %{expand: %%global build_3264bit 0}}
4     %if %{build_3264bit}
5     %define pkgext 32
6     %else
7     %define pkgext %{nil}
8     %endif
9    
10     %define name mplayer%{pkgext}
11     %define Name MPlayer
12     %define Summary Movie player for linux
13     %define prerel rc4
14     %define version 1.0
15     %define fversion %svn
16 luigiwalser 202792 %define svn r34578
17 luigiwalser 224349 %define ffmpegversion 0.10.2
18 blino 24858 %if %svn
19 luigiwalser 226411 %define rel 1.%prerel.0.%svn.7
20 blino 24858 %else
21 anssi 202249 %define rel 1.%prerel.6
22 blino 24858 %endif
23     %define release %mkrel %rel
24    
25     %define build_plf 0
26     %define build_optimization 0
27     %define build_debug 0
28     %define build_mencoder 1
29     %define build_gui 1
30 luigiwalser 196696 %define build_system_ffmpeg 1
31 blino 24858
32     %define build_yasm 1
33     %define build_live 1
34     %define build_vesa 1
35     %define build_theora 1
36     %define build_ggi 0
37     %define build_lirc 1
38     %define build_xmms 0
39     %define build_amr 0
40     %define build_arts 0
41     %define build_aa 1
42 luigiwalser 196699 %define build_cdda 0
43 blino 24858 %define build_compiz 0
44     %define build_dirac 1
45     %define build_dv 1
46     %define build_sdl 1
47     %define build_lzo 1
48     %define build_smb 1
49     %define build_mga 1
50     %define build_fbdev 1
51     %define build_dvb 1
52     %define build_fribidi 1
53     %define build_enca 1
54     %define build_alsa 1
55     %define build_jack 1
56     %define build_openal 0
57     %define build_pulse 1
58     %define build_schroedinger 1
59     %define build_twolame 0
60     %define build_lame 0
61     %define build_faac 0
62     %define build_faad 0
63     %define build_x264 0
64     %define build_xvid 0
65     %define build_dts 0
66     %define build_directfb 1
67     %define build_v4l2 1
68     %define build_xvmc 1
69     %define build_vdpau 1
70     %define build_ivtv 0
71     %define build_libass 1
72     %define build_vpx 1
73     %define build_rtmp 1
74 ahmad 81539 %define build_zr 0
75 luigiwalser 196698 %define build_libnut 1
76 luigiwalser 196699 %define build_cdio 1
77     %if %build_cdio
78     %define build_cdda 0
79     %endif
80 fwang 225140 %define build_bluray 1
81 blino 24858
82     %define build_smb 0
83    
84     %ifnarch %ix86
85     %define build_vesa 0
86     %endif
87    
88 cjw 100681 %if "%{?distro_section}" == "tainted"
89     %define build_plf 1
90     %endif
91    
92 blino 24858 %if %build_plf
93     %define build_amr 1
94     %define build_twolame 1
95     %define build_lame 1
96 cjw 100681 %define build_faac 0
97 blino 24858 %define build_faad 1
98     %define build_x264 1
99     %define build_xvid 1
100     %define build_dts 1
101     %define build_yasm 1
102     %define build_dirac 1
103     %define build_schroedinger 1
104     %endif
105    
106 luigiwalser 196696 %if %build_system_ffmpeg
107     %define build_amr 0
108     %define build_dirac 0
109     %define build_schroedinger 0
110     %define build_vpx 0
111     %define build_zr 0
112     %endif
113    
114 blino 24858 %{?_with_amr: %{expand: %%global build_amr 1}}
115     %{?_without_amr: %{expand: %%global build_amr 0}}
116     %{?_with_live: %{expand: %%global build_live 1}}
117     %{?_without_live: %{expand: %%global build_live 0}}
118     %{?_with_yasm: %{expand: %%global build_yasm 1}}
119     %{?_without_yasm: %{expand: %%global build_yasm 0}}
120     %{?_with_vesa: %{expand: %%global build_vesa 1}}
121     %{?_without_vesa: %{expand: %%global build_vesa 0}}
122     %{?_with_optimization: %{expand: %%global build_optimization 1}}
123     %{?_with_debug: %{expand: %%global build_debug 1}}
124     %{?_without_debug: %{expand: %%global build_debug 0}}
125     %{?_with_mencoder: %{expand: %%global build_mencoder 1}}
126     %{?_without_mencoder: %{expand: %%global build_mencoder 0}}
127     %{?_with_gui: %{expand: %%global build_gui 1}}
128     %{?_without_gui: %{expand: %%global build_gui 0}}
129 luigiwalser 196696 %{?_with_system_ffmpeg: %{expand: %%global build_system_ffmpeg 1}}
130     %{?_without_system_ffmpeg: %{expand: %%global build_system_ffmpeg 0}}
131 blino 24858 %{?_with_theora: %{expand: %%global build_theora 1}}
132     %{?_without_theora: %{expand: %%global build_theora 0}}
133     %{?_with_smb: %{expand: %%global build_smb 1}}
134     %{?_without_smb: %{expand: %%global build_smb 0}}
135     %{?_with_ggi: %{expand: %%global build_ggi 1}}
136     %{?_without_ggi: %{expand: %%global build_ggi 0}}
137     %{?_with_lirc: %{expand: %%global build_lirc 1}}
138     %{?_without_lirc: %{expand: %%global build_lirc 0}}
139     %{?_with_xmms: %{expand: %%global build_xmms 1}}
140     %{?_without_xmms: %{expand: %%global build_xmms 0}}
141     %{?_with_arts: %{expand: %%global build_arts 1}}
142     %{?_without_arts: %{expand: %%global build_arts 0}}
143     %{?_with_aa: %{expand: %%global build_aa 1}}
144     %{?_without_aa: %{expand: %%global build_aa 0}}
145     %{?_with_cdda: %{expand: %%global build_cdda 1}}
146     %{?_without_cdda: %{expand: %%global build_cdda 0}}
147     %{?_with_dirac: %{expand: %%global build_dirac 1}}
148     %{?_without_dirac: %{expand: %%global build_dirac 0}}
149     %{?_with_dv: %{expand: %%global build_dv 1}}
150     %{?_without_dv: %{expand: %%global build_dv 0}}
151     %{?_with_sdl: %{expand: %%global build_sdl 1}}
152     %{?_without_sdl: %{expand: %%global build_sdl 0}}
153     %{?_with_lzo: %{expand: %%global build_lzo 1}}
154     %{?_without_lzo: %{expand: %%global build_lzo 0}}
155     %{?_with_mga: %{expand: %%global build_mga 1}}
156     %{?_without_mga: %{expand: %%global build_mga 0}}
157     %{?_with_fribidi: %{expand: %%global build_fribidi 1}}
158     %{?_without_fribidi: %{expand: %%global build_fribidi 0}}
159     %{?_with_enca: %{expand: %%global build_enca 1}}
160     %{?_without_enca: %{expand: %%global build_enca 0}}
161     %{?_with_jack: %{expand: %%global build_jack 1}}
162     %{?_without_jack: %{expand: %%global build_jack 0}}
163     %{?_with_libass: %{expand: %%global build_libass 1}}
164     %{?_without_libass: %{expand: %%global build_libass 0}}
165     %{?_with_pulse: %{expand: %%global build_pulse 1}}
166     %{?_without_pulse: %{expand: %%global build_pulse 0}}
167     %{?_with_openal: %{expand: %%global build_openal 1}}
168     %{?_without_openal: %{expand: %%global build_openal 0}}
169     %{?_with_schroedinger: %{expand: %%global build_schroedinger 1}}
170     %{?_without_schroedinger: %{expand: %%global build_schroedinger 0}}
171     %{?_with_twolame: %{expand: %%global build_twolame 1}}
172     %{?_without_twolame: %{expand: %%global build_twolame 0}}
173     %{?_with_lame: %{expand: %%global build_lame 1}}
174     %{?_without_lame: %{expand: %%global build_lame 0}}
175     %{?_with_faac: %{expand: %%global build_faac 1}}
176     %{?_without_faac: %{expand: %%global build_faac 0}}
177     %{?_with_faad: %{expand: %%global build_faad 1}}
178     %{?_without_faad: %{expand: %%global build_faad 0}}
179     %{?_with_x264: %{expand: %%global build_x264 1}}
180     %{?_without_x264: %{expand: %%global build_x264 0}}
181     %{?_with_xvid: %{expand: %%global build_xvid 1}}
182     %{?_without_xvid: %{expand: %%global build_xvid 0}}
183     %{?_with_dts: %{expand: %%global build_dts 1}}
184     %{?_without_dts: %{expand: %%global build_dts 0}}
185     %{?_with_directfb: %{expand: %%global build_directfb 1}}
186     %{?_without_directfb: %{expand: %%global build_directfb 0}}
187     %{?_with_rtmp: %{expand: %%global build_rtmp 1}}
188     %{?_without_rtmp: %{expand: %%global build_rtmp 0}}
189     %{?_with_v4l2: %{expand: %%global build_v4l2 1}}
190     %{?_without_v4l2: %{expand: %%global build_v4l2 0}}
191     %{?_with_xvmc: %{expand: %%global build_xvmc 1}}
192     %{?_without_xvmc: %{expand: %%global build_xvmc 0}}
193     %{?_with_vdpau: %{expand: %%global build_vdpau 1}}
194     %{?_without_vdpau: %{expand: %%global build_vdpau 0}}
195 luigiwalser 196705 %{?_with_vpx: %{expand: %%global build_vpx 1}}
196     %{?_without_vpx: %{expand: %%global build_vpx 0}}
197 luigiwalser 196698 %{?_with_libnut: %{expand: %%global build_libnut 1}}
198     %{?_without_libnut: %{expand: %%global build_libnut 0}}
199 luigiwalser 196699 %{?_with_cdio: %{expand: %%global build_cdio 1}}
200     %{?_without_cdio: %{expand: %%global build_cdio 0}}
201 fwang 225140 %{?_with_bluray: %{expand: %%global build_bluray 1}}
202     %{?_without_bluray: %{expand: %%global build_bluray 0}}
203 blino 24858
204     Name: %{name}
205     Version: %{version}
206     Release: %{release}
207     Summary: %{Summary}
208     %if %svn
209     #gw generated using svn export
210     Source0: %{name}-%{svn}.tar.xz
211     %else
212     Source0: %{Name}-%{fversion}.tar.bz2
213     %endif
214 luigiwalser 202792 Source1: ffmpeg-%{ffmpegversion}.tar.bz2
215 blino 24858 #gw default skin
216 luigiwalser 223439 Source4: Blue-1.8.tar.bz2
217 zezinho 215565 Patch0: mplayer-1.0rc4-distro-config.patch
218 blino 24858 Patch3: mplayer-mp3lib-no-strict-aliasing.patch
219     Patch7: mplayer-1.0pre1-nomgafirst.patch
220     Patch21: mplayer-1.0rc2-compiz.patch
221     # fixes for crashes found while fixing CVE-2008-1558
222     Patch28: mplayer-rtsp-extra-fixes.patch
223 luigiwalser 193626 Patch31: mplayer-format-string-literal.patch
224 blino 24858 #gw HAVE_DLFCN_H isn't defined
225 luigiwalser 193626 Patch33: mplayer-have-dlfcn_h.patch
226 blino 24858 #gw fix crash: https://qa.mandriva.com/show_bug.cgi?id=55443
227 luigiwalser 193626 Patch35: mplayer-fix-dvd-crash.patch
228 anssi 202249 # fix lavcac3enc to not require internal FFmpeg headers (upstreamable)
229     Patch48: mplayer-lavcac3enc-build-with-shared.patch
230     # hack to build video filters that require internal FFmpeg headers -
231     # this requires the private headers to be present during build
232     # (it is somewhat bad, but there are many other files in mplayer that
233     # already require them, so we couldn't remove them anyway)
234     Patch49: mplayer-filters-hack-with-shared.patch
235 luigiwalser 223777 Patch50: mplayer-live555-r34800.patch
236 luigiwalser 226412 Patch51: mplayer-png-loading-r34589-r34594-r34595.diff
237 blino 24858 URL: http://www.mplayerhq.hu
238     License: GPLv2
239     Group: Video
240     BuildRequires: libncurses-devel
241     %if %build_aa
242     BuildRequires: libaa-devel
243     %endif
244     BuildRequires: a52dec-devel
245     %if %build_arts
246     BuildRequires: libarts-devel
247     %endif
248     %if %build_amr
249     BuildRequires: opencore-amr-devel
250     %endif
251    
252     %if %build_jack
253     BuildRequires: libjack-devel
254     %endif
255     %if %build_pulse
256     BuildRequires: libpulseaudio-devel
257     %endif
258     %if %build_openal
259     BuildRequires: libopenal-devel
260     %endif
261     %if %build_cdda
262     BuildRequires: libcdda-devel
263     %endif
264     %if %build_dirac
265     BuildRequires: libdirac-devel >= 0.9.0
266     %endif
267     %if %build_schroedinger
268     BuildRequires: libschroedinger-devel
269     %endif
270     %if %build_dv
271     BuildRequires: libdv-devel
272     %endif
273     BuildRequires: libdxr3-devel
274     BuildRequires: libjpeg-devel
275     BuildRequires: openjpeg-devel
276     %if %build_lirc
277     BuildRequires: liblirc-devel
278     %endif
279     %if %build_lzo
280     BuildRequires: liblzo-devel
281     %endif
282     BuildRequires: libmad-devel
283     BuildRequires: libnas-devel
284     BuildRequires: libpng-devel
285     %if %build_sdl
286     BuildRequires: libSDL-devel >= 1.1.8
287     %endif
288     BuildRequires: libtermcap-devel
289     %if %build_xmms
290     BuildRequires: libxmms-devel
291     %endif
292     %if %build_ggi
293     BuildRequires: libggiwmh-devel
294     %endif
295     %if %build_smb
296     # require samba < 3.2.0 to avoid shipping GPLv2 vs GPLv3
297     BuildRequires: libsmbclient-devel < 3.2.0
298     %endif
299     %if %build_twolame
300     BuildRequires: libtwolame-devel
301     %endif
302     %if %build_faac
303     BuildRequires: libfaac-devel
304     %endif
305     %if %build_faad
306     BuildRequires: libfaad2-devel
307     %endif
308     %if %build_x264
309 luigiwalser 194871 BuildRequires: libx264-devel >= 0.120
310 blino 24858 %endif
311     %if %build_xvid
312     BuildRequires: xvid-devel >= 1.0.0-0.beta2.1plf
313     %endif
314     %if %build_dts
315     BuildRequires: dtsdec-devel
316     %endif
317     %if %build_lame
318     BuildRequires: liblame-devel
319     %endif
320     %if %build_plf
321     Requires: %mklibname dvdcss 2
322     %endif
323     %if %build_live
324     BuildRequires: live-devel
325     %endif
326     %if %build_vesa
327     BuildRequires: libvbe-devel liblrmi-devel
328     %endif
329     %if %build_theora
330     BuildRequires: libtheora-devel
331     %endif
332     %if %build_fribidi
333     BuildRequires: libfribidi-devel >= 0.10.4
334     %endif
335     %if %build_enca
336     BuildRequires: libenca-devel
337     %endif
338     %if %build_directfb
339     BuildRequires: libdirectfb-devel
340     %endif
341     %if %build_xvmc
342     BuildRequires: libxvmc-devel
343     %endif
344     %if %build_vdpau
345     BuildRequires: vdpau-devel
346     %endif
347     %if %build_libass
348     BuildRequires: libass-devel
349     %endif
350     BuildRequires: gsm-devel
351     BuildRequires: libmpg123-devel
352     %if %build_vpx
353     BuildRequires: libvpx-devel
354     %endif
355     %if %build_rtmp
356     BuildRequires: rtmp-devel
357     %endif
358 luigiwalser 196698 %if %build_libnut
359     BuildRequires: libnut-devel
360     %endif
361 luigiwalser 196699 %if %build_cdio
362     BuildRequires: libcdio-devel
363     %endif
364 fwang 225143 %if %build_bluray
365 fwang 225140 BuildRequires: bluray-devel
366     %endif
367 blino 24858 BuildRequires: bzip2-devel
368     BuildRequires: libmng-devel
369     BuildRequires: libmesagl-devel
370     BuildRequires: libxxf86vm-devel
371     BuildRequires: libxxf86dga-devel
372     BuildRequires: libxscrnsaver-devel
373     BuildRequires: libspeex-devel
374     BuildRequires: libmpcdec-devel
375     BuildRequires: ladspa-devel
376     BuildRequires: libxslt-proc
377     BuildRequires: docbook-style-xsl
378     BuildRequires: docbook-dtd412-xml
379     BuildRequires: libcaca-devel
380     BuildRequires: giflib-devel
381     %if %build_yasm
382     BuildRequires: yasm
383     %endif
384     BuildRequires: libbs2b-devel
385 luigiwalser 196696 %if %build_system_ffmpeg
386     BuildRequires: ffmpeg-devel
387     %endif
388 luigiwalser 202791 BuildRequires: libdvdread-devel
389     BuildRequires: libdvdnav-devel
390 blino 24858
391     Provides: mplayer%{pkgext}1.0
392     Obsoletes: mplayer%{pkgext}1.0
393    
394    
395     %description
396     MPlayer is a movie player for LINUX (runs on many other Unices, and
397     non-x86 CPUs, see the documentation). It plays most MPEG, VOB, AVI,
398     VIVO, ASF/WMV, QT/MOV, FLI, NuppelVideo, yuv4mpeg, FILM, RoQ, and some
399     RealMedia files, supported by many native, XAnim, and Win32 DLL codecs.
400     You can watch VideoCD, SVCD, DVD, 3ivx, FLI, and even DivX movies too
401     (and you don't need the avifile library at all!). The another big
402     feature of mplayer is the wide range of supported output drivers. It
403     works with X11, Xv, DGA, OpenGL, SVGAlib, fbdev, AAlib, but you can use
404     SDL (and this way all drivers of SDL), VESA (on every VESA compatible
405     card, even without X!), and some lowlevel card-specific drivers (for
406     Matrox, 3Dfx and Radeon) too! Most of them supports software or hardware
407     scaling, so you can enjoy movies in fullscreen. MPlayer supports
408     displaying through some hardware MPEG decoder boards, such as the DVB
409     and DXR3/Hollywood+! And what about the nice big antialiased shaded
410     subtitles (9 supported types!!!) with european/ISO 8859-1,2 (hungarian,
411     english, czech, etc), cyrillic, korean fonts, and OSD?
412     %if %build_plf
413    
414 cjw 100681 This package is in the 'tainted' section because some included codecs
415     are covered by patents. It also includes support for reading DVDs
416     encrypted with CSS which might be illegal in some countries.
417 blino 24858 %endif
418    
419     %package doc
420     Summary: %{Name} documentation
421     Group: Books/Computer books
422 fwang 195140 BuildArch: noarch
423 blino 24858
424     %description doc
425     This package contains documentation for %{Name}.
426    
427     %if %build_gui
428     %package gui
429     Summary: GUI for %{name}
430     Group: Video
431     Requires: %{name} = %{version}
432     BuildRequires: gtk+2-devel
433     BuildRequires: imagemagick
434 luigiwalser 193598 Requires: soundwrapper
435 blino 24858 Provides: mplayer%{pkgext}1.0-gui
436     Obsoletes: mplayer%{pkgext}1.0-gui
437 ahmad 52786 Conflicts: mplayer-skins < 1.3-8
438 blino 24858
439     %description gui
440     This package contains a GUI for %{name}.
441     %endif
442    
443     %if %build_mencoder
444     %package -n mencoder%{pkgext}
445     Summary: MPlayer's movie encoder
446     Group: Video
447     Requires: %{name} = %version
448     Provides: mencoder%{pkgext}1.0
449     Obsoletes: mencoder%{pkgext}1.0
450    
451     %description -n mencoder%{pkgext}
452     MEncoder a movie encoder and is a part of the MPlayer package.
453     %if !%build_plf
454     Note: this version doesn't have support for encoding mp3 audio streams in the
455     video files.
456     %else
457 cjw 100681 This 'tainted' build has additional support for AAC decoding with libfaad
458 blino 24858 and MP3 encoding with lame, both are covered by software patents. It
459     also includes support for reading DVDs encrypted with CSS which might
460     be illegal in some countries.
461     %endif
462     %endif
463    
464    
465     %prep
466     %if %svn
467     %setup -q -n %name -a 4
468     %else
469     %setup -q -n MPlayer-%{version}%{prerel} -a 4
470     %endif
471     #gw as we have have used svn export:
472     echo %svn|sed s/^r// > snapshot_version
473     find DOCS -name .svn|xargs rm -rf
474     #gw fix permissions
475     chmod 644 AUTHORS Changelog README Copyright
476     rm -f Blue/README
477 luigiwalser 194871 %patch0 -p1 -b .distro-config
478 blino 24858 #%patch3 -p1 -b .mp2
479     #%patch7 -p1 -b .mga
480     #%patch21 -p0 -b .compiz
481     %patch28 -p1 -b .rtsp-extra-fixes
482     %patch31 -p1 -b .format~
483     %patch33 -p0
484     %patch35 -p0
485 anssi 202249 %patch48 -p1
486     %patch49 -p1
487 luigiwalser 223776 %patch50 -p0
488 luigiwalser 226410 %patch51 -p0
489 blino 24858
490     perl -pi -e 's^r\$svn_revision^%release^' version.sh
491    
492     mv DOCS/README README.DOCS
493    
494 luigiwalser 202792 tar -xjf %{SOURCE1}
495     mv ffmpeg-%{ffmpegversion} ffmpeg
496     pushd ffmpeg
497     popd
498    
499 blino 24858 %build
500     %if !%build_optimization
501     export CFLAGS="$CFLAGS $RPM_OPT_FLAGS"
502     %endif
503     %if %build_debug
504     export CFLAGS="$CFLAGS -g"
505     %endif
506     %ifarch ppc
507     export CFLAGS="$CFLAGS -mcpu=7450 -maltivec"
508     %endif
509     %if %build_directfb
510     export CPPFLAGS="-I%_includedir/directfb"
511     %endif
512     %if %{build_3264bit}
513     export EXESUF=32
514     %endif
515     export LDFLAGS="%{?ldflags}"
516     ./configure \
517     --prefix=%{_prefix} \
518     --datadir=%{_datadir}/%{name} \
519     --confdir=%{_sysconfdir}/%{name} \
520     --libdir=%_libdir \
521     %if !%build_optimization
522     --enable-runtime-cpudetection \
523     %ifarch %ix86
524     --enable-mmx \
525     --enable-3dnow \
526     --enable-sse \
527     --enable-sse2 \
528     --enable-fastmemcpy \
529     %endif
530     %endif
531     --enable-freetype \
532     --enable-nas \
533     %if %build_debug
534     --enable-debug=3 \
535     %else
536     --disable-sighandler \
537     %endif
538     %if %build_gui
539     --enable-gui \
540     %endif
541 luigiwalser 196696 %if %build_system_ffmpeg
542     --disable-ffmpeg_a \
543 fwang 225141 %else
544     --enable-ffmpeg_a \
545     --disable-ffmpeg_so \
546 luigiwalser 196696 %endif
547 blino 24858 --language=all \
548     %if ! %build_faad
549 luigiwalser 194871 --disable-faad \
550 blino 24858 --disable-decoder=AAC \
551     %endif
552     --disable-libdvdcss-internal \
553 luigiwalser 202791 --enable-dvdnav \
554     --disable-dvdread-internal \
555     --enable-dvdread \
556 blino 24858 %if %build_lirc
557     --enable-lirc \
558     %else
559     --disable-lirc \
560     %endif
561     --enable-tv \
562     %if ! %build_v4l2
563     --disable-tv-v4l2 \
564     %endif
565     --enable-joystick \
566     \
567     --enable-gl \
568     --disable-svga \
569     %if ! %build_mga
570     --disable-mga \
571     %endif
572     %if ! %build_fbdev
573     --disable-fbdev \
574     %endif
575     %if %build_directfb
576     --enable-directfb \
577     %else
578     --disable-directfb \
579     %endif
580     %if %build_mencoder
581     --enable-mencoder \
582     %else
583     --disable-mencoder \
584     %endif
585     %if ! %build_live
586     --disable-live \
587     %endif
588     %if ! %build_vesa
589     --disable-vesa \
590     %endif
591     %if %build_theora
592     --enable-theora \
593     %else
594     --disable-theora \
595     %endif
596     --enable-menu \
597     %if %build_xmms
598     --enable-xmms --with-xmmslibdir=%{_libdir} \
599     %endif
600     %if %build_smb
601     --enable-smb \
602     %endif
603     %if ! %build_dvb
604     --disable-dvb \
605     %endif
606     %if ! %build_ggi
607     --disable-ggi \
608     %endif
609     --codecsdir=%{_libdir}/codecs \
610     %if ! %build_arts
611     --disable-arts \
612     %endif
613     %if ! %build_jack
614     --disable-jack \
615     %endif
616     %if ! %build_aa
617     --disable-aa \
618     %endif
619     %if ! %build_cdda
620     --disable-cdparanoia \
621     %endif
622     %if ! %build_dv
623     --disable-libdv \
624     %endif
625     %if ! %build_lzo
626     --disable-liblzo \
627     %endif
628     %if ! %build_sdl
629     --disable-sdl \
630     %endif
631     %if ! %build_alsa
632     --disable-alsa \
633     %endif
634     %if ! %build_fribidi
635     --disable-fribidi \
636     %endif
637     %if !%build_enca
638     --disable-enca \
639     %endif
640     %if %build_pulse
641     --enable-pulse \
642     %endif
643     %if !%build_openal
644     --disable-openal \
645     %endif
646 ahmad 81539 %if %build_zr
647 blino 24858 --enable-zr \
648 ahmad 81539 %endif
649 blino 24858 %if %build_xvmc
650     --enable-xvmc \
651     %endif
652     %if ! %build_ivtv
653     --disable-ivtv \
654     %endif
655     %if ! %build_vdpau
656     --disable-vdpau
657     %endif
658    
659    
660     # Keep this line before empty end %%configure (ppc conditionnal pb)
661     make EXESUF=%{pkgext}
662     #gw make sure we have our version string included:
663     fgrep %release version.h
664    
665     %install
666 luigiwalser 193578 rm -rf %{buildroot}
667     install -d -m 755 %{buildroot}%{_bindir}
668     install -d -m 755 %{buildroot}%{_datadir}/%name
669     install -d -m 755 %{buildroot}%{_sysconfdir}/%name
670 luigiwalser 193683 install -m 755 mplayer%{pkgext} -D %{buildroot}%{_bindir}/mplayer%{pkgext}
671     for lang in en de fr hu pl zh_CN es it; do
672     install -m 644 DOCS/man/$lang/mplayer.1 -D %{buildroot}%{_mandir}/$([ "$lang" != "en" ] && echo $lang)/man1/mplayer%{pkgext}.1
673     done
674     %find_lang mplayer%{pkgext} --with-man
675 blino 24858
676     %if %build_mencoder
677 luigiwalser 193683 install -m 755 mencoder%{pkgext} -D %{buildroot}%{_bindir}/mencoder%{pkgext}
678    
679     for lang in en de fr hu pl zh_CN es it; do
680     ln -s mplayer%{pkgext}.1 %{buildroot}%{_mandir}/$([ "$lang" != "en" ] && echo $lang)/man1/mencoder%{pkgext}.1
681 blino 24858 done
682 luigiwalser 193683 %find_lang mencoder%{pkgext} --with-man
683 blino 24858 install -m 755 TOOLS/mencvcd.sh %buildroot%_bindir/mencvcd%{pkgext}
684     install -m 755 TOOLS/divx2svcd.sh %buildroot%_bindir/divx2svcd%{pkgext}
685     install -m 755 TOOLS/wma2ogg.pl %buildroot%_bindir/wma2ogg%{pkgext}.pl
686     install -m 755 TOOLS/midentify.sh %buildroot%_bindir/midentify%{pkgext}
687     %endif
688 luigiwalser 193578 install -m 644 etc/example.conf %{buildroot}%{_sysconfdir}/%{name}/mplayer.conf
689     install -m 644 etc/menu.conf %{buildroot}%{_sysconfdir}/%{name}
690 blino 24858
691     %if %build_gui
692     # default Skin
693 luigiwalser 196529 install -d -m 755 %buildroot%_datadir/%name/skins/
694     cp -r Blue %buildroot%_datadir/%name/skins/
695     ln -s Blue %buildroot%_datadir/%name/skins/default
696 blino 24858 # gmplayer equals mplayer -gui
697 luigiwalser 193587 ln -s mplayer%{pkgext} %{buildroot}%{_bindir}/gmplayer%{pkgext}
698 blino 24858 # icons
699 luigiwalser 193578 mkdir -p %{buildroot}{%_liconsdir,%_iconsdir,%{_miconsdir}}
700     convert -transparent white Blue/icons/icon48x48.png %{buildroot}%{_liconsdir}/mplayer%{pkgext}.png
701     convert -transparent white Blue/icons/icon32x32.png %{buildroot}%{_iconsdir}/mplayer%{pkgext}.png
702     convert -transparent white -scale 16x16 Blue/icons/icon48x48.png %{buildroot}%{_miconsdir}/mplayer%{pkgext}.png
703 blino 24858 install -D -m 644 etc/mplayer.desktop %buildroot%_datadir/applications/mplayer%{pkgext}.desktop
704     perl -pi -e 's@mplayer$@mplayer%{pkgext}@g' %buildroot%_datadir/applications/mplayer%{pkgext}.desktop
705     %endif
706     %if %{build_3264bit}
707     if [ -e %{buildroot}%{_liconsdir}/mplayer%{pkgext}.png ]; then
708     convert %{buildroot}%{_liconsdir}/mplayer%{pkgext}.png -channel green -negate \
709     %{buildroot}%{_liconsdir}/mplayer%{pkgext}.png
710     fi
711     if [ -e %{buildroot}%{_iconsdir}/mplayer%{pkgext}.png ]; then
712     convert %{buildroot}%{_iconsdir}/mplayer%{pkgext}.png -channel green -negate \
713     %{buildroot}%{_iconsdir}/mplayer%{pkgext}.png
714     fi
715     if [ -e %{buildroot}%{_miconsdir}/mplayer%{pkgext}.png ]; then
716     convert %{buildroot}%{_miconsdir}/mplayer%{pkgext}.png -channel green -negate \
717     %{buildroot}%{_miconsdir}/mplayer%{pkgext}.png
718     fi
719     %endif
720    
721     %if %build_debug
722     export DONT_STRIP=1
723     %endif
724    
725     %if %build_gui
726     %pre gui
727 luigiwalser 196529 if [ -d %_datadir/%name/skins/default ]
728     then rm -rf %_datadir/%name/skins/default
729 blino 24858 fi
730     %endif
731    
732     %clean
733     rm -rf %{buildroot}
734    
735 luigiwalser 193683 %files -f mplayer%{pkgext}.lang
736 blino 24858 %doc AUTHORS Changelog README Copyright
737     %dir %{_sysconfdir}/%name
738     %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}/mplayer.conf
739     %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}/menu.conf
740     %{_bindir}/midentify%{pkgext}
741     %{_bindir}/mplayer%{pkgext}
742     %{_mandir}/man1/mplayer%{pkgext}.1*
743     %dir %{_datadir}/%{name}
744    
745     %files doc
746 luigiwalser 194871 %defattr(-,root,root,755)
747 blino 24858 %doc README.DOCS
748 luigiwalser 194875 %doc DOCS/default.css DOCS/xml DOCS/tech/
749 luigiwalser 193578
750 blino 24858 %if %build_mencoder
751 luigiwalser 193683 %files -n mencoder%{pkgext} -f mencoder%{pkgext}.lang
752 blino 24858 %{_bindir}/mencoder%{pkgext}
753     %{_bindir}/divx2svcd%{pkgext}
754     %{_bindir}/mencvcd%{pkgext}
755     %{_bindir}/wma2ogg%{pkgext}.pl
756     %{_mandir}/man1/mencoder%{pkgext}.1*
757     %endif
758    
759     %if %build_gui
760     %files gui
761     %{_bindir}/gmplayer%{pkgext}
762     %_datadir/applications/mplayer%{pkgext}.desktop
763 luigiwalser 196529 %_datadir/%name/skins/
764 blino 24858 %{_iconsdir}/mplayer%{pkgext}.png
765     %{_miconsdir}/mplayer%{pkgext}.png
766     %{_liconsdir}/mplayer%{pkgext}.png
767     %endif
768    
769    
770    
771    

  ViewVC Help
Powered by ViewVC 1.1.30