/[packages]/cauldron/mythplugins/current/SPECS/mythplugins.spec
ViewVC logotype

Contents of /cauldron/mythplugins/current/SPECS/mythplugins.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 253382 - (show annotations) (download)
Sat Jun 2 11:13:02 2012 UTC (11 years, 10 months ago) by colin
File size: 12057 byte(s)
Update to latest fixes.
1 %define name mythplugins
2 %define version 0.25
3 %define gitversion v0.25-138-gbb0a4
4 %define fixesdate 20120602
5 %define rel 1
6
7 %define required_myth %{version}
8
9 %if %{fixesdate}
10 %define release %mkrel %fixesdate.%rel
11 %else
12 %define release %mkrel %rel
13 %endif
14
15 %if "%distro_section" == "tainted"
16 %global build_tainted 1
17 %else
18 %global build_tainted 0
19 %endif
20
21 BuildRequires: mesagl-devel
22 BuildRequires: libmyth-devel >= %{required_myth}
23 BuildRequires: python-mythtv >= %{required_myth}
24 BuildRequires: libvisual-devel
25 BuildRequires: fftw-devel
26 BuildRequires: SDL-devel
27 BuildRequires: libdvdread-devel
28 BuildRequires: libexif-devel
29 BuildRequires: id3tag-devel
30 BuildRequires: libvorbis-devel
31 BuildRequires: libflac-devel
32 BuildRequires: libcdaudio-devel
33 BuildRequires: libcdda-devel
34 BuildRequires: tiff-devel
35 BuildRequires: mysql-devel
36 BuildRequires: taglib-devel
37 BuildRequires: python-curl
38 BuildRequires: python-oauth
39 BuildRequires: perl-XML-XPath
40 BuildRequires: perl-Image-Size
41 BuildRequires: perl-Date-Manip
42 BuildRequires: perl-DateTime-Format-ISO8601
43 BuildRequires: perl-SOAP-Lite
44 BuildRequires: perl-XML-Simple
45 %if %{build_tainted}
46 BuildRequires: lame-devel
47 BuildRequires: libfaad2-devel
48 %endif
49 # (cg) Remove these once they are required in the python-mythtv package
50 BuildRequires: python-lxml
51 BuildRequires: python-mysql
52 # (cg) Ditto for the perl-DateTime-Format-ISO pkg
53 BuildRequires: perl(Class::Factory::Util)
54
55
56 Summary: Official MythTV plugins
57 Name: %{name}
58 Version: %{version}
59 Release: %{release}
60 URL: http://www.mythtv.org/
61 License: GPL
62 Group: Video
63 Source0: ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
64 Source1: update-fixes.sh
65 Patch001: fixes-%{gitversion}.patch
66 Patch100: 0100-lame-Allow-building-without-lame-libraries.patch
67
68 %description
69 Mythplugins for MythTV.
70
71 %if %{build_tainted}
72 This package is in the tainted section because it contains software that supports
73 codecs that may be covered by software patents.
74 %endif
75
76 %package -n mythtv-plugin-browser
77 Summary: Full web browser for MythTV
78 URL: http://www.mythtv.org/
79 Group: Video
80 Obsoletes: mythbrowser < 0.20a-7
81 Requires: mythtv-frontend >= %{required_myth}
82
83 %description -n mythtv-plugin-browser
84 MythBrowser is a full web browser for MythTV.
85
86 %package -n mythtv-plugin-gallery
87 Summary: Gallery/slideshow module for MythTV
88 Group: Video
89 Requires: mythtv-frontend >= %{required_myth}
90 Obsoletes: mythgallery < 0.20a-7
91
92 %description -n mythtv-plugin-gallery
93 A gallery/slideshow module for MythTV.
94
95 %package -n mythtv-plugin-game
96 Summary: Game frontend for MythTV
97 Group: Video
98 Requires: mythtv-frontend >= %{required_myth}
99 Obsoletes: mythgame < 0.20a-7
100
101 %description -n mythtv-plugin-game
102 A game frontend for MythTV.
103
104 %package -n mythtv-plugin-music
105 Summary: The music player add-on module for MythTV
106 Group: Video
107 #Requires: cdparanoia
108 Requires: mythtv-frontend >= %{required_myth}
109 Obsoletes: mythmusic < 0.20a-7
110
111 %description -n mythtv-plugin-music
112 The music player add-on module for MythTV.
113
114 %if %{build_tainted}
115 This package is in the tainted section because it contains software that supports
116 codecs that may be covered by software patents.
117 %endif
118
119 %package -n mythtv-plugin-netvision
120 Summary: NetVision for MythTV
121 Group: Video
122 Requires: mythtv-frontend >= %{required_myth}
123
124 %description -n mythtv-plugin-netvision
125 NetVision for MythTV. View popular media website content.
126
127 %package -n mythtv-plugin-news
128 Summary: RSS News feed plugin for MythTV
129 Group: Video
130 Requires: mythtv-frontend >= %{required_myth}
131 Obsoletes: mythnews < 0.20a-7
132
133 %description -n mythtv-plugin-news
134 An RSS News feed plugin for MythTV.
135
136 %package -n mythtv-plugin-weather
137 Summary: MythTV module that displays a weather forecast
138 Group: Video
139 Requires: mythtv-frontend >= %{required_myth}
140 Obsoletes: mythweather < 0.20a-7
141
142 %description -n mythtv-plugin-weather
143 A MythTV module that displays a weather forcast.
144
145 %package -n mythtv-mythweb
146 Summary: The web interface to MythTV
147 Group: Video
148 Requires: mythtv-backend >= %{required_myth}
149 Requires: apache-mod_php >= 2.0.54
150 Requires: php-mysql
151 Obsoletes: mythweb < 0.20a-7
152 # Requires autofinder is confused, requires nonexistent packages
153 %define _requires_exceptions pear*
154
155 %description -n mythtv-mythweb
156 The web interface to MythTV.
157
158 %package -n mythtv-plugin-zoneminder
159 Summary: Security camera plugin for MythTV
160 Group: Video
161 Requires: mythtv-frontend >= %{required_myth}
162
163 %description -n mythtv-plugin-zoneminder
164 A security camera plugin for MythTV.
165
166 %package -n mythtv-plugin-archive
167 Summary: Creates DVDs from your recorded shows
168 Group: Video
169 Requires: dvd+rw-tools
170 Requires: dvdauthor
171 Requires: ffmpeg
172 Requires: mjpegtools
173 Requires: python-imaging
174 Requires: python-mysql
175 Requires: mythtv-frontend >= %{required_myth}
176 %if %{build_tainted}
177 Requires: transcode
178 %endif
179 Requires: cdrkit-genisoimage
180 Obsoletes: mytharchive < 0.20a-7
181
182 %description -n mythtv-plugin-archive
183 MythArchive is a plugin for MythTV that lets you create DVDs
184 from your recorded shows, MythVideo files and any video files
185 available on your system. It can also archive recordings in a
186 proprietary format that archives not only the file but also all the
187 associated metadata like title, description and cut list information
188 which will mean you can create backups of myth recordings which can
189 later be restored or it will also allow you to move recordings
190 between myth systems without losing any of the metadata. It is a
191 complete rewrite of the old MythBurn bash scripts, now using python,
192 and the mythfrontend UI plugin.
193
194 %prep
195 %setup -q
196 %apply_patches
197
198 %build
199 %configure --enable-all --libdir-name=%{_lib} \
200 %if %{build_tainted}
201 --enable-mp3lame
202 %else
203 --disable-mp3lame
204 %endif
205
206 %make
207
208 %install
209
210 rm -rf %{buildroot}
211
212 INSTALL_ROOT=%{buildroot}; export INSTALL_ROOT
213 %makeinstall
214
215 #mythgallery
216 mkdir -p %{buildroot}%{_localstatedir}/lib/pictures
217 #mythmusic
218 mkdir -p %{buildroot}%{_localstatedir}/lib/mythmusic
219
220 install -d -m755 %{buildroot}%{_var}/www/mythweb
221 install -m644 mythweb/*.php %{buildroot}%{_var}/www/mythweb
222 install -m755 mythweb/*.pl %{buildroot}%{_var}/www/mythweb
223
224 for dir in classes includes js modules skins ; do
225 cp -r mythweb/$dir %{buildroot}%{_var}/www/mythweb
226 done
227
228 install -d -m755 %{buildroot}%{_localstatedir}/lib/mythweb/data
229 ln -s %{_localstatedir}/lib/mythweb/data %{buildroot}%{_var}/www/mythweb/data
230
231 # Create a default configuration for mythweb
232 cp mythweb/mythweb.conf.apache mythweb/mythweb.conf
233 perl -pi -e's|<Directory "/var/www/html" >|<Directory "%{_var}/www/mythweb" >|' mythweb/mythweb.conf
234 perl -pi -e's|# RewriteBase /mythweb| RewriteBase /mythweb|' mythweb/mythweb.conf
235
236 install -d -m755 %{buildroot}%{_sysconfdir}/httpd/conf/webapps.d
237 cat > %{buildroot}%{_sysconfdir}/httpd/conf/webapps.d/mythweb.conf <<EOF
238 Alias /mythweb %{_var}/www/mythweb
239
240 <Directory %{_var}/www/mythweb>
241 Order allow,deny
242 Deny from all
243 </Directory>
244 EOF
245
246 mkdir -p %{buildroot}{%_docdir}/mythtv-plugin-{browser,gallery,game,music,netvision,news,weather,video,zoneminder}
247
248
249 %clean
250 rm -rf %{buildroot}
251
252 %files -n mythtv-plugin-browser
253 %defattr(-,root,root,-)
254 %doc mythbrowser/README mythbrowser/COPYING mythbrowser/AUTHORS
255 %{_libdir}/mythtv/plugins/libmythbrowser.so
256 %{_datadir}/mythtv/i18n/mythbrowser_*.qm
257 %{_datadir}/mythtv/themes/default*/browser-ui.xml
258 %{_datadir}/mythtv/themes/default*/mb_*.png
259
260 %files -n mythtv-plugin-gallery
261 %defattr(-,root,root,-)
262 %doc mythgallery/README*
263 %{_libdir}/mythtv/plugins/libmythgallery.so
264 %{_datadir}/mythtv/i18n/mythgallery_*.qm
265 %{_datadir}/mythtv/themes/default*/gallery*
266 %{_localstatedir}/lib/pictures
267
268 %files -n mythtv-plugin-game
269 %defattr(-,root,root,-)
270 %doc mythgame/romdb*
271 %{_libdir}/mythtv/plugins/libmythgame.so
272 %{_datadir}/mythtv/i18n/mythgame_*.qm
273 %{_datadir}/mythtv/game_settings.xml
274 %{_datadir}/mythtv/themes/default*/game*
275 %dir %{_datadir}/mythtv/metadata
276 %{_datadir}/mythtv/metadata/Game
277
278 %files -n mythtv-plugin-music
279 %defattr(-,root,root,-)
280 %doc mythmusic/AUTHORS mythmusic/COPYING mythmusic/README* mythmusic/musicdb
281 %{_datadir}/mythtv/music_settings.xml
282 %{_datadir}/mythtv/musicmenu.xml
283 %{_libdir}/mythtv/plugins/libmythmusic.so
284 %{_localstatedir}/lib/mythmusic
285 %{_datadir}/mythtv/i18n/mythmusic_*.qm
286 %{_datadir}/mythtv/themes/default/ff_button*.png
287 %{_datadir}/mythtv/themes/default*/mm_*.png
288 %{_datadir}/mythtv/themes/default*/mm-*.png
289 %{_datadir}/mythtv/themes/default/music-*.png
290 %{_datadir}/mythtv/themes/default*/*music*.xml
291 %{_datadir}/mythtv/themes/default/next_button*.png
292 %{_datadir}/mythtv/themes/default/pause_button*.png
293 %{_datadir}/mythtv/themes/default/play_button*.png
294 %{_datadir}/mythtv/themes/default/prev_button*.png
295 %{_datadir}/mythtv/themes/default/rew_button*.png
296 %{_datadir}/mythtv/themes/default/selectionbar.png
297 %{_datadir}/mythtv/themes/default/stop_button*.png
298 %{_datadir}/mythtv/themes/default/track_info_background.png
299 %{_datadir}/mythtv/themes/default/miniplayer_background.png
300 %{_datadir}/mythtv/themes/default-wide/music-sel-bg.png
301
302 %files -n mythtv-plugin-netvision
303 %defattr(-,root,root,-)
304 %doc mythnetvision/README mythnetvision/ChangeLog mythnetvision/AUTHORS
305 %{_bindir}/mythfillnetvision
306 %{_libdir}/mythtv/plugins/libmythnetvision.so
307 %{_datadir}/mythtv/i18n/mythnetvision_*.qm
308 %{_datadir}/mythtv/mythnetvision
309 %{_datadir}/mythtv/netvisionmenu.xml
310 %{_datadir}/mythtv/themes/default*/netvision*.xml
311
312 %files -n mythtv-plugin-news
313 %defattr(-,root,root,-)
314 %doc mythnews/AUTHORS mythnews/COPYING mythnews/ChangeLog mythnews/README*
315 %{_libdir}/mythtv/plugins/libmythnews.so
316 %{_datadir}/mythtv/i18n/mythnews_*.qm
317 %{_datadir}/mythtv/mythnews
318 %{_datadir}/mythtv/themes/default*/news*
319 %{_datadir}/mythtv/themes/default/enclosures.png
320 %{_datadir}/mythtv/themes/default/need-download.png
321 %{_datadir}/mythtv/themes/default/podcast.png
322
323
324 %files -n mythtv-plugin-weather
325 %defattr(-,root,root,-)
326 %doc mythweather/AUTHORS mythweather/COPYING mythweather/README*
327 %{_libdir}/mythtv/plugins/libmythweather.so
328 %{_datadir}/mythtv/i18n/mythweather_*.qm
329 %{_datadir}/mythtv/mythweather
330 %{_datadir}/mythtv/themes/default/cloudy.png
331 %{_datadir}/mythtv/themes/default/fair.png
332 %{_datadir}/mythtv/themes/default/flurries.png
333 %{_datadir}/mythtv/themes/default/fog.png
334 %{_datadir}/mythtv/themes/default/logo.png
335 %{_datadir}/mythtv/themes/default/lshowers.png
336 %{_datadir}/mythtv/themes/default/mcloudy.png
337 %{_datadir}/mythtv/themes/default/pcloudy.png
338 %{_datadir}/mythtv/themes/default/rainsnow.png
339 %{_datadir}/mythtv/themes/default/showers.png
340 %{_datadir}/mythtv/themes/default/snowshow.png
341 %{_datadir}/mythtv/themes/default/sunny.png
342 %{_datadir}/mythtv/themes/default/thunshowers.png
343 %{_datadir}/mythtv/themes/default/unknown.png
344 %{_datadir}/mythtv/themes/default*/mw*.png
345 %{_datadir}/mythtv/themes/default*/weather-ui.xml
346 %{_datadir}/mythtv/weather_settings.xml
347
348 %files -n mythtv-mythweb
349 %defattr(-,root,root,-)
350 %doc mythweb/README* mythweb/LICENSE mythweb/INSTALL mythweb/mythweb.conf.*
351 %{_var}/www/mythweb
352 %dir %{_localstatedir}/lib/mythweb
353 %attr(-,apache,apache) %{_localstatedir}/lib/mythweb/data
354 %config(noreplace) %{_sysconfdir}/httpd/conf/webapps.d/mythweb.conf
355
356 %files -n mythtv-plugin-zoneminder
357 %defattr(-,root,root,-)
358 %doc mythzoneminder/README mythzoneminder/COPYING mythzoneminder/AUTHORS
359 %{_bindir}/mythzmserver
360 %{_libdir}/mythtv/plugins/libmythzoneminder.so
361 %{_datadir}/mythtv/zonemindermenu.xml
362 %{_datadir}/mythtv/themes/default*/zoneminder*.xml
363 %{_datadir}/mythtv/themes/default*/mz_*.png
364 %{_datadir}/mythtv/i18n/mythzoneminder_*.qm
365
366 %files -n mythtv-plugin-archive
367 %defattr(-,root,root)
368 %{_bindir}/mytharchivehelper
369 %{_libdir}/mythtv/plugins/libmytharchive.so
370 %{_datadir}/mythtv/archive*.xml
371 %{_datadir}/mythtv/mytharchive
372 %{_datadir}/mythtv/themes/default/ma_*.png
373 %{_datadir}/mythtv/themes/default/mytharchive-ui.xml
374 %{_datadir}/mythtv/themes/default/mythburn-ui.xml
375 %{_datadir}/mythtv/themes/default/mythnative-ui.xml
376 %{_datadir}/mythtv/themes/default-wide/mytharchive-ui.xml
377 %{_datadir}/mythtv/themes/default-wide/mythburn-ui.xml
378 %{_datadir}/mythtv/themes/default-wide/mythnative-ui.xml
379 %{_datadir}/mythtv/i18n/mytharchive_*.qm
380
381

  ViewVC Help
Powered by ViewVC 1.1.30