/[packages]/cauldron/ncpfs/current/SPECS/ncpfs.spec
ViewVC logotype

Contents of /cauldron/ncpfs/current/SPECS/ncpfs.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 273158 - (show annotations) (download)
Sat Jul 21 17:42:31 2012 UTC (11 years, 9 months ago) by colin
File size: 5125 byte(s)
Update for usrmove
1 %define major 2.3
2 %define libname %mklibname %{name} %{major}
3 %define develname %mklibname %{name} -d
4
5 Summary: Utilities for the ncpfs filesystem, a NetWare client for Linux
6 Name: ncpfs
7 Version: 2.2.6
8 Release: %mkrel 13
9 License: GPLv2+
10 Group: Networking/Other
11 URL: ftp://platan.vc.cvut.cz/pub/linux/ncpfs/
12 Source0: ftp://platan.vc.cvut.cz/pub/linux/ncpfs/%{name}-%{version}/%{name}-%{version}.tar.bz2
13 Patch0: ncpfs-2.2.3-fix.patch
14 Patch1: ncpfs-2.2.3-array.patch
15 Patch3: ncpfs-2.2.4-pie.patch
16 Patch5: ncpfs-2.2.6-getuid.patch
17 Patch6: ncpfs-2.2.4-gcc4.patch
18 Patch7: ncpfs-2.2.6-ldconfig.patch
19 Patch8: ncpfs-2.2.6-align.patch
20 Patch9: ncpfs-2.2.6-add-missing-header.patch
21 # From Fedora: fixes compilation failure (see Debian bug 428937)
22 # - AdamW 2007/12
23 Patch10: ncpfs-2.2.6-offsetof.patch
24 Patch11: ncpfs-2.2.6-LDFLAGS.diff
25 Patch12: ncpfs-2.2.6-CVE-2010-0788.diff
26 Patch13: ncpfs-2.2.6-CVE-2010-0790,0791.diff
27 Patch14: ncpfs-2.2.6-CVE-2011-1679,1680.diff
28 Requires(pre): filesystem >= 2.1.9-18
29 Requires: ipxutils
30 Requires: %{libname} = %{version}-%{release}
31 BuildRequires: pam-devel
32
33
34 %description
35 Ncpfs is a filesystem which understands the Novell NetWare(TM)
36 NCP protocol. Functionally, NCP is used for NetWare the way NFS
37 is used in the TCP/IP world. For a Linux system to mount a NetWare
38 filesystem, it needs a special mount program. The ncpfs package
39 contains such a mount program plus other tools for configuring and
40 using the ncpfs filesystem.
41
42 Install the ncpfs package if you need to use the ncpfs filesystem
43 to use Novell NetWare files or services.
44
45 %package -n ipxutils
46 Summary: Tools for configuring and debugging IPX interfaces and networks
47 Group: System/Configuration/Networking
48 Requires(pre): filesystem >= 2.1.9-18
49
50 %description -n ipxutils
51 The ipxutils package includes utilities (ipx_configure, ipx_internal_net,
52 ipx_interface, ipx_route) necessary for configuring and debugging IPX
53 interfaces and networks under Linux. IPX is the low-level protocol used
54 by Novell's NetWare file server system to transfer data.
55
56 Install ipxutils if you need to configure IPX networking on your network.
57
58 %package -n %{libname}
59 Summary: Library associated with ncpfs
60 Group: System/Libraries
61
62 %description -n %{libname}
63 This library is mandatory for ncpfs and ipxutils to run.
64
65 %package -n %{develname}
66 Summary: Development package with static libs and headers
67 Group: Development/C
68 Requires: %{libname} = %{version}-%{release}
69 Provides: %{name}-devel = %{version}-%{release}
70 Obsoletes: %{mklibname ncpfs 2.3 -d}
71
72 %description -n %{develname}
73 Static libraries and header files required for compiling xmms plugins.
74
75 %prep
76 %setup -q
77 %patch0 -p1 -b .fix
78 %patch1 -p1 -b .array
79 %patch3 -p1 -b .pie
80 %patch5 -p1 -b .getuid
81 %patch6 -p1 -b .gcc4
82 %patch7 -p1 -b .ld
83 %patch8 -p1 -b .align
84 %patch9 -p1 -b .header
85 %patch10 -p1 -b .offset
86 %patch11 -p1 -b .LDFLAGS
87 %patch12 -p1 -b .CVE-2010-0788
88 %patch13 -p1 -b .CVE-2010-0790,0791
89 %patch14 -p1 -b .CVE-2011-1679,1680
90
91 chmod +rw -R .
92
93 # lib64 fix
94 perl -pi -e "s|/lib/security\b|/%{_lib}/security|g" configure*
95
96 %build
97 chmod -R u+w po
98
99 CFLAGS="%{optflags} -fPIC" \
100 LDFLAGS="%{ldflags}" \
101 %configure2_5x \
102 --disable-rpath \
103 --enable-pam
104
105 %make clean
106 %make
107
108 %make -C ipxdump
109 mv ipxdump/README ipxdump/README.ipxdump
110
111 %install
112 rm -rf %{buildroot}
113
114 mkdir -p %{buildroot}%{_libdir}
115
116 %makeinstall_std install-dev
117
118 # Move ipx_configure/ipx_internal_net to permit /usr from NFS
119 for i in ipx_configure ipx_internal_net ipx_interface ; do
120 mv %{buildroot}%{_bindir}/$i %{buildroot}%{_sbindir}/$i
121 done
122
123 install -m755 ipxdump/ipxdump ipxdump/ipxparse %{buildroot}%{_bindir}/
124
125 ln -sf %{_bindir}/ncpmount %{buildroot}%{_sbindir}/mount.ncp
126 ln -sf %{_bindir}/ncpmount %{buildroot}%{_sbindir}/mount.ncpfs
127 ln -sf ncpmount.8 %{buildroot}%{_mandir}/man8/mount.ncp.8
128
129 %find_lang %{name}
130
131 #rm -f %{buildroot}/usr/share/locale/locale.alias
132
133 %post -n ipxutils
134 if [ -f %{_sysconfdir}/modules.conf ];then
135 if ! grep -q -E "^alias.*net-pf-4.*ipx" %{_sysconfdir}/modules.conf;then
136 echo "alias net-pf-4 ipx" >> %{_sysconfdir}/modules.conf
137 fi
138 else
139 echo "alias net-pf-4 ipx" >> %{_sysconfdir}/modules.conf
140 fi
141
142 %postun -n ipxutils
143 if [ "$1" = "0" ];then
144 if [ -f %{_sysconfdir}/modules.conf ];then
145 if grep -q -E "^alias.*net-pf-4.*ipx" %{_sysconfdir}/modules.conf;then
146 sed 's/^alias net-pf-4 ipx//' %{_sysconfdir}/modules.conf > %{_sysconfdir}/.modules.conf.ipx \
147 && mv -f %{_sysconfdir}/.modules.conf.ipx %{_sysconfdir}/modules.conf
148 fi
149 fi
150 fi
151
152
153 %clean
154 rm -rf %{buildroot}
155
156 %files -f %{name}.lang
157 %defattr(-,root,root)
158 %{_bindir}/n*
159 %{_bindir}/p*
160 %{_bindir}/slist
161 %{_sbindir}/mount.ncp*
162 %{_sbindir}/nwmsg
163 %{_mandir}/man1/*
164 %{_mandir}/man3/*
165 %{_mandir}/man5/*
166 %{_mandir}/man8/*
167 %doc BUGS Changes FAQ README
168
169 %files -n ipxutils
170 %defattr(-,root,root)
171 %doc ipx-1.0/COPYING ipx-1.0/README
172 %doc ipxdump/README.ipxdump
173 %{_sbindir}/ipx_*
174 %{_bindir}/ipx*
175 %{_mandir}/*/ipx*
176
177 %files -n %{libname}
178 %defattr(-,root,root)
179 /%{_lib}/security/*
180 %{_libdir}/libncp.so.*
181
182 %files -n %{develname}
183 %defattr(-,root,root)
184 %doc Changes
185 %{_libdir}/lib*.so
186 %{_libdir}/lib*.a
187 %{_includedir}/*
188
189

  ViewVC Help
Powered by ViewVC 1.1.30