/[packages]/cauldron/perl-Dir-Manifest/current/SPECS/perl-Dir-Manifest.spec
ViewVC logotype

Contents of /cauldron/perl-Dir-Manifest/current/SPECS/perl-Dir-Manifest.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1395124 - (show annotations) (download)
Wed Apr 24 08:48:03 2019 UTC (4 years, 11 months ago) by shlomif
File size: 1683 byte(s)
- Fix summary and description
1 %define upstream_name Dir-Manifest
2 %define upstream_version 0.0.3
3
4 %{?perl_default_filter}
5
6 Name: perl-%{upstream_name}
7 Version: %perl_convert_version %{upstream_version}
8 Release: %mkrel 2
9
10 Summary: Load texts or blobs from a directory of files
11 License: GPLv1+ or Artistic
12 Group: Development/Perl
13 Url: http://metacpan.org/release/%{upstream_name}
14 Source0: http://www.cpan.org/modules/by-module/Dir/%{upstream_name}-%{upstream_version}.tar.gz
15
16 BuildRequires: perl(Exporter)
17 BuildRequires: perl(File::Spec)
18 BuildRequires: perl(IO::Handle)
19 BuildRequires: perl(IPC::Open3)
20 BuildRequires: perl(Module::Build) >= 0.280.0
21 BuildRequires: perl(Moo)
22 BuildRequires: perl(Path::Tiny)
23 BuildRequires: perl(Socket)
24 BuildRequires: perl(Test::More) >= 0.880.0
25 BuildRequires: perl(parent)
26 BuildRequires: perl(strict)
27 BuildRequires: perl(warnings)
28 BuildArch: noarch
29
30 %description
31 Here is the primary use case: you have several long texts (and/or binary
32 blobs) that you wish to load from the code (e.g: for the "want"/expected
33 values of tests) and you wish to conveniently edit them, track them and
34 maintain them. Using Dir::Manifest you can put each in a
35 separate file in a directory, create a manifest file listing all valid
36 filenames/key and then say something like 'my $text =
37 $dir->text("deal24solution.txt", {lf => 1})'. And hopefully it will be done
38 securely and reliably.
39
40 %prep
41 %setup -q -n %{upstream_name}-%{upstream_version}
42
43 %build
44 %{__perl} Build.PL --installdirs=vendor
45
46 ./Build
47
48 %check
49 ./Build test
50
51 %install
52 ./Build install --destdir=%{buildroot}
53
54 %files
55 %doc Changes LICENSE META.json META.yml MYMETA.yml README
56 %{_mandir}/man3/*
57 %perl_vendorlib/*

  ViewVC Help
Powered by ViewVC 1.1.30