/[packages]/cauldron/perl-Module-Build/current/SPECS/perl-Module-Build.spec
ViewVC logotype

Annotation of /cauldron/perl-Module-Build/current/SPECS/perl-Module-Build.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 266674 - (hide annotations) (download)
Mon Jul 2 13:05:59 2012 UTC (11 years, 9 months ago) by jquelin
File size: 2840 byte(s)
update to 0.4001
1 jquelin 7396 %define upstream_name Module-Build
2 jquelin 266674 %define upstream_version 0.4001
3 jquelin 7396
4     Name: perl-%{upstream_name}
5     Version: %perl_convert_version %{upstream_version}
6 jquelin 252187 Release: %mkrel 1
7 jquelin 7396 Epoch: 1
8    
9     Summary: Build and install Perl modules
10     License: GPL+ or Artistic
11     Group: Development/Perl
12     Summary: Curses interface for Config::Model
13     Url: http://search.cpan.org/dist/%{upstream_name}
14     Source0: http://www.cpan.org/modules/by-module/Module/%{upstream_name}-%{upstream_version}.tar.gz
15    
16 jquelin 67598 BuildRequires: perl(CPAN::Meta) >= 2.110.420
17 jquelin 252187 BuildRequires: perl(CPAN::Meta::YAML) >= 0.3.0
18 jquelin 67598 BuildRequires: perl(Cwd)
19     BuildRequires: perl(Data::Dumper)
20     BuildRequires: perl(ExtUtils::CBuilder) >= 0.270.0
21     BuildRequires: perl(ExtUtils::Install)
22     BuildRequires: perl(ExtUtils::Manifest)
23     BuildRequires: perl(ExtUtils::Mkbootstrap)
24     BuildRequires: perl(ExtUtils::ParseXS) >= 2.210.0
25     BuildRequires: perl(File::Basename)
26     BuildRequires: perl(File::Compare)
27     BuildRequires: perl(File::Copy)
28     BuildRequires: perl(File::Find)
29     BuildRequires: perl(File::Path)
30     BuildRequires: perl(File::Spec) >= 0.820.0
31     BuildRequires: perl(File::Temp) >= 0.150.0
32     BuildRequires: perl(Getopt::Long)
33     BuildRequires: perl(IO::File)
34     BuildRequires: perl(Module::Metadata) >= 1.0.2
35     BuildRequires: perl(Parse::CPAN::Meta) >= 1.440.100
36     BuildRequires: perl(Perl::OSType) >= 1.0.0
37     BuildRequires: perl(Test::Harness)
38     BuildRequires: perl(Test::More) >= 0.490.0
39     BuildRequires: perl(Text::Abbrev)
40     BuildRequires: perl(Text::ParseWords)
41     BuildRequires: perl(version) >= 0.870.0
42     BuildRequires: perl-devel
43 jquelin 7396 # (tv) this is a soft dep (require instead of use); w/o it some builds failed with
44     # "Module::Build is not configured with C_support":
45 jquelin 67598 BuildArch: noarch
46 jquelin 24252
47 jquelin 7396 Suggests: perl-ExtUtils-CBuilder
48    
49     %description
50     Module::Build is a system for building, testing, and installing Perl modules.
51     It is meant to be a replacement for ExtUtils::MakeMaker. Developers may alter
52     the behavior of the module through subclassing in a much more straightforward
53     way than with MakeMaker. It also does not require a make on your system - most
54     of the Module::Build code is pure-perl and written in a very cross-platform
55     way. In fact, you don't even need a shell, so even platforms like MacOS
56     (traditional) can use it fairly easily. Its only prerequisites are modules that
57     are included with perl 5.6.0, and it works fine on perl 5.005 if you can
58     install a few additional modules.
59    
60     %prep
61     %setup -q -n %{upstream_name}-%{upstream_version}
62    
63     %build
64     %{__perl} Makefile.PL INSTALLDIRS=vendor
65     perl Build.PL installdirs=vendor
66     ./Build
67    
68     %check
69     ./Build test
70    
71 jquelin 252126 %install
72     ./Build install destdir=%{buildroot}
73     for i in %{buildroot}/%{_bindir}/*; do mv $i $i-%{upstream_version}; done
74 jquelin 7396
75     %files
76 jquelin 252187 %doc Changes INSTALL LICENSE META.json META.yml MYMETA.yml README
77 jquelin 252129 %{_bindir}/*
78 jquelin 7396 %{perl_vendorlib}/inc
79     %{perl_vendorlib}/Module
80 jquelin 252187 %{_mandir}/*/*

  ViewVC Help
Powered by ViewVC 1.1.30