/[packages]/cauldron/perl-Mojolicious-Plugin-Bootstrap3/current/SPECS/perl-Mojolicious-Plugin-Bootstrap3.spec
ViewVC logotype

Contents of /cauldron/perl-Mojolicious-Plugin-Bootstrap3/current/SPECS/perl-Mojolicious-Plugin-Bootstrap3.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 913451 - (show annotations) (download)
Tue Dec 22 14:08:38 2015 UTC (4 years, 10 months ago) by doktor5000
File size: 1839 byte(s)
- adapt to Mageia
- adapt to Mageia perl policy
  o replace URL and Source
  o added upstream github URL in comment
  o remove explicit versionned Requires on perl itself
  o adjust version on BuildRequires Mojolicious::Plugin::AssetPack
  o added comment for explicit Requires on perl(Mojolicious::Plugin::AssetPack)
- add Group

1 %global module Mojolicious-Plugin-Bootstrap3
2 %global upstream_version 3.3505
3
4 %{?perl_default_filter}
5
6 Name: perl-%{module}
7 Version: %perl_convert_version %{upstream_version}
8 Release: %mkrel 1
9 Summary: Mojolicious + http://getbootstrap.com/
10 License: Artistic 2.0
11 Group: Development/Perl
12 # also available via github: https://github.com/jhthorsen/mojolicious-plugin-bootstrap3
13 URL: http://search.cpan.org/dist/%{module}
14 Source0: http://www.cpan.org/modules/by-module/Mojolicious/%{module}-%{upstream_version}.tar.gz
15
16 BuildArch: noarch
17 BuildRequires: make
18 BuildRequires: perl
19 BuildRequires: perl(Cwd)
20 BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
21 BuildRequires: perl(File::Basename)
22 BuildRequires: perl(File::Copy)
23 BuildRequires: perl(File::Find)
24 BuildRequires: perl(File::Path)
25 BuildRequires: perl(File::Spec)
26 BuildRequires: perl(File::Temp)
27 BuildRequires: perl(Mojo::Base)
28 BuildRequires: perl(Mojolicious) >= 6.00
29 BuildRequires: perl(Mojolicious::Plugin)
30 BuildRequires: perl(Mojolicious::Plugin::AssetPack) >= 0.670
31 BuildRequires: perl(Mojo::Util)
32 BuildRequires: perl(Test::Mojo)
33 BuildRequires: perl(Test::More) >= 0.88
34 BuildRequires: perl(constant)
35 # (doktor5000) not added via automatic Requires generation
36 # require for additional content, and also require minimum version
37 Requires: perl(Mojolicious::Plugin::AssetPack) >= 0.670
38
39 %description
40 Mojolicious::Plugin::Bootstrap3 is used to include http://getbootstrap.com/
41 CSS and JavaScript files into your project.
42
43 %prep
44 %setup -q -n Mojolicious-Plugin-Bootstrap3-%{upstream_version}
45
46 %build
47 %{__perl} Makefile.PL INSTALLDIRS=vendor
48
49 %make
50
51 %check
52 %make test
53
54 %install
55 %make_install
56 %{_fixperms} %{buildroot}/*
57
58 %files
59 %doc Changes README
60 %{perl_vendorlib}/Mojolicious*
61 %{_mandir}/man3/Mojolicious*
62

  ViewVC Help
Powered by ViewVC 1.1.28