/[packages]/cauldron/perl-Statistics-CaseResampling/current/SPECS/perl-Statistics-CaseResampling.spec
ViewVC logotype

Contents of /cauldron/perl-Statistics-CaseResampling/current/SPECS/perl-Statistics-CaseResampling.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1243233 - (show annotations) (download)
Thu Jul 12 10:00:02 2018 UTC (5 years, 9 months ago) by tv
File size: 1880 byte(s)
imported package perl-Statistics-CaseResampling
1 %define upstream_name Statistics-CaseResampling
2 %define upstream_version 0.15
3
4 %{?perl_default_filter}
5
6 Name: perl-%{upstream_name}
7 Version: %perl_convert_version %{upstream_version}
8 Release: %mkrel 1
9
10 Summary: Efficient resampling and calculation of medians with confidence intervals
11 License: GPLv1+ or Artistic
12 Group: Development/Perl
13 Url: http://metacpan.org/release/%{upstream_name}
14 Source0: http://www.cpan.org/modules/by-module/Statistics/%{upstream_name}-%{upstream_version}.tar.gz
15
16 BuildRequires: perl(ExtUtils::MakeMaker)
17 BuildRequires: perl(ExtUtils::MakeMaker)
18 BuildRequires: perl(List::Util)
19 BuildRequires: perl-devel
20
21 %description
22 The purpose of this (XS) module is to calculate the median (or in principle
23 also other statistics) with confidence intervals on a sample. To do that,
24 it uses a technique called bootstrapping. In a nutshell, it resamples the
25 sample a lot of times and for each resample, it calculates the median. From
26 the distribution of medians, it then calculates the confidence limits.
27
28 In order to implement the confidence limit calculation, various other
29 functions had to be implemented efficiently (both algorithmically efficient
30 and done in C). These functions may be useful in their own right and are
31 thus exposed to Perl. Most notably, this exposes a median (and general
32 selection) algorithm that works in linear time as opposed to the trivial
33 implementation that requires 'O(n*log(n))'.
34
35 Random numbers
36 The resampling involves drawing *many* random numbers. Therefore, the
37 module comes with an embedded Mersenne twister (taken from
38 'Math::Random::MT').
39
40 %prep
41 %setup -q -n %{upstream_name}-%{upstream_version}
42
43 %build
44 %{__perl} Makefile.PL INSTALLDIRS=vendor
45
46 %make_build
47
48 %check
49 %make_build test
50
51 %install
52 %make_install
53
54 %files
55 %doc META.yml Changes README
56 %{_mandir}/man3/*
57 %perl_vendorlib/*
58
59

  ViewVC Help
Powered by ViewVC 1.1.30