/[packages]/cauldron/postgresql9.2/current/SPECS/postgresql9.2.spec
ViewVC logotype

Contents of /cauldron/postgresql9.2/current/SPECS/postgresql9.2.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 813903 - (show annotations) (download)
Sat Feb 7 09:31:57 2015 UTC (9 years, 2 months ago) by oden
File size: 22919 byte(s)
- 9.2.10 (fixes CVE-2014-8161, CVE-2015-0241, CVE-2015-0242, CVE-2015-0243, CVE-2015-0244)
1 %define Werror_cflags %{nil}
2 %define _disable_ld_no_undefined 1
3
4 %define perl_version %(rpm -q --qf "%{VERSION}" perl)
5 %define perl_epoch %(rpm -q --qf "%{EPOCH}" perl)
6
7 %define pgdata /var/lib/pgsql
8 %define logrotatedir %{_sysconfdir}/logrotate.d
9
10 %define major 5.5
11 %define major_ecpg 6
12
13 %define bname postgresql
14 %define current_major_version 9.2
15 %define current_minor_version 10
16
17 %define rel 1
18
19
20 %define libname %mklibname pq%{current_major_version} _%{major}
21 %define libecpg %mklibname ecpg%{current_major_version} _%{major_ecpg}
22
23 # (blino) FIXME: enable back when ossp_uuid (and php) are available
24 %define withuuid 1
25 #define withuuid 1
26
27 Summary: PostgreSQL client programs and libraries
28 Name: %{bname}%{current_major_version}
29 Version: %{current_major_version}.%{current_minor_version}
30 Release: %mkrel %{rel}
31 License: BSD
32 Group: Databases
33 URL: http://www.postgresql.org/
34 Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
35 Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.md5
36 Source10: postgres.profile
37 Source11: postgresql.service
38 Source13: postgresql.distro.releasenote
39 Source14: postgresql_initdb.sh
40 Patch0: postgresql-9.2.6-libpq_soname.diff
41 Requires: perl
42 Provides: postgresql-clients = %{version}-%{release}
43 Conflicts: postgresql-clients < %{version}-%{release}
44 BuildRequires: bison
45 BuildRequires: flex
46 BuildRequires: openssl-devel
47 BuildRequires: pam-devel
48 BuildRequires: perl-devel
49 BuildRequires: python-devel
50 BuildRequires: readline-devel
51 BuildRequires: tcl-devel
52 BuildRequires: libxml2-devel
53 BuildRequires: libxslt-devel
54 BuildRequires: zlib-devel
55 %if %withuuid
56 BuildRequires: ossp_uuid-devel
57 %endif
58 # Need to build doc
59 BuildRequires: docbook-dtd42-sgml
60 BuildRequires: openjade
61 BuildRequires: docbook-utils
62 BuildRequires: docbook-style-xsl
63 BuildRequires: xsltproc
64 Provides: %{bname}-virtual = %{current_major_version}
65 Conflicts: %{bname}-virtual < %{current_major_version}
66 Provides: %{bname} = %{version}-%{release}
67 Conflicts: %{bname} < %{version}-%{release}
68
69 %description
70 PostgreSQL is an advanced Object-Relational database management system (DBMS)
71 that supports almost all SQL constructs (including transactions, subselects and
72 user-defined types and functions). The postgresql package includes the client
73 programs and libraries that you'll need to access a PostgreSQL DBMS server.
74 These PostgreSQL client programs are programs that directly manipulate the
75 internal structure of PostgreSQL databases on a PostgreSQL server. These client
76 programs can be located on the same machine with the PostgreSQL server, or may
77 be on a remote machine which accesses a PostgreSQL server over a network
78 connection. This package contains the client libraries for C and C++, as well
79 as command-line utilities for managing PostgreSQL databases on a PostgreSQL
80 server.
81
82 If you want to manipulate a PostgreSQL database on a remote PostgreSQL server,
83 you need this package. You also need to install this package if you're
84 installing the postgresql-server package.
85
86 %package -n %{libname}
87 Summary: The shared libraries required for any PostgreSQL clients
88 Group: System/Libraries
89 Conflicts: postgresql-libs < %{version}-%{release}
90 Provides: postgresql-libs = %{version}-%{release}
91 Provides: libpq = %{version}-%{release}
92 Provides: %{libname}-virtual = %{current_major_version}
93 Conflicts: %{libname}-virtual < %{current_major_version}
94 # Avoid conflicts with lib having bad major
95 Conflicts: libpq3 = 8.0.2
96
97 %description -n %{libname}
98 C and C++ libraries to enable user programs to communicate with the PostgreSQL
99 database backend. The backend can be on another machine and accessed through
100 TCP/IP.
101
102 %package -n %{libecpg}
103 Summary: Shared library libecpg for PostgreSQL
104 Group: System/Libraries
105 Requires: postgresql%{current_major_version} = %{version}-%{release}
106 Provides: libecpg = %{version}-%{release}
107 Provides: %{libecpg}-virtual = %{current_major_version}
108 Conflicts: %{libecpg}-virtual < %{current_major_version}
109
110 %description -n %{libecpg}
111 Libecpg is used by programs built with ecpg (Embedded PostgreSQL for C) Use
112 postgresql-dev to develop such programs.
113
114 %package server
115 Summary: The programs needed to create and run a PostgreSQL server
116 Group: Databases
117 Provides: sqlserver
118 Requires(post): %{libname} >= %{version}-%{release}
119 Requires(preun): %{libname} >= %{version}-%{release}
120 # add/remove services
121 Requires(post): rpm-helper
122 Requires(preun): rpm-helper
123 # add/del user
124 Requires(pre): rpm-helper
125 Requires(postun): rpm-helper
126 Requires(pre): postgresql%{current_major_version} >= %{version}-%{release}
127 Requires(post): postgresql%{current_major_version} >= %{version}-%{release}
128 Conflicts: postgresql < 7.3
129 Provides: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
130 Provides: %{bname}-server-virtual = %{current_major_version}
131 Conflicts: %{bname}-server-virtual < %{current_major_version}
132 Provides: %{bname}-server = %{version}-%{release}
133 Conflicts: %{bname}8.3-test < %{version}-%{release}
134 Requires: postgresql-plpgsql = %{version}-%{release}
135
136 %description server
137 The postgresql-server package includes the programs needed to create and run a
138 PostgreSQL server, which will in turn allow you to create and maintain
139 PostgreSQL databases. PostgreSQL is an advanced Object-Relational database
140 management system (DBMS) that supports almost all SQL constructs (including
141 transactions, subselects and user-defined types and functions). You should
142 install postgresql-server if you want to create and maintain your own
143 PostgreSQL databases and/or your own PostgreSQL server. You also need to
144 install the postgresql and postgresql-devel packages.
145
146 After installing this package, please read postgresql.%{_vendor}.releasenote.
147
148 %package docs
149 Summary: Extra documentation for PostgreSQL
150 Group: Databases
151 BuildArch: noarch
152 Provides: %{bname}-docs-virtual = %{current_major_version}
153 Conflicts: %{bname}-docs-virtual < %{current_major_version}
154
155 %description docs
156 The postgresql-docs package includes the SGML source for the documentation as
157 well as the documentation in other formats, and some extra documentation.
158 Install this package if you want to help with the PostgreSQL documentation
159 project, or if you want to generate printed documentation.
160
161 %package contrib
162 Summary: Contributed binaries distributed with PostgreSQL
163 Group: Databases
164 Requires: postgresql%{current_major_version}-server = %{version}-%{release}
165 Provides: %{bname}-contrib-virtual = %{current_major_version}
166 Conflicts: %{bname}-contrib-virtual < %{current_major_version}
167
168 %description contrib
169 The postgresql-contrib package includes the contrib tree distributed with the
170 PostgreSQL tarball. Selected contrib modules are prebuilt.
171
172 %package devel
173 Summary: PostgreSQL development header files and libraries
174 Group: Development/Databases
175 Requires: postgresql%{current_major_version} = %{version}-%{release}
176 Provides: %{bname}-devel-virtual = %{current_major_version}
177 Conflicts: %{bname}-devel-virtual < %{current_major_version}
178 Requires: %{libname} = %{version}-%{release}
179 Provides: postgresql-libs-devel = %{version}-%{release}
180 Provides: pq-devel = %{version}-%{release}
181 # Avoid conflicts with lib having bad major
182 Conflicts: libpq3-devel = 8.0.2
183 %if %_lib != lib
184 Provides: libpq-devel = %{version}-%{release}
185 %endif
186 Provides: %{_lib}pq-devel = %{version}
187 Conflicts: %{_lib}pq-devel < %{version}
188 Requires: %{libecpg} = %{version}-%{release}
189 Provides: libecpg-devel = %{version}-%{release}
190 Provides: %{_lib}ecpg-devel = %{version}-%{release}
191 Conflicts: %{_lib}ecpg-devel < %{version}-%{release}
192 Conflicts: %mklibname -d ecpg 5
193 Conflicts: %mklibname -d pq 5
194 Conflicts: %mklibname -d pq8.3
195 Conflicts: %mklibname -d ecpg8.3
196 Conflicts: %mklibname -d pq8.4
197 Conflicts: %mklibname -d ecpg8.4
198 Provides: %{bname}-devel = %{version}-%{release}
199 Conflicts: %{bname}-devel < %{version}-%{release}
200
201 %description devel
202 The postgresql-devel package contains the header files and libraries needed to
203 compile C or C++ applications which will directly interact with a PostgreSQL
204 database management server and the ecpg Embedded C Postgres preprocessor. You
205 need to install this package if you want to develop applications which will
206 interact with a PostgreSQL server. If you're installing postgresql-server, you
207 need to install this package.
208
209 %package pl
210 Summary: Procedurals languages for PostgreSQL
211 Group: Databases
212 Conflicts: libpgsql2
213 Requires: %{name}-plpython = %{version}-%{release}
214 Requires: %{name}-plperl = %{version}-%{release}
215 Requires: %{name}-pltcl = %{version}-%{release}
216 Requires: %{name}-plpgsql = %{version}-%{release}
217 Provides: %{bname}-pl-virtual = %{current_major_version}
218 Conflicts: %{bname}-pl-virtual < %{current_major_version}
219 Conflicts: %{bname}-pl < %{version}-%{release}
220 Provides: %{bname}-pl = %{version}-%{release}
221
222 %description pl
223 PostgreSQL is an advanced Object-Relational database management system. The
224 postgresql-pl will install the the PL/Perl, PL/Tcl, and PL/Python procedural
225 languages for the backend. PL/Pgsql is part of the core server package.
226
227 %package plpython
228 Summary: The PL/Python procedural language for PostgreSQL
229 Group: Databases
230 Requires: postgresql%{current_major_version}-server = %{version}
231 Conflicts: postgresql-pl < %version-%release
232 Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
233 Provides: %{bname}-plpython-virtual = %{current_major_version}
234 Conflicts: %{bname}-plpython-virtual < %{current_major_version}
235 Conflicts: %{bname}-plpython < %{version}-%{release}
236 Provides: %{bname}-plpython = %{version}-%{release}
237
238 %description plpython
239 PostgreSQL is an advanced Object-Relational database management system. The
240 postgresql-plpython package contains the the PL/Python procedural languages for
241 the backend. PL/Python is part of the core server package.
242
243 %package plperl
244 Summary: The PL/Perl procedural language for PostgreSQL
245 Group: Databases
246 Requires: postgresql%{current_major_version}-server = %{version}
247 Requires: perl-base = %{perl_epoch}:%{perl_version}
248 Conflicts: postgresql-pl < %version-%release
249 Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
250 Provides: %{bname}-plperl-virtual = %{current_major_version}
251 Conflicts: %{bname}-plperl-virtual < %{current_major_version}
252 Conflicts: %{bname}-plperl < %{version}-%{release}
253 Provides: %{bname}-plperl = %{version}-%{release}
254
255 %description plperl
256 PostgreSQL is an advanced Object-Relational database management system. The
257 postgresql-plperl package contains the the PL/Perl procedural languages for the
258 backend. PL/Perl is part of the core server package.
259
260 %package pltcl
261 Summary: The PL/Tcl procedural language for PostgreSQL
262 Group: Databases
263 Requires: postgresql%{current_major_version}-server = %{version}
264 Conflicts: postgresql-pl < %version-%release
265 Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
266 Provides: %{bname}-pltcl-virtual = %{current_major_version}
267 Conflicts: %{bname}-pltcl-virtual < %{current_major_version}
268 Conflicts: %{bname}-pltcl < %{version}-%{release}
269 Provides: %{bname}-pltcl = %{version}-%{release}
270
271 %description pltcl
272 PostgreSQL is an advanced Object-Relational database management system. The
273 postgresql-pltcl package contains the the PL/Tcl procedural languages for the
274 backend. PL/Tcl is part of the core server package.
275
276 %package plpgsql
277 Summary: The PL/PgSQL procedural language for PostgreSQL
278 Group: Databases
279 Requires: postgresql%{current_major_version}-server = %{version}
280 Conflicts: postgresql-pl < %version-%release
281 Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
282 Provides: %{bname}-plpgsql-virtual = %{current_major_version}
283 Conflicts: %{bname}-plpgsql-virtual < %{current_major_version}
284 Conflicts: %{bname}-plpgsql < %{version}-%{release}
285 Provides: %{bname}-plpgsql = %{version}-%{release}
286
287 %description plpgsql
288 PostgreSQL is an advanced Object-Relational database management system. The
289 postgresql-plpgsql package contains the the PL/PgSQL procedural languages for
290 the backend. PL/PgSQL is part of the core server package.
291
292 %prep
293
294 %setup -q -n %{bname}-%{version}
295 cp src/Makefile.shlib src/Makefile.libpq.shlib
296 %patch0 -p1
297
298 %build
299
300 %serverbuild
301
302 %configure2_5x \
303 --disable-rpath \
304 --with-perl \
305 --with-python \
306 --with-tcl --with-tclconfig=%{_libdir} \
307 --with-openssl \
308 --with-pam \
309 --with-libxml \
310 --with-libxslt \
311 --libdir=%{_libdir} \
312 --mandir=%{_mandir} \
313 --prefix=%_prefix \
314 --sysconfdir=%{_sysconfdir}/pgsql \
315 --enable-nls \
316 %if %{withuuid}
317 --with-ossp-uuid
318 %endif
319
320 # $(rpathdir) come from Makefile
321 perl -pi -e 's|^all:|LINK.shared=\$(COMPILER) -shared -Wl,-rpath,\$(rpathdir),-soname,\$(soname)\nall:|' src/pl/plperl/GNUmakefile
322
323 %make world
324
325 pushd src/test
326 make all
327 popd
328
329 %check
330 make check
331
332 %install
333 make DESTDIR=%{buildroot} install-world install-docs
334
335 # install odbcinst.ini
336 mkdir -p %{buildroot}%{_sysconfdir}/pgsql
337
338 # copy over Makefile.global to the include dir....
339 #install -m755 src/Makefile.global %{buildroot}%{_includedir}/pgsql/
340
341 # PGDATA needs removal of group and world permissions due to pg_pwd hole.
342 install -d -m 700 %{buildroot}/var/lib/pgsql/data
343
344 # backups of data go here...
345 install -d -m 700 %{buildroot}/var/lib/pgsql/backups
346
347 # Create the multiple postmaster startup directory
348 install -d -m 700 %{buildroot}/etc/sysconfig/pgsql
349
350 # install systemd units
351 mkdir -p %{buildroot}%{_unitdir}
352 install -m 644 %{SOURCE11} %{buildroot}%{_unitdir}/%{bname}.service
353
354 # install helper script for env initialisation
355 mkdir -p %{buildroot}%{_libexecdir}
356 install -m 755 %{SOURCE14} %{buildroot}%{_libexecdir}/
357
358 mkdir -p %{buildroot}/var/log/postgres
359
360 mkdir -p %{buildroot}%{logrotatedir}
361 cat > %{buildroot}%{logrotatedir}/%{bname} <<EOF
362 /var/log/postgres/postgresql {
363 notifempty
364 missingok
365 copytruncate
366 }
367 EOF
368
369 mv %{buildroot}%{_docdir}/%{bname}/html %{buildroot}%{_docdir}/%{name}-docs-%{version}
370
371 echo -n '' > main.lst
372 for i in \
373 pg_ctl initdb pg_config psql pg_dump pgscripts libpq libecpg \
374 ecpg libpq%{major} ecpglib%{major_ecpg}; do
375 %find_lang $i-%{current_major_version}
376 cat $i-%{current_major_version}.lang >> main.lst
377 %find_lang $i
378 cat $i.lang >> main.lst
379 done
380 echo -n '' > server.lst
381 for i in postgres pg_resetxlog pg_controldata plpgsql plpython plperl pltcl pg_basebackup; do
382 %find_lang $i
383 cat $i.lang >> server.lst
384 %find_lang $i-%{current_major_version}
385 cat $i-%{current_major_version}.lang >> server.lst
386 done
387
388 # pg_ctl.lang initdb.lang pg_config.lang psql.lang pg_dump.lang pgscripts.lang \
389 # postgres.lang pg_resetxlog.lang pg_controldata.lang \
390 # libpq.lang libecpg.lang \
391
392 # taken directly in build dir.
393 rm -fr %{buildroot}%{_datadir}/doc/postgresql/contrib/
394 rm -fr %{buildroot}%{_datadir}/doc/postgresql/extension/
395
396 mkdir -p %{buildroot}/%{_sys_macros_dir}
397 cat > %{buildroot}/%{_sys_macros_dir}/%{name}.macros <<EOF
398 %%postgresql_version %{version}
399 %%postgresql_major %{current_major_version}
400 %%postgresql_minor %{current_minor_version}
401 %%pgmodules_req Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
402 EOF
403
404 cat %{SOURCE13} > postgresql.%{_vendor}.releasenote
405 cat > README.urpmi <<EOF
406 You just installed or updated %{bname} server.
407 You can find important information about %{distribution} %{bname} rpms and database
408 management in:
409
410 %{_defaultdocdir}/%{name}-server/postgresql.%{_vendor}.releasenote
411
412 Please read it.
413 EOF
414
415 # postgres' .profile and .bashrc
416 install -D -m 700 %{SOURCE10} %{buildroot}/var/lib/pgsql/.profile
417 (
418 cd %{buildroot}/var/lib/pgsql/
419 ln -s .profile .bashrc
420 )
421
422 cat > %{buildroot}%{_sysconfdir}/sysconfig/postgresql <<EOF
423 # Olivier Thauvin <nanardon@mandriva.org>
424
425 # The database location:
426 # You probably won't change this
427 # PGDATA=/var/lib/pgsql/data
428
429 # What is the based locales for postgresql
430 # Setting locales to C allow to use any encoding
431 # ISO or UTF, any other choice will restrict you
432 # either ISO or UTF.
433 LC_ALL=C
434
435 # These are additional to pass to pg_ctl when starting/restarting postgresql.
436 # PGOPTIONS=
437 EOF
438
439 %pre server
440 %_pre_useradd postgres /var/lib/pgsql /bin/bash
441
442 [ ! -f %{pgdata}/data/PG_VERSION ] && exit 0
443 mypgversion=`cat %{pgdata}/data/PG_VERSION`
444 [ $mypgversion = %{current_major_version} ] && exit 0
445
446 echo ""
447 echo "You currently have database tree for Postgresql $mypgversion"
448 echo "You must use postgresql${mypgversion}-server"
449 echo "To update you Postgresql server, dump your databases"
450 echo "delete /var/lib/pgsql/data/ content, upgrade the server, then"
451 echo "restore your databases from your backup"
452 echo ""
453
454 exit 1
455
456 %post server
457 %_post_service %{bname}
458
459 %preun server
460 %_preun_service %{bname}
461
462 %postun server
463 %_postun_userdel postgres
464
465 %files -f main.lst
466 %doc doc/KNOWN_BUGS doc/MISSING_FEATURES
467 %doc COPYRIGHT README HISTORY doc/bug.template
468 %{_bindir}/clusterdb
469 %{_bindir}/createdb
470 %{_bindir}/createlang
471 %{_bindir}/createuser
472 %{_bindir}/dropdb
473 %{_bindir}/droplang
474 %{_bindir}/dropuser
475 %{_bindir}/pg_dump
476 %{_bindir}/pg_dumpall
477 %{_bindir}/pg_restore
478 %{_bindir}/psql
479 %{_bindir}/reindexdb
480 %{_bindir}/vacuumdb
481 %{_mandir}/man1/clusterdb.*
482 %{_mandir}/man1/createdb.*
483 %{_mandir}/man1/createlang.*
484 %{_mandir}/man1/createuser.*
485 %{_mandir}/man1/dropdb.*
486 %{_mandir}/man1/droplang.*
487 %{_mandir}/man1/dropuser.*
488 %{_mandir}/man1/pg_dump.*
489 %{_mandir}/man1/pg_dumpall.*
490 %{_mandir}/man1/pg_restore.*
491 %{_mandir}/man1/psql.*
492 %{_mandir}/man1/vacuumdb.*
493 %{_mandir}/man1/reindexdb.*
494 %{_mandir}/man7/*
495 %{_sys_macros_dir}/%{name}.macros
496
497 %files -n %{libname}
498 %{_libdir}/libpq.so.%{major}*
499
500 %files -n %{libecpg}
501 %{_libdir}/libecpg.so.%{major_ecpg}*
502 %{_libdir}/libecpg_compat.so.*
503 %{_libdir}/libpgtypes.so.*
504
505 %files docs
506 %doc %{_docdir}/%{name}-docs-%{version}
507
508 %files contrib
509 # %doc contrib/*/README.* contrib/spi/*.example
510 %{_libdir}/postgresql/_int.so
511 %{_libdir}/postgresql/btree_gist.so
512 %{_libdir}/postgresql/chkpass.so
513 %{_libdir}/postgresql/cube.so
514 %{_libdir}/postgresql/dblink.so
515 %{_libdir}/postgresql/earthdistance.so
516 %{_libdir}/postgresql/fuzzystrmatch.so
517 %{_libdir}/postgresql/insert_username.so
518 %{_libdir}/postgresql/lo.so
519 %{_libdir}/postgresql/ltree.so
520 %{_libdir}/postgresql/moddatetime.so
521 %{_libdir}/postgresql/pgcrypto.so
522 %{_libdir}/postgresql/pgstattuple.so
523 %{_libdir}/postgresql/refint.so
524 %{_libdir}/postgresql/seg.so
525 %{_libdir}/postgresql/tablefunc.so
526 %{_libdir}/postgresql/timetravel.so
527 %{_libdir}/postgresql/pg_trgm.so
528 %{_libdir}/postgresql/autoinc.so
529 %{_libdir}/postgresql/pg_buffercache.so
530 %{_libdir}/postgresql/adminpack.so
531 %{_libdir}/postgresql/hstore.so
532 %{_libdir}/postgresql/isn.so
533 %{_libdir}/postgresql/pg_freespacemap.so
534 %{_libdir}/postgresql/pgrowlocks.so
535 %{_libdir}/postgresql/sslinfo.so
536 %{_libdir}/postgresql/pageinspect.so
537 %{_libdir}/postgresql/tcn.so
538
539 %{_bindir}/oid2name
540 %{_bindir}/pgbench
541 %{_bindir}/vacuumlo
542 %{_bindir}/pg_test_timing
543 %{_mandir}/man1/oid2name.1*
544 %{_mandir}/man1/pgbench.1*
545 %{_mandir}/man1/pg_test_timing.1*
546 %{_mandir}/man1/vacuumlo.1*
547
548 %files server -f server.lst
549 %config(noreplace) %{_sysconfdir}/sysconfig/postgresql
550 %doc README.urpmi postgresql.%{_vendor}.releasenote
551 %{_unitdir}/%{bname}.service
552 %{_bindir}/initdb
553 %{_bindir}/pg_controldata
554 %{_bindir}/pg_ctl
555 %{_bindir}/pg_resetxlog
556 %{_bindir}/postgres
557 %{_bindir}/postmaster
558 %{_bindir}/pg_standby
559 %{_bindir}/pg_archivecleanup
560 %{_bindir}/pg_upgrade
561 %{_bindir}/pg_basebackup
562 %{_bindir}/pg_receivexlog
563 %{_bindir}/pg_test_fsync
564 %{_mandir}/man1/initdb.1*
565 %{_mandir}/man1/pg_archivecleanup.1*
566 %{_mandir}/man1/pg_controldata.*
567 %{_mandir}/man1/pg_ctl.1*
568 %{_mandir}/man1/pg_receivexlog.1*
569 %{_mandir}/man1/pg_standby.1*
570 %{_mandir}/man1/pg_resetxlog.*
571 %{_mandir}/man1/postgres.1*
572 %{_mandir}/man1/postmaster.1*
573 %{_mandir}/man1/pg_basebackup.1*
574 %{_mandir}/man1/pg_test_fsync.1*
575 %{_mandir}/man1/pg_upgrade.1*
576 %dir %{_libdir}/postgresql
577 %dir %{_datadir}/postgresql
578 %attr(644,postgres,postgres) %config(noreplace) /var/lib/pgsql/.bashrc
579 %attr(-,postgres,postgres) /var/lib/pgsql/.profile
580 %attr(700,postgres,postgres) %dir %{pgdata}
581 %attr(-,postgres,postgres) %{pgdata}/data
582 %attr(700,postgres,postgres) %dir %{pgdata}/backups
583 %{_libdir}/postgresql/*_and_*.so
584 %{_libdir}/postgresql/pgxml.so
585 %{_libdir}/postgresql/dict_int.so
586 %{_libdir}/postgresql/dict_xsyn.so
587 %{_libdir}/postgresql/test_parser.so
588 %{_libdir}/postgresql/tsearch2.so
589 %{_libdir}/postgresql/dict_snowball.so
590 %{_libdir}/postgresql/auto_explain.so
591 %{_libdir}/postgresql/btree_gin.so
592 %{_libdir}/postgresql/citext.so
593 %{_libdir}/postgresql/pg_stat_statements.so
594 %{_libdir}/postgresql/auth_delay.so
595 %{_libdir}/postgresql/dummy_seclabel.so
596 %{_libdir}/postgresql/file_fdw.so
597 %{_libexecdir}/postgresql_initdb.sh
598 %if %{withuuid}
599 %{_libdir}/postgresql/uuid-ossp.so
600 %endif
601 %{_libdir}/postgresql/euc2004_sjis2004.so
602 %{_libdir}/postgresql/libpqwalreceiver.so
603 %{_libdir}/postgresql/passwordcheck.so
604 %{_libdir}/postgresql/pg_upgrade_support.so
605 %{_libdir}/postgresql/unaccent.so
606 %{_datadir}/postgresql/postgres.bki
607 %{_datadir}/postgresql/postgres.description
608 %{_datadir}/postgresql/*.sample
609 %{_datadir}/postgresql/timezone
610 %{_datadir}/postgresql/system_views.sql
611 %{_datadir}/postgresql/conversion_create.sql
612 %{_datadir}/postgresql/information_schema.sql
613 %{_datadir}/postgresql/snowball_create.sql
614 %{_datadir}/postgresql/sql_features.txt
615 %{_datadir}/postgresql/postgres.shdescription
616 %dir %{_datadir}/postgresql/timezonesets
617 %{_datadir}/postgresql/timezonesets/Africa.txt
618 %{_datadir}/postgresql/timezonesets/America.txt
619 %{_datadir}/postgresql/timezonesets/Antarctica.txt
620 %{_datadir}/postgresql/timezonesets/Asia.txt
621 %{_datadir}/postgresql/timezonesets/Atlantic.txt
622 %{_datadir}/postgresql/timezonesets/Australia
623 %{_datadir}/postgresql/timezonesets/Australia.txt
624 %{_datadir}/postgresql/timezonesets/Default
625 %{_datadir}/postgresql/timezonesets/Etc.txt
626 %{_datadir}/postgresql/timezonesets/Europe.txt
627 %{_datadir}/postgresql/timezonesets/India
628 %{_datadir}/postgresql/timezonesets/Indian.txt
629 %{_datadir}/postgresql/timezonesets/Pacific.txt
630 %{_datadir}/postgresql/tsearch_data
631 %{_datadir}/postgresql/extension
632
633 %attr(700,postgres,postgres) %dir /var/log/postgres
634 %{logrotatedir}/%{bname}
635
636 %files devel
637 # %doc doc/TODO doc/TODO.detail
638 %{_includedir}/*
639 %{_bindir}/ecpg
640 %{_libdir}/lib*.so
641 %{_libdir}/lib*.a
642 %{_libdir}/postgresql/pgxs/
643 %{_mandir}/man1/ecpg.1*
644 %{_bindir}/pg_config
645 %{_mandir}/man1/pg_config.1*
646 %{_mandir}/man3/SPI_*.3*
647 %{_mandir}/man3/dblink*.3*
648
649 %files pl
650
651 %files plpython
652 %{_libdir}/postgresql/plpython2.so
653
654 %files plperl
655 %{_libdir}/postgresql/plperl.so
656
657 %files pltcl
658 %{_libdir}/postgresql/pltcl.so
659 %{_bindir}/pltcl_delmod
660 %{_bindir}/pltcl_listmod
661 %{_bindir}/pltcl_loadmod
662 %{_datadir}/postgresql/unknown.pltcl
663
664 %files plpgsql
665 %{_libdir}/postgresql/plpgsql.so

  ViewVC Help
Powered by ViewVC 1.1.30