/[packages]/cauldron/postgresql9.3/current/SPECS/postgresql9.3.spec
ViewVC logotype

Annotation of /cauldron/postgresql9.3/current/SPECS/postgresql9.3.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 327996 - (hide annotations) (download)
Sat Dec 8 00:22:11 2012 UTC (11 years, 4 months ago) by fwang
Original Path: cauldron/postgresql9.2/current/SPECS/postgresql9.2.spec
File size: 22890 byte(s)
new version 9.2.2
1 fwang 298251 %define Werror_cflags %nil
2     %define _disable_ld_no_undefined 1
3    
4     %define perl_version %(rpm -q --qf "%{VERSION}" perl)
5     %define perl_epoch %(rpm -q --qf "%{EPOCH}" perl)
6    
7     %define pgdata /var/lib/pgsql
8     %define logrotatedir %{_sysconfdir}/logrotate.d
9    
10     %define major 5
11     %define major_ecpg 6
12    
13     %define bname postgresql
14     %define current_major_version 9.2
15 fwang 327996 %define current_minor_version 2
16 fwang 298251
17     # Define if it's a beta
18 fwang 304559 # define beta rc2
19 fwang 298251
20 fwang 327996 %define rel 1
21 fwang 298251
22     %define release %mkrel %{?beta:0.rc.%{beta}.}%{rel}
23    
24     %define libname %mklibname pq%{current_major_version} _%{major}
25     %define libecpg %mklibname ecpg%{current_major_version} _%{major_ecpg}
26    
27     # (blino) FIXME: enable back when ossp_uuid (and php) are available
28     %define withuuid 0
29     #define withuuid 1
30    
31     Summary: PostgreSQL client programs and libraries
32     Name: %{bname}%{current_major_version}
33     Version: %{current_major_version}%{?!beta:.%{current_minor_version}}
34     Release: %release
35     License: BSD
36     Group: Databases
37     URL: http://www.postgresql.org/
38     Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}%{?beta}.tar.bz2
39     Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}%{?beta}.tar.bz2.md5
40     Source10: postgres.profile
41 fwang 298258 Source11: postgresql.service
42 fwang 298251 Source13: postgresql.distro.releasenote
43    
44     Requires: perl
45     Provides: postgresql-clients = %{version}-%{release}
46     Conflicts: postgresql-clients < %{version}-%{release}
47     BuildRequires: bison flex
48     BuildRequires: openssl-devel
49     BuildRequires: pam-devel
50     BuildRequires: perl-devel
51     BuildRequires: python-devel
52     BuildRequires: readline-devel
53     BuildRequires: tcl-devel
54     BuildRequires: libxml2-devel
55     BuildRequires: libxslt-devel
56     BuildRequires: zlib-devel
57     %if %withuuid
58     BuildRequires: ossp_uuid-devel
59     %endif
60     # Need to build doc
61     BuildRequires: docbook-dtd42-sgml openjade docbook-utils docbook-style-xsl xsltproc
62     Provides: %{bname}-virtual = %{current_major_version}
63     Conflicts: %{bname}-virtual < %{current_major_version}
64     Provides: %{bname} = %{version}-%{release}
65     Conflicts: %{bname} < %{version}-%{release}
66    
67     %description
68     PostgreSQL is an advanced Object-Relational database management system (DBMS)
69     that supports almost all SQL constructs (including transactions, subselects and
70     user-defined types and functions). The postgresql package includes the client
71     programs and libraries that you'll need to access a PostgreSQL DBMS server.
72     These PostgreSQL client programs are programs that directly manipulate the
73     internal structure of PostgreSQL databases on a PostgreSQL server. These client
74     programs can be located on the same machine with the PostgreSQL server, or may
75     be on a remote machine which accesses a PostgreSQL server over a network
76     connection. This package contains the client libraries for C and C++, as well
77     as command-line utilities for managing PostgreSQL databases on a PostgreSQL
78     server.
79    
80     If you want to manipulate a PostgreSQL database on a remote PostgreSQL server,
81     you need this package. You also need to install this package if you're
82     installing the postgresql-server package.
83    
84     %package -n %{libname}
85     Summary: The shared libraries required for any PostgreSQL clients
86     Group: System/Libraries
87     Conflicts: postgresql-libs < %{version}-%{release}
88     Provides: postgresql-libs = %{version}-%{release}
89     Provides: libpq = %{version}-%{release}
90     Provides: %{libname}-virtual = %{current_major_version}
91     Conflicts: %{libname}-virtual < %{current_major_version}
92     # Avoid conflicts with lib having bad major
93     Conflicts: libpq3 = 8.0.2
94    
95     %description -n %{libname}
96     C and C++ libraries to enable user programs to communicate with the PostgreSQL
97     database backend. The backend can be on another machine and accessed through
98     TCP/IP.
99    
100     %package -n %{libecpg}
101     Summary: Shared library libecpg for PostgreSQL
102     Group: System/Libraries
103     Requires: postgresql%{current_major_version} = %{version}-%{release}
104     Provides: libecpg = %{version}-%{release}
105     Provides: %{libecpg}-virtual = %{current_major_version}
106     Conflicts: %{libecpg}-virtual < %{current_major_version}
107    
108     %description -n %{libecpg}
109     Libecpg is used by programs built with ecpg (Embedded PostgreSQL for C) Use
110     postgresql-dev to develop such programs.
111    
112     %package server
113     Summary: The programs needed to create and run a PostgreSQL server
114     Group: Databases
115     Provides: sqlserver
116     Requires(post): %{libname} >= %{version}-%{release}
117     Requires(preun): %{libname} >= %{version}-%{release}
118     # add/remove services
119     Requires(post): rpm-helper
120     Requires(preun): rpm-helper
121     # add/del user
122     Requires(pre): rpm-helper
123     Requires(postun): rpm-helper
124     Requires(pre): postgresql%{current_major_version} >= %{version}-%{release}
125     Requires(post): postgresql%{current_major_version} >= %{version}-%{release}
126     Conflicts: postgresql < 7.3
127     Provides: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
128     Provides: %{bname}-server-virtual = %{current_major_version}
129     Conflicts: %{bname}-server-virtual < %{current_major_version}
130     Provides: %{bname}-server = %{version}-%{release}
131     Conflicts: %{bname}8.3-test < %{version}-%{release}
132     Requires: postgresql-plpgsql = %{version}-%{release}
133    
134     %description server
135     The postgresql-server package includes the programs needed to create and run a
136     PostgreSQL server, which will in turn allow you to create and maintain
137     PostgreSQL databases. PostgreSQL is an advanced Object-Relational database
138     management system (DBMS) that supports almost all SQL constructs (including
139     transactions, subselects and user-defined types and functions). You should
140     install postgresql-server if you want to create and maintain your own
141     PostgreSQL databases and/or your own PostgreSQL server. You also need to
142     install the postgresql and postgresql-devel packages.
143    
144     After installing this package, please read postgresql.%{_vendor}.releasenote.
145    
146     %package docs
147     Summary: Extra documentation for PostgreSQL
148     Group: Databases
149 fwang 298885 BuildArch: noarch
150 fwang 298251 Provides: %{bname}-docs-virtual = %{current_major_version}
151     Conflicts: %{bname}-docs-virtual < %{current_major_version}
152    
153     %description docs
154     The postgresql-docs package includes the SGML source for the documentation as
155     well as the documentation in other formats, and some extra documentation.
156     Install this package if you want to help with the PostgreSQL documentation
157     project, or if you want to generate printed documentation.
158    
159     %package contrib
160     Summary: Contributed binaries distributed with PostgreSQL
161     Group: Databases
162     Requires: postgresql%{current_major_version}-server = %{version}-%{release}
163     Provides: %{bname}-contrib-virtual = %{current_major_version}
164     Conflicts: %{bname}-contrib-virtual < %{current_major_version}
165    
166     %description contrib
167     The postgresql-contrib package includes the contrib tree distributed with the
168     PostgreSQL tarball. Selected contrib modules are prebuilt.
169    
170     %package devel
171     Summary: PostgreSQL development header files and libraries
172     Group: Development/Databases
173     Requires: postgresql%{current_major_version} = %{version}-%{release}
174     Provides: %{bname}-devel-virtual = %{current_major_version}
175     Conflicts: %{bname}-devel-virtual < %{current_major_version}
176     Requires: %{libname} = %{version}-%{release}
177     Provides: postgresql-libs-devel = %{version}-%{release}
178     Provides: pq-devel = %{version}-%{release}
179     # Avoid conflicts with lib having bad major
180     Conflicts: libpq3-devel = 8.0.2
181     %if %_lib != lib
182     Provides: libpq-devel = %{version}-%{release}
183     %endif
184     Provides: %{_lib}pq-devel = %{version}
185     Conflicts: %{_lib}pq-devel < %{version}
186     Requires: %{libecpg} = %{version}-%{release}
187     Provides: libecpg-devel = %{version}-%{release}
188     Provides: %{_lib}ecpg-devel = %{version}-%{release}
189     Conflicts: %{_lib}ecpg-devel < %{version}-%{release}
190     Conflicts: %mklibname -d ecpg 5
191     Conflicts: %mklibname -d pq 5
192     Conflicts: %mklibname -d pq8.3
193     Conflicts: %mklibname -d ecpg8.3
194     Conflicts: %mklibname -d pq8.4
195     Conflicts: %mklibname -d ecpg8.4
196     Provides: %{bname}-devel = %{version}-%{release}
197     Conflicts: %{bname}-devel < %{version}-%{release}
198    
199     %description devel
200     The postgresql-devel package contains the header files and libraries needed to
201     compile C or C++ applications which will directly interact with a PostgreSQL
202     database management server and the ecpg Embedded C Postgres preprocessor. You
203     need to install this package if you want to develop applications which will
204     interact with a PostgreSQL server. If you're installing postgresql-server, you
205     need to install this package.
206    
207     %package pl
208     Summary: Procedurals languages for PostgreSQL
209     Group: Databases
210     Conflicts: libpgsql2
211     Requires: %{name}-plpython = %{version}-%{release}
212     Requires: %{name}-plperl = %{version}-%{release}
213     Requires: %{name}-pltcl = %{version}-%{release}
214     Requires: %{name}-plpgsql = %{version}-%{release}
215     Provides: %{bname}-pl-virtual = %{current_major_version}
216     Conflicts: %{bname}-pl-virtual < %{current_major_version}
217     Conflicts: %{bname}-pl < %{version}-%{release}
218     Provides: %{bname}-pl = %{version}-%{release}
219    
220     %description pl
221     PostgreSQL is an advanced Object-Relational database management system. The
222     postgresql-pl will install the the PL/Perl, PL/Tcl, and PL/Python procedural
223     languages for the backend. PL/Pgsql is part of the core server package.
224    
225     %package plpython
226     Summary: The PL/Python procedural language for PostgreSQL
227     Group: Databases
228     Requires: postgresql%{current_major_version}-server = %{version}
229     Conflicts: postgresql-pl < %version-%release
230     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
231     Provides: %{bname}-plpython-virtual = %{current_major_version}
232     Conflicts: %{bname}-plpython-virtual < %{current_major_version}
233     Conflicts: %{bname}-plpython < %{version}-%{release}
234     Provides: %{bname}-plpython = %{version}-%{release}
235    
236     %description plpython
237     PostgreSQL is an advanced Object-Relational database management system. The
238     postgresql-plpython package contains the the PL/Python procedural languages for
239     the backend. PL/Python is part of the core server package.
240    
241     %package plperl
242     Summary: The PL/Perl procedural language for PostgreSQL
243     Group: Databases
244     Requires: postgresql%{current_major_version}-server = %{version}
245     Requires: perl-base = %{perl_epoch}:%{perl_version}
246     Conflicts: postgresql-pl < %version-%release
247     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
248     Provides: %{bname}-plperl-virtual = %{current_major_version}
249     Conflicts: %{bname}-plperl-virtual < %{current_major_version}
250     Conflicts: %{bname}-plperl < %{version}-%{release}
251     Provides: %{bname}-plperl = %{version}-%{release}
252    
253     %description plperl
254     PostgreSQL is an advanced Object-Relational database management system. The
255     postgresql-plperl package contains the the PL/Perl procedural languages for the
256     backend. PL/Perl is part of the core server package.
257    
258     %package pltcl
259     Summary: The PL/Tcl procedural language for PostgreSQL
260     Group: Databases
261     Requires: postgresql%{current_major_version}-server = %{version}
262     Conflicts: postgresql-pl < %version-%release
263     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
264     Provides: %{bname}-pltcl-virtual = %{current_major_version}
265     Conflicts: %{bname}-pltcl-virtual < %{current_major_version}
266     Conflicts: %{bname}-pltcl < %{version}-%{release}
267     Provides: %{bname}-pltcl = %{version}-%{release}
268    
269     %description pltcl
270     PostgreSQL is an advanced Object-Relational database management system. The
271     postgresql-pltcl package contains the the PL/Tcl procedural languages for the
272     backend. PL/Tcl is part of the core server package.
273    
274     %package plpgsql
275     Summary: The PL/PgSQL procedural language for PostgreSQL
276     Group: Databases
277     Requires: postgresql%{current_major_version}-server = %{version}
278     Conflicts: postgresql-pl < %version-%release
279     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
280     Provides: %{bname}-plpgsql-virtual = %{current_major_version}
281     Conflicts: %{bname}-plpgsql-virtual < %{current_major_version}
282     Conflicts: %{bname}-plpgsql < %{version}-%{release}
283     Provides: %{bname}-plpgsql = %{version}-%{release}
284    
285     %description plpgsql
286     PostgreSQL is an advanced Object-Relational database management system. The
287     postgresql-plpgsql package contains the the PL/PgSQL procedural languages for
288     the backend. PL/PgSQL is part of the core server package.
289    
290     %prep
291    
292     %setup -q -n %{bname}-%{version}%{?beta}
293    
294     %build
295    
296     %serverbuild
297    
298 fwang 298259 %configure2_5x \
299 fwang 298251 --disable-rpath \
300     --with-perl \
301     --with-python \
302     --with-tcl --with-tclconfig=%{_libdir} \
303     --with-openssl \
304     --with-pam \
305     --with-libxml \
306     --with-libxslt \
307     --libdir=%{_libdir} \
308     --mandir=%{_mandir} \
309     --prefix=%_prefix \
310     --sysconfdir=%{_sysconfdir}/pgsql \
311     --enable-nls \
312     %if %withuuid
313     --with-ossp-uuid
314     %endif
315    
316     # $(rpathdir) come from Makefile
317     perl -pi -e 's|^all:|LINK.shared=\$(COMPILER) -shared -Wl,-rpath,\$(rpathdir),-soname,\$(soname)\nall:|' src/pl/plperl/GNUmakefile
318    
319     %make world
320    
321     pushd src/test
322     make all
323     popd
324    
325     %check
326     make check
327    
328     %install
329     make DESTDIR=%{buildroot} install-world install-docs
330    
331     # install odbcinst.ini
332     mkdir -p %{buildroot}%{_sysconfdir}/pgsql
333    
334     # copy over Makefile.global to the include dir....
335     #install -m755 src/Makefile.global %{buildroot}%{_includedir}/pgsql/
336    
337     # PGDATA needs removal of group and world permissions due to pg_pwd hole.
338     install -d -m 700 %{buildroot}/var/lib/pgsql/data
339    
340     # backups of data go here...
341     install -d -m 700 %{buildroot}/var/lib/pgsql/backups
342    
343     # Create the multiple postmaster startup directory
344     install -d -m 700 %{buildroot}/etc/sysconfig/pgsql
345    
346 fwang 298258 # install systemd units
347     mkdir -p %{buildroot}%{_unitdir}
348     install -m 644 %{SOURCE11} %{buildroot}%{_unitdir}/%{bname}.service
349 fwang 298251
350     mkdir -p %buildroot/var/log/postgres
351    
352     mkdir -p %buildroot%logrotatedir
353     cat > %buildroot%logrotatedir/%{bname} <<EOF
354     /var/log/postgres/postgresql {
355     notifempty
356     missingok
357     copytruncate
358     }
359     EOF
360    
361     mv %{buildroot}%{_docdir}/%{bname}/html %{buildroot}%{_docdir}/%{name}-docs-%{version}
362    
363     echo -n '' > main.lst
364     for i in \
365     pg_ctl initdb pg_config psql pg_dump pgscripts libpq libecpg \
366     ecpg libpq%{major} ecpglib%{major_ecpg}; do
367     %find_lang $i-%{current_major_version}
368     cat $i-%{current_major_version}.lang >> main.lst
369     %find_lang $i
370     cat $i.lang >> main.lst
371     done
372     echo -n '' > server.lst
373     for i in postgres pg_resetxlog pg_controldata plpgsql plpython plperl pltcl pg_basebackup; do
374     %find_lang $i
375     cat $i.lang >> server.lst
376     %find_lang $i-%{current_major_version}
377     cat $i-%{current_major_version}.lang >> server.lst
378     done
379    
380     # pg_ctl.lang initdb.lang pg_config.lang psql.lang pg_dump.lang pgscripts.lang \
381     # postgres.lang pg_resetxlog.lang pg_controldata.lang \
382     # libpq.lang libecpg.lang \
383    
384     # taken directly in build dir.
385     rm -fr %{buildroot}%{_datadir}/doc/postgresql/contrib/
386     rm -fr %{buildroot}%{_datadir}/doc/postgresql/extension/
387    
388     mkdir -p %buildroot/%_sys_macros_dir
389     cat > %buildroot/%_sys_macros_dir/%{name}.macros <<EOF
390     %%postgresql_version %{version}
391     %%postgresql_major %{current_major_version}
392     %%postgresql_minor %{current_minor_version}
393     %%pgmodules_req Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
394     EOF
395    
396     cat %{SOURCE13} > postgresql.%{_vendor}.releasenote
397     cat > README.urpmi <<EOF
398     You just installed or updated %{bname} server.
399     You can find important information about %{distribution} %{bname} rpms and database
400     management in:
401    
402     %{_defaultdocdir}/%{name}-server/postgresql.%{_vendor}.releasenote
403    
404     Please read it.
405     EOF
406    
407     # postgres' .profile and .bashrc
408     install -D -m 700 %SOURCE10 %{buildroot}/var/lib/pgsql/.profile
409     (
410     cd %{buildroot}/var/lib/pgsql/
411     ln -s .profile .bashrc
412     )
413    
414     cat > %buildroot%_sysconfdir/sysconfig/postgresql <<EOF
415     # Olivier Thauvin <nanardon@mandriva.org>
416    
417     # The database location:
418     # You probably won't change this
419     # PGDATA=/var/lib/pgsql/data
420    
421     # What is the based locales for postgresql
422     # Setting locales to C allow to use any encoding
423     # ISO or UTF, any other choice will restrict you
424     # either ISO or UTF.
425     LC_ALL=C
426    
427     # These are additional to pass to pg_ctl when starting/restarting postgresql.
428     # PGOPTIONS=
429     EOF
430    
431     %pre server
432     %_pre_useradd postgres /var/lib/pgsql /bin/bash
433    
434     [ ! -f %pgdata/data/PG_VERSION ] && exit 0
435     mypgversion=`cat %pgdata/data/PG_VERSION`
436     [ $mypgversion = %{current_major_version} ] && exit 0
437    
438     echo ""
439     echo "You currently have database tree for Postgresql $mypgversion"
440     echo "You must use postgresql${mypgversion}-server"
441     echo "To update you Postgresql server, dump your databases"
442     echo "delete /var/lib/pgsql/data/ content, upgrade the server, then"
443     echo "restore your databases from your backup"
444     echo ""
445    
446     exit 1
447    
448     %posttrans server
449     %_post_service %{bname}
450    
451     %preun server
452     %_preun_service %{bname}
453    
454     %postun server
455     %_postun_userdel postgres
456    
457     %files -f main.lst
458     %defattr(-,root,root)
459     %doc doc/KNOWN_BUGS doc/MISSING_FEATURES
460     %doc COPYRIGHT README HISTORY doc/bug.template
461     %{_bindir}/clusterdb
462     %{_bindir}/createdb
463     %{_bindir}/createlang
464     %{_bindir}/createuser
465     %{_bindir}/dropdb
466     %{_bindir}/droplang
467     %{_bindir}/dropuser
468     %{_bindir}/pg_dump
469     %{_bindir}/pg_dumpall
470     %{_bindir}/pg_restore
471     %{_bindir}/psql
472     %{_bindir}/reindexdb
473     %{_bindir}/vacuumdb
474     %{_mandir}/man1/clusterdb.*
475     %{_mandir}/man1/createdb.*
476     %{_mandir}/man1/createlang.*
477     %{_mandir}/man1/createuser.*
478     %{_mandir}/man1/dropdb.*
479     %{_mandir}/man1/droplang.*
480     %{_mandir}/man1/dropuser.*
481     %{_mandir}/man1/pg_dump.*
482     %{_mandir}/man1/pg_dumpall.*
483     %{_mandir}/man1/pg_restore.*
484     %{_mandir}/man1/psql.*
485     %{_mandir}/man1/vacuumdb.*
486     %{_mandir}/man1/reindexdb.*
487     %{_mandir}/man7/*
488     %_sys_macros_dir/%{name}.macros
489    
490     %files -n %{libname}
491     %defattr(-,root,root)
492     %{_libdir}/libpq.so.%{major}*
493    
494     %files -n %{libecpg}
495     %defattr(-,root,root)
496     %{_libdir}/libecpg.so.%{major_ecpg}*
497     %{_libdir}/libecpg_compat.so.*
498     %{_libdir}/libpgtypes.so.*
499    
500     %files docs
501     %defattr(-,root,root)
502     %doc %{_docdir}/%{name}-docs-%{version}
503    
504     %files contrib
505     %defattr(-,root,root)
506     # %doc contrib/*/README.* contrib/spi/*.example
507     %{_libdir}/postgresql/_int.so
508     %{_libdir}/postgresql/btree_gist.so
509     %{_libdir}/postgresql/chkpass.so
510     %{_libdir}/postgresql/cube.so
511     %{_libdir}/postgresql/dblink.so
512     %{_libdir}/postgresql/earthdistance.so
513     %{_libdir}/postgresql/fuzzystrmatch.so
514     %{_libdir}/postgresql/insert_username.so
515     %{_libdir}/postgresql/lo.so
516     %{_libdir}/postgresql/ltree.so
517     %{_libdir}/postgresql/moddatetime.so
518     %{_libdir}/postgresql/pgcrypto.so
519     %{_libdir}/postgresql/pgstattuple.so
520     %{_libdir}/postgresql/refint.so
521     %{_libdir}/postgresql/seg.so
522     %{_libdir}/postgresql/tablefunc.so
523     %{_libdir}/postgresql/timetravel.so
524     %{_libdir}/postgresql/pg_trgm.so
525     %{_libdir}/postgresql/autoinc.so
526     %{_libdir}/postgresql/pg_buffercache.so
527     %{_libdir}/postgresql/adminpack.so
528     %{_libdir}/postgresql/hstore.so
529     %{_libdir}/postgresql/isn.so
530     %{_libdir}/postgresql/pg_freespacemap.so
531     %{_libdir}/postgresql/pgrowlocks.so
532     %{_libdir}/postgresql/sslinfo.so
533     %{_libdir}/postgresql/pageinspect.so
534 fwang 298259 %{_libdir}/postgresql/tcn.so
535 fwang 298251
536     %{_bindir}/oid2name
537     %{_bindir}/pgbench
538     %{_bindir}/vacuumlo
539 fwang 298259 %{_bindir}/pg_test_timing
540     %{_mandir}/man1/oid2name.1*
541     %{_mandir}/man1/pgbench.1*
542     %{_mandir}/man1/pg_test_timing.1*
543     %{_mandir}/man1/vacuumlo.1*
544 fwang 298251
545     %files server -f server.lst
546     %defattr(-,root,root)
547     %config(noreplace) %{_sysconfdir}/sysconfig/postgresql
548     %doc README.urpmi postgresql.%{_vendor}.releasenote
549 fwang 298258 %{_unitdir}/%{bname}.service
550 fwang 298251 %{_bindir}/initdb
551     %{_bindir}/pg_controldata
552     %{_bindir}/pg_ctl
553     %{_bindir}/pg_resetxlog
554     %{_bindir}/postgres
555     %{_bindir}/postmaster
556     %{_bindir}/pg_standby
557     %{_bindir}/pg_archivecleanup
558     %{_bindir}/pg_upgrade
559     %{_bindir}/pg_basebackup
560 fwang 298259 %{_bindir}/pg_receivexlog
561 fwang 298251 %{_bindir}/pg_test_fsync
562     %{_mandir}/man1/initdb.1*
563 fwang 298259 %{_mandir}/man1/pg_archivecleanup.1*
564 fwang 298251 %{_mandir}/man1/pg_controldata.*
565     %{_mandir}/man1/pg_ctl.1*
566 fwang 298259 %{_mandir}/man1/pg_receivexlog.1*
567     %{_mandir}/man1/pg_standby.1*
568 fwang 298251 %{_mandir}/man1/pg_resetxlog.*
569     %{_mandir}/man1/postgres.1*
570     %{_mandir}/man1/postmaster.1*
571     %{_mandir}/man1/pg_basebackup.1*
572 fwang 298259 %{_mandir}/man1/pg_test_fsync.1*
573     %{_mandir}/man1/pg_upgrade.1*
574 fwang 298251 %dir %{_libdir}/postgresql
575     %dir %{_datadir}/postgresql
576     %attr(644,postgres,postgres) %config(noreplace) /var/lib/pgsql/.bashrc
577     %attr(-,postgres,postgres) /var/lib/pgsql/.profile
578     %attr(700,postgres,postgres) %dir %{pgdata}
579     %attr(-,postgres,postgres) %{pgdata}/data
580     %attr(700,postgres,postgres) %dir %{pgdata}/backups
581     %{_libdir}/postgresql/*_and_*.so
582     %{_libdir}/postgresql/pgxml.so
583     %{_libdir}/postgresql/dict_int.so
584     %{_libdir}/postgresql/dict_xsyn.so
585     %{_libdir}/postgresql/test_parser.so
586     %{_libdir}/postgresql/tsearch2.so
587     %{_libdir}/postgresql/dict_snowball.so
588     %{_libdir}/postgresql/auto_explain.so
589     %{_libdir}/postgresql/btree_gin.so
590     %{_libdir}/postgresql/citext.so
591     %{_libdir}/postgresql/pg_stat_statements.so
592     %{_libdir}/postgresql/auth_delay.so
593     %{_libdir}/postgresql/dummy_seclabel.so
594     %{_libdir}/postgresql/file_fdw.so
595     %if %withuuid
596     %{_libdir}/postgresql/uuid-ossp.so
597     %endif
598     %{_libdir}/postgresql/euc2004_sjis2004.so
599     %{_libdir}/postgresql/libpqwalreceiver.so
600     %{_libdir}/postgresql/passwordcheck.so
601     %{_libdir}/postgresql/pg_upgrade_support.so
602     %{_libdir}/postgresql/unaccent.so
603     %{_datadir}/postgresql/postgres.bki
604     %{_datadir}/postgresql/postgres.description
605     %{_datadir}/postgresql/*.sample
606     %{_datadir}/postgresql/timezone
607     %{_datadir}/postgresql/system_views.sql
608     %{_datadir}/postgresql/conversion_create.sql
609     %{_datadir}/postgresql/information_schema.sql
610     %{_datadir}/postgresql/snowball_create.sql
611     %{_datadir}/postgresql/sql_features.txt
612     %{_datadir}/postgresql/postgres.shdescription
613     %dir %{_datadir}/postgresql/timezonesets
614     %{_datadir}/postgresql/timezonesets/Africa.txt
615     %{_datadir}/postgresql/timezonesets/America.txt
616     %{_datadir}/postgresql/timezonesets/Antarctica.txt
617     %{_datadir}/postgresql/timezonesets/Asia.txt
618     %{_datadir}/postgresql/timezonesets/Atlantic.txt
619     %{_datadir}/postgresql/timezonesets/Australia
620     %{_datadir}/postgresql/timezonesets/Australia.txt
621     %{_datadir}/postgresql/timezonesets/Default
622     %{_datadir}/postgresql/timezonesets/Etc.txt
623     %{_datadir}/postgresql/timezonesets/Europe.txt
624     %{_datadir}/postgresql/timezonesets/India
625     %{_datadir}/postgresql/timezonesets/Indian.txt
626     %{_datadir}/postgresql/timezonesets/Pacific.txt
627     %{_datadir}/postgresql/tsearch_data
628     %{_datadir}/postgresql/extension
629    
630     %attr(700,postgres,postgres) %dir /var/log/postgres
631     %logrotatedir/%{bname}
632    
633     %files devel
634     %defattr(-,root,root)
635     # %doc doc/TODO doc/TODO.detail
636     %{_includedir}/*
637     %{_bindir}/ecpg
638     %{_libdir}/lib*.so
639 fwang 298885 %{_libdir}/lib*.a
640 fwang 298251 %{_libdir}/postgresql/pgxs/
641     %{_mandir}/man1/ecpg.1*
642     %{_bindir}/pg_config
643     %{_mandir}/man1/pg_config.1*
644     %{_mandir}/man3/SPI_*.3*
645     %{_mandir}/man3/dblink*.3*
646    
647     %files pl
648     %defattr(-,root,root)
649    
650     %files plpython
651     %defattr(-,root,root)
652     %{_libdir}/postgresql/plpython2.so
653    
654     %files plperl
655     %defattr(-,root,root)
656     %{_libdir}/postgresql/plperl.so
657    
658     %files pltcl
659     %defattr(-,root,root)
660     %{_libdir}/postgresql/pltcl.so
661     %{_bindir}/pltcl_delmod
662     %{_bindir}/pltcl_listmod
663     %{_bindir}/pltcl_loadmod
664     %{_datadir}/postgresql/unknown.pltcl
665    
666     %files plpgsql
667     %defattr(-,root,root)
668     %{_libdir}/postgresql/plpgsql.so
669    

  ViewVC Help
Powered by ViewVC 1.1.30