/[packages]/cauldron/postgresql9.3/current/SPECS/postgresql9.3.spec
ViewVC logotype

Annotation of /cauldron/postgresql9.3/current/SPECS/postgresql9.3.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 378121 - (hide annotations) (download)
Sun Jan 13 19:32:10 2013 UTC (11 years, 3 months ago) by umeabot
Original Path: cauldron/postgresql9.2/current/SPECS/postgresql9.2.spec
File size: 23064 byte(s)
Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
1 fwang 298251 %define Werror_cflags %nil
2     %define _disable_ld_no_undefined 1
3    
4     %define perl_version %(rpm -q --qf "%{VERSION}" perl)
5     %define perl_epoch %(rpm -q --qf "%{EPOCH}" perl)
6    
7     %define pgdata /var/lib/pgsql
8     %define logrotatedir %{_sysconfdir}/logrotate.d
9    
10     %define major 5
11     %define major_ecpg 6
12    
13     %define bname postgresql
14     %define current_major_version 9.2
15 fwang 327996 %define current_minor_version 2
16 fwang 298251
17     # Define if it's a beta
18 fwang 304559 # define beta rc2
19 fwang 298251
20 umeabot 378121 %define rel 3
21 fwang 298251
22     %define release %mkrel %{?beta:0.rc.%{beta}.}%{rel}
23    
24     %define libname %mklibname pq%{current_major_version} _%{major}
25     %define libecpg %mklibname ecpg%{current_major_version} _%{major_ecpg}
26    
27     # (blino) FIXME: enable back when ossp_uuid (and php) are available
28     %define withuuid 0
29     #define withuuid 1
30    
31     Summary: PostgreSQL client programs and libraries
32     Name: %{bname}%{current_major_version}
33     Version: %{current_major_version}%{?!beta:.%{current_minor_version}}
34     Release: %release
35     License: BSD
36     Group: Databases
37     URL: http://www.postgresql.org/
38     Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}%{?beta}.tar.bz2
39     Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}%{?beta}.tar.bz2.md5
40     Source10: postgres.profile
41 fwang 298258 Source11: postgresql.service
42 fwang 298251 Source13: postgresql.distro.releasenote
43 neoclust 344748 Source14: postgresql_initdb.sh
44 fwang 298251
45     Requires: perl
46     Provides: postgresql-clients = %{version}-%{release}
47     Conflicts: postgresql-clients < %{version}-%{release}
48     BuildRequires: bison flex
49     BuildRequires: openssl-devel
50     BuildRequires: pam-devel
51     BuildRequires: perl-devel
52     BuildRequires: python-devel
53     BuildRequires: readline-devel
54     BuildRequires: tcl-devel
55     BuildRequires: libxml2-devel
56     BuildRequires: libxslt-devel
57     BuildRequires: zlib-devel
58     %if %withuuid
59     BuildRequires: ossp_uuid-devel
60     %endif
61     # Need to build doc
62     BuildRequires: docbook-dtd42-sgml openjade docbook-utils docbook-style-xsl xsltproc
63     Provides: %{bname}-virtual = %{current_major_version}
64     Conflicts: %{bname}-virtual < %{current_major_version}
65     Provides: %{bname} = %{version}-%{release}
66     Conflicts: %{bname} < %{version}-%{release}
67    
68     %description
69     PostgreSQL is an advanced Object-Relational database management system (DBMS)
70     that supports almost all SQL constructs (including transactions, subselects and
71     user-defined types and functions). The postgresql package includes the client
72     programs and libraries that you'll need to access a PostgreSQL DBMS server.
73     These PostgreSQL client programs are programs that directly manipulate the
74     internal structure of PostgreSQL databases on a PostgreSQL server. These client
75     programs can be located on the same machine with the PostgreSQL server, or may
76     be on a remote machine which accesses a PostgreSQL server over a network
77     connection. This package contains the client libraries for C and C++, as well
78     as command-line utilities for managing PostgreSQL databases on a PostgreSQL
79     server.
80    
81     If you want to manipulate a PostgreSQL database on a remote PostgreSQL server,
82     you need this package. You also need to install this package if you're
83     installing the postgresql-server package.
84    
85     %package -n %{libname}
86     Summary: The shared libraries required for any PostgreSQL clients
87     Group: System/Libraries
88     Conflicts: postgresql-libs < %{version}-%{release}
89     Provides: postgresql-libs = %{version}-%{release}
90     Provides: libpq = %{version}-%{release}
91     Provides: %{libname}-virtual = %{current_major_version}
92     Conflicts: %{libname}-virtual < %{current_major_version}
93     # Avoid conflicts with lib having bad major
94     Conflicts: libpq3 = 8.0.2
95    
96     %description -n %{libname}
97     C and C++ libraries to enable user programs to communicate with the PostgreSQL
98     database backend. The backend can be on another machine and accessed through
99     TCP/IP.
100    
101     %package -n %{libecpg}
102     Summary: Shared library libecpg for PostgreSQL
103     Group: System/Libraries
104     Requires: postgresql%{current_major_version} = %{version}-%{release}
105     Provides: libecpg = %{version}-%{release}
106     Provides: %{libecpg}-virtual = %{current_major_version}
107     Conflicts: %{libecpg}-virtual < %{current_major_version}
108    
109     %description -n %{libecpg}
110     Libecpg is used by programs built with ecpg (Embedded PostgreSQL for C) Use
111     postgresql-dev to develop such programs.
112    
113     %package server
114     Summary: The programs needed to create and run a PostgreSQL server
115     Group: Databases
116     Provides: sqlserver
117     Requires(post): %{libname} >= %{version}-%{release}
118     Requires(preun): %{libname} >= %{version}-%{release}
119     # add/remove services
120     Requires(post): rpm-helper
121     Requires(preun): rpm-helper
122     # add/del user
123     Requires(pre): rpm-helper
124     Requires(postun): rpm-helper
125     Requires(pre): postgresql%{current_major_version} >= %{version}-%{release}
126     Requires(post): postgresql%{current_major_version} >= %{version}-%{release}
127     Conflicts: postgresql < 7.3
128     Provides: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
129     Provides: %{bname}-server-virtual = %{current_major_version}
130     Conflicts: %{bname}-server-virtual < %{current_major_version}
131     Provides: %{bname}-server = %{version}-%{release}
132     Conflicts: %{bname}8.3-test < %{version}-%{release}
133     Requires: postgresql-plpgsql = %{version}-%{release}
134    
135     %description server
136     The postgresql-server package includes the programs needed to create and run a
137     PostgreSQL server, which will in turn allow you to create and maintain
138     PostgreSQL databases. PostgreSQL is an advanced Object-Relational database
139     management system (DBMS) that supports almost all SQL constructs (including
140     transactions, subselects and user-defined types and functions). You should
141     install postgresql-server if you want to create and maintain your own
142     PostgreSQL databases and/or your own PostgreSQL server. You also need to
143     install the postgresql and postgresql-devel packages.
144    
145     After installing this package, please read postgresql.%{_vendor}.releasenote.
146    
147     %package docs
148     Summary: Extra documentation for PostgreSQL
149     Group: Databases
150 fwang 298885 BuildArch: noarch
151 fwang 298251 Provides: %{bname}-docs-virtual = %{current_major_version}
152     Conflicts: %{bname}-docs-virtual < %{current_major_version}
153    
154     %description docs
155     The postgresql-docs package includes the SGML source for the documentation as
156     well as the documentation in other formats, and some extra documentation.
157     Install this package if you want to help with the PostgreSQL documentation
158     project, or if you want to generate printed documentation.
159    
160     %package contrib
161     Summary: Contributed binaries distributed with PostgreSQL
162     Group: Databases
163     Requires: postgresql%{current_major_version}-server = %{version}-%{release}
164     Provides: %{bname}-contrib-virtual = %{current_major_version}
165     Conflicts: %{bname}-contrib-virtual < %{current_major_version}
166    
167     %description contrib
168     The postgresql-contrib package includes the contrib tree distributed with the
169     PostgreSQL tarball. Selected contrib modules are prebuilt.
170    
171     %package devel
172     Summary: PostgreSQL development header files and libraries
173     Group: Development/Databases
174     Requires: postgresql%{current_major_version} = %{version}-%{release}
175     Provides: %{bname}-devel-virtual = %{current_major_version}
176     Conflicts: %{bname}-devel-virtual < %{current_major_version}
177     Requires: %{libname} = %{version}-%{release}
178     Provides: postgresql-libs-devel = %{version}-%{release}
179     Provides: pq-devel = %{version}-%{release}
180     # Avoid conflicts with lib having bad major
181     Conflicts: libpq3-devel = 8.0.2
182     %if %_lib != lib
183     Provides: libpq-devel = %{version}-%{release}
184     %endif
185     Provides: %{_lib}pq-devel = %{version}
186     Conflicts: %{_lib}pq-devel < %{version}
187     Requires: %{libecpg} = %{version}-%{release}
188     Provides: libecpg-devel = %{version}-%{release}
189     Provides: %{_lib}ecpg-devel = %{version}-%{release}
190     Conflicts: %{_lib}ecpg-devel < %{version}-%{release}
191     Conflicts: %mklibname -d ecpg 5
192     Conflicts: %mklibname -d pq 5
193     Conflicts: %mklibname -d pq8.3
194     Conflicts: %mklibname -d ecpg8.3
195     Conflicts: %mklibname -d pq8.4
196     Conflicts: %mklibname -d ecpg8.4
197     Provides: %{bname}-devel = %{version}-%{release}
198     Conflicts: %{bname}-devel < %{version}-%{release}
199    
200     %description devel
201     The postgresql-devel package contains the header files and libraries needed to
202     compile C or C++ applications which will directly interact with a PostgreSQL
203     database management server and the ecpg Embedded C Postgres preprocessor. You
204     need to install this package if you want to develop applications which will
205     interact with a PostgreSQL server. If you're installing postgresql-server, you
206     need to install this package.
207    
208     %package pl
209     Summary: Procedurals languages for PostgreSQL
210     Group: Databases
211     Conflicts: libpgsql2
212     Requires: %{name}-plpython = %{version}-%{release}
213     Requires: %{name}-plperl = %{version}-%{release}
214     Requires: %{name}-pltcl = %{version}-%{release}
215     Requires: %{name}-plpgsql = %{version}-%{release}
216     Provides: %{bname}-pl-virtual = %{current_major_version}
217     Conflicts: %{bname}-pl-virtual < %{current_major_version}
218     Conflicts: %{bname}-pl < %{version}-%{release}
219     Provides: %{bname}-pl = %{version}-%{release}
220    
221     %description pl
222     PostgreSQL is an advanced Object-Relational database management system. The
223     postgresql-pl will install the the PL/Perl, PL/Tcl, and PL/Python procedural
224     languages for the backend. PL/Pgsql is part of the core server package.
225    
226     %package plpython
227     Summary: The PL/Python procedural language for PostgreSQL
228     Group: Databases
229     Requires: postgresql%{current_major_version}-server = %{version}
230     Conflicts: postgresql-pl < %version-%release
231     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
232     Provides: %{bname}-plpython-virtual = %{current_major_version}
233     Conflicts: %{bname}-plpython-virtual < %{current_major_version}
234     Conflicts: %{bname}-plpython < %{version}-%{release}
235     Provides: %{bname}-plpython = %{version}-%{release}
236    
237     %description plpython
238     PostgreSQL is an advanced Object-Relational database management system. The
239     postgresql-plpython package contains the the PL/Python procedural languages for
240     the backend. PL/Python is part of the core server package.
241    
242     %package plperl
243     Summary: The PL/Perl procedural language for PostgreSQL
244     Group: Databases
245     Requires: postgresql%{current_major_version}-server = %{version}
246     Requires: perl-base = %{perl_epoch}:%{perl_version}
247     Conflicts: postgresql-pl < %version-%release
248     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
249     Provides: %{bname}-plperl-virtual = %{current_major_version}
250     Conflicts: %{bname}-plperl-virtual < %{current_major_version}
251     Conflicts: %{bname}-plperl < %{version}-%{release}
252     Provides: %{bname}-plperl = %{version}-%{release}
253    
254     %description plperl
255     PostgreSQL is an advanced Object-Relational database management system. The
256     postgresql-plperl package contains the the PL/Perl procedural languages for the
257     backend. PL/Perl is part of the core server package.
258    
259     %package pltcl
260     Summary: The PL/Tcl procedural language for PostgreSQL
261     Group: Databases
262     Requires: postgresql%{current_major_version}-server = %{version}
263     Conflicts: postgresql-pl < %version-%release
264     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
265     Provides: %{bname}-pltcl-virtual = %{current_major_version}
266     Conflicts: %{bname}-pltcl-virtual < %{current_major_version}
267     Conflicts: %{bname}-pltcl < %{version}-%{release}
268     Provides: %{bname}-pltcl = %{version}-%{release}
269    
270     %description pltcl
271     PostgreSQL is an advanced Object-Relational database management system. The
272     postgresql-pltcl package contains the the PL/Tcl procedural languages for the
273     backend. PL/Tcl is part of the core server package.
274    
275     %package plpgsql
276     Summary: The PL/PgSQL procedural language for PostgreSQL
277     Group: Databases
278     Requires: postgresql%{current_major_version}-server = %{version}
279     Conflicts: postgresql-pl < %version-%release
280     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
281     Provides: %{bname}-plpgsql-virtual = %{current_major_version}
282     Conflicts: %{bname}-plpgsql-virtual < %{current_major_version}
283     Conflicts: %{bname}-plpgsql < %{version}-%{release}
284     Provides: %{bname}-plpgsql = %{version}-%{release}
285    
286     %description plpgsql
287     PostgreSQL is an advanced Object-Relational database management system. The
288     postgresql-plpgsql package contains the the PL/PgSQL procedural languages for
289     the backend. PL/PgSQL is part of the core server package.
290    
291     %prep
292    
293     %setup -q -n %{bname}-%{version}%{?beta}
294    
295     %build
296    
297     %serverbuild
298    
299 fwang 298259 %configure2_5x \
300 fwang 298251 --disable-rpath \
301     --with-perl \
302     --with-python \
303     --with-tcl --with-tclconfig=%{_libdir} \
304     --with-openssl \
305     --with-pam \
306     --with-libxml \
307     --with-libxslt \
308     --libdir=%{_libdir} \
309     --mandir=%{_mandir} \
310     --prefix=%_prefix \
311     --sysconfdir=%{_sysconfdir}/pgsql \
312     --enable-nls \
313     %if %withuuid
314     --with-ossp-uuid
315     %endif
316    
317     # $(rpathdir) come from Makefile
318     perl -pi -e 's|^all:|LINK.shared=\$(COMPILER) -shared -Wl,-rpath,\$(rpathdir),-soname,\$(soname)\nall:|' src/pl/plperl/GNUmakefile
319    
320     %make world
321    
322     pushd src/test
323     make all
324     popd
325    
326     %check
327     make check
328    
329     %install
330     make DESTDIR=%{buildroot} install-world install-docs
331    
332     # install odbcinst.ini
333     mkdir -p %{buildroot}%{_sysconfdir}/pgsql
334    
335     # copy over Makefile.global to the include dir....
336     #install -m755 src/Makefile.global %{buildroot}%{_includedir}/pgsql/
337    
338     # PGDATA needs removal of group and world permissions due to pg_pwd hole.
339     install -d -m 700 %{buildroot}/var/lib/pgsql/data
340    
341     # backups of data go here...
342     install -d -m 700 %{buildroot}/var/lib/pgsql/backups
343    
344     # Create the multiple postmaster startup directory
345     install -d -m 700 %{buildroot}/etc/sysconfig/pgsql
346    
347 fwang 298258 # install systemd units
348     mkdir -p %{buildroot}%{_unitdir}
349     install -m 644 %{SOURCE11} %{buildroot}%{_unitdir}/%{bname}.service
350 fwang 298251
351 neoclust 344748 # install helper script for env initialisation
352     install -m 755 %{SOURCE14} %{buildroot}/%{_libexecdir}/
353    
354 fwang 298251 mkdir -p %buildroot/var/log/postgres
355    
356     mkdir -p %buildroot%logrotatedir
357     cat > %buildroot%logrotatedir/%{bname} <<EOF
358     /var/log/postgres/postgresql {
359     notifempty
360     missingok
361     copytruncate
362     }
363     EOF
364    
365     mv %{buildroot}%{_docdir}/%{bname}/html %{buildroot}%{_docdir}/%{name}-docs-%{version}
366    
367     echo -n '' > main.lst
368     for i in \
369     pg_ctl initdb pg_config psql pg_dump pgscripts libpq libecpg \
370     ecpg libpq%{major} ecpglib%{major_ecpg}; do
371     %find_lang $i-%{current_major_version}
372     cat $i-%{current_major_version}.lang >> main.lst
373     %find_lang $i
374     cat $i.lang >> main.lst
375     done
376     echo -n '' > server.lst
377     for i in postgres pg_resetxlog pg_controldata plpgsql plpython plperl pltcl pg_basebackup; do
378     %find_lang $i
379     cat $i.lang >> server.lst
380     %find_lang $i-%{current_major_version}
381     cat $i-%{current_major_version}.lang >> server.lst
382     done
383    
384     # pg_ctl.lang initdb.lang pg_config.lang psql.lang pg_dump.lang pgscripts.lang \
385     # postgres.lang pg_resetxlog.lang pg_controldata.lang \
386     # libpq.lang libecpg.lang \
387    
388     # taken directly in build dir.
389     rm -fr %{buildroot}%{_datadir}/doc/postgresql/contrib/
390     rm -fr %{buildroot}%{_datadir}/doc/postgresql/extension/
391    
392     mkdir -p %buildroot/%_sys_macros_dir
393     cat > %buildroot/%_sys_macros_dir/%{name}.macros <<EOF
394     %%postgresql_version %{version}
395     %%postgresql_major %{current_major_version}
396     %%postgresql_minor %{current_minor_version}
397     %%pgmodules_req Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
398     EOF
399    
400     cat %{SOURCE13} > postgresql.%{_vendor}.releasenote
401     cat > README.urpmi <<EOF
402     You just installed or updated %{bname} server.
403     You can find important information about %{distribution} %{bname} rpms and database
404     management in:
405    
406     %{_defaultdocdir}/%{name}-server/postgresql.%{_vendor}.releasenote
407    
408     Please read it.
409     EOF
410    
411     # postgres' .profile and .bashrc
412     install -D -m 700 %SOURCE10 %{buildroot}/var/lib/pgsql/.profile
413     (
414     cd %{buildroot}/var/lib/pgsql/
415     ln -s .profile .bashrc
416     )
417    
418     cat > %buildroot%_sysconfdir/sysconfig/postgresql <<EOF
419     # Olivier Thauvin <nanardon@mandriva.org>
420    
421     # The database location:
422     # You probably won't change this
423     # PGDATA=/var/lib/pgsql/data
424    
425     # What is the based locales for postgresql
426     # Setting locales to C allow to use any encoding
427     # ISO or UTF, any other choice will restrict you
428     # either ISO or UTF.
429     LC_ALL=C
430    
431     # These are additional to pass to pg_ctl when starting/restarting postgresql.
432     # PGOPTIONS=
433     EOF
434    
435     %pre server
436     %_pre_useradd postgres /var/lib/pgsql /bin/bash
437    
438     [ ! -f %pgdata/data/PG_VERSION ] && exit 0
439     mypgversion=`cat %pgdata/data/PG_VERSION`
440     [ $mypgversion = %{current_major_version} ] && exit 0
441    
442     echo ""
443     echo "You currently have database tree for Postgresql $mypgversion"
444     echo "You must use postgresql${mypgversion}-server"
445     echo "To update you Postgresql server, dump your databases"
446     echo "delete /var/lib/pgsql/data/ content, upgrade the server, then"
447     echo "restore your databases from your backup"
448     echo ""
449    
450     exit 1
451    
452     %posttrans server
453     %_post_service %{bname}
454    
455     %preun server
456     %_preun_service %{bname}
457    
458     %postun server
459     %_postun_userdel postgres
460    
461     %files -f main.lst
462     %defattr(-,root,root)
463     %doc doc/KNOWN_BUGS doc/MISSING_FEATURES
464     %doc COPYRIGHT README HISTORY doc/bug.template
465     %{_bindir}/clusterdb
466     %{_bindir}/createdb
467     %{_bindir}/createlang
468     %{_bindir}/createuser
469     %{_bindir}/dropdb
470     %{_bindir}/droplang
471     %{_bindir}/dropuser
472     %{_bindir}/pg_dump
473     %{_bindir}/pg_dumpall
474     %{_bindir}/pg_restore
475     %{_bindir}/psql
476     %{_bindir}/reindexdb
477     %{_bindir}/vacuumdb
478     %{_mandir}/man1/clusterdb.*
479     %{_mandir}/man1/createdb.*
480     %{_mandir}/man1/createlang.*
481     %{_mandir}/man1/createuser.*
482     %{_mandir}/man1/dropdb.*
483     %{_mandir}/man1/droplang.*
484     %{_mandir}/man1/dropuser.*
485     %{_mandir}/man1/pg_dump.*
486     %{_mandir}/man1/pg_dumpall.*
487     %{_mandir}/man1/pg_restore.*
488     %{_mandir}/man1/psql.*
489     %{_mandir}/man1/vacuumdb.*
490     %{_mandir}/man1/reindexdb.*
491     %{_mandir}/man7/*
492     %_sys_macros_dir/%{name}.macros
493    
494     %files -n %{libname}
495     %defattr(-,root,root)
496     %{_libdir}/libpq.so.%{major}*
497    
498     %files -n %{libecpg}
499     %defattr(-,root,root)
500     %{_libdir}/libecpg.so.%{major_ecpg}*
501     %{_libdir}/libecpg_compat.so.*
502     %{_libdir}/libpgtypes.so.*
503    
504     %files docs
505     %defattr(-,root,root)
506     %doc %{_docdir}/%{name}-docs-%{version}
507    
508     %files contrib
509     %defattr(-,root,root)
510     # %doc contrib/*/README.* contrib/spi/*.example
511     %{_libdir}/postgresql/_int.so
512     %{_libdir}/postgresql/btree_gist.so
513     %{_libdir}/postgresql/chkpass.so
514     %{_libdir}/postgresql/cube.so
515     %{_libdir}/postgresql/dblink.so
516     %{_libdir}/postgresql/earthdistance.so
517     %{_libdir}/postgresql/fuzzystrmatch.so
518     %{_libdir}/postgresql/insert_username.so
519     %{_libdir}/postgresql/lo.so
520     %{_libdir}/postgresql/ltree.so
521     %{_libdir}/postgresql/moddatetime.so
522     %{_libdir}/postgresql/pgcrypto.so
523     %{_libdir}/postgresql/pgstattuple.so
524     %{_libdir}/postgresql/refint.so
525     %{_libdir}/postgresql/seg.so
526     %{_libdir}/postgresql/tablefunc.so
527     %{_libdir}/postgresql/timetravel.so
528     %{_libdir}/postgresql/pg_trgm.so
529     %{_libdir}/postgresql/autoinc.so
530     %{_libdir}/postgresql/pg_buffercache.so
531     %{_libdir}/postgresql/adminpack.so
532     %{_libdir}/postgresql/hstore.so
533     %{_libdir}/postgresql/isn.so
534     %{_libdir}/postgresql/pg_freespacemap.so
535     %{_libdir}/postgresql/pgrowlocks.so
536     %{_libdir}/postgresql/sslinfo.so
537     %{_libdir}/postgresql/pageinspect.so
538 fwang 298259 %{_libdir}/postgresql/tcn.so
539 fwang 298251
540     %{_bindir}/oid2name
541     %{_bindir}/pgbench
542     %{_bindir}/vacuumlo
543 fwang 298259 %{_bindir}/pg_test_timing
544     %{_mandir}/man1/oid2name.1*
545     %{_mandir}/man1/pgbench.1*
546     %{_mandir}/man1/pg_test_timing.1*
547     %{_mandir}/man1/vacuumlo.1*
548 fwang 298251
549     %files server -f server.lst
550     %defattr(-,root,root)
551     %config(noreplace) %{_sysconfdir}/sysconfig/postgresql
552     %doc README.urpmi postgresql.%{_vendor}.releasenote
553 fwang 298258 %{_unitdir}/%{bname}.service
554 fwang 298251 %{_bindir}/initdb
555     %{_bindir}/pg_controldata
556     %{_bindir}/pg_ctl
557     %{_bindir}/pg_resetxlog
558     %{_bindir}/postgres
559     %{_bindir}/postmaster
560     %{_bindir}/pg_standby
561     %{_bindir}/pg_archivecleanup
562     %{_bindir}/pg_upgrade
563     %{_bindir}/pg_basebackup
564 fwang 298259 %{_bindir}/pg_receivexlog
565 fwang 298251 %{_bindir}/pg_test_fsync
566     %{_mandir}/man1/initdb.1*
567 fwang 298259 %{_mandir}/man1/pg_archivecleanup.1*
568 fwang 298251 %{_mandir}/man1/pg_controldata.*
569     %{_mandir}/man1/pg_ctl.1*
570 fwang 298259 %{_mandir}/man1/pg_receivexlog.1*
571     %{_mandir}/man1/pg_standby.1*
572 fwang 298251 %{_mandir}/man1/pg_resetxlog.*
573     %{_mandir}/man1/postgres.1*
574     %{_mandir}/man1/postmaster.1*
575     %{_mandir}/man1/pg_basebackup.1*
576 fwang 298259 %{_mandir}/man1/pg_test_fsync.1*
577     %{_mandir}/man1/pg_upgrade.1*
578 fwang 298251 %dir %{_libdir}/postgresql
579     %dir %{_datadir}/postgresql
580     %attr(644,postgres,postgres) %config(noreplace) /var/lib/pgsql/.bashrc
581     %attr(-,postgres,postgres) /var/lib/pgsql/.profile
582     %attr(700,postgres,postgres) %dir %{pgdata}
583     %attr(-,postgres,postgres) %{pgdata}/data
584     %attr(700,postgres,postgres) %dir %{pgdata}/backups
585     %{_libdir}/postgresql/*_and_*.so
586     %{_libdir}/postgresql/pgxml.so
587     %{_libdir}/postgresql/dict_int.so
588     %{_libdir}/postgresql/dict_xsyn.so
589     %{_libdir}/postgresql/test_parser.so
590     %{_libdir}/postgresql/tsearch2.so
591     %{_libdir}/postgresql/dict_snowball.so
592     %{_libdir}/postgresql/auto_explain.so
593     %{_libdir}/postgresql/btree_gin.so
594     %{_libdir}/postgresql/citext.so
595     %{_libdir}/postgresql/pg_stat_statements.so
596     %{_libdir}/postgresql/auth_delay.so
597     %{_libdir}/postgresql/dummy_seclabel.so
598     %{_libdir}/postgresql/file_fdw.so
599 neoclust 344748 %{_libexecdir}/postgresql_initdb.sh
600 fwang 298251 %if %withuuid
601     %{_libdir}/postgresql/uuid-ossp.so
602     %endif
603     %{_libdir}/postgresql/euc2004_sjis2004.so
604     %{_libdir}/postgresql/libpqwalreceiver.so
605     %{_libdir}/postgresql/passwordcheck.so
606     %{_libdir}/postgresql/pg_upgrade_support.so
607     %{_libdir}/postgresql/unaccent.so
608     %{_datadir}/postgresql/postgres.bki
609     %{_datadir}/postgresql/postgres.description
610     %{_datadir}/postgresql/*.sample
611     %{_datadir}/postgresql/timezone
612     %{_datadir}/postgresql/system_views.sql
613     %{_datadir}/postgresql/conversion_create.sql
614     %{_datadir}/postgresql/information_schema.sql
615     %{_datadir}/postgresql/snowball_create.sql
616     %{_datadir}/postgresql/sql_features.txt
617     %{_datadir}/postgresql/postgres.shdescription
618     %dir %{_datadir}/postgresql/timezonesets
619     %{_datadir}/postgresql/timezonesets/Africa.txt
620     %{_datadir}/postgresql/timezonesets/America.txt
621     %{_datadir}/postgresql/timezonesets/Antarctica.txt
622     %{_datadir}/postgresql/timezonesets/Asia.txt
623     %{_datadir}/postgresql/timezonesets/Atlantic.txt
624     %{_datadir}/postgresql/timezonesets/Australia
625     %{_datadir}/postgresql/timezonesets/Australia.txt
626     %{_datadir}/postgresql/timezonesets/Default
627     %{_datadir}/postgresql/timezonesets/Etc.txt
628     %{_datadir}/postgresql/timezonesets/Europe.txt
629     %{_datadir}/postgresql/timezonesets/India
630     %{_datadir}/postgresql/timezonesets/Indian.txt
631     %{_datadir}/postgresql/timezonesets/Pacific.txt
632     %{_datadir}/postgresql/tsearch_data
633     %{_datadir}/postgresql/extension
634    
635     %attr(700,postgres,postgres) %dir /var/log/postgres
636     %logrotatedir/%{bname}
637    
638     %files devel
639     %defattr(-,root,root)
640     # %doc doc/TODO doc/TODO.detail
641     %{_includedir}/*
642     %{_bindir}/ecpg
643     %{_libdir}/lib*.so
644 fwang 298885 %{_libdir}/lib*.a
645 fwang 298251 %{_libdir}/postgresql/pgxs/
646     %{_mandir}/man1/ecpg.1*
647     %{_bindir}/pg_config
648     %{_mandir}/man1/pg_config.1*
649     %{_mandir}/man3/SPI_*.3*
650     %{_mandir}/man3/dblink*.3*
651    
652     %files pl
653     %defattr(-,root,root)
654    
655     %files plpython
656     %defattr(-,root,root)
657     %{_libdir}/postgresql/plpython2.so
658    
659     %files plperl
660     %defattr(-,root,root)
661     %{_libdir}/postgresql/plperl.so
662    
663     %files pltcl
664     %defattr(-,root,root)
665     %{_libdir}/postgresql/pltcl.so
666     %{_bindir}/pltcl_delmod
667     %{_bindir}/pltcl_listmod
668     %{_bindir}/pltcl_loadmod
669     %{_datadir}/postgresql/unknown.pltcl
670    
671     %files plpgsql
672     %defattr(-,root,root)
673     %{_libdir}/postgresql/plpgsql.so
674    

  ViewVC Help
Powered by ViewVC 1.1.30