/[packages]/cauldron/postgresql9.3/current/SPECS/postgresql9.3.spec
ViewVC logotype

Annotation of /cauldron/postgresql9.3/current/SPECS/postgresql9.3.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 378364 - (hide annotations) (download)
Sun Jan 13 19:56:48 2013 UTC (11 years, 3 months ago) by neoclust
Original Path: cauldron/postgresql9.2/current/SPECS/postgresql9.2.spec
File size: 23101 byte(s)
SILENT: Create libexec folder
1 fwang 298251 %define Werror_cflags %nil
2     %define _disable_ld_no_undefined 1
3    
4     %define perl_version %(rpm -q --qf "%{VERSION}" perl)
5     %define perl_epoch %(rpm -q --qf "%{EPOCH}" perl)
6    
7     %define pgdata /var/lib/pgsql
8     %define logrotatedir %{_sysconfdir}/logrotate.d
9    
10     %define major 5
11     %define major_ecpg 6
12    
13     %define bname postgresql
14     %define current_major_version 9.2
15 fwang 327996 %define current_minor_version 2
16 fwang 298251
17     # Define if it's a beta
18 fwang 304559 # define beta rc2
19 fwang 298251
20 umeabot 378121 %define rel 3
21 fwang 298251
22     %define release %mkrel %{?beta:0.rc.%{beta}.}%{rel}
23    
24     %define libname %mklibname pq%{current_major_version} _%{major}
25     %define libecpg %mklibname ecpg%{current_major_version} _%{major_ecpg}
26    
27     # (blino) FIXME: enable back when ossp_uuid (and php) are available
28     %define withuuid 0
29     #define withuuid 1
30    
31     Summary: PostgreSQL client programs and libraries
32     Name: %{bname}%{current_major_version}
33     Version: %{current_major_version}%{?!beta:.%{current_minor_version}}
34     Release: %release
35     License: BSD
36     Group: Databases
37     URL: http://www.postgresql.org/
38     Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}%{?beta}.tar.bz2
39     Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}%{?beta}.tar.bz2.md5
40     Source10: postgres.profile
41 fwang 298258 Source11: postgresql.service
42 fwang 298251 Source13: postgresql.distro.releasenote
43 neoclust 344748 Source14: postgresql_initdb.sh
44 fwang 298251
45     Requires: perl
46     Provides: postgresql-clients = %{version}-%{release}
47     Conflicts: postgresql-clients < %{version}-%{release}
48     BuildRequires: bison flex
49     BuildRequires: openssl-devel
50     BuildRequires: pam-devel
51     BuildRequires: perl-devel
52     BuildRequires: python-devel
53     BuildRequires: readline-devel
54     BuildRequires: tcl-devel
55     BuildRequires: libxml2-devel
56     BuildRequires: libxslt-devel
57     BuildRequires: zlib-devel
58     %if %withuuid
59     BuildRequires: ossp_uuid-devel
60     %endif
61     # Need to build doc
62     BuildRequires: docbook-dtd42-sgml openjade docbook-utils docbook-style-xsl xsltproc
63     Provides: %{bname}-virtual = %{current_major_version}
64     Conflicts: %{bname}-virtual < %{current_major_version}
65     Provides: %{bname} = %{version}-%{release}
66     Conflicts: %{bname} < %{version}-%{release}
67    
68     %description
69     PostgreSQL is an advanced Object-Relational database management system (DBMS)
70     that supports almost all SQL constructs (including transactions, subselects and
71     user-defined types and functions). The postgresql package includes the client
72     programs and libraries that you'll need to access a PostgreSQL DBMS server.
73     These PostgreSQL client programs are programs that directly manipulate the
74     internal structure of PostgreSQL databases on a PostgreSQL server. These client
75     programs can be located on the same machine with the PostgreSQL server, or may
76     be on a remote machine which accesses a PostgreSQL server over a network
77     connection. This package contains the client libraries for C and C++, as well
78     as command-line utilities for managing PostgreSQL databases on a PostgreSQL
79     server.
80    
81     If you want to manipulate a PostgreSQL database on a remote PostgreSQL server,
82     you need this package. You also need to install this package if you're
83     installing the postgresql-server package.
84    
85     %package -n %{libname}
86     Summary: The shared libraries required for any PostgreSQL clients
87     Group: System/Libraries
88     Conflicts: postgresql-libs < %{version}-%{release}
89     Provides: postgresql-libs = %{version}-%{release}
90     Provides: libpq = %{version}-%{release}
91     Provides: %{libname}-virtual = %{current_major_version}
92     Conflicts: %{libname}-virtual < %{current_major_version}
93     # Avoid conflicts with lib having bad major
94     Conflicts: libpq3 = 8.0.2
95    
96     %description -n %{libname}
97     C and C++ libraries to enable user programs to communicate with the PostgreSQL
98     database backend. The backend can be on another machine and accessed through
99     TCP/IP.
100    
101     %package -n %{libecpg}
102     Summary: Shared library libecpg for PostgreSQL
103     Group: System/Libraries
104     Requires: postgresql%{current_major_version} = %{version}-%{release}
105     Provides: libecpg = %{version}-%{release}
106     Provides: %{libecpg}-virtual = %{current_major_version}
107     Conflicts: %{libecpg}-virtual < %{current_major_version}
108    
109     %description -n %{libecpg}
110     Libecpg is used by programs built with ecpg (Embedded PostgreSQL for C) Use
111     postgresql-dev to develop such programs.
112    
113     %package server
114     Summary: The programs needed to create and run a PostgreSQL server
115     Group: Databases
116     Provides: sqlserver
117     Requires(post): %{libname} >= %{version}-%{release}
118     Requires(preun): %{libname} >= %{version}-%{release}
119     # add/remove services
120     Requires(post): rpm-helper
121     Requires(preun): rpm-helper
122     # add/del user
123     Requires(pre): rpm-helper
124     Requires(postun): rpm-helper
125     Requires(pre): postgresql%{current_major_version} >= %{version}-%{release}
126     Requires(post): postgresql%{current_major_version} >= %{version}-%{release}
127     Conflicts: postgresql < 7.3
128     Provides: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
129     Provides: %{bname}-server-virtual = %{current_major_version}
130     Conflicts: %{bname}-server-virtual < %{current_major_version}
131     Provides: %{bname}-server = %{version}-%{release}
132     Conflicts: %{bname}8.3-test < %{version}-%{release}
133     Requires: postgresql-plpgsql = %{version}-%{release}
134    
135     %description server
136     The postgresql-server package includes the programs needed to create and run a
137     PostgreSQL server, which will in turn allow you to create and maintain
138     PostgreSQL databases. PostgreSQL is an advanced Object-Relational database
139     management system (DBMS) that supports almost all SQL constructs (including
140     transactions, subselects and user-defined types and functions). You should
141     install postgresql-server if you want to create and maintain your own
142     PostgreSQL databases and/or your own PostgreSQL server. You also need to
143     install the postgresql and postgresql-devel packages.
144    
145     After installing this package, please read postgresql.%{_vendor}.releasenote.
146    
147     %package docs
148     Summary: Extra documentation for PostgreSQL
149     Group: Databases
150 fwang 298885 BuildArch: noarch
151 fwang 298251 Provides: %{bname}-docs-virtual = %{current_major_version}
152     Conflicts: %{bname}-docs-virtual < %{current_major_version}
153    
154     %description docs
155     The postgresql-docs package includes the SGML source for the documentation as
156     well as the documentation in other formats, and some extra documentation.
157     Install this package if you want to help with the PostgreSQL documentation
158     project, or if you want to generate printed documentation.
159    
160     %package contrib
161     Summary: Contributed binaries distributed with PostgreSQL
162     Group: Databases
163     Requires: postgresql%{current_major_version}-server = %{version}-%{release}
164     Provides: %{bname}-contrib-virtual = %{current_major_version}
165     Conflicts: %{bname}-contrib-virtual < %{current_major_version}
166    
167     %description contrib
168     The postgresql-contrib package includes the contrib tree distributed with the
169     PostgreSQL tarball. Selected contrib modules are prebuilt.
170    
171     %package devel
172     Summary: PostgreSQL development header files and libraries
173     Group: Development/Databases
174     Requires: postgresql%{current_major_version} = %{version}-%{release}
175     Provides: %{bname}-devel-virtual = %{current_major_version}
176     Conflicts: %{bname}-devel-virtual < %{current_major_version}
177     Requires: %{libname} = %{version}-%{release}
178     Provides: postgresql-libs-devel = %{version}-%{release}
179     Provides: pq-devel = %{version}-%{release}
180     # Avoid conflicts with lib having bad major
181     Conflicts: libpq3-devel = 8.0.2
182     %if %_lib != lib
183     Provides: libpq-devel = %{version}-%{release}
184     %endif
185     Provides: %{_lib}pq-devel = %{version}
186     Conflicts: %{_lib}pq-devel < %{version}
187     Requires: %{libecpg} = %{version}-%{release}
188     Provides: libecpg-devel = %{version}-%{release}
189     Provides: %{_lib}ecpg-devel = %{version}-%{release}
190     Conflicts: %{_lib}ecpg-devel < %{version}-%{release}
191     Conflicts: %mklibname -d ecpg 5
192     Conflicts: %mklibname -d pq 5
193     Conflicts: %mklibname -d pq8.3
194     Conflicts: %mklibname -d ecpg8.3
195     Conflicts: %mklibname -d pq8.4
196     Conflicts: %mklibname -d ecpg8.4
197     Provides: %{bname}-devel = %{version}-%{release}
198     Conflicts: %{bname}-devel < %{version}-%{release}
199    
200     %description devel
201     The postgresql-devel package contains the header files and libraries needed to
202     compile C or C++ applications which will directly interact with a PostgreSQL
203     database management server and the ecpg Embedded C Postgres preprocessor. You
204     need to install this package if you want to develop applications which will
205     interact with a PostgreSQL server. If you're installing postgresql-server, you
206     need to install this package.
207    
208     %package pl
209     Summary: Procedurals languages for PostgreSQL
210     Group: Databases
211     Conflicts: libpgsql2
212     Requires: %{name}-plpython = %{version}-%{release}
213     Requires: %{name}-plperl = %{version}-%{release}
214     Requires: %{name}-pltcl = %{version}-%{release}
215     Requires: %{name}-plpgsql = %{version}-%{release}
216     Provides: %{bname}-pl-virtual = %{current_major_version}
217     Conflicts: %{bname}-pl-virtual < %{current_major_version}
218     Conflicts: %{bname}-pl < %{version}-%{release}
219     Provides: %{bname}-pl = %{version}-%{release}
220    
221     %description pl
222     PostgreSQL is an advanced Object-Relational database management system. The
223     postgresql-pl will install the the PL/Perl, PL/Tcl, and PL/Python procedural
224     languages for the backend. PL/Pgsql is part of the core server package.
225    
226     %package plpython
227     Summary: The PL/Python procedural language for PostgreSQL
228     Group: Databases
229     Requires: postgresql%{current_major_version}-server = %{version}
230     Conflicts: postgresql-pl < %version-%release
231     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
232     Provides: %{bname}-plpython-virtual = %{current_major_version}
233     Conflicts: %{bname}-plpython-virtual < %{current_major_version}
234     Conflicts: %{bname}-plpython < %{version}-%{release}
235     Provides: %{bname}-plpython = %{version}-%{release}
236    
237     %description plpython
238     PostgreSQL is an advanced Object-Relational database management system. The
239     postgresql-plpython package contains the the PL/Python procedural languages for
240     the backend. PL/Python is part of the core server package.
241    
242     %package plperl
243     Summary: The PL/Perl procedural language for PostgreSQL
244     Group: Databases
245     Requires: postgresql%{current_major_version}-server = %{version}
246     Requires: perl-base = %{perl_epoch}:%{perl_version}
247     Conflicts: postgresql-pl < %version-%release
248     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
249     Provides: %{bname}-plperl-virtual = %{current_major_version}
250     Conflicts: %{bname}-plperl-virtual < %{current_major_version}
251     Conflicts: %{bname}-plperl < %{version}-%{release}
252     Provides: %{bname}-plperl = %{version}-%{release}
253    
254     %description plperl
255     PostgreSQL is an advanced Object-Relational database management system. The
256     postgresql-plperl package contains the the PL/Perl procedural languages for the
257     backend. PL/Perl is part of the core server package.
258    
259     %package pltcl
260     Summary: The PL/Tcl procedural language for PostgreSQL
261     Group: Databases
262     Requires: postgresql%{current_major_version}-server = %{version}
263     Conflicts: postgresql-pl < %version-%release
264     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
265     Provides: %{bname}-pltcl-virtual = %{current_major_version}
266     Conflicts: %{bname}-pltcl-virtual < %{current_major_version}
267     Conflicts: %{bname}-pltcl < %{version}-%{release}
268     Provides: %{bname}-pltcl = %{version}-%{release}
269    
270     %description pltcl
271     PostgreSQL is an advanced Object-Relational database management system. The
272     postgresql-pltcl package contains the the PL/Tcl procedural languages for the
273     backend. PL/Tcl is part of the core server package.
274    
275     %package plpgsql
276     Summary: The PL/PgSQL procedural language for PostgreSQL
277     Group: Databases
278     Requires: postgresql%{current_major_version}-server = %{version}
279     Conflicts: postgresql-pl < %version-%release
280     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
281     Provides: %{bname}-plpgsql-virtual = %{current_major_version}
282     Conflicts: %{bname}-plpgsql-virtual < %{current_major_version}
283     Conflicts: %{bname}-plpgsql < %{version}-%{release}
284     Provides: %{bname}-plpgsql = %{version}-%{release}
285    
286     %description plpgsql
287     PostgreSQL is an advanced Object-Relational database management system. The
288     postgresql-plpgsql package contains the the PL/PgSQL procedural languages for
289     the backend. PL/PgSQL is part of the core server package.
290    
291     %prep
292    
293     %setup -q -n %{bname}-%{version}%{?beta}
294    
295     %build
296    
297     %serverbuild
298    
299 fwang 298259 %configure2_5x \
300 fwang 298251 --disable-rpath \
301     --with-perl \
302     --with-python \
303     --with-tcl --with-tclconfig=%{_libdir} \
304     --with-openssl \
305     --with-pam \
306     --with-libxml \
307     --with-libxslt \
308     --libdir=%{_libdir} \
309     --mandir=%{_mandir} \
310     --prefix=%_prefix \
311     --sysconfdir=%{_sysconfdir}/pgsql \
312     --enable-nls \
313     %if %withuuid
314     --with-ossp-uuid
315     %endif
316    
317     # $(rpathdir) come from Makefile
318     perl -pi -e 's|^all:|LINK.shared=\$(COMPILER) -shared -Wl,-rpath,\$(rpathdir),-soname,\$(soname)\nall:|' src/pl/plperl/GNUmakefile
319    
320     %make world
321    
322     pushd src/test
323     make all
324     popd
325    
326     %check
327     make check
328    
329     %install
330     make DESTDIR=%{buildroot} install-world install-docs
331    
332     # install odbcinst.ini
333     mkdir -p %{buildroot}%{_sysconfdir}/pgsql
334    
335     # copy over Makefile.global to the include dir....
336     #install -m755 src/Makefile.global %{buildroot}%{_includedir}/pgsql/
337    
338     # PGDATA needs removal of group and world permissions due to pg_pwd hole.
339     install -d -m 700 %{buildroot}/var/lib/pgsql/data
340    
341     # backups of data go here...
342     install -d -m 700 %{buildroot}/var/lib/pgsql/backups
343    
344     # Create the multiple postmaster startup directory
345     install -d -m 700 %{buildroot}/etc/sysconfig/pgsql
346    
347 fwang 298258 # install systemd units
348     mkdir -p %{buildroot}%{_unitdir}
349     install -m 644 %{SOURCE11} %{buildroot}%{_unitdir}/%{bname}.service
350 fwang 298251
351 neoclust 344748 # install helper script for env initialisation
352 neoclust 378364 mkdir -p %{buildroot}/%{_libexecdir}
353 neoclust 344748 install -m 755 %{SOURCE14} %{buildroot}/%{_libexecdir}/
354    
355 fwang 298251 mkdir -p %buildroot/var/log/postgres
356    
357     mkdir -p %buildroot%logrotatedir
358     cat > %buildroot%logrotatedir/%{bname} <<EOF
359     /var/log/postgres/postgresql {
360     notifempty
361     missingok
362     copytruncate
363     }
364     EOF
365    
366     mv %{buildroot}%{_docdir}/%{bname}/html %{buildroot}%{_docdir}/%{name}-docs-%{version}
367    
368     echo -n '' > main.lst
369     for i in \
370     pg_ctl initdb pg_config psql pg_dump pgscripts libpq libecpg \
371     ecpg libpq%{major} ecpglib%{major_ecpg}; do
372     %find_lang $i-%{current_major_version}
373     cat $i-%{current_major_version}.lang >> main.lst
374     %find_lang $i
375     cat $i.lang >> main.lst
376     done
377     echo -n '' > server.lst
378     for i in postgres pg_resetxlog pg_controldata plpgsql plpython plperl pltcl pg_basebackup; do
379     %find_lang $i
380     cat $i.lang >> server.lst
381     %find_lang $i-%{current_major_version}
382     cat $i-%{current_major_version}.lang >> server.lst
383     done
384    
385     # pg_ctl.lang initdb.lang pg_config.lang psql.lang pg_dump.lang pgscripts.lang \
386     # postgres.lang pg_resetxlog.lang pg_controldata.lang \
387     # libpq.lang libecpg.lang \
388    
389     # taken directly in build dir.
390     rm -fr %{buildroot}%{_datadir}/doc/postgresql/contrib/
391     rm -fr %{buildroot}%{_datadir}/doc/postgresql/extension/
392    
393     mkdir -p %buildroot/%_sys_macros_dir
394     cat > %buildroot/%_sys_macros_dir/%{name}.macros <<EOF
395     %%postgresql_version %{version}
396     %%postgresql_major %{current_major_version}
397     %%postgresql_minor %{current_minor_version}
398     %%pgmodules_req Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
399     EOF
400    
401     cat %{SOURCE13} > postgresql.%{_vendor}.releasenote
402     cat > README.urpmi <<EOF
403     You just installed or updated %{bname} server.
404     You can find important information about %{distribution} %{bname} rpms and database
405     management in:
406    
407     %{_defaultdocdir}/%{name}-server/postgresql.%{_vendor}.releasenote
408    
409     Please read it.
410     EOF
411    
412     # postgres' .profile and .bashrc
413     install -D -m 700 %SOURCE10 %{buildroot}/var/lib/pgsql/.profile
414     (
415     cd %{buildroot}/var/lib/pgsql/
416     ln -s .profile .bashrc
417     )
418    
419     cat > %buildroot%_sysconfdir/sysconfig/postgresql <<EOF
420     # Olivier Thauvin <nanardon@mandriva.org>
421    
422     # The database location:
423     # You probably won't change this
424     # PGDATA=/var/lib/pgsql/data
425    
426     # What is the based locales for postgresql
427     # Setting locales to C allow to use any encoding
428     # ISO or UTF, any other choice will restrict you
429     # either ISO or UTF.
430     LC_ALL=C
431    
432     # These are additional to pass to pg_ctl when starting/restarting postgresql.
433     # PGOPTIONS=
434     EOF
435    
436     %pre server
437     %_pre_useradd postgres /var/lib/pgsql /bin/bash
438    
439     [ ! -f %pgdata/data/PG_VERSION ] && exit 0
440     mypgversion=`cat %pgdata/data/PG_VERSION`
441     [ $mypgversion = %{current_major_version} ] && exit 0
442    
443     echo ""
444     echo "You currently have database tree for Postgresql $mypgversion"
445     echo "You must use postgresql${mypgversion}-server"
446     echo "To update you Postgresql server, dump your databases"
447     echo "delete /var/lib/pgsql/data/ content, upgrade the server, then"
448     echo "restore your databases from your backup"
449     echo ""
450    
451     exit 1
452    
453     %posttrans server
454     %_post_service %{bname}
455    
456     %preun server
457     %_preun_service %{bname}
458    
459     %postun server
460     %_postun_userdel postgres
461    
462     %files -f main.lst
463     %defattr(-,root,root)
464     %doc doc/KNOWN_BUGS doc/MISSING_FEATURES
465     %doc COPYRIGHT README HISTORY doc/bug.template
466     %{_bindir}/clusterdb
467     %{_bindir}/createdb
468     %{_bindir}/createlang
469     %{_bindir}/createuser
470     %{_bindir}/dropdb
471     %{_bindir}/droplang
472     %{_bindir}/dropuser
473     %{_bindir}/pg_dump
474     %{_bindir}/pg_dumpall
475     %{_bindir}/pg_restore
476     %{_bindir}/psql
477     %{_bindir}/reindexdb
478     %{_bindir}/vacuumdb
479     %{_mandir}/man1/clusterdb.*
480     %{_mandir}/man1/createdb.*
481     %{_mandir}/man1/createlang.*
482     %{_mandir}/man1/createuser.*
483     %{_mandir}/man1/dropdb.*
484     %{_mandir}/man1/droplang.*
485     %{_mandir}/man1/dropuser.*
486     %{_mandir}/man1/pg_dump.*
487     %{_mandir}/man1/pg_dumpall.*
488     %{_mandir}/man1/pg_restore.*
489     %{_mandir}/man1/psql.*
490     %{_mandir}/man1/vacuumdb.*
491     %{_mandir}/man1/reindexdb.*
492     %{_mandir}/man7/*
493     %_sys_macros_dir/%{name}.macros
494    
495     %files -n %{libname}
496     %defattr(-,root,root)
497     %{_libdir}/libpq.so.%{major}*
498    
499     %files -n %{libecpg}
500     %defattr(-,root,root)
501     %{_libdir}/libecpg.so.%{major_ecpg}*
502     %{_libdir}/libecpg_compat.so.*
503     %{_libdir}/libpgtypes.so.*
504    
505     %files docs
506     %defattr(-,root,root)
507     %doc %{_docdir}/%{name}-docs-%{version}
508    
509     %files contrib
510     %defattr(-,root,root)
511     # %doc contrib/*/README.* contrib/spi/*.example
512     %{_libdir}/postgresql/_int.so
513     %{_libdir}/postgresql/btree_gist.so
514     %{_libdir}/postgresql/chkpass.so
515     %{_libdir}/postgresql/cube.so
516     %{_libdir}/postgresql/dblink.so
517     %{_libdir}/postgresql/earthdistance.so
518     %{_libdir}/postgresql/fuzzystrmatch.so
519     %{_libdir}/postgresql/insert_username.so
520     %{_libdir}/postgresql/lo.so
521     %{_libdir}/postgresql/ltree.so
522     %{_libdir}/postgresql/moddatetime.so
523     %{_libdir}/postgresql/pgcrypto.so
524     %{_libdir}/postgresql/pgstattuple.so
525     %{_libdir}/postgresql/refint.so
526     %{_libdir}/postgresql/seg.so
527     %{_libdir}/postgresql/tablefunc.so
528     %{_libdir}/postgresql/timetravel.so
529     %{_libdir}/postgresql/pg_trgm.so
530     %{_libdir}/postgresql/autoinc.so
531     %{_libdir}/postgresql/pg_buffercache.so
532     %{_libdir}/postgresql/adminpack.so
533     %{_libdir}/postgresql/hstore.so
534     %{_libdir}/postgresql/isn.so
535     %{_libdir}/postgresql/pg_freespacemap.so
536     %{_libdir}/postgresql/pgrowlocks.so
537     %{_libdir}/postgresql/sslinfo.so
538     %{_libdir}/postgresql/pageinspect.so
539 fwang 298259 %{_libdir}/postgresql/tcn.so
540 fwang 298251
541     %{_bindir}/oid2name
542     %{_bindir}/pgbench
543     %{_bindir}/vacuumlo
544 fwang 298259 %{_bindir}/pg_test_timing
545     %{_mandir}/man1/oid2name.1*
546     %{_mandir}/man1/pgbench.1*
547     %{_mandir}/man1/pg_test_timing.1*
548     %{_mandir}/man1/vacuumlo.1*
549 fwang 298251
550     %files server -f server.lst
551     %defattr(-,root,root)
552     %config(noreplace) %{_sysconfdir}/sysconfig/postgresql
553     %doc README.urpmi postgresql.%{_vendor}.releasenote
554 fwang 298258 %{_unitdir}/%{bname}.service
555 fwang 298251 %{_bindir}/initdb
556     %{_bindir}/pg_controldata
557     %{_bindir}/pg_ctl
558     %{_bindir}/pg_resetxlog
559     %{_bindir}/postgres
560     %{_bindir}/postmaster
561     %{_bindir}/pg_standby
562     %{_bindir}/pg_archivecleanup
563     %{_bindir}/pg_upgrade
564     %{_bindir}/pg_basebackup
565 fwang 298259 %{_bindir}/pg_receivexlog
566 fwang 298251 %{_bindir}/pg_test_fsync
567     %{_mandir}/man1/initdb.1*
568 fwang 298259 %{_mandir}/man1/pg_archivecleanup.1*
569 fwang 298251 %{_mandir}/man1/pg_controldata.*
570     %{_mandir}/man1/pg_ctl.1*
571 fwang 298259 %{_mandir}/man1/pg_receivexlog.1*
572     %{_mandir}/man1/pg_standby.1*
573 fwang 298251 %{_mandir}/man1/pg_resetxlog.*
574     %{_mandir}/man1/postgres.1*
575     %{_mandir}/man1/postmaster.1*
576     %{_mandir}/man1/pg_basebackup.1*
577 fwang 298259 %{_mandir}/man1/pg_test_fsync.1*
578     %{_mandir}/man1/pg_upgrade.1*
579 fwang 298251 %dir %{_libdir}/postgresql
580     %dir %{_datadir}/postgresql
581     %attr(644,postgres,postgres) %config(noreplace) /var/lib/pgsql/.bashrc
582     %attr(-,postgres,postgres) /var/lib/pgsql/.profile
583     %attr(700,postgres,postgres) %dir %{pgdata}
584     %attr(-,postgres,postgres) %{pgdata}/data
585     %attr(700,postgres,postgres) %dir %{pgdata}/backups
586     %{_libdir}/postgresql/*_and_*.so
587     %{_libdir}/postgresql/pgxml.so
588     %{_libdir}/postgresql/dict_int.so
589     %{_libdir}/postgresql/dict_xsyn.so
590     %{_libdir}/postgresql/test_parser.so
591     %{_libdir}/postgresql/tsearch2.so
592     %{_libdir}/postgresql/dict_snowball.so
593     %{_libdir}/postgresql/auto_explain.so
594     %{_libdir}/postgresql/btree_gin.so
595     %{_libdir}/postgresql/citext.so
596     %{_libdir}/postgresql/pg_stat_statements.so
597     %{_libdir}/postgresql/auth_delay.so
598     %{_libdir}/postgresql/dummy_seclabel.so
599     %{_libdir}/postgresql/file_fdw.so
600 neoclust 344748 %{_libexecdir}/postgresql_initdb.sh
601 fwang 298251 %if %withuuid
602     %{_libdir}/postgresql/uuid-ossp.so
603     %endif
604     %{_libdir}/postgresql/euc2004_sjis2004.so
605     %{_libdir}/postgresql/libpqwalreceiver.so
606     %{_libdir}/postgresql/passwordcheck.so
607     %{_libdir}/postgresql/pg_upgrade_support.so
608     %{_libdir}/postgresql/unaccent.so
609     %{_datadir}/postgresql/postgres.bki
610     %{_datadir}/postgresql/postgres.description
611     %{_datadir}/postgresql/*.sample
612     %{_datadir}/postgresql/timezone
613     %{_datadir}/postgresql/system_views.sql
614     %{_datadir}/postgresql/conversion_create.sql
615     %{_datadir}/postgresql/information_schema.sql
616     %{_datadir}/postgresql/snowball_create.sql
617     %{_datadir}/postgresql/sql_features.txt
618     %{_datadir}/postgresql/postgres.shdescription
619     %dir %{_datadir}/postgresql/timezonesets
620     %{_datadir}/postgresql/timezonesets/Africa.txt
621     %{_datadir}/postgresql/timezonesets/America.txt
622     %{_datadir}/postgresql/timezonesets/Antarctica.txt
623     %{_datadir}/postgresql/timezonesets/Asia.txt
624     %{_datadir}/postgresql/timezonesets/Atlantic.txt
625     %{_datadir}/postgresql/timezonesets/Australia
626     %{_datadir}/postgresql/timezonesets/Australia.txt
627     %{_datadir}/postgresql/timezonesets/Default
628     %{_datadir}/postgresql/timezonesets/Etc.txt
629     %{_datadir}/postgresql/timezonesets/Europe.txt
630     %{_datadir}/postgresql/timezonesets/India
631     %{_datadir}/postgresql/timezonesets/Indian.txt
632     %{_datadir}/postgresql/timezonesets/Pacific.txt
633     %{_datadir}/postgresql/tsearch_data
634     %{_datadir}/postgresql/extension
635    
636     %attr(700,postgres,postgres) %dir /var/log/postgres
637     %logrotatedir/%{bname}
638    
639     %files devel
640     %defattr(-,root,root)
641     # %doc doc/TODO doc/TODO.detail
642     %{_includedir}/*
643     %{_bindir}/ecpg
644     %{_libdir}/lib*.so
645 fwang 298885 %{_libdir}/lib*.a
646 fwang 298251 %{_libdir}/postgresql/pgxs/
647     %{_mandir}/man1/ecpg.1*
648     %{_bindir}/pg_config
649     %{_mandir}/man1/pg_config.1*
650     %{_mandir}/man3/SPI_*.3*
651     %{_mandir}/man3/dblink*.3*
652    
653     %files pl
654     %defattr(-,root,root)
655    
656     %files plpython
657     %defattr(-,root,root)
658     %{_libdir}/postgresql/plpython2.so
659    
660     %files plperl
661     %defattr(-,root,root)
662     %{_libdir}/postgresql/plperl.so
663    
664     %files pltcl
665     %defattr(-,root,root)
666     %{_libdir}/postgresql/pltcl.so
667     %{_bindir}/pltcl_delmod
668     %{_bindir}/pltcl_listmod
669     %{_bindir}/pltcl_loadmod
670     %{_datadir}/postgresql/unknown.pltcl
671    
672     %files plpgsql
673     %defattr(-,root,root)
674     %{_libdir}/postgresql/plpgsql.so
675    

  ViewVC Help
Powered by ViewVC 1.1.30