/[packages]/cauldron/postgresql9.3/current/SPECS/postgresql9.3.spec
ViewVC logotype

Annotation of /cauldron/postgresql9.3/current/SPECS/postgresql9.3.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 477006 - (hide annotations) (download)
Tue Sep 10 00:55:06 2013 UTC (10 years, 7 months ago) by fwang
File size: 22950 byte(s)
add fedora patch to make it use tmpfiles.d
1 luigiwalser 378422 %define Werror_cflags %{nil}
2 fwang 298251 %define _disable_ld_no_undefined 1
3    
4     %define perl_version %(rpm -q --qf "%{VERSION}" perl)
5     %define perl_epoch %(rpm -q --qf "%{EPOCH}" perl)
6    
7     %define pgdata /var/lib/pgsql
8     %define logrotatedir %{_sysconfdir}/logrotate.d
9    
10     %define major 5
11     %define major_ecpg 6
12    
13     %define bname postgresql
14 fwang 477003 %define current_major_version 9.3
15     %define current_minor_version 0
16 fwang 298251
17 fwang 477003 %define rel 1
18 fwang 298251
19 fwang 477003 %define release %mkrel %{rel}
20 fwang 298251
21     %define libname %mklibname pq%{current_major_version} _%{major}
22     %define libecpg %mklibname ecpg%{current_major_version} _%{major_ecpg}
23    
24     # (blino) FIXME: enable back when ossp_uuid (and php) are available
25     %define withuuid 0
26     #define withuuid 1
27    
28     Summary: PostgreSQL client programs and libraries
29     Name: %{bname}%{current_major_version}
30 fwang 477003 Version: %{current_major_version}.%{current_minor_version}
31 fwang 298251 Release: %release
32     License: BSD
33     Group: Databases
34     URL: http://www.postgresql.org/
35 fwang 477003 Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
36     Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.md5
37 fwang 298251 Source10: postgres.profile
38 fwang 298258 Source11: postgresql.service
39 fwang 298251 Source13: postgresql.distro.releasenote
40 luigiwalser 378422 Source14: postgresql_initdb.sh
41 fwang 477006 Source15: postgresql.tmpfiles.d
42     Patch6: postgresql-var-run-socket.patch
43 fwang 298251
44     Requires: perl
45     Provides: postgresql-clients = %{version}-%{release}
46     Conflicts: postgresql-clients < %{version}-%{release}
47     BuildRequires: bison flex
48     BuildRequires: openssl-devel
49     BuildRequires: pam-devel
50     BuildRequires: perl-devel
51     BuildRequires: python-devel
52     BuildRequires: readline-devel
53     BuildRequires: tcl-devel
54     BuildRequires: libxml2-devel
55     BuildRequires: libxslt-devel
56     BuildRequires: zlib-devel
57     %if %withuuid
58     BuildRequires: ossp_uuid-devel
59     %endif
60     # Need to build doc
61     BuildRequires: docbook-dtd42-sgml openjade docbook-utils docbook-style-xsl xsltproc
62     Provides: %{bname}-virtual = %{current_major_version}
63     Conflicts: %{bname}-virtual < %{current_major_version}
64     Provides: %{bname} = %{version}-%{release}
65     Conflicts: %{bname} < %{version}-%{release}
66    
67     %description
68     PostgreSQL is an advanced Object-Relational database management system (DBMS)
69     that supports almost all SQL constructs (including transactions, subselects and
70     user-defined types and functions). The postgresql package includes the client
71     programs and libraries that you'll need to access a PostgreSQL DBMS server.
72     These PostgreSQL client programs are programs that directly manipulate the
73     internal structure of PostgreSQL databases on a PostgreSQL server. These client
74     programs can be located on the same machine with the PostgreSQL server, or may
75     be on a remote machine which accesses a PostgreSQL server over a network
76     connection. This package contains the client libraries for C and C++, as well
77     as command-line utilities for managing PostgreSQL databases on a PostgreSQL
78     server.
79    
80     If you want to manipulate a PostgreSQL database on a remote PostgreSQL server,
81     you need this package. You also need to install this package if you're
82     installing the postgresql-server package.
83    
84     %package -n %{libname}
85     Summary: The shared libraries required for any PostgreSQL clients
86     Group: System/Libraries
87     Conflicts: postgresql-libs < %{version}-%{release}
88     Provides: postgresql-libs = %{version}-%{release}
89     Provides: libpq = %{version}-%{release}
90     Provides: %{libname}-virtual = %{current_major_version}
91     Conflicts: %{libname}-virtual < %{current_major_version}
92    
93     %description -n %{libname}
94     C and C++ libraries to enable user programs to communicate with the PostgreSQL
95     database backend. The backend can be on another machine and accessed through
96     TCP/IP.
97    
98     %package -n %{libecpg}
99     Summary: Shared library libecpg for PostgreSQL
100     Group: System/Libraries
101     Requires: postgresql%{current_major_version} = %{version}-%{release}
102     Provides: libecpg = %{version}-%{release}
103     Provides: %{libecpg}-virtual = %{current_major_version}
104     Conflicts: %{libecpg}-virtual < %{current_major_version}
105    
106     %description -n %{libecpg}
107     Libecpg is used by programs built with ecpg (Embedded PostgreSQL for C) Use
108     postgresql-dev to develop such programs.
109    
110     %package server
111     Summary: The programs needed to create and run a PostgreSQL server
112     Group: Databases
113     Provides: sqlserver
114     Requires(post): %{libname} >= %{version}-%{release}
115     Requires(preun): %{libname} >= %{version}-%{release}
116     # add/remove services
117     Requires(post): rpm-helper
118     Requires(preun): rpm-helper
119     # add/del user
120     Requires(pre): rpm-helper
121     Requires(postun): rpm-helper
122     Requires(pre): postgresql%{current_major_version} >= %{version}-%{release}
123     Requires(post): postgresql%{current_major_version} >= %{version}-%{release}
124     Provides: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
125     Provides: %{bname}-server-virtual = %{current_major_version}
126     Conflicts: %{bname}-server-virtual < %{current_major_version}
127     Provides: %{bname}-server = %{version}-%{release}
128     Requires: postgresql-plpgsql = %{version}-%{release}
129    
130     %description server
131     The postgresql-server package includes the programs needed to create and run a
132     PostgreSQL server, which will in turn allow you to create and maintain
133     PostgreSQL databases. PostgreSQL is an advanced Object-Relational database
134     management system (DBMS) that supports almost all SQL constructs (including
135     transactions, subselects and user-defined types and functions). You should
136     install postgresql-server if you want to create and maintain your own
137     PostgreSQL databases and/or your own PostgreSQL server. You also need to
138     install the postgresql and postgresql-devel packages.
139    
140     After installing this package, please read postgresql.%{_vendor}.releasenote.
141    
142     %package docs
143     Summary: Extra documentation for PostgreSQL
144     Group: Databases
145 fwang 298885 BuildArch: noarch
146 fwang 298251 Provides: %{bname}-docs-virtual = %{current_major_version}
147     Conflicts: %{bname}-docs-virtual < %{current_major_version}
148    
149     %description docs
150     The postgresql-docs package includes the SGML source for the documentation as
151     well as the documentation in other formats, and some extra documentation.
152     Install this package if you want to help with the PostgreSQL documentation
153     project, or if you want to generate printed documentation.
154    
155     %package contrib
156     Summary: Contributed binaries distributed with PostgreSQL
157     Group: Databases
158     Requires: postgresql%{current_major_version}-server = %{version}-%{release}
159     Provides: %{bname}-contrib-virtual = %{current_major_version}
160     Conflicts: %{bname}-contrib-virtual < %{current_major_version}
161    
162     %description contrib
163     The postgresql-contrib package includes the contrib tree distributed with the
164     PostgreSQL tarball. Selected contrib modules are prebuilt.
165    
166     %package devel
167     Summary: PostgreSQL development header files and libraries
168     Group: Development/Databases
169     Requires: postgresql%{current_major_version} = %{version}-%{release}
170     Provides: %{bname}-devel-virtual = %{current_major_version}
171     Conflicts: %{bname}-devel-virtual < %{current_major_version}
172     Requires: %{libname} = %{version}-%{release}
173     Provides: postgresql-libs-devel = %{version}-%{release}
174     Provides: pq-devel = %{version}-%{release}
175     %if %_lib != lib
176     Provides: libpq-devel = %{version}-%{release}
177     %endif
178     Provides: %{_lib}pq-devel = %{version}
179     Conflicts: %{_lib}pq-devel < %{version}
180     Requires: %{libecpg} = %{version}-%{release}
181     Provides: libecpg-devel = %{version}-%{release}
182     Provides: %{_lib}ecpg-devel = %{version}-%{release}
183     Conflicts: %{_lib}ecpg-devel < %{version}-%{release}
184     Provides: %{bname}-devel = %{version}-%{release}
185     Conflicts: %{bname}-devel < %{version}-%{release}
186    
187     %description devel
188     The postgresql-devel package contains the header files and libraries needed to
189     compile C or C++ applications which will directly interact with a PostgreSQL
190     database management server and the ecpg Embedded C Postgres preprocessor. You
191     need to install this package if you want to develop applications which will
192     interact with a PostgreSQL server. If you're installing postgresql-server, you
193     need to install this package.
194    
195     %package pl
196     Summary: Procedurals languages for PostgreSQL
197     Group: Databases
198     Conflicts: libpgsql2
199     Requires: %{name}-plpython = %{version}-%{release}
200     Requires: %{name}-plperl = %{version}-%{release}
201     Requires: %{name}-pltcl = %{version}-%{release}
202     Requires: %{name}-plpgsql = %{version}-%{release}
203     Provides: %{bname}-pl-virtual = %{current_major_version}
204     Conflicts: %{bname}-pl-virtual < %{current_major_version}
205     Conflicts: %{bname}-pl < %{version}-%{release}
206     Provides: %{bname}-pl = %{version}-%{release}
207    
208     %description pl
209     PostgreSQL is an advanced Object-Relational database management system. The
210     postgresql-pl will install the the PL/Perl, PL/Tcl, and PL/Python procedural
211     languages for the backend. PL/Pgsql is part of the core server package.
212    
213     %package plpython
214     Summary: The PL/Python procedural language for PostgreSQL
215     Group: Databases
216     Requires: postgresql%{current_major_version}-server = %{version}
217     Conflicts: postgresql-pl < %version-%release
218     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
219     Provides: %{bname}-plpython-virtual = %{current_major_version}
220     Conflicts: %{bname}-plpython-virtual < %{current_major_version}
221     Conflicts: %{bname}-plpython < %{version}-%{release}
222     Provides: %{bname}-plpython = %{version}-%{release}
223    
224     %description plpython
225     PostgreSQL is an advanced Object-Relational database management system. The
226     postgresql-plpython package contains the the PL/Python procedural languages for
227     the backend. PL/Python is part of the core server package.
228    
229     %package plperl
230     Summary: The PL/Perl procedural language for PostgreSQL
231     Group: Databases
232     Requires: postgresql%{current_major_version}-server = %{version}
233     Requires: perl-base = %{perl_epoch}:%{perl_version}
234     Conflicts: postgresql-pl < %version-%release
235     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
236     Provides: %{bname}-plperl-virtual = %{current_major_version}
237     Conflicts: %{bname}-plperl-virtual < %{current_major_version}
238     Conflicts: %{bname}-plperl < %{version}-%{release}
239     Provides: %{bname}-plperl = %{version}-%{release}
240    
241     %description plperl
242     PostgreSQL is an advanced Object-Relational database management system. The
243     postgresql-plperl package contains the the PL/Perl procedural languages for the
244     backend. PL/Perl is part of the core server package.
245    
246     %package pltcl
247     Summary: The PL/Tcl procedural language for PostgreSQL
248     Group: Databases
249     Requires: postgresql%{current_major_version}-server = %{version}
250     Conflicts: postgresql-pl < %version-%release
251     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
252     Provides: %{bname}-pltcl-virtual = %{current_major_version}
253     Conflicts: %{bname}-pltcl-virtual < %{current_major_version}
254     Conflicts: %{bname}-pltcl < %{version}-%{release}
255     Provides: %{bname}-pltcl = %{version}-%{release}
256    
257     %description pltcl
258     PostgreSQL is an advanced Object-Relational database management system. The
259     postgresql-pltcl package contains the the PL/Tcl procedural languages for the
260     backend. PL/Tcl is part of the core server package.
261    
262     %package plpgsql
263     Summary: The PL/PgSQL procedural language for PostgreSQL
264     Group: Databases
265     Requires: postgresql%{current_major_version}-server = %{version}
266     Conflicts: postgresql-pl < %version-%release
267     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
268     Provides: %{bname}-plpgsql-virtual = %{current_major_version}
269     Conflicts: %{bname}-plpgsql-virtual < %{current_major_version}
270     Conflicts: %{bname}-plpgsql < %{version}-%{release}
271     Provides: %{bname}-plpgsql = %{version}-%{release}
272    
273     %description plpgsql
274     PostgreSQL is an advanced Object-Relational database management system. The
275     postgresql-plpgsql package contains the the PL/PgSQL procedural languages for
276     the backend. PL/PgSQL is part of the core server package.
277    
278     %prep
279 fwang 477003 %setup -q -n %{bname}-%{version}
280 fwang 477006 %apply_patches
281 fwang 298251
282     %build
283    
284     %serverbuild
285    
286 fwang 298259 %configure2_5x \
287 fwang 298251 --disable-rpath \
288     --with-perl \
289     --with-python \
290     --with-tcl --with-tclconfig=%{_libdir} \
291     --with-openssl \
292     --with-pam \
293     --with-libxml \
294     --with-libxslt \
295     --libdir=%{_libdir} \
296     --mandir=%{_mandir} \
297     --prefix=%_prefix \
298     --sysconfdir=%{_sysconfdir}/pgsql \
299     --enable-nls \
300 luigiwalser 378422 %if %{withuuid}
301 fwang 298251 --with-ossp-uuid
302     %endif
303    
304     # $(rpathdir) come from Makefile
305     perl -pi -e 's|^all:|LINK.shared=\$(COMPILER) -shared -Wl,-rpath,\$(rpathdir),-soname,\$(soname)\nall:|' src/pl/plperl/GNUmakefile
306    
307     %make world
308    
309     pushd src/test
310     make all
311     popd
312    
313     %check
314     make check
315    
316     %install
317     make DESTDIR=%{buildroot} install-world install-docs
318    
319     # install odbcinst.ini
320     mkdir -p %{buildroot}%{_sysconfdir}/pgsql
321    
322     # copy over Makefile.global to the include dir....
323     #install -m755 src/Makefile.global %{buildroot}%{_includedir}/pgsql/
324    
325     # PGDATA needs removal of group and world permissions due to pg_pwd hole.
326     install -d -m 700 %{buildroot}/var/lib/pgsql/data
327    
328     # backups of data go here...
329     install -d -m 700 %{buildroot}/var/lib/pgsql/backups
330    
331     # Create the multiple postmaster startup directory
332     install -d -m 700 %{buildroot}/etc/sysconfig/pgsql
333    
334 fwang 298258 # install systemd units
335     mkdir -p %{buildroot}%{_unitdir}
336     install -m 644 %{SOURCE11} %{buildroot}%{_unitdir}/%{bname}.service
337 fwang 298251
338 fwang 477006 # Create the directory for sockets.
339     install -d -m 755 %{buildroot}/var/run/postgresql
340    
341     # ... and make a tmpfiles script to recreate it at reboot.
342     mkdir -p %{buildroot}%{_tmpfilesdir}
343     install -m 0644 %{SOURCE15} %{buildroot}%{_tmpfilesdir}/postgresql.conf
344    
345 neoclust 344748 # install helper script for env initialisation
346 luigiwalser 378422 mkdir -p %{buildroot}%{_libexecdir}
347     install -m 755 %{SOURCE14} %{buildroot}%{_libexecdir}/
348 neoclust 344748
349 luigiwalser 378422 mkdir -p %{buildroot}/var/log/postgres
350 fwang 298251
351 luigiwalser 378422 mkdir -p %{buildroot}%{logrotatedir}
352     cat > %{buildroot}%{logrotatedir}/%{bname} <<EOF
353 fwang 298251 /var/log/postgres/postgresql {
354     notifempty
355     missingok
356     copytruncate
357     }
358     EOF
359    
360     mv %{buildroot}%{_docdir}/%{bname}/html %{buildroot}%{_docdir}/%{name}-docs-%{version}
361    
362     echo -n '' > main.lst
363     for i in \
364     pg_ctl initdb pg_config psql pg_dump pgscripts libpq libecpg \
365     ecpg libpq%{major} ecpglib%{major_ecpg}; do
366     %find_lang $i-%{current_major_version}
367     cat $i-%{current_major_version}.lang >> main.lst
368     %find_lang $i
369     cat $i.lang >> main.lst
370     done
371     echo -n '' > server.lst
372     for i in postgres pg_resetxlog pg_controldata plpgsql plpython plperl pltcl pg_basebackup; do
373     %find_lang $i
374     cat $i.lang >> server.lst
375     %find_lang $i-%{current_major_version}
376     cat $i-%{current_major_version}.lang >> server.lst
377     done
378    
379     # pg_ctl.lang initdb.lang pg_config.lang psql.lang pg_dump.lang pgscripts.lang \
380     # postgres.lang pg_resetxlog.lang pg_controldata.lang \
381     # libpq.lang libecpg.lang \
382    
383     # taken directly in build dir.
384     rm -fr %{buildroot}%{_datadir}/doc/postgresql/contrib/
385     rm -fr %{buildroot}%{_datadir}/doc/postgresql/extension/
386    
387 luigiwalser 378422 mkdir -p %{buildroot}/%{_sys_macros_dir}
388     cat > %{buildroot}/%{_sys_macros_dir}/%{name}.macros <<EOF
389 fwang 298251 %%postgresql_version %{version}
390     %%postgresql_major %{current_major_version}
391     %%postgresql_minor %{current_minor_version}
392     %%pgmodules_req Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
393     EOF
394    
395     cat %{SOURCE13} > postgresql.%{_vendor}.releasenote
396     cat > README.urpmi <<EOF
397     You just installed or updated %{bname} server.
398     You can find important information about %{distribution} %{bname} rpms and database
399     management in:
400    
401     %{_defaultdocdir}/%{name}-server/postgresql.%{_vendor}.releasenote
402    
403     Please read it.
404     EOF
405    
406     # postgres' .profile and .bashrc
407 luigiwalser 378422 install -D -m 700 %{SOURCE10} %{buildroot}/var/lib/pgsql/.profile
408 fwang 298251 (
409     cd %{buildroot}/var/lib/pgsql/
410     ln -s .profile .bashrc
411     )
412    
413 luigiwalser 378422 cat > %{buildroot}%{_sysconfdir}/sysconfig/postgresql <<EOF
414 fwang 298251 # Olivier Thauvin <nanardon@mandriva.org>
415    
416     # The database location:
417     # You probably won't change this
418     # PGDATA=/var/lib/pgsql/data
419    
420     # What is the based locales for postgresql
421     # Setting locales to C allow to use any encoding
422     # ISO or UTF, any other choice will restrict you
423     # either ISO or UTF.
424     LC_ALL=C
425    
426     # These are additional to pass to pg_ctl when starting/restarting postgresql.
427     # PGOPTIONS=
428     EOF
429    
430     %pre server
431     %_pre_useradd postgres /var/lib/pgsql /bin/bash
432    
433 luigiwalser 378422 [ ! -f %{pgdata}/data/PG_VERSION ] && exit 0
434     mypgversion=`cat %{pgdata}/data/PG_VERSION`
435 fwang 298251 [ $mypgversion = %{current_major_version} ] && exit 0
436    
437     echo ""
438     echo "You currently have database tree for Postgresql $mypgversion"
439     echo "You must use postgresql${mypgversion}-server"
440     echo "To update you Postgresql server, dump your databases"
441     echo "delete /var/lib/pgsql/data/ content, upgrade the server, then"
442     echo "restore your databases from your backup"
443     echo ""
444    
445     exit 1
446    
447 neoclust 397736 %post server
448 fwang 298251 %_post_service %{bname}
449    
450     %preun server
451     %_preun_service %{bname}
452    
453     %postun server
454     %_postun_userdel postgres
455    
456     %files -f main.lst
457     %doc doc/KNOWN_BUGS doc/MISSING_FEATURES
458     %doc COPYRIGHT README HISTORY doc/bug.template
459     %{_bindir}/clusterdb
460     %{_bindir}/createdb
461     %{_bindir}/createlang
462     %{_bindir}/createuser
463     %{_bindir}/dropdb
464     %{_bindir}/droplang
465     %{_bindir}/dropuser
466     %{_bindir}/pg_dump
467     %{_bindir}/pg_dumpall
468 fwang 477005 %{_bindir}/pg_isready
469 fwang 298251 %{_bindir}/pg_restore
470     %{_bindir}/psql
471     %{_bindir}/reindexdb
472     %{_bindir}/vacuumdb
473     %{_mandir}/man1/clusterdb.*
474     %{_mandir}/man1/createdb.*
475     %{_mandir}/man1/createlang.*
476     %{_mandir}/man1/createuser.*
477     %{_mandir}/man1/dropdb.*
478     %{_mandir}/man1/droplang.*
479     %{_mandir}/man1/dropuser.*
480     %{_mandir}/man1/pg_dump.*
481     %{_mandir}/man1/pg_dumpall.*
482 fwang 477005 %{_mandir}/man1/pg_isready.*
483 fwang 298251 %{_mandir}/man1/pg_restore.*
484     %{_mandir}/man1/psql.*
485     %{_mandir}/man1/vacuumdb.*
486     %{_mandir}/man1/reindexdb.*
487     %{_mandir}/man7/*
488 luigiwalser 378422 %{_sys_macros_dir}/%{name}.macros
489 fwang 298251
490     %files -n %{libname}
491     %{_libdir}/libpq.so.%{major}*
492    
493     %files -n %{libecpg}
494     %{_libdir}/libecpg.so.%{major_ecpg}*
495     %{_libdir}/libecpg_compat.so.*
496     %{_libdir}/libpgtypes.so.*
497    
498     %files docs
499     %doc %{_docdir}/%{name}-docs-%{version}
500    
501     %files contrib
502     # %doc contrib/*/README.* contrib/spi/*.example
503     %{_libdir}/postgresql/_int.so
504     %{_libdir}/postgresql/btree_gist.so
505     %{_libdir}/postgresql/chkpass.so
506     %{_libdir}/postgresql/cube.so
507     %{_libdir}/postgresql/dblink.so
508     %{_libdir}/postgresql/earthdistance.so
509     %{_libdir}/postgresql/fuzzystrmatch.so
510     %{_libdir}/postgresql/insert_username.so
511     %{_libdir}/postgresql/lo.so
512     %{_libdir}/postgresql/ltree.so
513     %{_libdir}/postgresql/moddatetime.so
514     %{_libdir}/postgresql/pgcrypto.so
515     %{_libdir}/postgresql/pgstattuple.so
516     %{_libdir}/postgresql/refint.so
517     %{_libdir}/postgresql/seg.so
518     %{_libdir}/postgresql/tablefunc.so
519     %{_libdir}/postgresql/timetravel.so
520     %{_libdir}/postgresql/pg_trgm.so
521     %{_libdir}/postgresql/autoinc.so
522     %{_libdir}/postgresql/pg_buffercache.so
523     %{_libdir}/postgresql/adminpack.so
524     %{_libdir}/postgresql/hstore.so
525     %{_libdir}/postgresql/isn.so
526     %{_libdir}/postgresql/pg_freespacemap.so
527     %{_libdir}/postgresql/pgrowlocks.so
528     %{_libdir}/postgresql/sslinfo.so
529     %{_libdir}/postgresql/pageinspect.so
530 fwang 298259 %{_libdir}/postgresql/tcn.so
531 fwang 477005 %{_libdir}/postgresql/postgres_fdw.so
532     %{_libdir}/postgresql/worker_spi.so
533 fwang 298251
534     %{_bindir}/oid2name
535     %{_bindir}/pgbench
536     %{_bindir}/vacuumlo
537 fwang 298259 %{_bindir}/pg_test_timing
538 fwang 477005 %{_bindir}/pg_xlogdump
539 fwang 298259 %{_mandir}/man1/oid2name.1*
540     %{_mandir}/man1/pgbench.1*
541     %{_mandir}/man1/pg_test_timing.1*
542 fwang 477005 %{_mandir}/man1/pg_xlogdump.1*
543 fwang 298259 %{_mandir}/man1/vacuumlo.1*
544 fwang 298251
545     %files server -f server.lst
546     %config(noreplace) %{_sysconfdir}/sysconfig/postgresql
547     %doc README.urpmi postgresql.%{_vendor}.releasenote
548 fwang 298258 %{_unitdir}/%{bname}.service
549 fwang 298251 %{_bindir}/initdb
550     %{_bindir}/pg_controldata
551     %{_bindir}/pg_ctl
552     %{_bindir}/pg_resetxlog
553     %{_bindir}/postgres
554     %{_bindir}/postmaster
555     %{_bindir}/pg_standby
556     %{_bindir}/pg_archivecleanup
557     %{_bindir}/pg_upgrade
558     %{_bindir}/pg_basebackup
559 fwang 298259 %{_bindir}/pg_receivexlog
560 fwang 298251 %{_bindir}/pg_test_fsync
561     %{_mandir}/man1/initdb.1*
562 fwang 298259 %{_mandir}/man1/pg_archivecleanup.1*
563 fwang 298251 %{_mandir}/man1/pg_controldata.*
564     %{_mandir}/man1/pg_ctl.1*
565 fwang 298259 %{_mandir}/man1/pg_receivexlog.1*
566     %{_mandir}/man1/pg_standby.1*
567 fwang 298251 %{_mandir}/man1/pg_resetxlog.*
568     %{_mandir}/man1/postgres.1*
569     %{_mandir}/man1/postmaster.1*
570     %{_mandir}/man1/pg_basebackup.1*
571 fwang 298259 %{_mandir}/man1/pg_test_fsync.1*
572     %{_mandir}/man1/pg_upgrade.1*
573 fwang 298251 %dir %{_libdir}/postgresql
574     %dir %{_datadir}/postgresql
575 fwang 477006 %{_tmpfilesdir}/postgresql.conf
576     %attr(755,postgres,postgres) %dir /var/run/postgresql
577 fwang 477005 %config(noreplace) /var/lib/pgsql/.bashrc
578 fwang 298251 %attr(-,postgres,postgres) /var/lib/pgsql/.profile
579     %attr(700,postgres,postgres) %dir %{pgdata}
580     %attr(-,postgres,postgres) %{pgdata}/data
581     %attr(700,postgres,postgres) %dir %{pgdata}/backups
582     %{_libdir}/postgresql/*_and_*.so
583     %{_libdir}/postgresql/pgxml.so
584     %{_libdir}/postgresql/dict_int.so
585     %{_libdir}/postgresql/dict_xsyn.so
586     %{_libdir}/postgresql/test_parser.so
587     %{_libdir}/postgresql/tsearch2.so
588     %{_libdir}/postgresql/dict_snowball.so
589     %{_libdir}/postgresql/auto_explain.so
590     %{_libdir}/postgresql/btree_gin.so
591     %{_libdir}/postgresql/citext.so
592     %{_libdir}/postgresql/pg_stat_statements.so
593     %{_libdir}/postgresql/auth_delay.so
594     %{_libdir}/postgresql/dummy_seclabel.so
595     %{_libdir}/postgresql/file_fdw.so
596 neoclust 344748 %{_libexecdir}/postgresql_initdb.sh
597 luigiwalser 378422 %if %{withuuid}
598 fwang 298251 %{_libdir}/postgresql/uuid-ossp.so
599     %endif
600     %{_libdir}/postgresql/euc2004_sjis2004.so
601     %{_libdir}/postgresql/libpqwalreceiver.so
602     %{_libdir}/postgresql/passwordcheck.so
603     %{_libdir}/postgresql/pg_upgrade_support.so
604     %{_libdir}/postgresql/unaccent.so
605     %{_datadir}/postgresql/postgres.bki
606     %{_datadir}/postgresql/postgres.description
607     %{_datadir}/postgresql/*.sample
608     %{_datadir}/postgresql/timezone
609     %{_datadir}/postgresql/system_views.sql
610     %{_datadir}/postgresql/conversion_create.sql
611     %{_datadir}/postgresql/information_schema.sql
612     %{_datadir}/postgresql/snowball_create.sql
613     %{_datadir}/postgresql/sql_features.txt
614     %{_datadir}/postgresql/postgres.shdescription
615     %dir %{_datadir}/postgresql/timezonesets
616     %{_datadir}/postgresql/timezonesets/Africa.txt
617     %{_datadir}/postgresql/timezonesets/America.txt
618     %{_datadir}/postgresql/timezonesets/Antarctica.txt
619     %{_datadir}/postgresql/timezonesets/Asia.txt
620     %{_datadir}/postgresql/timezonesets/Atlantic.txt
621     %{_datadir}/postgresql/timezonesets/Australia
622     %{_datadir}/postgresql/timezonesets/Australia.txt
623     %{_datadir}/postgresql/timezonesets/Default
624     %{_datadir}/postgresql/timezonesets/Etc.txt
625     %{_datadir}/postgresql/timezonesets/Europe.txt
626     %{_datadir}/postgresql/timezonesets/India
627     %{_datadir}/postgresql/timezonesets/Indian.txt
628     %{_datadir}/postgresql/timezonesets/Pacific.txt
629     %{_datadir}/postgresql/tsearch_data
630     %{_datadir}/postgresql/extension
631    
632     %attr(700,postgres,postgres) %dir /var/log/postgres
633 luigiwalser 378422 %{logrotatedir}/%{bname}
634 fwang 298251
635     %files devel
636     # %doc doc/TODO doc/TODO.detail
637     %{_includedir}/*
638     %{_bindir}/ecpg
639     %{_libdir}/lib*.so
640 fwang 298885 %{_libdir}/lib*.a
641 fwang 477005 %{_libdir}/pkgconfig/*.pc
642 fwang 298251 %{_libdir}/postgresql/pgxs/
643     %{_mandir}/man1/ecpg.1*
644     %{_bindir}/pg_config
645     %{_mandir}/man1/pg_config.1*
646     %{_mandir}/man3/SPI_*.3*
647     %{_mandir}/man3/dblink*.3*
648    
649     %files pl
650    
651     %files plpython
652     %{_libdir}/postgresql/plpython2.so
653    
654     %files plperl
655     %{_libdir}/postgresql/plperl.so
656    
657     %files pltcl
658     %{_libdir}/postgresql/pltcl.so
659     %{_bindir}/pltcl_delmod
660     %{_bindir}/pltcl_listmod
661     %{_bindir}/pltcl_loadmod
662     %{_datadir}/postgresql/unknown.pltcl
663    
664     %files plpgsql
665     %{_libdir}/postgresql/plpgsql.so

  ViewVC Help
Powered by ViewVC 1.1.30