/[packages]/cauldron/postgresql9.4/current/SPECS/postgresql9.4.spec
ViewVC logotype

Annotation of /cauldron/postgresql9.4/current/SPECS/postgresql9.4.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 798277 - (hide annotations) (download)
Sat Nov 22 09:40:59 2014 UTC (9 years, 5 months ago) by cjw
File size: 23369 byte(s)
imported package postgresql9.4
1 cjw 798277 %define Werror_cflags %{nil}
2     %define _disable_ld_no_undefined 1
3    
4     %define perl_version %(rpm -q --qf "%{VERSION}" perl)
5     %define perl_epoch %(rpm -q --qf "%{EPOCH}" perl)
6    
7     %define pgdata /var/lib/pgsql
8     %define logrotatedir %{_sysconfdir}/logrotate.d
9    
10     %define major 5
11     %define major_ecpg 6
12    
13     %define bname postgresql
14     %define current_major_version 9.4
15     # upstream minor version, comment out for releases without minor version
16     #define current_minor_version 0
17     # upstream prerelease name, comment out for final releases
18     %define beta rc1
19    
20     %define rel 0.%{beta}.1
21    
22    
23     %define libname %mklibname pq%{current_major_version} _%{major}
24     %define libecpg %mklibname ecpg%{current_major_version} _%{major_ecpg}
25    
26     %define withuuid 1
27    
28     Summary: PostgreSQL client programs and libraries
29     Name: %{bname}%{current_major_version}
30     Version: %{current_major_version}%{?current_minor_version:.}%{?current_minor_version}
31     Release: %mkrel %{rel}
32     License: BSD
33     Group: Databases
34     URL: http://www.postgresql.org/
35     Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}%{?beta}.tar.bz2
36     Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}%{?beta}.tar.bz2.md5
37     Source10: postgres.profile
38     Source11: postgresql.service
39     Source13: postgresql.distro.releasenote
40     Source14: postgresql_initdb.sh
41     Source15: postgresql.tmpfiles.d
42    
43     Requires: perl
44     Provides: postgresql-clients = %{version}-%{release}
45     Conflicts: postgresql-clients < %{version}-%{release}
46     BuildRequires: bison
47     BuildRequires: flex
48     BuildRequires: openssl-devel
49     BuildRequires: pam-devel
50     BuildRequires: perl-devel
51     BuildRequires: python-devel
52     BuildRequires: readline-devel
53     BuildRequires: tcl-devel
54     BuildRequires: libxml2-devel
55     BuildRequires: libxslt-devel
56     BuildRequires: zlib-devel
57     %if %withuuid
58     BuildRequires: ossp_uuid-devel
59     %endif
60     # Need to build doc
61     BuildRequires: docbook-dtd42-sgml
62     BuildRequires: openjade
63     BuildRequires: docbook-utils
64     BuildRequires: docbook-style-xsl
65     BuildRequires: xsltproc
66     Provides: %{bname}-virtual = %{current_major_version}
67     Conflicts: %{bname}-virtual < %{current_major_version}
68     Provides: %{bname} = %{version}-%{release}
69     Conflicts: %{bname} < %{version}-%{release}
70    
71     %description
72     PostgreSQL is an advanced Object-Relational database management system (DBMS)
73     that supports almost all SQL constructs (including transactions, subselects and
74     user-defined types and functions). The postgresql package includes the client
75     programs and libraries that you'll need to access a PostgreSQL DBMS server.
76     These PostgreSQL client programs are programs that directly manipulate the
77     internal structure of PostgreSQL databases on a PostgreSQL server. These client
78     programs can be located on the same machine with the PostgreSQL server, or may
79     be on a remote machine which accesses a PostgreSQL server over a network
80     connection. This package contains the client libraries for C and C++, as well
81     as command-line utilities for managing PostgreSQL databases on a PostgreSQL
82     server.
83    
84     If you want to manipulate a PostgreSQL database on a remote PostgreSQL server,
85     you need this package. You also need to install this package if you're
86     installing the postgresql-server package.
87    
88     %package -n %{libname}
89     Summary: The shared libraries required for any PostgreSQL clients
90     Group: System/Libraries
91     Conflicts: %mklibname pq 9.3 5
92     Conflicts: %mklibname pq 9.2 5
93     Conflicts: %mklibname pq 9.1 5
94     Conflicts: %mklibname pq 9.0 5
95     Provides: postgresql-libs = %{version}-%{release}
96     Provides: libpq = %{version}-%{release}
97     Provides: %{libname}-virtual = %{current_major_version}
98     Conflicts: %{libname}-virtual < %{current_major_version}
99    
100     %description -n %{libname}
101     C and C++ libraries to enable user programs to communicate with the PostgreSQL
102     database backend. The backend can be on another machine and accessed through
103     TCP/IP.
104    
105     %package -n %{libecpg}
106     Summary: Shared library libecpg for PostgreSQL
107     Group: System/Libraries
108     Requires: postgresql%{current_major_version} = %{version}-%{release}
109     Provides: libecpg = %{version}-%{release}
110     Provides: %{libecpg}-virtual = %{current_major_version}
111     Conflicts: %{libecpg}-virtual < %{current_major_version}
112    
113     %description -n %{libecpg}
114     Libecpg is used by programs built with ecpg (Embedded PostgreSQL for C) Use
115     postgresql-dev to develop such programs.
116    
117     %package server
118     Summary: The programs needed to create and run a PostgreSQL server
119     Group: Databases
120     Provides: sqlserver
121     Requires(post): %{libname} >= %{version}-%{release}
122     Requires(preun): %{libname} >= %{version}-%{release}
123     # add/remove services
124     Requires(post): rpm-helper
125     Requires(preun): rpm-helper
126     # add/del user
127     Requires(pre): rpm-helper
128     Requires(postun): rpm-helper
129     Requires(pre): postgresql%{current_major_version} >= %{version}-%{release}
130     Requires(post): postgresql%{current_major_version} >= %{version}-%{release}
131     Provides: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
132     Provides: %{bname}-server-virtual = %{current_major_version}
133     Conflicts: %{bname}-server-virtual < %{current_major_version}
134     Provides: %{bname}-server = %{version}-%{release}
135     Requires: postgresql-plpgsql = %{version}-%{release}
136    
137     %description server
138     The postgresql-server package includes the programs needed to create and run a
139     PostgreSQL server, which will in turn allow you to create and maintain
140     PostgreSQL databases. PostgreSQL is an advanced Object-Relational database
141     management system (DBMS) that supports almost all SQL constructs (including
142     transactions, subselects and user-defined types and functions). You should
143     install postgresql-server if you want to create and maintain your own
144     PostgreSQL databases and/or your own PostgreSQL server. You also need to
145     install the postgresql and postgresql-devel packages.
146    
147     After installing this package, please read postgresql.%{_vendor}.releasenote.
148    
149     %package docs
150     Summary: Extra documentation for PostgreSQL
151     Group: Databases
152     BuildArch: noarch
153     Provides: %{bname}-docs-virtual = %{current_major_version}
154     Conflicts: %{bname}-docs-virtual < %{current_major_version}
155    
156     %description docs
157     The postgresql-docs package includes the SGML source for the documentation as
158     well as the documentation in other formats, and some extra documentation.
159     Install this package if you want to help with the PostgreSQL documentation
160     project, or if you want to generate printed documentation.
161    
162     %package contrib
163     Summary: Contributed binaries distributed with PostgreSQL
164     Group: Databases
165     Requires: postgresql%{current_major_version}-server = %{version}-%{release}
166     Provides: %{bname}-contrib-virtual = %{current_major_version}
167     Conflicts: %{bname}-contrib-virtual < %{current_major_version}
168    
169     %description contrib
170     The postgresql-contrib package includes the contrib tree distributed with the
171     PostgreSQL tarball. Selected contrib modules are prebuilt.
172    
173     %package devel
174     Summary: PostgreSQL development header files and libraries
175     Group: Development/Databases
176     Requires: postgresql%{current_major_version} = %{version}-%{release}
177     Provides: %{bname}-devel-virtual = %{current_major_version}
178     Conflicts: %{bname}-devel-virtual < %{current_major_version}
179     Requires: %{libname} = %{version}-%{release}
180     Provides: postgresql-libs-devel = %{version}-%{release}
181     Provides: pq-devel = %{version}-%{release}
182     %if %_lib != lib
183     Provides: libpq-devel = %{version}-%{release}
184     %endif
185     Provides: %{_lib}pq-devel = %{version}
186     Conflicts: %{_lib}pq-devel < %{version}
187     Requires: %{libecpg} = %{version}-%{release}
188     Provides: libecpg-devel = %{version}-%{release}
189     Provides: %{_lib}ecpg-devel = %{version}-%{release}
190     Conflicts: %{_lib}ecpg-devel < %{version}-%{release}
191     Provides: %{bname}-devel = %{version}-%{release}
192     Conflicts: %{bname}-devel < %{version}-%{release}
193    
194     %description devel
195     The postgresql-devel package contains the header files and libraries needed to
196     compile C or C++ applications which will directly interact with a PostgreSQL
197     database management server and the ecpg Embedded C Postgres preprocessor. You
198     need to install this package if you want to develop applications which will
199     interact with a PostgreSQL server. If you're installing postgresql-server, you
200     need to install this package.
201    
202     %package pl
203     Summary: Procedurals languages for PostgreSQL
204     Group: Databases
205     Conflicts: libpgsql2
206     Requires: %{name}-plpython = %{version}-%{release}
207     Requires: %{name}-plperl = %{version}-%{release}
208     Requires: %{name}-pltcl = %{version}-%{release}
209     Requires: %{name}-plpgsql = %{version}-%{release}
210     Provides: %{bname}-pl-virtual = %{current_major_version}
211     Conflicts: %{bname}-pl-virtual < %{current_major_version}
212     Conflicts: %{bname}-pl < %{version}-%{release}
213     Provides: %{bname}-pl = %{version}-%{release}
214    
215     %description pl
216     PostgreSQL is an advanced Object-Relational database management system. The
217     postgresql-pl will install the the PL/Perl, PL/Tcl, and PL/Python procedural
218     languages for the backend. PL/Pgsql is part of the core server package.
219    
220     %package plpython
221     Summary: The PL/Python procedural language for PostgreSQL
222     Group: Databases
223     Requires: postgresql%{current_major_version}-server = %{version}
224     Conflicts: postgresql-pl < %version-%release
225     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
226     Provides: %{bname}-plpython-virtual = %{current_major_version}
227     Conflicts: %{bname}-plpython-virtual < %{current_major_version}
228     Conflicts: %{bname}-plpython < %{version}-%{release}
229     Provides: %{bname}-plpython = %{version}-%{release}
230    
231     %description plpython
232     PostgreSQL is an advanced Object-Relational database management system. The
233     postgresql-plpython package contains the the PL/Python procedural languages for
234     the backend. PL/Python is part of the core server package.
235    
236     %package plperl
237     Summary: The PL/Perl procedural language for PostgreSQL
238     Group: Databases
239     Requires: postgresql%{current_major_version}-server = %{version}
240     Requires: perl-base = %{perl_epoch}:%{perl_version}
241     Conflicts: postgresql-pl < %version-%release
242     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
243     Provides: %{bname}-plperl-virtual = %{current_major_version}
244     Conflicts: %{bname}-plperl-virtual < %{current_major_version}
245     Conflicts: %{bname}-plperl < %{version}-%{release}
246     Provides: %{bname}-plperl = %{version}-%{release}
247    
248     %description plperl
249     PostgreSQL is an advanced Object-Relational database management system. The
250     postgresql-plperl package contains the the PL/Perl procedural languages for the
251     backend. PL/Perl is part of the core server package.
252    
253     %package pltcl
254     Summary: The PL/Tcl procedural language for PostgreSQL
255     Group: Databases
256     Requires: postgresql%{current_major_version}-server = %{version}
257     Conflicts: postgresql-pl < %version-%release
258     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
259     Provides: %{bname}-pltcl-virtual = %{current_major_version}
260     Conflicts: %{bname}-pltcl-virtual < %{current_major_version}
261     Conflicts: %{bname}-pltcl < %{version}-%{release}
262     Provides: %{bname}-pltcl = %{version}-%{release}
263    
264     %description pltcl
265     PostgreSQL is an advanced Object-Relational database management system. The
266     postgresql-pltcl package contains the the PL/Tcl procedural languages for the
267     backend. PL/Tcl is part of the core server package.
268    
269     %package plpgsql
270     Summary: The PL/PgSQL procedural language for PostgreSQL
271     Group: Databases
272     Requires: postgresql%{current_major_version}-server = %{version}
273     Conflicts: postgresql-pl < %version-%release
274     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
275     Provides: %{bname}-plpgsql-virtual = %{current_major_version}
276     Conflicts: %{bname}-plpgsql-virtual < %{current_major_version}
277     Conflicts: %{bname}-plpgsql < %{version}-%{release}
278     Provides: %{bname}-plpgsql = %{version}-%{release}
279    
280     %description plpgsql
281     PostgreSQL is an advanced Object-Relational database management system. The
282     postgresql-plpgsql package contains the the PL/PgSQL procedural languages for
283     the backend. PL/PgSQL is part of the core server package.
284    
285     %prep
286     %setup -q -n %{bname}-%{version}%{?beta}
287     %apply_patches
288    
289     %build
290    
291     %serverbuild
292    
293     %configure2_5x \
294     --disable-rpath \
295     --with-perl \
296     --with-python \
297     --with-tcl --with-tclconfig=%{_libdir} \
298     --with-openssl \
299     --with-pam \
300     --with-libxml \
301     --with-libxslt \
302     --libdir=%{_libdir} \
303     --mandir=%{_mandir} \
304     --prefix=%_prefix \
305     --sysconfdir=%{_sysconfdir}/pgsql \
306     --enable-nls \
307     %if %{withuuid}
308     --with-ossp-uuid
309     %endif
310    
311     # $(rpathdir) come from Makefile
312     perl -pi -e 's|^all:|LINK.shared=\$(COMPILER) -shared -Wl,-rpath,\$(rpathdir),-soname,\$(soname)\nall:|' src/pl/plperl/GNUmakefile
313    
314     %make world
315    
316     pushd src/test
317     make all
318     popd
319    
320     %check
321     make check
322    
323     %install
324     make DESTDIR=%{buildroot} install-world install-docs
325    
326     # install odbcinst.ini
327     mkdir -p %{buildroot}%{_sysconfdir}/pgsql
328    
329     # copy over Makefile.global to the include dir....
330     #install -m755 src/Makefile.global %{buildroot}%{_includedir}/pgsql/
331    
332     # PGDATA needs removal of group and world permissions due to pg_pwd hole.
333     install -d -m 700 %{buildroot}/var/lib/pgsql/data
334    
335     # backups of data go here...
336     install -d -m 700 %{buildroot}/var/lib/pgsql/backups
337    
338     # Create the multiple postmaster startup directory
339     install -d -m 700 %{buildroot}/etc/sysconfig/pgsql
340    
341     # install systemd units
342     mkdir -p %{buildroot}%{_unitdir}
343     install -m 644 %{SOURCE11} %{buildroot}%{_unitdir}/%{bname}.service
344    
345     # Create the directory for sockets.
346     install -d -m 755 %{buildroot}/var/run/postgresql
347    
348     # ... and make a tmpfiles script to recreate it at reboot.
349     mkdir -p %{buildroot}%{_tmpfilesdir}
350     install -m 0644 %{SOURCE15} %{buildroot}%{_tmpfilesdir}/postgresql.conf
351    
352     # install helper script for env initialisation
353     mkdir -p %{buildroot}%{_libexecdir}
354     install -m 755 %{SOURCE14} %{buildroot}%{_libexecdir}/
355    
356     mkdir -p %{buildroot}/var/log/postgres
357    
358     mkdir -p %{buildroot}%{logrotatedir}
359     cat > %{buildroot}%{logrotatedir}/%{bname} <<EOF
360     /var/log/postgres/postgresql {
361     notifempty
362     missingok
363     copytruncate
364     }
365     EOF
366    
367     mv %{buildroot}%{_docdir}/%{bname}/html %{buildroot}%{_docdir}/%{name}-docs-%{version}
368    
369     echo -n '' > main.lst
370     for i in \
371     pg_ctl initdb pg_config psql pg_dump pgscripts libpq libecpg \
372     ecpg libpq%{major} ecpglib%{major_ecpg}; do
373     %find_lang $i-%{current_major_version}
374     cat $i-%{current_major_version}.lang >> main.lst
375     %find_lang $i
376     cat $i.lang >> main.lst
377     done
378     echo -n '' > server.lst
379     for i in postgres pg_resetxlog pg_controldata plpgsql plpython plperl pltcl pg_basebackup; do
380     %find_lang $i
381     cat $i.lang >> server.lst
382     %find_lang $i-%{current_major_version}
383     cat $i-%{current_major_version}.lang >> server.lst
384     done
385    
386     # pg_ctl.lang initdb.lang pg_config.lang psql.lang pg_dump.lang pgscripts.lang \
387     # postgres.lang pg_resetxlog.lang pg_controldata.lang \
388     # libpq.lang libecpg.lang \
389    
390     # taken directly in build dir.
391     rm -fr %{buildroot}%{_datadir}/doc/postgresql/contrib/
392     rm -fr %{buildroot}%{_datadir}/doc/postgresql/extension/
393    
394     mkdir -p %{buildroot}/%{_sys_macros_dir}
395     cat > %{buildroot}/%{_sys_macros_dir}/%{name}.macros <<EOF
396     %%postgresql_version %{version}
397     %%postgresql_major %{current_major_version}
398     %%postgresql_minor %{current_minor_version}
399     %%pgmodules_req Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
400     EOF
401    
402     cat %{SOURCE13} > postgresql.%{_vendor}.releasenote
403     cat > README.urpmi <<EOF
404     You just installed or updated %{bname} server.
405     You can find important information about %{distribution} %{bname} rpms and database
406     management in:
407    
408     %{_defaultdocdir}/%{name}-server/postgresql.%{_vendor}.releasenote
409    
410     Please read it.
411     EOF
412    
413     # postgres' .profile and .bashrc
414     install -D -m 700 %{SOURCE10} %{buildroot}/var/lib/pgsql/.profile
415     (
416     cd %{buildroot}/var/lib/pgsql/
417     ln -s .profile .bashrc
418     )
419    
420     cat > %{buildroot}%{_sysconfdir}/sysconfig/postgresql <<EOF
421     # Olivier Thauvin <nanardon@mandriva.org>
422    
423     # The database location:
424     # You probably won't change this
425     # PGDATA=/var/lib/pgsql/data
426    
427     # What is the based locales for postgresql
428     # Setting locales to C allow to use any encoding
429     # ISO or UTF, any other choice will restrict you
430     # either ISO or UTF.
431     LC_ALL=C
432    
433     # These are additional to pass to pg_ctl when starting/restarting postgresql.
434     # PGOPTIONS=
435     EOF
436    
437     %pre server
438     %_pre_useradd postgres /var/lib/pgsql /bin/bash
439    
440     [ ! -f %{pgdata}/data/PG_VERSION ] && exit 0
441     mypgversion=`cat %{pgdata}/data/PG_VERSION`
442     [ $mypgversion = %{current_major_version} ] && exit 0
443    
444     echo ""
445     echo "You currently have database tree for Postgresql $mypgversion"
446     echo "You must use postgresql${mypgversion}-server"
447     echo "To update you Postgresql server, dump your databases"
448     echo "delete /var/lib/pgsql/data/ content, upgrade the server, then"
449     echo "restore your databases from your backup"
450     echo ""
451    
452     exit 1
453    
454     %post server
455     %_post_service %{bname}
456    
457     %_tmpfilescreate %{_tmpfilesdir}/%{bname}
458    
459     %preun server
460     %_preun_service %{bname}
461    
462     %postun server
463     %_postun_userdel postgres
464    
465     %files -f main.lst
466     %doc doc/KNOWN_BUGS doc/MISSING_FEATURES
467     %doc COPYRIGHT README HISTORY doc/bug.template
468     %{_bindir}/clusterdb
469     %{_bindir}/createdb
470     %{_bindir}/createlang
471     %{_bindir}/createuser
472     %{_bindir}/dropdb
473     %{_bindir}/droplang
474     %{_bindir}/dropuser
475     %{_bindir}/pg_dump
476     %{_bindir}/pg_dumpall
477     %{_bindir}/pg_isready
478     %{_bindir}/pg_restore
479     %{_bindir}/psql
480     %{_bindir}/reindexdb
481     %{_bindir}/vacuumdb
482     %{_mandir}/man1/clusterdb.*
483     %{_mandir}/man1/createdb.*
484     %{_mandir}/man1/createlang.*
485     %{_mandir}/man1/createuser.*
486     %{_mandir}/man1/dropdb.*
487     %{_mandir}/man1/droplang.*
488     %{_mandir}/man1/dropuser.*
489     %{_mandir}/man1/pg_dump.*
490     %{_mandir}/man1/pg_dumpall.*
491     %{_mandir}/man1/pg_isready.*
492     %{_mandir}/man1/pg_restore.*
493     %{_mandir}/man1/psql.*
494     %{_mandir}/man1/vacuumdb.*
495     %{_mandir}/man1/reindexdb.*
496     %{_mandir}/man7/*
497     %{_sys_macros_dir}/%{name}.macros
498    
499     %files -n %{libname}
500     %{_libdir}/libpq.so.%{major}*
501    
502     %files -n %{libecpg}
503     %{_libdir}/libecpg.so.%{major_ecpg}*
504     %{_libdir}/libecpg_compat.so.*
505     %{_libdir}/libpgtypes.so.*
506    
507     %files docs
508     %doc %{_docdir}/%{name}-docs-%{version}
509    
510     %files contrib
511     # %doc contrib/*/README.* contrib/spi/*.example
512     %{_libdir}/postgresql/_int.so
513     %{_libdir}/postgresql/btree_gist.so
514     %{_libdir}/postgresql/chkpass.so
515     %{_libdir}/postgresql/cube.so
516     %{_libdir}/postgresql/dblink.so
517     %{_libdir}/postgresql/earthdistance.so
518     %{_libdir}/postgresql/fuzzystrmatch.so
519     %{_libdir}/postgresql/insert_username.so
520     %{_libdir}/postgresql/lo.so
521     %{_libdir}/postgresql/ltree.so
522     %{_libdir}/postgresql/moddatetime.so
523     %{_libdir}/postgresql/pgcrypto.so
524     %{_libdir}/postgresql/pgstattuple.so
525     %{_libdir}/postgresql/refint.so
526     %{_libdir}/postgresql/seg.so
527     %{_libdir}/postgresql/tablefunc.so
528     %{_libdir}/postgresql/timetravel.so
529     %{_libdir}/postgresql/pg_trgm.so
530     %{_libdir}/postgresql/autoinc.so
531     %{_libdir}/postgresql/pg_buffercache.so
532     %{_libdir}/postgresql/adminpack.so
533     %{_libdir}/postgresql/hstore.so
534     %{_libdir}/postgresql/isn.so
535     %{_libdir}/postgresql/pg_freespacemap.so
536     %{_libdir}/postgresql/pgrowlocks.so
537     %{_libdir}/postgresql/sslinfo.so
538     %{_libdir}/postgresql/pageinspect.so
539     %{_libdir}/postgresql/tcn.so
540     %{_libdir}/postgresql/postgres_fdw.so
541     %{_libdir}/postgresql/worker_spi.so
542    
543     %{_bindir}/oid2name
544     %{_bindir}/pgbench
545     %{_bindir}/vacuumlo
546     %{_bindir}/pg_test_timing
547     %{_bindir}/pg_xlogdump
548     %{_mandir}/man1/oid2name.1*
549     %{_mandir}/man1/pgbench.1*
550     %{_mandir}/man1/pg_test_timing.1*
551     %{_mandir}/man1/pg_xlogdump.1*
552     %{_mandir}/man1/vacuumlo.1*
553    
554     %files server -f server.lst
555     %config(noreplace) %{_sysconfdir}/sysconfig/postgresql
556     %doc README.urpmi postgresql.%{_vendor}.releasenote
557     %{_unitdir}/%{bname}.service
558     %{_bindir}/initdb
559     %{_bindir}/pg_archivecleanup
560     %{_bindir}/pg_basebackup
561     %{_bindir}/pg_controldata
562     %{_bindir}/pg_ctl
563     %{_bindir}/pg_receivexlog
564     %{_bindir}/pg_recvlogical
565     %{_bindir}/pg_resetxlog
566     %{_bindir}/pg_standby
567     %{_bindir}/pg_test_fsync
568     %{_bindir}/pg_upgrade
569     %{_bindir}/postgres
570     %{_bindir}/postmaster
571     %{_mandir}/man1/initdb.1*
572     %{_mandir}/man1/pg_archivecleanup.1*
573     %{_mandir}/man1/pg_basebackup.1*
574     %{_mandir}/man1/pg_controldata.*
575     %{_mandir}/man1/pg_ctl.1*
576     %{_mandir}/man1/pg_receivexlog.1*
577     %{_mandir}/man1/pg_recvlogical.1*
578     %{_mandir}/man1/pg_resetxlog.*
579     %{_mandir}/man1/pg_standby.1*
580     %{_mandir}/man1/pg_test_fsync.1*
581     %{_mandir}/man1/pg_upgrade.1*
582     %{_mandir}/man1/postgres.1*
583     %{_mandir}/man1/postmaster.1*
584     %dir %{_libdir}/postgresql
585     %dir %{_datadir}/postgresql
586     %{_tmpfilesdir}/postgresql.conf
587     %attr(755,postgres,postgres) %ghost %dir /var/run/postgresql
588     %config(noreplace) /var/lib/pgsql/.bashrc
589     %attr(-,postgres,postgres) /var/lib/pgsql/.profile
590     %attr(700,postgres,postgres) %dir %{pgdata}
591     %attr(-,postgres,postgres) %{pgdata}/data
592     %attr(700,postgres,postgres) %dir %{pgdata}/backups
593     %{_libdir}/postgresql/*_and_*.so
594     %{_libdir}/postgresql/auth_delay.so
595     %{_libdir}/postgresql/auto_explain.so
596     %{_libdir}/postgresql/btree_gin.so
597     %{_libdir}/postgresql/citext.so
598     %{_libdir}/postgresql/dict_int.so
599     %{_libdir}/postgresql/dict_snowball.so
600     %{_libdir}/postgresql/dict_xsyn.so
601     %{_libdir}/postgresql/dummy_seclabel.so
602     %{_libdir}/postgresql/file_fdw.so
603     %{_libdir}/postgresql/pg_prewarm.so
604     %{_libdir}/postgresql/pg_stat_statements.so
605     %{_libdir}/postgresql/pgxml.so
606     %{_libdir}/postgresql/test_decoding.so
607     %{_libdir}/postgresql/test_parser.so
608     %{_libdir}/postgresql/test_shm_mq.so
609     %{_libdir}/postgresql/tsearch2.so
610     %{_libexecdir}/postgresql_initdb.sh
611     %if %{withuuid}
612     %{_libdir}/postgresql/uuid-ossp.so
613     %endif
614     %{_libdir}/postgresql/euc2004_sjis2004.so
615     %{_libdir}/postgresql/libpqwalreceiver.so
616     %{_libdir}/postgresql/passwordcheck.so
617     %{_libdir}/postgresql/pg_upgrade_support.so
618     %{_libdir}/postgresql/unaccent.so
619     %{_datadir}/postgresql/postgres.bki
620     %{_datadir}/postgresql/postgres.description
621     %{_datadir}/postgresql/*.sample
622     %{_datadir}/postgresql/timezone
623     %{_datadir}/postgresql/system_views.sql
624     %{_datadir}/postgresql/conversion_create.sql
625     %{_datadir}/postgresql/information_schema.sql
626     %{_datadir}/postgresql/snowball_create.sql
627     %{_datadir}/postgresql/sql_features.txt
628     %{_datadir}/postgresql/postgres.shdescription
629     %dir %{_datadir}/postgresql/timezonesets
630     %{_datadir}/postgresql/timezonesets/Africa.txt
631     %{_datadir}/postgresql/timezonesets/America.txt
632     %{_datadir}/postgresql/timezonesets/Antarctica.txt
633     %{_datadir}/postgresql/timezonesets/Asia.txt
634     %{_datadir}/postgresql/timezonesets/Atlantic.txt
635     %{_datadir}/postgresql/timezonesets/Australia
636     %{_datadir}/postgresql/timezonesets/Australia.txt
637     %{_datadir}/postgresql/timezonesets/Default
638     %{_datadir}/postgresql/timezonesets/Etc.txt
639     %{_datadir}/postgresql/timezonesets/Europe.txt
640     %{_datadir}/postgresql/timezonesets/India
641     %{_datadir}/postgresql/timezonesets/Indian.txt
642     %{_datadir}/postgresql/timezonesets/Pacific.txt
643     %{_datadir}/postgresql/tsearch_data
644     %{_datadir}/postgresql/extension
645    
646     %attr(700,postgres,postgres) %dir /var/log/postgres
647     %{logrotatedir}/%{bname}
648    
649     %files devel
650     # %doc doc/TODO doc/TODO.detail
651     %{_includedir}/*
652     %{_bindir}/ecpg
653     %{_libdir}/lib*.so
654     %{_libdir}/lib*.a
655     %{_libdir}/pkgconfig/*.pc
656     %{_libdir}/postgresql/pgxs/
657     %{_mandir}/man1/ecpg.1*
658     %{_bindir}/pg_config
659     %{_mandir}/man1/pg_config.1*
660     %{_mandir}/man3/SPI_*.3*
661     %{_mandir}/man3/dblink*.3*
662    
663     %files pl
664    
665     %files plpython
666     %{_libdir}/postgresql/plpython2.so
667    
668     %files plperl
669     %{_libdir}/postgresql/plperl.so
670    
671     %files pltcl
672     %{_libdir}/postgresql/pltcl.so
673     %{_bindir}/pltcl_delmod
674     %{_bindir}/pltcl_listmod
675     %{_bindir}/pltcl_loadmod
676     %{_datadir}/postgresql/unknown.pltcl
677    
678     %files plpgsql
679     %{_libdir}/postgresql/plpgsql.so

  ViewVC Help
Powered by ViewVC 1.1.30