/[packages]/cauldron/postgresql9.4/current/SPECS/postgresql9.4.spec
ViewVC logotype

Annotation of /cauldron/postgresql9.4/current/SPECS/postgresql9.4.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 798833 - (hide annotations) (download)
Mon Nov 24 15:35:42 2014 UTC (9 years, 4 months ago) by cjw
File size: 23610 byte(s)
- remove incorrect -fPIC from optflags

1 cjw 798277 %define Werror_cflags %{nil}
2     %define _disable_ld_no_undefined 1
3    
4     %define perl_version %(rpm -q --qf "%{VERSION}" perl)
5     %define perl_epoch %(rpm -q --qf "%{EPOCH}" perl)
6    
7     %define pgdata /var/lib/pgsql
8     %define logrotatedir %{_sysconfdir}/logrotate.d
9    
10     %define major 5
11     %define major_ecpg 6
12    
13     %define bname postgresql
14     %define current_major_version 9.4
15     # upstream minor version, comment out for releases without minor version
16     #define current_minor_version 0
17     # upstream prerelease name, comment out for final releases
18     %define beta rc1
19    
20 cjw 798833 %define rel 0.%{beta}.2
21 cjw 798277
22    
23     %define libname %mklibname pq%{current_major_version} _%{major}
24     %define libecpg %mklibname ecpg%{current_major_version} _%{major_ecpg}
25    
26     %define withuuid 1
27    
28     Summary: PostgreSQL client programs and libraries
29     Name: %{bname}%{current_major_version}
30     Version: %{current_major_version}%{?current_minor_version:.}%{?current_minor_version}
31     Release: %mkrel %{rel}
32     License: BSD
33     Group: Databases
34     URL: http://www.postgresql.org/
35     Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}%{?beta}.tar.bz2
36     Source5: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}%{?beta}.tar.bz2.md5
37     Source10: postgres.profile
38     Source11: postgresql.service
39     Source13: postgresql.distro.releasenote
40     Source14: postgresql_initdb.sh
41     Source15: postgresql.tmpfiles.d
42    
43     Requires: perl
44     Provides: postgresql-clients = %{version}-%{release}
45     Conflicts: postgresql-clients < %{version}-%{release}
46     BuildRequires: bison
47     BuildRequires: flex
48     BuildRequires: openssl-devel
49     BuildRequires: pam-devel
50     BuildRequires: perl-devel
51     BuildRequires: python-devel
52     BuildRequires: readline-devel
53     BuildRequires: tcl-devel
54     BuildRequires: libxml2-devel
55     BuildRequires: libxslt-devel
56     BuildRequires: zlib-devel
57     %if %withuuid
58     BuildRequires: ossp_uuid-devel
59     %endif
60     # Need to build doc
61     BuildRequires: docbook-dtd42-sgml
62     BuildRequires: openjade
63     BuildRequires: docbook-utils
64     BuildRequires: docbook-style-xsl
65     BuildRequires: xsltproc
66     Provides: %{bname}-virtual = %{current_major_version}
67     Conflicts: %{bname}-virtual < %{current_major_version}
68     Provides: %{bname} = %{version}-%{release}
69     Conflicts: %{bname} < %{version}-%{release}
70    
71     %description
72     PostgreSQL is an advanced Object-Relational database management system (DBMS)
73     that supports almost all SQL constructs (including transactions, subselects and
74     user-defined types and functions). The postgresql package includes the client
75     programs and libraries that you'll need to access a PostgreSQL DBMS server.
76     These PostgreSQL client programs are programs that directly manipulate the
77     internal structure of PostgreSQL databases on a PostgreSQL server. These client
78     programs can be located on the same machine with the PostgreSQL server, or may
79     be on a remote machine which accesses a PostgreSQL server over a network
80     connection. This package contains the client libraries for C and C++, as well
81     as command-line utilities for managing PostgreSQL databases on a PostgreSQL
82     server.
83    
84     If you want to manipulate a PostgreSQL database on a remote PostgreSQL server,
85     you need this package. You also need to install this package if you're
86     installing the postgresql-server package.
87    
88     %package -n %{libname}
89     Summary: The shared libraries required for any PostgreSQL clients
90     Group: System/Libraries
91     Conflicts: %mklibname pq 9.3 5
92     Conflicts: %mklibname pq 9.2 5
93     Conflicts: %mklibname pq 9.1 5
94     Conflicts: %mklibname pq 9.0 5
95     Provides: postgresql-libs = %{version}-%{release}
96     Provides: libpq = %{version}-%{release}
97     Provides: %{libname}-virtual = %{current_major_version}
98     Conflicts: %{libname}-virtual < %{current_major_version}
99    
100     %description -n %{libname}
101     C and C++ libraries to enable user programs to communicate with the PostgreSQL
102     database backend. The backend can be on another machine and accessed through
103     TCP/IP.
104    
105     %package -n %{libecpg}
106     Summary: Shared library libecpg for PostgreSQL
107     Group: System/Libraries
108     Requires: postgresql%{current_major_version} = %{version}-%{release}
109     Provides: libecpg = %{version}-%{release}
110     Provides: %{libecpg}-virtual = %{current_major_version}
111     Conflicts: %{libecpg}-virtual < %{current_major_version}
112    
113     %description -n %{libecpg}
114     Libecpg is used by programs built with ecpg (Embedded PostgreSQL for C) Use
115     postgresql-dev to develop such programs.
116    
117     %package server
118     Summary: The programs needed to create and run a PostgreSQL server
119     Group: Databases
120     Provides: sqlserver
121     Requires(post): %{libname} >= %{version}-%{release}
122     Requires(preun): %{libname} >= %{version}-%{release}
123     # add/remove services
124     Requires(post): rpm-helper
125     Requires(preun): rpm-helper
126     # add/del user
127     Requires(pre): rpm-helper
128     Requires(postun): rpm-helper
129     Requires(pre): postgresql%{current_major_version} >= %{version}-%{release}
130     Requires(post): postgresql%{current_major_version} >= %{version}-%{release}
131     Provides: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
132     Provides: %{bname}-server-virtual = %{current_major_version}
133     Conflicts: %{bname}-server-virtual < %{current_major_version}
134     Provides: %{bname}-server = %{version}-%{release}
135     Requires: postgresql-plpgsql = %{version}-%{release}
136    
137     %description server
138     The postgresql-server package includes the programs needed to create and run a
139     PostgreSQL server, which will in turn allow you to create and maintain
140     PostgreSQL databases. PostgreSQL is an advanced Object-Relational database
141     management system (DBMS) that supports almost all SQL constructs (including
142     transactions, subselects and user-defined types and functions). You should
143     install postgresql-server if you want to create and maintain your own
144     PostgreSQL databases and/or your own PostgreSQL server. You also need to
145     install the postgresql and postgresql-devel packages.
146    
147     After installing this package, please read postgresql.%{_vendor}.releasenote.
148    
149     %package docs
150     Summary: Extra documentation for PostgreSQL
151     Group: Databases
152     BuildArch: noarch
153     Provides: %{bname}-docs-virtual = %{current_major_version}
154     Conflicts: %{bname}-docs-virtual < %{current_major_version}
155    
156     %description docs
157     The postgresql-docs package includes the SGML source for the documentation as
158     well as the documentation in other formats, and some extra documentation.
159     Install this package if you want to help with the PostgreSQL documentation
160     project, or if you want to generate printed documentation.
161    
162     %package contrib
163     Summary: Contributed binaries distributed with PostgreSQL
164     Group: Databases
165     Requires: postgresql%{current_major_version}-server = %{version}-%{release}
166     Provides: %{bname}-contrib-virtual = %{current_major_version}
167     Conflicts: %{bname}-contrib-virtual < %{current_major_version}
168    
169     %description contrib
170     The postgresql-contrib package includes the contrib tree distributed with the
171     PostgreSQL tarball. Selected contrib modules are prebuilt.
172    
173     %package devel
174     Summary: PostgreSQL development header files and libraries
175     Group: Development/Databases
176     Requires: postgresql%{current_major_version} = %{version}-%{release}
177     Provides: %{bname}-devel-virtual = %{current_major_version}
178     Conflicts: %{bname}-devel-virtual < %{current_major_version}
179     Requires: %{libname} = %{version}-%{release}
180     Provides: postgresql-libs-devel = %{version}-%{release}
181     Provides: pq-devel = %{version}-%{release}
182     %if %_lib != lib
183     Provides: libpq-devel = %{version}-%{release}
184     %endif
185     Provides: %{_lib}pq-devel = %{version}
186     Conflicts: %{_lib}pq-devel < %{version}
187     Requires: %{libecpg} = %{version}-%{release}
188     Provides: libecpg-devel = %{version}-%{release}
189     Provides: %{_lib}ecpg-devel = %{version}-%{release}
190     Conflicts: %{_lib}ecpg-devel < %{version}-%{release}
191     Provides: %{bname}-devel = %{version}-%{release}
192     Conflicts: %{bname}-devel < %{version}-%{release}
193    
194     %description devel
195     The postgresql-devel package contains the header files and libraries needed to
196     compile C or C++ applications which will directly interact with a PostgreSQL
197     database management server and the ecpg Embedded C Postgres preprocessor. You
198     need to install this package if you want to develop applications which will
199     interact with a PostgreSQL server. If you're installing postgresql-server, you
200     need to install this package.
201    
202     %package pl
203     Summary: Procedurals languages for PostgreSQL
204     Group: Databases
205     Conflicts: libpgsql2
206     Requires: %{name}-plpython = %{version}-%{release}
207     Requires: %{name}-plperl = %{version}-%{release}
208     Requires: %{name}-pltcl = %{version}-%{release}
209     Requires: %{name}-plpgsql = %{version}-%{release}
210     Provides: %{bname}-pl-virtual = %{current_major_version}
211     Conflicts: %{bname}-pl-virtual < %{current_major_version}
212     Conflicts: %{bname}-pl < %{version}-%{release}
213     Provides: %{bname}-pl = %{version}-%{release}
214    
215     %description pl
216     PostgreSQL is an advanced Object-Relational database management system. The
217     postgresql-pl will install the the PL/Perl, PL/Tcl, and PL/Python procedural
218     languages for the backend. PL/Pgsql is part of the core server package.
219    
220     %package plpython
221     Summary: The PL/Python procedural language for PostgreSQL
222     Group: Databases
223     Requires: postgresql%{current_major_version}-server = %{version}
224     Conflicts: postgresql-pl < %version-%release
225     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
226     Provides: %{bname}-plpython-virtual = %{current_major_version}
227     Conflicts: %{bname}-plpython-virtual < %{current_major_version}
228     Conflicts: %{bname}-plpython < %{version}-%{release}
229     Provides: %{bname}-plpython = %{version}-%{release}
230    
231     %description plpython
232     PostgreSQL is an advanced Object-Relational database management system. The
233     postgresql-plpython package contains the the PL/Python procedural languages for
234     the backend. PL/Python is part of the core server package.
235    
236     %package plperl
237     Summary: The PL/Perl procedural language for PostgreSQL
238     Group: Databases
239     Requires: postgresql%{current_major_version}-server = %{version}
240     Requires: perl-base = %{perl_epoch}:%{perl_version}
241     Conflicts: postgresql-pl < %version-%release
242     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
243     Provides: %{bname}-plperl-virtual = %{current_major_version}
244     Conflicts: %{bname}-plperl-virtual < %{current_major_version}
245     Conflicts: %{bname}-plperl < %{version}-%{release}
246     Provides: %{bname}-plperl = %{version}-%{release}
247    
248     %description plperl
249     PostgreSQL is an advanced Object-Relational database management system. The
250     postgresql-plperl package contains the the PL/Perl procedural languages for the
251     backend. PL/Perl is part of the core server package.
252    
253     %package pltcl
254     Summary: The PL/Tcl procedural language for PostgreSQL
255     Group: Databases
256     Requires: postgresql%{current_major_version}-server = %{version}
257     Conflicts: postgresql-pl < %version-%release
258     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
259     Provides: %{bname}-pltcl-virtual = %{current_major_version}
260     Conflicts: %{bname}-pltcl-virtual < %{current_major_version}
261     Conflicts: %{bname}-pltcl < %{version}-%{release}
262     Provides: %{bname}-pltcl = %{version}-%{release}
263    
264     %description pltcl
265     PostgreSQL is an advanced Object-Relational database management system. The
266     postgresql-pltcl package contains the the PL/Tcl procedural languages for the
267     backend. PL/Tcl is part of the core server package.
268    
269     %package plpgsql
270     Summary: The PL/PgSQL procedural language for PostgreSQL
271     Group: Databases
272     Requires: postgresql%{current_major_version}-server = %{version}
273     Conflicts: postgresql-pl < %version-%release
274     Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
275     Provides: %{bname}-plpgsql-virtual = %{current_major_version}
276     Conflicts: %{bname}-plpgsql-virtual < %{current_major_version}
277     Conflicts: %{bname}-plpgsql < %{version}-%{release}
278     Provides: %{bname}-plpgsql = %{version}-%{release}
279    
280     %description plpgsql
281     PostgreSQL is an advanced Object-Relational database management system. The
282     postgresql-plpgsql package contains the the PL/PgSQL procedural languages for
283     the backend. PL/PgSQL is part of the core server package.
284    
285     %prep
286     %setup -q -n %{bname}-%{version}%{?beta}
287     %apply_patches
288    
289     %build
290    
291     %serverbuild
292    
293 cjw 798833 # -fPIC is only needed for shared objects, should not be in optflags
294     export CFLAGS=$(echo "$CFLAGS"|sed -e 's/-fPIC//')
295     export CXXFLAGS=$(echo "$CXXFLAGS"|sed -e 's/-fPIC//')
296     export RPM_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS"|sed -e 's/-fPIC//')
297    
298 cjw 798277 %configure2_5x \
299     --disable-rpath \
300     --with-perl \
301     --with-python \
302     --with-tcl --with-tclconfig=%{_libdir} \
303     --with-openssl \
304     --with-pam \
305     --with-libxml \
306     --with-libxslt \
307     --libdir=%{_libdir} \
308     --mandir=%{_mandir} \
309     --prefix=%_prefix \
310     --sysconfdir=%{_sysconfdir}/pgsql \
311     --enable-nls \
312     %if %{withuuid}
313     --with-ossp-uuid
314     %endif
315    
316     # $(rpathdir) come from Makefile
317     perl -pi -e 's|^all:|LINK.shared=\$(COMPILER) -shared -Wl,-rpath,\$(rpathdir),-soname,\$(soname)\nall:|' src/pl/plperl/GNUmakefile
318    
319     %make world
320    
321     pushd src/test
322     make all
323     popd
324    
325     %check
326     make check
327    
328     %install
329     make DESTDIR=%{buildroot} install-world install-docs
330    
331     # install odbcinst.ini
332     mkdir -p %{buildroot}%{_sysconfdir}/pgsql
333    
334     # copy over Makefile.global to the include dir....
335     #install -m755 src/Makefile.global %{buildroot}%{_includedir}/pgsql/
336    
337     # PGDATA needs removal of group and world permissions due to pg_pwd hole.
338     install -d -m 700 %{buildroot}/var/lib/pgsql/data
339    
340     # backups of data go here...
341     install -d -m 700 %{buildroot}/var/lib/pgsql/backups
342    
343     # Create the multiple postmaster startup directory
344     install -d -m 700 %{buildroot}/etc/sysconfig/pgsql
345    
346     # install systemd units
347     mkdir -p %{buildroot}%{_unitdir}
348     install -m 644 %{SOURCE11} %{buildroot}%{_unitdir}/%{bname}.service
349    
350     # Create the directory for sockets.
351     install -d -m 755 %{buildroot}/var/run/postgresql
352    
353     # ... and make a tmpfiles script to recreate it at reboot.
354     mkdir -p %{buildroot}%{_tmpfilesdir}
355     install -m 0644 %{SOURCE15} %{buildroot}%{_tmpfilesdir}/postgresql.conf
356    
357     # install helper script for env initialisation
358     mkdir -p %{buildroot}%{_libexecdir}
359     install -m 755 %{SOURCE14} %{buildroot}%{_libexecdir}/
360    
361     mkdir -p %{buildroot}/var/log/postgres
362    
363     mkdir -p %{buildroot}%{logrotatedir}
364     cat > %{buildroot}%{logrotatedir}/%{bname} <<EOF
365     /var/log/postgres/postgresql {
366     notifempty
367     missingok
368     copytruncate
369     }
370     EOF
371    
372     mv %{buildroot}%{_docdir}/%{bname}/html %{buildroot}%{_docdir}/%{name}-docs-%{version}
373    
374     echo -n '' > main.lst
375     for i in \
376     pg_ctl initdb pg_config psql pg_dump pgscripts libpq libecpg \
377     ecpg libpq%{major} ecpglib%{major_ecpg}; do
378     %find_lang $i-%{current_major_version}
379     cat $i-%{current_major_version}.lang >> main.lst
380     %find_lang $i
381     cat $i.lang >> main.lst
382     done
383     echo -n '' > server.lst
384     for i in postgres pg_resetxlog pg_controldata plpgsql plpython plperl pltcl pg_basebackup; do
385     %find_lang $i
386     cat $i.lang >> server.lst
387     %find_lang $i-%{current_major_version}
388     cat $i-%{current_major_version}.lang >> server.lst
389     done
390    
391     # pg_ctl.lang initdb.lang pg_config.lang psql.lang pg_dump.lang pgscripts.lang \
392     # postgres.lang pg_resetxlog.lang pg_controldata.lang \
393     # libpq.lang libecpg.lang \
394    
395     # taken directly in build dir.
396     rm -fr %{buildroot}%{_datadir}/doc/postgresql/contrib/
397     rm -fr %{buildroot}%{_datadir}/doc/postgresql/extension/
398    
399     mkdir -p %{buildroot}/%{_sys_macros_dir}
400     cat > %{buildroot}/%{_sys_macros_dir}/%{name}.macros <<EOF
401     %%postgresql_version %{version}
402     %%postgresql_major %{current_major_version}
403     %%postgresql_minor %{current_minor_version}
404     %%pgmodules_req Requires: %{?arch_tagged:%arch_tagged %{bname}-server-ABI}%{?!arch_tagged:%{bname}-server-ABI} = %{current_major_version}
405     EOF
406    
407     cat %{SOURCE13} > postgresql.%{_vendor}.releasenote
408     cat > README.urpmi <<EOF
409     You just installed or updated %{bname} server.
410     You can find important information about %{distribution} %{bname} rpms and database
411     management in:
412    
413     %{_defaultdocdir}/%{name}-server/postgresql.%{_vendor}.releasenote
414    
415     Please read it.
416     EOF
417    
418     # postgres' .profile and .bashrc
419     install -D -m 700 %{SOURCE10} %{buildroot}/var/lib/pgsql/.profile
420     (
421     cd %{buildroot}/var/lib/pgsql/
422     ln -s .profile .bashrc
423     )
424    
425     cat > %{buildroot}%{_sysconfdir}/sysconfig/postgresql <<EOF
426     # Olivier Thauvin <nanardon@mandriva.org>
427    
428     # The database location:
429     # You probably won't change this
430     # PGDATA=/var/lib/pgsql/data
431    
432     # What is the based locales for postgresql
433     # Setting locales to C allow to use any encoding
434     # ISO or UTF, any other choice will restrict you
435     # either ISO or UTF.
436     LC_ALL=C
437    
438     # These are additional to pass to pg_ctl when starting/restarting postgresql.
439     # PGOPTIONS=
440     EOF
441    
442     %pre server
443     %_pre_useradd postgres /var/lib/pgsql /bin/bash
444    
445     [ ! -f %{pgdata}/data/PG_VERSION ] && exit 0
446     mypgversion=`cat %{pgdata}/data/PG_VERSION`
447     [ $mypgversion = %{current_major_version} ] && exit 0
448    
449     echo ""
450     echo "You currently have database tree for Postgresql $mypgversion"
451     echo "You must use postgresql${mypgversion}-server"
452     echo "To update you Postgresql server, dump your databases"
453     echo "delete /var/lib/pgsql/data/ content, upgrade the server, then"
454     echo "restore your databases from your backup"
455     echo ""
456    
457     exit 1
458    
459     %post server
460     %_post_service %{bname}
461    
462     %_tmpfilescreate %{_tmpfilesdir}/%{bname}
463    
464     %preun server
465     %_preun_service %{bname}
466    
467     %postun server
468     %_postun_userdel postgres
469    
470     %files -f main.lst
471     %doc doc/KNOWN_BUGS doc/MISSING_FEATURES
472     %doc COPYRIGHT README HISTORY doc/bug.template
473     %{_bindir}/clusterdb
474     %{_bindir}/createdb
475     %{_bindir}/createlang
476     %{_bindir}/createuser
477     %{_bindir}/dropdb
478     %{_bindir}/droplang
479     %{_bindir}/dropuser
480     %{_bindir}/pg_dump
481     %{_bindir}/pg_dumpall
482     %{_bindir}/pg_isready
483     %{_bindir}/pg_restore
484     %{_bindir}/psql
485     %{_bindir}/reindexdb
486     %{_bindir}/vacuumdb
487     %{_mandir}/man1/clusterdb.*
488     %{_mandir}/man1/createdb.*
489     %{_mandir}/man1/createlang.*
490     %{_mandir}/man1/createuser.*
491     %{_mandir}/man1/dropdb.*
492     %{_mandir}/man1/droplang.*
493     %{_mandir}/man1/dropuser.*
494     %{_mandir}/man1/pg_dump.*
495     %{_mandir}/man1/pg_dumpall.*
496     %{_mandir}/man1/pg_isready.*
497     %{_mandir}/man1/pg_restore.*
498     %{_mandir}/man1/psql.*
499     %{_mandir}/man1/vacuumdb.*
500     %{_mandir}/man1/reindexdb.*
501     %{_mandir}/man7/*
502     %{_sys_macros_dir}/%{name}.macros
503    
504     %files -n %{libname}
505     %{_libdir}/libpq.so.%{major}*
506    
507     %files -n %{libecpg}
508     %{_libdir}/libecpg.so.%{major_ecpg}*
509     %{_libdir}/libecpg_compat.so.*
510     %{_libdir}/libpgtypes.so.*
511    
512     %files docs
513     %doc %{_docdir}/%{name}-docs-%{version}
514    
515     %files contrib
516     # %doc contrib/*/README.* contrib/spi/*.example
517     %{_libdir}/postgresql/_int.so
518     %{_libdir}/postgresql/btree_gist.so
519     %{_libdir}/postgresql/chkpass.so
520     %{_libdir}/postgresql/cube.so
521     %{_libdir}/postgresql/dblink.so
522     %{_libdir}/postgresql/earthdistance.so
523     %{_libdir}/postgresql/fuzzystrmatch.so
524     %{_libdir}/postgresql/insert_username.so
525     %{_libdir}/postgresql/lo.so
526     %{_libdir}/postgresql/ltree.so
527     %{_libdir}/postgresql/moddatetime.so
528     %{_libdir}/postgresql/pgcrypto.so
529     %{_libdir}/postgresql/pgstattuple.so
530     %{_libdir}/postgresql/refint.so
531     %{_libdir}/postgresql/seg.so
532     %{_libdir}/postgresql/tablefunc.so
533     %{_libdir}/postgresql/timetravel.so
534     %{_libdir}/postgresql/pg_trgm.so
535     %{_libdir}/postgresql/autoinc.so
536     %{_libdir}/postgresql/pg_buffercache.so
537     %{_libdir}/postgresql/adminpack.so
538     %{_libdir}/postgresql/hstore.so
539     %{_libdir}/postgresql/isn.so
540     %{_libdir}/postgresql/pg_freespacemap.so
541     %{_libdir}/postgresql/pgrowlocks.so
542     %{_libdir}/postgresql/sslinfo.so
543     %{_libdir}/postgresql/pageinspect.so
544     %{_libdir}/postgresql/tcn.so
545     %{_libdir}/postgresql/postgres_fdw.so
546     %{_libdir}/postgresql/worker_spi.so
547    
548     %{_bindir}/oid2name
549     %{_bindir}/pgbench
550     %{_bindir}/vacuumlo
551     %{_bindir}/pg_test_timing
552     %{_bindir}/pg_xlogdump
553     %{_mandir}/man1/oid2name.1*
554     %{_mandir}/man1/pgbench.1*
555     %{_mandir}/man1/pg_test_timing.1*
556     %{_mandir}/man1/pg_xlogdump.1*
557     %{_mandir}/man1/vacuumlo.1*
558    
559     %files server -f server.lst
560     %config(noreplace) %{_sysconfdir}/sysconfig/postgresql
561     %doc README.urpmi postgresql.%{_vendor}.releasenote
562     %{_unitdir}/%{bname}.service
563     %{_bindir}/initdb
564     %{_bindir}/pg_archivecleanup
565     %{_bindir}/pg_basebackup
566     %{_bindir}/pg_controldata
567     %{_bindir}/pg_ctl
568     %{_bindir}/pg_receivexlog
569     %{_bindir}/pg_recvlogical
570     %{_bindir}/pg_resetxlog
571     %{_bindir}/pg_standby
572     %{_bindir}/pg_test_fsync
573     %{_bindir}/pg_upgrade
574     %{_bindir}/postgres
575     %{_bindir}/postmaster
576     %{_mandir}/man1/initdb.1*
577     %{_mandir}/man1/pg_archivecleanup.1*
578     %{_mandir}/man1/pg_basebackup.1*
579     %{_mandir}/man1/pg_controldata.*
580     %{_mandir}/man1/pg_ctl.1*
581     %{_mandir}/man1/pg_receivexlog.1*
582     %{_mandir}/man1/pg_recvlogical.1*
583     %{_mandir}/man1/pg_resetxlog.*
584     %{_mandir}/man1/pg_standby.1*
585     %{_mandir}/man1/pg_test_fsync.1*
586     %{_mandir}/man1/pg_upgrade.1*
587     %{_mandir}/man1/postgres.1*
588     %{_mandir}/man1/postmaster.1*
589     %dir %{_libdir}/postgresql
590     %dir %{_datadir}/postgresql
591     %{_tmpfilesdir}/postgresql.conf
592     %attr(755,postgres,postgres) %ghost %dir /var/run/postgresql
593     %config(noreplace) /var/lib/pgsql/.bashrc
594     %attr(-,postgres,postgres) /var/lib/pgsql/.profile
595     %attr(700,postgres,postgres) %dir %{pgdata}
596     %attr(-,postgres,postgres) %{pgdata}/data
597     %attr(700,postgres,postgres) %dir %{pgdata}/backups
598     %{_libdir}/postgresql/*_and_*.so
599     %{_libdir}/postgresql/auth_delay.so
600     %{_libdir}/postgresql/auto_explain.so
601     %{_libdir}/postgresql/btree_gin.so
602     %{_libdir}/postgresql/citext.so
603     %{_libdir}/postgresql/dict_int.so
604     %{_libdir}/postgresql/dict_snowball.so
605     %{_libdir}/postgresql/dict_xsyn.so
606     %{_libdir}/postgresql/dummy_seclabel.so
607     %{_libdir}/postgresql/file_fdw.so
608     %{_libdir}/postgresql/pg_prewarm.so
609     %{_libdir}/postgresql/pg_stat_statements.so
610     %{_libdir}/postgresql/pgxml.so
611     %{_libdir}/postgresql/test_decoding.so
612     %{_libdir}/postgresql/test_parser.so
613     %{_libdir}/postgresql/test_shm_mq.so
614     %{_libdir}/postgresql/tsearch2.so
615     %{_libexecdir}/postgresql_initdb.sh
616     %if %{withuuid}
617     %{_libdir}/postgresql/uuid-ossp.so
618     %endif
619     %{_libdir}/postgresql/euc2004_sjis2004.so
620     %{_libdir}/postgresql/libpqwalreceiver.so
621     %{_libdir}/postgresql/passwordcheck.so
622     %{_libdir}/postgresql/pg_upgrade_support.so
623     %{_libdir}/postgresql/unaccent.so
624     %{_datadir}/postgresql/postgres.bki
625     %{_datadir}/postgresql/postgres.description
626     %{_datadir}/postgresql/*.sample
627     %{_datadir}/postgresql/timezone
628     %{_datadir}/postgresql/system_views.sql
629     %{_datadir}/postgresql/conversion_create.sql
630     %{_datadir}/postgresql/information_schema.sql
631     %{_datadir}/postgresql/snowball_create.sql
632     %{_datadir}/postgresql/sql_features.txt
633     %{_datadir}/postgresql/postgres.shdescription
634     %dir %{_datadir}/postgresql/timezonesets
635     %{_datadir}/postgresql/timezonesets/Africa.txt
636     %{_datadir}/postgresql/timezonesets/America.txt
637     %{_datadir}/postgresql/timezonesets/Antarctica.txt
638     %{_datadir}/postgresql/timezonesets/Asia.txt
639     %{_datadir}/postgresql/timezonesets/Atlantic.txt
640     %{_datadir}/postgresql/timezonesets/Australia
641     %{_datadir}/postgresql/timezonesets/Australia.txt
642     %{_datadir}/postgresql/timezonesets/Default
643     %{_datadir}/postgresql/timezonesets/Etc.txt
644     %{_datadir}/postgresql/timezonesets/Europe.txt
645     %{_datadir}/postgresql/timezonesets/India
646     %{_datadir}/postgresql/timezonesets/Indian.txt
647     %{_datadir}/postgresql/timezonesets/Pacific.txt
648     %{_datadir}/postgresql/tsearch_data
649     %{_datadir}/postgresql/extension
650    
651     %attr(700,postgres,postgres) %dir /var/log/postgres
652     %{logrotatedir}/%{bname}
653    
654     %files devel
655     # %doc doc/TODO doc/TODO.detail
656     %{_includedir}/*
657     %{_bindir}/ecpg
658     %{_libdir}/lib*.so
659     %{_libdir}/lib*.a
660     %{_libdir}/pkgconfig/*.pc
661     %{_libdir}/postgresql/pgxs/
662     %{_mandir}/man1/ecpg.1*
663     %{_bindir}/pg_config
664     %{_mandir}/man1/pg_config.1*
665     %{_mandir}/man3/SPI_*.3*
666     %{_mandir}/man3/dblink*.3*
667    
668     %files pl
669    
670     %files plpython
671     %{_libdir}/postgresql/plpython2.so
672    
673     %files plperl
674     %{_libdir}/postgresql/plperl.so
675    
676     %files pltcl
677     %{_libdir}/postgresql/pltcl.so
678     %{_bindir}/pltcl_delmod
679     %{_bindir}/pltcl_listmod
680     %{_bindir}/pltcl_loadmod
681     %{_datadir}/postgresql/unknown.pltcl
682    
683     %files plpgsql
684     %{_libdir}/postgresql/plpgsql.so

  ViewVC Help
Powered by ViewVC 1.1.30