/[packages]/cauldron/python-flake8/current/SPECS/python-flake8.spec
ViewVC logotype

Contents of /cauldron/python-flake8/current/SPECS/python-flake8.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1379327 - (show annotations) (download)
Wed Mar 20 23:11:02 2019 UTC (5 years, 1 month ago) by shlomif
File size: 2554 byte(s)
- Rebuild for new entrypoints, pycodestyle
1 # Created by pyp2rpm-1.0.1
2 %global pypi_name flake8
3
4 Name: python-%{pypi_name}
5 Version: 3.7.7
6 Release: %mkrel 2
7 Group: Development/Python
8 Summary: The modular source code checker: pep8, pyflakes and co
9 License: MIT
10 URL: https://pypi.python.org/pypi/flake8
11 Source0: http://pypi.io/packages/source/f/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
12 BuildArch: noarch
13
14 %description
15 Flake8 is a wrapper around these tools:
16 - PyFlakes
17 - pep8
18 - Ned Batchelder's McCabe script
19
20 Flake8 runs all the tools by launching
21 the single ``flake8`` script.
22 It displays the warnings in a per-file, merged
23 output.
24
25 %package -n python2-%{pypi_name}
26 Group: Development/Python
27 Summary: the modular source code checker: pep8, pyflakes and co
28 BuildRequires: python2-devel
29 BuildRequires: python2dist(setuptools)
30 BuildRequires: python2-nose
31 BuildRequires: python2-mccabe
32 BuildRequires: python2-pytest-runner
33 %{?python_provide:%python_provide python2-%{pypi_name}}
34
35 %description -n python2-%{pypi_name}
36 Flake8 is a wrapper around these tools:
37 - PyFlakes
38 - pep8
39 - Ned Batchelder's McCabe script
40
41 Flake8 runs all the tools by launching
42 the single ``flake8`` script.
43 It displays the warnings in a per-file, merged
44 output.
45
46 This is version of the package running with Python 2.
47
48 %package -n python3-%{pypi_name}
49 Group: Development/Python
50 Summary: the modular source code checker: pep8, pyflakes and co
51 BuildRequires: python3-devel
52 BuildRequires: python3dist(setuptools)
53 BuildRequires: python3-nose
54 BuildRequires: python3-mccabe
55 BuildRequires: python3-pytest-runner
56 %{?python_provide:%python_provide python3-%{pypi_name}}
57
58 %description -n python3-%{pypi_name}
59 Flake8 is a wrapper around these tools:
60 - PyFlakes
61 - pep8
62 - Ned Batchelder's McCabe script
63
64 Flake8 runs all the tools by launching
65 the single ``flake8`` script.
66 It displays the warnings in a per-file, merged
67 output.
68
69 This is version of the package running with Python 3.
70
71 %prep
72 %setup -q -n %{pypi_name}-%{version}
73
74 # remove bundled egg-info
75 rm -rf flake8.egg-info
76
77 %build
78 %py2_build
79 %py3_build
80
81 %install
82 %py2_install
83 mv %{buildroot}%{_bindir}/flake8 %{buildroot}%{_bindir}/python2-flake8
84
85 %py3_install
86
87 %files -n python2-%{pypi_name}
88 %doc LICENSE
89 %{_bindir}/python2-flake8
90 %{python2_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
91 %{python2_sitelib}/%{pypi_name}/
92
93 %files -n python3-%{pypi_name}
94 %doc LICENSE
95 %{_bindir}/flake8
96 %{python3_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
97 %{python3_sitelib}/%{pypi_name}/

  ViewVC Help
Powered by ViewVC 1.1.30