/[packages]/cauldron/python-virtinst/current/SPECS/python-virtinst.spec
ViewVC logotype

Annotation of /cauldron/python-virtinst/current/SPECS/python-virtinst.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 138009 - (hide annotations) (download)
Fri Sep 2 14:43:12 2011 UTC (12 years, 7 months ago) by misc
File size: 2069 byte(s)
remove buggy patch ( incorrect tabulation ), see https://bugzilla.redhat.com/show_bug.cgi?id=733121
for a proper patch

1 ahmad 67343 %define module virtinst
2     %define name python-%{name}
3 cjw 133115 %define version 0.600.0
4     %define release %mkrel 1
5 ahmad 67343
6 ahmad 67371 Name: python-%{module}
7     Version: %{version}
8     Release: %{release}
9     Summary: Python modules for starting Xen guest installations
10     License: GPLv2+
11     Group: Development/Python
12     Url: http://virt-manager.et.redhat.com/
13     Source: http://virt-manager.et.redhat.com/download/sources/virtinst/%{module}-%{version}.tar.gz
14 ahmad 67343 Requires: python-libvirt >= 0.1.4-4
15     Requires: python-urlgrabber
16     Requires: python-libxml2
17     BuildRequires: python-devel
18     BuildRequires: python-libvirt
19     BuildRequires: python-libxml2
20     BuildRequires: python-urlgrabber
21     BuildArch: noarch
22 ahmad 67371 ExcludeArch: ppc ppc64 s390 s390x
23 ahmad 67343
24     %description
25 ahmad 67371 virtinst is a module to help in starting installations of Fedora/Red Hat
26     Enterprise Linux related distributions inside of virtual machines. It supports
27     both paravirt guests (for which only FC and RHEL guests are currently supported)
28     as well as fully virtualized guests. It uses libvirt (http://www.libvirt.org)
29     for starting things.
30 ahmad 67343
31     Also contained is a simple script virt-install which uses
32     virtinst in a command line mode.
33    
34     %prep
35     %setup -q -n %{module}-%{version}
36    
37     %build
38     python setup.py build
39    
40     %install
41     rm -rf %{buildroot}
42     python setup.py install --root=%{buildroot}
43     mkdir -p %{buildroot}/%{_sbindir}
44     mv %{buildroot}/%{_bindir}/virt-install %{buildroot}/%{_sbindir}/virt-install
45    
46     ln -s virtinst %{buildroot}%{python_sitelib}/xeninst
47     ln -s virt-install %{buildroot}/%{_sbindir}/xenguest-install
48    
49     %find_lang virtinst
50    
51     %clean
52     rm -rf %{buildroot}
53    
54     %files -f virtinst.lang
55     %defattr(-,root,root)
56     %doc README
57     %{python_sitelib}/virtinst
58     %{python_sitelib}/virtconv
59     %{python_sitelib}/xeninst
60     %{python_sitelib}/*.egg-info
61     %{_bindir}/virt-convert
62     %{_bindir}/virt-clone
63     %{_bindir}/virt-image
64     %{_sbindir}/virt-install
65     %{_sbindir}/xenguest-install
66     %{_mandir}/man1/virt-convert.1*
67     %{_mandir}/man1/virt-clone.1*
68     %{_mandir}/man1/virt-image.1*
69     %{_mandir}/man1/virt-install.1*
70     %{_mandir}/man5/virt-image.5*

  ViewVC Help
Powered by ViewVC 1.1.30