/[packages]/cauldron/qcad/current/SPECS/qcad.spec
ViewVC logotype

Contents of /cauldron/qcad/current/SPECS/qcad.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 904809 - (show annotations) (download)
Sun Nov 22 00:33:59 2015 UTC (8 years, 5 months ago) by alexl
File size: 5703 byte(s)
- less list of requires and buildrequires
1 Summary: A professional CAD system
2 Name: qcad
3 Version: 3.12.2.3
4 Release: %mkrel 2
5 Group: Graphics/Editors and Converters
6 License: GPLv3 with exceptions, CC-BY, GPLv2+, LGPLv2.1, BSD
7 URL: http://www.qcad.org
8 # https://github.com/qcad/qcad/archive/v%{version}.tar.gz
9 Source0: %{name}-%{version}.tar.gz
10 # http://www.qcad.org/bugtracker/index.php?do=details&task_id=1307
11 Patch0: %{name}-3.12.2.3-mga-fix-i18n.patch
12
13 # minimal BuildRequires
14 BuildRequires: qt5-devel
15 BuildRequires: pkgconfig(Qt5Designer)
16 BuildRequires: pkgconfig(Qt5Script)
17 BuildRequires: pkgconfig(Qt5Svg)
18 BuildRequires: pkgconfig(Qt5WebKit)
19 BuildRequires: pkgconfig(Qt5XmlPatterns)
20 BuildRequires: pkgconfig(Qt5WebKitWidgets)
21 BuildRequires: pkgconfig(Qt5ScriptTools)
22 BuildRequires: pkgconfig(Qt5Help)
23 BuildRequires: pkgconfig(glu)
24
25 # extra BuildRequires and simular Requires for additional plugins, which were not installed by BuildRequires above
26 BuildRequires: qtimageformats5
27 Requires: qtimageformats5
28
29 %description
30 QCad is a professional CAD System. With QCad you can easily construct
31 and change drawings with ISO-text and many other features and save
32 them as DXF-files. These DXF-files are the interface to many
33 CAD-systems such as AutoCAD(TM) and many others.
34
35 %prep
36 %setup -q
37 %autopatch -p1
38
39 %build
40 # Use the 5.4.1 generator with Qt 5.4.0
41 #ln -s qt-labs-qtscriptgenerator-5.4.1 src/3rdparty/qt-labs-qtscriptgenerator-5.4.0
42 #ln -s qt-labs-qtscriptgenerator-5.4.1.pro src/3rdparty/qt-labs-qtscriptgenerator-5.4.0/qt-labs-qtscriptgenerator-5.4.0.pro
43 %qmake_qt5
44 %make
45
46 %install
47 # remove project files
48 find . \( -name '*.pri' -or -name '*.pro' -or -name '*.ts' \) -delete
49 find . \( -name 'Makefile*' -or -name '.gitignore' \) -delete
50
51 install -dm755 %{buildroot}%{_datadir}/%{name}
52 cp -r examples fonts libraries linetypes patterns plugins scripts ts %{buildroot}%{_datadir}/%{name}
53 cp release/* %{buildroot}%{_datadir}/%{name}
54
55 # qt
56 for sofiles in %{_qt5_plugindir}/imageformats/*.so
57 do
58 ln -sf ${sofiles} %{buildroot}%{_datadir}/%{name}/plugins/imageformats/${sofiles##/*/}
59 done
60
61 for sofiles in %{_qt5_plugindir}/sqldrivers/*.so
62 do
63 ln -sf ${sofiles} %{buildroot}%{_datadir}/%{name}/plugins/sqldrivers/${sofiles##/*/}
64 done
65
66 for sofiles in %{_qt5_plugindir}/printsupport/*.so
67 do
68 ln -sf ${sofiles} %{buildroot}%{_datadir}/%{name}/plugins/printsupport/${sofiles##/*/}
69 done
70
71 install -Dm644 scripts/%{name}_icon.png %{buildroot}%{_iconsdir}/%{name}_icon.png
72
73 install -dm0755 %{buildroot}%{_bindir}
74 echo -e '#!/bin/sh\ncd %{_datadir}/%{name}\nLD_LIBRARY_PATH=`pwd`:%{_libdir}/%{name}:$LD_LIBRARY_PATH exec ./%{name}-bin' > %{buildroot}%{_bindir}/%{name}
75 chmod 0755 %{buildroot}%{_bindir}/%{name}
76
77 rm -f %{buildroot}%{_datadir}/%{name}/*.a
78
79 install -dm0755 %{buildroot}%{_libdir}/%{name}
80 mv %{buildroot}%{_datadir}/%{name}/*.so %{buildroot}%{_libdir}/%{name}
81
82 # man page
83 install -Dm644 %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
84
85 # documentation for help system
86 install -Dm644 readme.txt %{buildroot}%{_datadir}/%{name}/readme.txt
87
88 # desktop
89 install -m 755 -d %{buildroot}%{_datadir}/applications
90 cat > %{buildroot}%{_datadir}/applications/%{name}.desktop <<EOF
91 [Desktop Entry]
92 Name=Qcad
93 GenericName=CAD system
94 GenericName[da]=Computerhjulpet design (CAD)
95 GenericName[de]=System für computerunterstützte Konstruktion
96 GenericName[it]=Sistema CAD
97 GenericName[ja]=コンピュータ支援設計 (CAD) システム
98 GenericName[ru]=Система автоматизированного проектирования
99 GenericName[sk]=CAD systém
100 GenericName[uk]=Система автоматизованого проектування
101 Comment=A professional CAD system
102 Comment[ru]=Профессиональная CAD система
103 Comment[sq]=Një sistem profesional CAD
104 Comment[be]=Прафэсійная CAD-сыстэма
105 Comment[ast]=Un sistema CAD profesional
106 Comment[bn]=পেশাদারী CAD পদ্ধতি
107 Comment[bs]=Profesionalni sistem CAD
108 Comment[pt_BR]=Um sistema CAD profissional
109 Comment[bg]=Професионална CAD система
110 Comment[ca]=Un sistema CAD professional
111 Comment[ca@valencia]=Un sistema CAD professional
112 Comment[zh_HK]=專業 CAD 系統
113 Comment[da]=Et professionelt CAD-system
114 Comment[cs]=Profesionální CAD systém
115 Comment[crh]=Profesyonel CAD Sistemi
116 Comment[zh_TW]=專業 CAD 系統
117 Comment[zh_CN]=一个专业的 CAD 系统
118 Comment[nl]=Een professioneel CAD-systeem
119 Comment[fi]=Ammattimainen CAD-järjestelmä
120 Comment[fr]=Un système de CAO professionnel
121 Comment[gl]=Un sistema de CAD profesional
122 Comment[de]=Ein professionelles CAD-System
123 Comment[el]=Ένα επαγγελματικό σύστημα σχεδίασης CAD
124 Comment[is]=Hágæða teiknikerfi (CAD)
125 Comment[hu]=Professzionális CAD-rendszer
126 Comment[it]=Un sistema CAD professionale
127 Comment[ja]=プロフェッショナル CAD システム
128 Comment[ky]=Кесиптик CAD - тутуму
129 Comment[ms]=Sistem CAD profesional
130 Comment[nb]=Et profesjonelt CAD-system
131 Comment[pt]=Um sistema CAD profissional
132 Comment[pl]=Profesjonalny system CAD
133 Comment[oc]=Un sistèma de CAO professional
134 Comment[ro]=Un sistem profesional CAD
135 Comment[tg]=Системаи касбии CAD
136 Comment[sv]=Professionellt CAD-system
137 Comment[es]=Un sistema CAD profesional
138 Comment[sl]=Profesionalni sistem CAD
139 Comment[uk]=Професійна САПР
140 Comment[tr]=Profesyonel CAD Sistemi
141 Exec=%{name}
142 Icon=%{name}_icon
143 Terminal=false
144 Type=Application
145 Categories=Office;Chart;Qt;
146 StartupNotify=true
147 EOF
148
149 %files
150 %doc readme.txt LICENSE.txt README.md gpl-3.0.txt cc-by-3.0.txt gpl-3.0-exceptions.txt
151 %{_bindir}/%{name}
152 %{_libdir}/%{name}/*.so
153 %{_iconsdir}/*.png
154 %{_datadir}/%{name}
155 %{_datadir}/applications/*.desktop
156 %{_mandir}/man1/%{name}.1.*

  ViewVC Help
Powered by ViewVC 1.1.30