/[packages]/cauldron/qtlocation5/current/SPECS/qtlocation5.spec
ViewVC logotype

Contents of /cauldron/qtlocation5/current/SPECS/qtlocation5.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1378536 - (show annotations) (download)
Mon Mar 18 01:23:19 2019 UTC (5 years, 1 month ago) by neoclust
File size: 7638 byte(s)
New version 5.12.0
1 %ifarch %{arm}
2 %define build_docs 0
3 %else
4 %define build_docs 1
5 %endif
6
7 %define qtmajor 5
8 %define qtminor 12
9 %define qtsubminor 2
10
11 %define rel 1
12 %define pre rc
13 %define snapshot 0
14
15 %define qtversion %{qtmajor}.%{qtminor}.%{qtsubminor}
16
17 %define libqtpositioning %mklibname qt5positioning %qtmajor
18 %define libqtpositioning_d %mklibname qt5positioning -d
19
20 %define libqtpositioningquick %mklibname qt5positioningquick %qtmajor
21
22 %define libqtlocation %mklibname qt5location %qtmajor
23 %define libqtlocation_d %mklibname qt5location -d
24
25 %if %snapshot
26 %define qttarballdir qtlocation-everywhere-src-%{qtversion}-%pre
27 %else
28 %define qttarballdir qtlocation-everywhere-src-%{qtversion}
29 %endif
30
31 Name: qtlocation5
32 Version: %{qtversion}
33 Release: %mkrel %{rel}
34 Summary: Qt%{qtmajor} Location component
35 Group: Development/KDE and Qt
36 License: LGPLv2 with exceptions or GPLv3 with exceptions and GFDL
37 URL: https://www.qt.io
38 Source0: https://download.qt.io/official_releases/qt/%{qtmajor}.%{qtminor}/%{version}/submodules/%{qttarballdir}.tar.xz
39 BuildRequires: qtbase5-devel >= %{version}
40 BuildRequires: pkgconfig(Qt5Quick) >= %{version}
41 BuildRequires: pkgconfig(Qt5Qml) >= %{version}
42 BuildRequires: pkgconfig(geoclue)
43 BuildRequires: pkgconfig(gypsy)
44 BuildRequires: pkgconfig(gconf-2.0)
45 BuildRequires: pkgconfig(icu-i18n)
46 BuildRequires: pkgconfig(libcrypto)
47 BuildRequires: pkgconfig(libssl)
48 #Branch Patchs
49
50 #Trunk Patchs
51
52 #Patch from Mageia
53
54 %description
55 Qt%{qtmajor} Location component.
56
57 %files
58 %{_qt5_qml}/QtLocation/
59 %{_qt5_qml}/Qt/labs/location/
60 %{_qt5_examplesdir}/location/
61 %{_qt5_plugindir}/geoservices/
62
63 #------------------------------------------------------------------------------
64
65 %if %{build_docs}
66 %package doc
67 Summary: QtLocation%{qtmajor} APIs and tools docs
68 Group: Documentation
69 BuildArch: noarch
70 BuildRequires: qttools5
71 # This one is required to build QCH-format documentation
72 # for APIs and tools in this package set
73 BuildRequires: qttools5-assistant
74 Recommends: qttools5-assistant
75
76 %description doc
77 Documentation for APIs and tools in QtLocation%{qtmajor} package for use with
78 Qt Assistant.
79
80 %files doc
81 %{_qt5_docdir}/qtlocation.qch
82 %{_qt5_docdir}/qtlocation/
83 %{_qt5_docdir}/qtpositioning.qch
84 %{_qt5_docdir}/qtpositioning/
85 %endif
86
87 #------------------------------------------------------------------------------
88
89 %package -n qtpositioning5
90 Summary: Qt%{qtmajor} Positioning Component
91 Group: System/Libraries
92 Requires: %{libqtpositioning} = %{version}
93 Provides: qt5positioning = %{version}
94
95 %description -n qtpositioning5
96 Qt%{qtmajor} Positioning Component.
97
98 The Positioning module provides positioning information via QML
99 and C++ interfaces.
100
101 %files -n qtpositioning5
102 %{_qt5_qml}/QtPositioning/
103 %{_qt5_plugindir}/position/
104 %{_qt5_examplesdir}/positioning/
105
106 #------------------------------------------------------------------------------
107
108 %package -n %{libqtpositioning}
109 Summary: Qt%{qtmajor} Positioning Component Library
110 Group: System/Libraries
111
112 %description -n %{libqtpositioning}
113 Qt%{qtmajor} Positioning Component Library.
114
115 The Positioning module provides positioning information via QML
116 and C++ interfaces.
117
118 %files -n %{libqtpositioning}
119 %{_qt5_libdir}/libQt5Positioning.so.%{qtmajor}*
120
121 #------------------------------------------------------------------------------
122
123 %package -n %{libqtpositioningquick}
124 Summary: Qt%{qtmajor} Positioning Component Library
125 Group: System/Libraries
126
127 %description -n %{libqtpositioningquick}
128 Qt%{qtmajor} Positioning Component Library.
129
130 The Positioning module provides positioning information via QML
131 and C++ interfaces.
132
133 %files -n %{libqtpositioningquick}
134 %{_qt5_libdir}/libQt5PositioningQuick.so.%{qtmajor}*
135
136 #------------------------------------------------------------------------------
137
138 %package -n %{libqtpositioning_d}
139 Summary: Devel files needed to build apps based on QtPositioning
140 Group: Development/KDE and Qt
141 Requires: %{libqtpositioning} = %version
142 Requires: %{libqtpositioningquick} = %version
143 Provides: libqtpositioning5-devel = %version
144 Provides: libqt5positioning-devel = %version
145 Provides: qtpositioning5-devel = %version
146 Provides: qt5positioning-devel = %version
147
148 Provides: libqtpositioning5-private-devel = %version
149 Provides: libqt5positioning-private-devel = %version
150 Provides: qtpositioning5-private-devel = %version
151 Provides: qt5positioning-private-devel = %version
152
153 Provides: libqtpositioningquick5-private-devel = %version
154 Provides: libqt5positioningquick-private-devel = %version
155 Provides: qtpositioningquick5-private-devel = %version
156 Provides: qt5positioningquick-private-devel = %version
157
158 %description -n %{libqtpositioning_d}
159 Devel files needed to build apps based on Qt Positioning.
160
161 %files -n %{libqtpositioning_d}
162 %{_qt5_libdir}/libQt5Positioning.prl
163 %{_qt5_libdir}/libQt5Positioning.so
164 %{_qt5_libdir}/libQt5PositioningQuick.prl
165 %{_qt5_libdir}/libQt5PositioningQuick.so
166 %{_qt5_libdir}/pkgconfig/Qt5Positioning.pc
167 %{_qt5_libdir}/pkgconfig/Qt5PositioningQuick.pc
168 %{_qt5_libdir}/cmake/Qt5Positioning/
169 %{_qt5_libdir}/cmake/Qt5PositioningQuick/
170 %{_qt5_datadir}/examples/positioning
171 %{_qt5_datadir}/mkspecs/modules/qt_lib_positioning.pri
172 %{_qt5_includedir}/QtPositioning/
173 %{_qt5_datadir}/mkspecs/modules/qt_lib_positioning_private.pri
174 %{_qt5_includedir}/QtPositioningQuick/
175 %{_qt5_datadir}/mkspecs/modules/qt_lib_positioningquick.pri
176 %{_qt5_datadir}/mkspecs/modules/qt_lib_positioningquick_private.pri
177
178 #------------------------------------------------------------------------------
179
180 %package -n %{libqtlocation}
181 Summary: Qt%{qtmajor} Location Component Library
182 Group: System/Libraries
183
184 %description -n %{libqtlocation}
185 Qt%{qtmajor} Location Component Library.
186
187 The Location module provides location information via QML and C++ interfaces.
188
189 %files -n %{libqtlocation}
190 %{_qt5_libdir}/libQt5Location.so.%{qtmajor}*
191
192 #------------------------------------------------------------------------------
193
194 %package -n %{libqtlocation_d}
195 Summary: Devel files needed to build apps based on QtLocation
196 Group: Development/KDE and Qt
197 Requires: %{libqtlocation} = %version
198 Provides: libqtlocation5-devel = %version
199 Provides: libqt5location-devel = %version
200 Provides: qtlocation5-devel = %version
201 Provides: qt5location-devel = %version
202
203 Provides: libqtlocation5-private-devel = %version
204 Provides: libqt5location-private-devel = %version
205 Provides: qtloation5-private-devel = %version
206 Provides: qt5location-private-devel = %version
207
208 %description -n %{libqtlocation_d}
209 Devel files needed to build apps based on Qt Location.
210
211 %files -n %{libqtlocation_d}
212 %{_qt5_libdir}/cmake/Qt5Location
213 %{_qt5_libdir}/libQt5Location.prl
214 %{_qt5_libdir}/libQt5Location.so
215 %{_qt5_libdir}/pkgconfig/Qt5Location.pc
216 %{_qt5_includedir}/QtLocation
217 %{_qt5_datadir}/mkspecs/modules/qt_lib_location.pri
218 %{_qt5_datadir}/mkspecs/modules/qt_lib_location_private.pri
219
220 #------------------------------------------------------------------------------
221
222 %prep
223 %setup -q -n qtlocation-everywhere-src-%{qtversion}
224
225 %build
226 %qmake_qt5
227 %__make -j4
228
229 %if %{build_docs}
230 %__make docs
231 %endif
232
233 %install
234 %make_install INSTALL_ROOT=%{buildroot}
235
236 %if %{build_docs}
237 %make_install install_docs INSTALL_ROOT=%{buildroot}
238 %endif
239
240 # .la and .a files, die, die, die.
241 find %{buildroot} -name '*.la' -delete

  ViewVC Help
Powered by ViewVC 1.1.30