/[packages]/cauldron/roundcubemail/current/SPECS/roundcubemail.spec
ViewVC logotype

Annotation of /cauldron/roundcubemail/current/SPECS/roundcubemail.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 188735 - (hide annotations) (download)
Thu Dec 29 18:08:51 2011 UTC (12 years, 3 months ago) by dams
File size: 3949 byte(s)
- Update README.urpmi to warn about 'upgrade' of the database (bug #3862)

1 dams 188735 %define rel 2
2 dams 129149 %define beta 0
3     %if %beta
4     %define release %mkrel 0.%beta.%rel
5     %define distname %name-%version-%beta-dep.tar.gz
6     %define dirname %name-%version-%beta-dep
7     %else
8     %define release %mkrel %rel
9     %define distname %name-%version-dep.tar.gz
10     %define dirname %name-%version-dep
11     %endif
12    
13     Name: roundcubemail
14 dams 184800 Version: 0.7
15 dams 129149 Release: %{release}
16     Summary: A PHP-based webmail server
17     Group: System/Servers
18 dams 129151 License: GPLv3
19 dams 129149 # Use the -dep tarballs. These use system copies of the PHP stuff
20     # rather than including them, which is better for our purposes.
21     # - AdamW 2007/07
22     URL: http://www.roundcube.net/
23     Source0: http://downloads.sourceforge.net/roundcubemail/%{distname}
24 dams 188735 Source1: README.urpmi
25 dams 129149 Epoch: 1
26     #BuildRequires: apache-devel pcre-devel rpm-helper
27     Requires: apache-mod_php
28     Requires: php-gd
29     Requires: php-gettext
30     Requires: php-iconv
31     Requires: php-mbstring
32     Requires: php-mcrypt
33     Requires: php-openssl
34     Requires: php-pspell
35     Requires: php-session
36     Requires: php-pear-Auth_SASL
37     Requires: php-pear-Mail_Mime
38     Requires: php-pear-Net_SMTP
39     Requires: php-pear-Net_LDAP2
40     Requires: php-pear-MDB2
41     Requires: php-pear-Net_IDNA2
42     # The installer suggests the use of these, but they're not
43     # required - AdamW 2011/01
44     Suggests: php-fileinfo
45     Suggests: php-intl
46     # Most people will probably use mysql, but you can use sqlite or
47     # pgsql, so not a hard require - AdamW 2008/10
48     Suggests: php-pear-MDB2_Driver_mysql
49    
50     BuildArch: noarch
51    
52     %description
53     RoundCube Webmail is a browser-based multilingual IMAP client with an
54     application-like user interface. It provides full functionality you
55     expect from an e-mail client, including MIME support, address book,
56     folder manipulation, message searching and spell checking. RoundCube
57     Webmail is written in PHP and requires a MySQL or PostgreSQL database.
58     The user interface is fully skinnable using XHTML and CSS 2.
59    
60 dams 188735 If upgading an existing installation, please read instructions under
61     %{docdir}/README.urpmi for upgrading your MySQL/PostgreSQL/SQLite
62     database.
63    
64 dams 129149 %prep
65     %setup -q -n %{dirname}
66    
67     %build
68    
69     %install
70     rm -rf %{buildroot}
71     # tell it that we're moving the configuration files
72     for i in installer/index.php program/include/iniset.php; do \
73     sed -i \
74     -e "s,INSTALL_PATH . 'config','%{_sysconfdir}/%{name}',g" \
75     $i; \
76     done
77     # use systemwide log dir and temp dir
78     sed -i \
79     -e 's,logs/,%{_logdir}/%{name}/,g' \
80     -e 's,temp/,/tmp/,g' \
81     config/main.inc.php.dist
82     mkdir -p %{buildroot}%{_datadir}/%{name}
83     mkdir -p %{buildroot}%{_sysconfdir}/%{name}
84     mkdir -p %{buildroot}%{_logdir}/%{name}
85     cp -a config/db.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/db.inc.php
86     cp -a config/db.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/db.inc.php.dist
87     cp -a config/main.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/main.inc.php
88     cp -a config/main.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/main.inc.php.dist
89     rm -rf config
90     rm -rf temp
91     rm -rf logs
92     cp -a * %{buildroot}%{_datadir}/%{name}
93    
94     pushd %{buildroot}%{_datadir}/%{name}
95     rm -f CHANGELOG INSTALL UPGRADING LICENSE README
96     popd
97    
98 dams 188735 mkdir -p %{buildroot}%{_defaultdocdir}/%{name}
99     install -p %{SOURCE1} %{buildroot}%{_defaultdocdir}/%{name}/README.urpmi
100 dams 129149
101     mkdir -p %{buildroot}%{_webappconfdir}
102     cat > %{buildroot}%{_webappconfdir}/%{name}.conf <<EOF
103     Alias /%{name} %{_datadir}/%{name}
104    
105     <Directory %{_datadir}/%{name}>
106     Order allow,deny
107     Allow from all
108     </Directory>
109    
110     <Directory %{_datadir}/%{name}/SQL>
111     Order deny,allow
112     Deny from all
113     </Directory>
114    
115     php_value suhosin.session.encrypt Off
116     EOF
117    
118     %files
119 dams 188735 %doc CHANGELOG README UPGRADING
120 dams 129149 %{_datadir}/%{name}
121     %dir %{_sysconfdir}/%{name}
122     %{_logdir}/%{name}
123     # these store the default values, the installer refers to them
124     # no need to edit them so they're not tagged config - AdamW 2011/01
125     %{_sysconfdir}/%{name}/db.inc.php.dist
126     %{_sysconfdir}/%{name}/main.inc.php.dist
127     %config(noreplace) %{_sysconfdir}/%{name}/db.inc.php
128     %config(noreplace) %{_sysconfdir}/%{name}/main.inc.php
129     %config(noreplace) %{_webappconfdir}/%{name}.conf

  ViewVC Help
Powered by ViewVC 1.1.30