/[packages]/cauldron/roundcubemail/current/SPECS/roundcubemail.spec
ViewVC logotype

Annotation of /cauldron/roundcubemail/current/SPECS/roundcubemail.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 194498 - (hide annotations) (download)
Tue Jan 10 11:54:29 2012 UTC (12 years, 2 months ago) by guillomovitch
File size: 4938 byte(s)
no need to advertise distribution-specific documentation in package description
1 dams 194074 %define rel 1
2 dams 129149 %define beta 0
3     %if %beta
4     %define release %mkrel 0.%beta.%rel
5     %define distname %name-%version-%beta-dep.tar.gz
6     %define dirname %name-%version-%beta-dep
7     %else
8     %define release %mkrel %rel
9     %define distname %name-%version-dep.tar.gz
10     %define dirname %name-%version-dep
11     %endif
12    
13     Name: roundcubemail
14 dams 194074 Version: 0.7.1
15 dams 129149 Release: %{release}
16     Summary: A PHP-based webmail server
17     Group: System/Servers
18 dams 129151 License: GPLv3
19 dams 129149 # Use the -dep tarballs. These use system copies of the PHP stuff
20     # rather than including them, which is better for our purposes.
21     # - AdamW 2007/07
22     URL: http://www.roundcube.net/
23     Source0: http://downloads.sourceforge.net/roundcubemail/%{distname}
24     Epoch: 1
25     #BuildRequires: apache-devel pcre-devel rpm-helper
26     Requires: apache-mod_php
27     Requires: php-gd
28     Requires: php-gettext
29     Requires: php-iconv
30     Requires: php-mbstring
31     Requires: php-mcrypt
32     Requires: php-openssl
33     Requires: php-pspell
34     Requires: php-session
35     Requires: php-pear-Auth_SASL
36     Requires: php-pear-Mail_Mime
37     Requires: php-pear-Net_SMTP
38     Requires: php-pear-Net_LDAP2
39     Requires: php-pear-MDB2
40     Requires: php-pear-Net_IDNA2
41     # The installer suggests the use of these, but they're not
42     # required - AdamW 2011/01
43     Suggests: php-fileinfo
44     Suggests: php-intl
45     # Most people will probably use mysql, but you can use sqlite or
46     # pgsql, so not a hard require - AdamW 2008/10
47     Suggests: php-pear-MDB2_Driver_mysql
48    
49     BuildArch: noarch
50    
51     %description
52     RoundCube Webmail is a browser-based multilingual IMAP client with an
53     application-like user interface. It provides full functionality you
54     expect from an e-mail client, including MIME support, address book,
55     folder manipulation, message searching and spell checking. RoundCube
56     Webmail is written in PHP and requires a MySQL or PostgreSQL database.
57     The user interface is fully skinnable using XHTML and CSS 2.
58    
59     %prep
60     %setup -q -n %{dirname}
61    
62     %build
63    
64     %install
65     rm -rf %{buildroot}
66     # tell it that we're moving the configuration files
67     for i in installer/index.php program/include/iniset.php; do \
68     sed -i \
69     -e "s,INSTALL_PATH . 'config','%{_sysconfdir}/%{name}',g" \
70     $i; \
71     done
72     # use systemwide log dir and temp dir
73     sed -i \
74     -e 's,logs/,%{_logdir}/%{name}/,g' \
75     -e 's,temp/,/tmp/,g' \
76     config/main.inc.php.dist
77     mkdir -p %{buildroot}%{_datadir}/%{name}
78     mkdir -p %{buildroot}%{_sysconfdir}/%{name}
79     mkdir -p %{buildroot}%{_logdir}/%{name}
80     cp -a config/db.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/db.inc.php
81     cp -a config/main.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/main.inc.php
82     rm -rf config
83     rm -rf temp
84     rm -rf logs
85     cp -a * %{buildroot}%{_datadir}/%{name}
86    
87     pushd %{buildroot}%{_datadir}/%{name}
88     rm -f CHANGELOG INSTALL UPGRADING LICENSE README
89     popd
90    
91     mkdir -p %{buildroot}%{_webappconfdir}
92     cat > %{buildroot}%{_webappconfdir}/%{name}.conf <<EOF
93     Alias /%{name} %{_datadir}/%{name}
94    
95     <Directory %{_datadir}/%{name}>
96     Order allow,deny
97     Allow from all
98     </Directory>
99    
100     <Directory %{_datadir}/%{name}/SQL>
101     Order deny,allow
102     Deny from all
103     </Directory>
104    
105     php_value suhosin.session.encrypt Off
106     EOF
107    
108 guillomovitch 188741 cat > README.urpmi <<EOF
109     Mageia RPM specific notes
110    
111     setup
112     -----
113     The setup used here differs from a standard installation in the following
114     ways:
115     * Logs are stored to /var/log/roundcubemail
116     * Temporary files are placed in /tmp
117     * Configuration files (main.inc.php and db.inc.php) are placed in
118     %{_sysconfdir}/roundcubemail
119    
120 dams 194074 configuration/upgrade
121 guillomovitch 188741 -------
122     Use the GUI to do the configuration/upgrade:
123     RoundCube provides an installer which can help you to do all
124     the installation/upgrade. The feature is disabled by default for
125     security reasons but you can enable it in 'main.inc.php' by
126     setting the 'enable_installer' variable to 'true'.
127     Once done, browse http://server/roundcubemail/installer
128    
129     Use the CLI to do the configuration/upgrade:
130     You will need to edit %{_sysconfdir}/roundcubemail/main.inc.php and
131     %{_sysconfdir}/roundcubemail/db.inc.php appropriately for your site before you
132     can use Roundcube. You must at least configure an appropriate mail
133     server and port in main.inc.php, and change the
134     $rcmail_config['des_key'] setting. In db.inc.php you must configure
135     an appropriate database location and user; in the most simple
136     configuration, you would create a new user and database both named
137     'roundcubemail' on a MySQL server running on the same machine, give
138     the roundcubemail user full read/write access to the roundcubemail
139     database, and set db.inc.php appropriately.
140    
141     Information:
142     - you can drop all of the tables and use the '*.initial.sql' file
143     to fully recreate the database.
144     - If any database change is needed, go to %{_datadir}/roundcubemail/SQL
145     and use '*.update.sql' where '*' is your database backend type.
146     EOF
147    
148 dams 129149 %files
149 dams 188735 %doc CHANGELOG README UPGRADING
150 dams 129149 %{_datadir}/%{name}
151     %dir %{_sysconfdir}/%{name}
152     %{_logdir}/%{name}
153 guillomovitch 188741 %attr(640,root,apache) %config(noreplace) %{_sysconfdir}/%{name}/db.inc.php
154 dams 129149 %config(noreplace) %{_sysconfdir}/%{name}/main.inc.php
155     %config(noreplace) %{_webappconfdir}/%{name}.conf

  ViewVC Help
Powered by ViewVC 1.1.30