/[packages]/cauldron/roundcubemail/current/SPECS/roundcubemail.spec
ViewVC logotype

Annotation of /cauldron/roundcubemail/current/SPECS/roundcubemail.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 228591 - (hide annotations) (download)
Thu Apr 5 00:45:26 2012 UTC (12 years ago) by dams
File size: 4917 byte(s)
remove 'php-pspell' as a require
1 dams 228591 %define rel 2
2 dams 129149 %define beta 0
3     %if %beta
4     %define release %mkrel 0.%beta.%rel
5     %define distname %name-%version-%beta-dep.tar.gz
6     %define dirname %name-%version-%beta-dep
7     %else
8     %define release %mkrel %rel
9     %define distname %name-%version-dep.tar.gz
10     %define dirname %name-%version-dep
11     %endif
12    
13     Name: roundcubemail
14 dams 194074 Version: 0.7.1
15 dams 129149 Release: %{release}
16     Summary: A PHP-based webmail server
17     Group: System/Servers
18 dams 129151 License: GPLv3
19 dams 129149 # Use the -dep tarballs. These use system copies of the PHP stuff
20     # rather than including them, which is better for our purposes.
21     # - AdamW 2007/07
22     URL: http://www.roundcube.net/
23     Source0: http://downloads.sourceforge.net/roundcubemail/%{distname}
24     Epoch: 1
25     #BuildRequires: apache-devel pcre-devel rpm-helper
26     Requires: apache-mod_php
27     Requires: php-gd
28     Requires: php-gettext
29     Requires: php-iconv
30     Requires: php-mbstring
31     Requires: php-mcrypt
32     Requires: php-openssl
33     Requires: php-session
34     Requires: php-pear-Auth_SASL
35     Requires: php-pear-Mail_Mime
36     Requires: php-pear-Net_SMTP
37     Requires: php-pear-Net_LDAP2
38     Requires: php-pear-MDB2
39     Requires: php-pear-Net_IDNA2
40     # The installer suggests the use of these, but they're not
41     # required - AdamW 2011/01
42     Suggests: php-fileinfo
43     Suggests: php-intl
44     # Most people will probably use mysql, but you can use sqlite or
45     # pgsql, so not a hard require - AdamW 2008/10
46     Suggests: php-pear-MDB2_Driver_mysql
47    
48     BuildArch: noarch
49    
50     %description
51     RoundCube Webmail is a browser-based multilingual IMAP client with an
52     application-like user interface. It provides full functionality you
53     expect from an e-mail client, including MIME support, address book,
54     folder manipulation, message searching and spell checking. RoundCube
55     Webmail is written in PHP and requires a MySQL or PostgreSQL database.
56     The user interface is fully skinnable using XHTML and CSS 2.
57    
58     %prep
59     %setup -q -n %{dirname}
60    
61     %build
62    
63     %install
64     rm -rf %{buildroot}
65     # tell it that we're moving the configuration files
66     for i in installer/index.php program/include/iniset.php; do \
67     sed -i \
68     -e "s,INSTALL_PATH . 'config','%{_sysconfdir}/%{name}',g" \
69     $i; \
70     done
71     # use systemwide log dir and temp dir
72     sed -i \
73     -e 's,logs/,%{_logdir}/%{name}/,g' \
74     -e 's,temp/,/tmp/,g' \
75     config/main.inc.php.dist
76     mkdir -p %{buildroot}%{_datadir}/%{name}
77     mkdir -p %{buildroot}%{_sysconfdir}/%{name}
78     mkdir -p %{buildroot}%{_logdir}/%{name}
79     cp -a config/db.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/db.inc.php
80     cp -a config/main.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/main.inc.php
81     rm -rf config
82     rm -rf temp
83     rm -rf logs
84     cp -a * %{buildroot}%{_datadir}/%{name}
85    
86     pushd %{buildroot}%{_datadir}/%{name}
87     rm -f CHANGELOG INSTALL UPGRADING LICENSE README
88     popd
89    
90     mkdir -p %{buildroot}%{_webappconfdir}
91     cat > %{buildroot}%{_webappconfdir}/%{name}.conf <<EOF
92     Alias /%{name} %{_datadir}/%{name}
93    
94     <Directory %{_datadir}/%{name}>
95     Order allow,deny
96     Allow from all
97     </Directory>
98    
99     <Directory %{_datadir}/%{name}/SQL>
100     Order deny,allow
101     Deny from all
102     </Directory>
103    
104     php_value suhosin.session.encrypt Off
105     EOF
106    
107 guillomovitch 188741 cat > README.urpmi <<EOF
108     Mageia RPM specific notes
109    
110     setup
111     -----
112     The setup used here differs from a standard installation in the following
113     ways:
114     * Logs are stored to /var/log/roundcubemail
115     * Temporary files are placed in /tmp
116     * Configuration files (main.inc.php and db.inc.php) are placed in
117     %{_sysconfdir}/roundcubemail
118    
119 dams 194074 configuration/upgrade
120 guillomovitch 188741 -------
121     Use the GUI to do the configuration/upgrade:
122     RoundCube provides an installer which can help you to do all
123     the installation/upgrade. The feature is disabled by default for
124     security reasons but you can enable it in 'main.inc.php' by
125     setting the 'enable_installer' variable to 'true'.
126     Once done, browse http://server/roundcubemail/installer
127    
128     Use the CLI to do the configuration/upgrade:
129     You will need to edit %{_sysconfdir}/roundcubemail/main.inc.php and
130     %{_sysconfdir}/roundcubemail/db.inc.php appropriately for your site before you
131     can use Roundcube. You must at least configure an appropriate mail
132     server and port in main.inc.php, and change the
133     $rcmail_config['des_key'] setting. In db.inc.php you must configure
134     an appropriate database location and user; in the most simple
135     configuration, you would create a new user and database both named
136     'roundcubemail' on a MySQL server running on the same machine, give
137     the roundcubemail user full read/write access to the roundcubemail
138     database, and set db.inc.php appropriately.
139    
140     Information:
141     - you can drop all of the tables and use the '*.initial.sql' file
142     to fully recreate the database.
143     - If any database change is needed, go to %{_datadir}/roundcubemail/SQL
144     and use '*.update.sql' where '*' is your database backend type.
145     EOF
146    
147 dams 129149 %files
148 dams 188735 %doc CHANGELOG README UPGRADING
149 dams 129149 %{_datadir}/%{name}
150     %dir %{_sysconfdir}/%{name}
151     %{_logdir}/%{name}
152 guillomovitch 188741 %attr(640,root,apache) %config(noreplace) %{_sysconfdir}/%{name}/db.inc.php
153 dams 129149 %config(noreplace) %{_sysconfdir}/%{name}/main.inc.php
154     %config(noreplace) %{_webappconfdir}/%{name}.conf

  ViewVC Help
Powered by ViewVC 1.1.30