/[packages]/cauldron/roundcubemail/pristine/SPECS/roundcubemail.spec
ViewVC logotype

Annotation of /cauldron/roundcubemail/pristine/SPECS/roundcubemail.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 402221 - (hide annotations) (download)
Wed Mar 13 03:40:22 2013 UTC (11 years ago) by spuhler
Original Path: cauldron/roundcubemail/current/SPECS/roundcubemail.spec
File size: 4776 byte(s)
corrected spelling of Requires: php-pdo_mysql from php-pdo-mysql
1 dams 291171 %define oname %{name}-%{version}-dep
2 dams 129149
3     Name: roundcubemail
4 dams 397860 Version: 0.8.5
5 spuhler 402221 Release: %mkrel 3
6 dams 129149 Summary: A PHP-based webmail server
7     Group: System/Servers
8 dams 129151 License: GPLv3
9 dams 129149 # Use the -dep tarballs. These use system copies of the PHP stuff
10     # rather than including them, which is better for our purposes.
11     # - AdamW 2007/07
12     URL: http://www.roundcube.net/
13 dams 291171 Source0: http://downloads.sourceforge.net/%{name}/%{oname}.tar.gz
14     Patch0: roundcubemail-0.8.1-strict.patch
15 dams 129149 Epoch: 1
16     #BuildRequires: apache-devel pcre-devel rpm-helper
17     Requires: apache-mod_php
18     Requires: php-gd
19     Requires: php-gettext
20     Requires: php-iconv
21     Requires: php-mbstring
22     Requires: php-mcrypt
23     Requires: php-openssl
24     Requires: php-session
25 spuhler 402221 Requires: php-pdo_mysql
26 dams 129149 Requires: php-pear-Auth_SASL
27     Requires: php-pear-Mail_Mime
28     Requires: php-pear-Net_SMTP
29     Requires: php-pear-Net_LDAP2
30     Requires: php-pear-MDB2
31     Requires: php-pear-Net_IDNA2
32     # The installer suggests the use of these, but they're not
33     # required - AdamW 2011/01
34     Suggests: php-fileinfo
35     Suggests: php-intl
36     # Most people will probably use mysql, but you can use sqlite or
37     # pgsql, so not a hard require - AdamW 2008/10
38     Suggests: php-pear-MDB2_Driver_mysql
39     BuildArch: noarch
40    
41     %description
42     RoundCube Webmail is a browser-based multilingual IMAP client with an
43     application-like user interface. It provides full functionality you
44     expect from an e-mail client, including MIME support, address book,
45     folder manipulation, message searching and spell checking. RoundCube
46     Webmail is written in PHP and requires a MySQL or PostgreSQL database.
47     The user interface is fully skinnable using XHTML and CSS 2.
48    
49     %prep
50 dams 291171 %setup -q -n %{oname}
51     %apply_patches
52 dams 129149
53     %build
54    
55     %install
56     # tell it that we're moving the configuration files
57     for i in installer/index.php program/include/iniset.php; do \
58     sed -i \
59     -e "s,INSTALL_PATH . 'config','%{_sysconfdir}/%{name}',g" \
60     $i; \
61     done
62     # use systemwide log dir and temp dir
63     sed -i \
64     -e 's,logs/,%{_logdir}/%{name}/,g' \
65     -e 's,temp/,/tmp/,g' \
66     config/main.inc.php.dist
67     mkdir -p %{buildroot}%{_datadir}/%{name}
68     mkdir -p %{buildroot}%{_sysconfdir}/%{name}
69     mkdir -p %{buildroot}%{_logdir}/%{name}
70     cp -a config/db.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/db.inc.php
71     cp -a config/main.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/main.inc.php
72     rm -rf config
73     rm -rf temp
74     rm -rf logs
75     cp -a * %{buildroot}%{_datadir}/%{name}
76    
77     pushd %{buildroot}%{_datadir}/%{name}
78     rm -f CHANGELOG INSTALL UPGRADING LICENSE README
79     popd
80    
81     mkdir -p %{buildroot}%{_webappconfdir}
82     cat > %{buildroot}%{_webappconfdir}/%{name}.conf <<EOF
83     Alias /%{name} %{_datadir}/%{name}
84    
85     <Directory %{_datadir}/%{name}>
86 spuhler 394137 AllowOverride All
87     Require all granted
88 dams 129149 </Directory>
89    
90     <Directory %{_datadir}/%{name}/SQL>
91 spuhler 394137 AllowOverride All
92     Require all granted
93 dams 129149 </Directory>
94    
95     php_value suhosin.session.encrypt Off
96     EOF
97    
98 guillomovitch 188741 cat > README.urpmi <<EOF
99     Mageia RPM specific notes
100    
101     setup
102     -----
103     The setup used here differs from a standard installation in the following
104     ways:
105     * Logs are stored to /var/log/roundcubemail
106     * Temporary files are placed in /tmp
107     * Configuration files (main.inc.php and db.inc.php) are placed in
108     %{_sysconfdir}/roundcubemail
109    
110 dams 194074 configuration/upgrade
111 guillomovitch 188741 -------
112     Use the GUI to do the configuration/upgrade:
113     RoundCube provides an installer which can help you to do all
114     the installation/upgrade. The feature is disabled by default for
115     security reasons but you can enable it in 'main.inc.php' by
116     setting the 'enable_installer' variable to 'true'.
117     Once done, browse http://server/roundcubemail/installer
118    
119     Use the CLI to do the configuration/upgrade:
120     You will need to edit %{_sysconfdir}/roundcubemail/main.inc.php and
121     %{_sysconfdir}/roundcubemail/db.inc.php appropriately for your site before you
122     can use Roundcube. You must at least configure an appropriate mail
123     server and port in main.inc.php, and change the
124     $rcmail_config['des_key'] setting. In db.inc.php you must configure
125     an appropriate database location and user; in the most simple
126     configuration, you would create a new user and database both named
127     'roundcubemail' on a MySQL server running on the same machine, give
128     the roundcubemail user full read/write access to the roundcubemail
129     database, and set db.inc.php appropriately.
130    
131     Information:
132     - you can drop all of the tables and use the '*.initial.sql' file
133     to fully recreate the database.
134     - If any database change is needed, go to %{_datadir}/roundcubemail/SQL
135     and use '*.update.sql' where '*' is your database backend type.
136     EOF
137    
138 dams 129149 %files
139 dams 291171 %doc CHANGELOG LICENSE README.md SQL UPGRADING
140 dams 129149 %{_datadir}/%{name}
141     %dir %{_sysconfdir}/%{name}
142 spuhler 394179 %attr(740,apache,apache)%{_logdir}/%{name}
143 spuhler 394143 %attr(640,root,apache)%config(noreplace) %{_sysconfdir}/%{name}/db.inc.php
144 dams 129149 %config(noreplace) %{_sysconfdir}/%{name}/main.inc.php
145     %config(noreplace) %{_webappconfdir}/%{name}.conf

  ViewVC Help
Powered by ViewVC 1.1.30