/[packages]/cauldron/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /cauldron/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1140281 - (hide annotations) (download)
Mon Aug 14 15:14:50 2017 UTC (6 years, 8 months ago) by pterjan
File size: 23504 byte(s)
Fix group
1 shlomif 893775 # Taken from the fedora ruby-2.2.3 .spec. Thanks!
2 blino 1152
3 shlomif 893775 %global major_version 2
4 pterjan 1139983 %global minor_version 4
5     %global teeny_version 1
6 shlomif 893775 %global major_minor_version %{major_version}.%{minor_version}
7    
8     %global ruby_version %{major_minor_version}.%{teeny_version}
9     %global ruby_release %{ruby_version}
10    
11     # Specify the named version. It has precedense to revision.
12     #%%global milestone rc1
13    
14     # Keep the revision enabled for pre-releases from SVN.
15     #%%global revision 48936
16    
17     %global ruby_archive %{name}-%{ruby_version}
18    
19     # If revision and milestone are removed/commented out, the official release build is expected.
20     %if 0%{?milestone:1}%{?revision:1} != 0
21     %global development_release %{?milestone}%{?!milestone:%{?revision:r%{revision}}}
22     %global ruby_archive %{ruby_archive}-%{?milestone}%{?!milestone:%{?revision:r%{revision}}}
23     %endif
24    
25    
26 pterjan 1109449 %define rel 1
27 pterjan 894460 %{!?release_string:%global release_string %mkrel %{?development_release:0.}%{rel}%{?development_release:.%{development_release}}}
28 shlomif 893775
29     # The RubyGems library has to stay out of Ruby directory three, since the
30     # RubyGems should be share by all Ruby implementations.
31     %global rubygems_dir %{_datadir}/rubygems
32    
33 pterjan 1139983 # Bundled libraries versions
34     %global rubygems_version 2.6.11
35     %global molinillo_version 0.5.7
36    
37 shlomif 893775 # TODO: The IRB has strange versioning. Keep the Ruby's versioning ATM.
38     # http://redmine.ruby-lang.org/issues/5313
39     %global irb_version %{ruby_version}
40 pterjan 1139983 %global bigdecimal_version 1.3.0
41     %global did_you_mean_version 1.1.0
42     %global io_console_version 0.4.6
43     %global json_version 2.0.2
44     %global minitest_version 5.10.1
45     %global net_telnet_version 0.1.1
46     %global openssl_version 2.0.3
47     %global power_assert_version 0.4.1
48     %global psych_version 2.2.2
49     %global rake_version 12.0.0
50     %global rdoc_version 5.0.0
51     %global test_unit_version 3.2.3
52     %global xmlrpc_version 0.2.1
53 shlomif 893775
54     # Might not be needed in the future, if we are lucky enough.
55     # https://bugzilla.redhat.com/show_bug.cgi?id=888262
56     %global tapset_root %{_datadir}/systemtap
57     %global tapset_dir %{tapset_root}/tapset
58     %global tapset_libdir %(echo %{_libdir} | sed 's/64//')*
59    
60     %global _normalized_cpu %(echo %{_target_cpu} | sed 's/^ppc/powerpc/;s/i.86/i386/;s/sparcv./sparc/')
61    
62     %global with_rubypick 1
63    
64     # Additional defines by Mageia.
65    
66     %define subver %{major_minor_version}
67 pterjan 1140265 %define rubyapi %{subver}.1
68 shlomif 893775 %define rubyver %{ruby_version}
69    
70 fwang 291590 %define libname %mklibname ruby %{subver}
71    
72 pterjan 1140037 %global ruby_libdir %{_datadir}/%{name}
73     %global ruby_libarchdir %{_libdir}/%{name}
74 fwang 291557
75 fwang 290007 # This is the local lib/arch and should not be used for packaging.
76 pterjan 1140037 %global ruby_sitedir site_ruby
77     %global ruby_sitelibdir %{_prefix}/local/share/%{name}/%{ruby_sitedir}
78     %global ruby_sitearchdir %{_prefix}/local/%{_lib}/%{name}/%{ruby_sitedir}
79 fwang 290007
80     # This is the general location for libs/archs compatible with all
81     # or most of the Ruby versions available in the Fedora repositories.
82 pterjan 1140037 %global ruby_vendordir vendor_ruby
83     %global ruby_vendorlibdir %{ruby_libdir}/%{ruby_vendordir}
84     %global ruby_vendorarchdir %{ruby_libarchdir}/%{ruby_vendordir}
85 fwang 290007
86 pterjan 601596 # The RubyGems library has to stay out of Ruby directory tree, since the
87     # RubyGems should be shared by all Ruby implementations.
88 pterjan 1140037 %define gem_dir %{_datadir}/gems
89 fwang 290007
90 pterjan 1140265 %define bootstrap 1
91     %define build_gems 1
92 fwang 292558
93 blino 1152 Summary: Object Oriented Script Language
94     Name: ruby
95 shlomif 893775 Version: %{rubyver}
96 pterjan 894460 Release: %release_string
97 kamil 397518 License: Ruby or BSD
98 blino 1152 Group: Development/Ruby
99     BuildRequires: autoconf
100     BuildRequires: byacc
101 shlomif 291698 BuildRequires: doxygen
102 blino 1152 BuildRequires: ncurses-devel
103     BuildRequires: readline-devel
104 fwang 276350 BuildRequires: db-devel
105 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
106 blino 1152 BuildRequires: openssl-devel
107     BuildRequires: zlib-devel
108 fwang 289987 BuildRequires: libffi-devel
109     BuildRequires: yaml-devel
110 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
111 pterjan 1139983 # Needed to pass test_set_program_name(TestRubyOptions)
112     BuildRequires: procps
113 tv 674762 Conflicts: ruby-devel < 2.0.0.p451-4.mga5
114 blino 1152 Obsoletes: ruby-rexml
115     Provides: ruby-rexml
116 pterjan 1140083 # Tcl/Tk support was removed from stdlib in Ruby 2.4
117     Obsoletes: ruby-tk < 2.4.0
118 pterjan 435566 # Couldn't get the standalone gem to work
119     Provides: rubygem(psych)
120 blino 1152 # explicit file provides (since such requires are automatically added by find-requires)
121     Provides: /usr/bin/ruby
122 pterjan 894480 Provides: ruby(abi) = %subver
123 shlomif 893775 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}.tar.xz
124 pterjan 435211 Source1: operating_system.rb
125 blino 1152 Source3: ruby.macros
126 tv 673709 # From FC:
127     # RPM dependency generators.
128     Source8: rubygems.attr
129     Source9: rubygems.req
130     Source10: rubygems.prov
131 shlomif 893775 URL: http://ruby-lang.org/
132 fwang 292558 %if !%bootstrap
133 fwang 293395 BuildRequires: ruby
134 fwang 292558 %endif
135 pterjan 895045 %if !%bootstrap || %build_gems
136 pterjan 894524 Requires: rubygems >= %{rubygems_version}
137     %endif
138 blino 1152
139 fwang 290007 # == FEDORA PATCHES BEGINS ==
140 pterjan 1139983 # Fix ruby_version abuse.
141     # https://bugs.ruby-lang.org/issues/11002
142     Patch0: ruby-2.3.0-ruby_version.patch
143 pterjan 435211 # http://bugs.ruby-lang.org/issues/7807
144 pterjan 1139983 Patch1: ruby-2.1.0-Prevent-duplicated-paths-when-empty-version-string-i.patch
145 shlomif 893775 # Allows to override libruby.so placement. Hopefully we will be able to return
146     # to plain --with-rubyarchprefix.
147     # http://bugs.ruby-lang.org/issues/8973
148 pterjan 1139983 Patch2: ruby-2.1.0-Enable-configuration-of-archlibdir.patch
149 shlomif 893775 # Force multiarch directories for i.86 to be always named i386. This solves
150     # some differencies in build between Fedora and RHEL.
151 pterjan 1139983 Patch3: ruby-2.1.0-always-use-i386.patch
152 fwang 290007 # Allows to install RubyGems into custom directory, outside of Ruby's tree.
153 shlomif 893775 # http://bugs.ruby-lang.org/issues/5617
154     Patch4: ruby-2.1.0-custom-rubygems-location.patch
155 pterjan 435211 # Make mkmf verbose by default
156 shlomif 893775 Patch5: ruby-1.9.3-mkmf-verbose.patch
157     # Adds support for '--with-prelude' configuration option. This allows to built
158     # in support for ABRT.
159     # http://bugs.ruby-lang.org/issues/8566
160     Patch6: ruby-2.1.0-Allow-to-specify-additional-preludes-by-configuratio.patch
161 luigiwalser 1050409 # Use miniruby to regenerate prelude.c.
162     # https://bugs.ruby-lang.org/issues/10554
163     Patch7: ruby-2.2.3-Generate-preludes-using-miniruby.patch
164 pterjan 1139983 # Workaround "an invalid stdio handle" error on PPC, due to recently introduced
165     # hardening features of glibc (rhbz#1361037).
166     # https://bugs.ruby-lang.org/issues/12666
167     Patch9: ruby-2.3.1-Rely-on-ldd-to-detect-glibc.patch
168     # Fix OpenSSL::TestSSL#test_sslctx_set_params failures due to recent changes in
169     # OpenSSL.
170     # https://github.com/ruby/openssl/issues/127
171     Patch10: ruby-2.5.0-allow-3DES-cipher-suites-in-test_sslctx_set_params.patch
172 fwang 290007 # == FEDORA PATCHES ENDS ==
173 pterjan 601634 # operating_system.rb sets default_dir to user_dir for non root, this causes the build
174     # to install gems into user dir
175 pterjan 1139983 #Patch20: ruby-2.3.0-Do-not-install-to-user-dir.patch
176 luigiwalser 795834
177 fwang 291591 %package -n %{libname}
178 fwang 291590 Summary: Libraries necessary to run Ruby
179     Group: Development/Ruby
180    
181 blino 1152 %package doc
182     Summary: Documentation for the powerful language Ruby
183     Group: Development/Ruby
184 fwang 202696 BuildArch: noarch
185 blino 1152
186     %package devel
187     Summary: Development file for the powerful language Ruby
188     Group: Development/Ruby
189 fwang 311925 Requires: %{name} = %{version}
190     Requires: %{libname} = %{version}
191 blino 1152
192 fwang 291551 %package RubyGems
193     Summary: The Ruby standard for packaging ruby libraries
194     Group: Development/Ruby
195 fwang 291590 Version: %{rubygems_version}
196 fwang 291551 Requires: ruby(abi) = %{subver}
197 fwang 291590 Provides: gem = %{rubygems_version}
198     Provides: rubygems = %{rubygems_version}
199     Provides: ruby(rubygems) = %{rubygems_version}
200 fwang 292586 Conflicts: rpm-mageia-setup-build < 1.159
201 fwang 291561 BuildArch: noarch
202 fwang 291551
203     %package rake
204     Summary: Simple ruby build program with capabilities similar to make
205     Group: Development/Ruby
206 pterjan 1140276 Version: %{rake_version}
207 fwang 291551 Requires: ruby(abi) = %{subver}
208 fwang 291561 BuildArch: noarch
209 fwang 291551
210 fwang 291562 %package minitest
211 shlomif 291733 Summary: Minitest provides a complete suite of testing facilities
212 fwang 291562 Group: Development/Ruby
213 pterjan 1140276 Version: %{minitest_version}
214 fwang 291562 License: MIT
215 fwang 291590 Requires: ruby(abi) = %{subver}
216     Requires: ruby(rubygems) >= %{rubygems_version}
217 fwang 291562 BuildArch: noarch
218    
219 pterjan 1140265 %package openssl
220     Summary: OpenSSL provides SSL, TLS and general purpose cryptography
221     Group: Development/Ruby
222     Version: %{openssl_version}
223     License: Ruby or BSD
224     Requires: ruby(abi) = %{subver}
225     Requires: ruby(rubygems) >= %{rubygems_version}
226    
227 pterjan 894459 %package power_assert
228     Summary: Power Assert for Ruby
229     Group: Development/Ruby
230 pterjan 1140276 Version: %{power_assert_version}
231 pterjan 894459 License: BSD
232     Requires: ruby(abi) = %{subver}
233     Requires: ruby(rubygems) >= %{rubygems_version}
234     BuildArch: noarch
235    
236 fwang 291562 %package json
237     Summary: This is a JSON implementation as a Ruby extension in C
238     Group: Development/Ruby
239 pterjan 1140276 Version: %{json_version}
240 fwang 291562 License: Ruby or GPLv2
241 fwang 291590 Requires: ruby(abi) = %{subver}
242     Requires: ruby(rubygems) >= %{rubygems_version}
243 pterjan 1140277 Conflicts: ruby < 4.3.1
244 fwang 291562
245     %package rdoc
246     Summary: A tool to generate HTML and command-line documentation for Ruby projects
247     Group: Development/Ruby
248 pterjan 1140276 Version: %{rdoc_version}
249 fwang 291562 License: GPLv2 and Ruby and MIT
250 fwang 291590 Requires: ruby(abi) = %{subver}
251     Requires: ruby(rubygems) >= %{rubygems_version}
252     Requires: ruby(irb) = %{version}
253 pterjan 1140276 Provides: rdoc = %{rdoc_version}
254     Provides: ri = %{rdoc_version}
255 fwang 291562 BuildArch: noarch
256    
257 fwang 291590 %package irb
258     Summary: The Interactive Ruby
259     Group: Development/Ruby
260     Provides: irb = %{version}-%{release}
261     Provides: ruby(irb) = %{version}-%{release}
262 fwang 313459 Conflicts: ruby < 1.9
263 fwang 313460 BuildArch: noarch
264 fwang 291590
265     %package bigdecimal
266     Summary: BigDecimal provides arbitrary-precision floating point decimal arithmetic
267     Group: Development/Ruby
268 pterjan 1140276 Version: %{bigdecimal_version}
269 fwang 291590 License: GPL+ or Artistic
270     Requires: ruby(abi) = %{subver}
271     Requires: ruby(rubygems) >= %{rubygems_version}
272    
273 pterjan 1140265 %package did_you_mean
274     Summary: "Did you mean?" experience in Ruby
275     Version: %{did_you_mean_version}
276     Group: Development/Ruby
277     License: MIT
278     Requires: ruby(rubygems) >= %{rubygems_version}
279    
280 fwang 291590 %package io-console
281     Summary: IO/Console is a simple console utilizing library
282     Group: Development/Ruby
283 pterjan 1140276 Version: %{io_console_version}
284 fwang 291590 Requires: ruby(abi) = %{subver}
285     Requires: ruby(rubygems) >= %{rubygems_version}
286    
287 pterjan 1139983 %package psych
288 pterjan 435211 Summary: A libyaml wrapper for Ruby
289 pterjan 1140276 Version: %{psych_version}
290 pterjan 435211 Group: Development/Ruby
291     License: MIT
292     Requires: ruby(abi) = %{subver}
293     Requires: ruby(rubygems) >= %{rubygems_version}
294     Conflicts: ruby < 2.0.0
295    
296 pterjan 1140265 %package net-telnet
297     Summary: Provides telnet client functionality
298     Version: %{net_telnet_version}
299     Group: Development/Ruby
300     Requires: ruby(rubygems) >= %{rubygems_version}
301    
302 pterjan 1139983 %package test-unit
303 pterjan 435211 Summary: test/unit compatible API testing framework
304 pterjan 1140276 Version: %{test_unit_version}
305 pterjan 435211 Group: Development/Ruby
306     License: MIT
307 pterjan 1139983 Provides: rubygem(test-unit) = %{test_unit_version}
308 pterjan 435211 Requires: ruby(abi) = %{subver}
309     Requires: ruby(rubygems) >= %{rubygems_version}
310     Conflicts: ruby < 2.0.0
311     BuildArch: noarch
312    
313 pterjan 1139983 %package xmlrpc
314     Summary: XMLRPC is a lightweight protocol that enables remote procedure calls over HTTP
315     Version: %{xmlrpc_version}
316 pterjan 1140281 Group: Development/Ruby
317 pterjan 1139983 License: Ruby or BSD
318     Requires: ruby(abi) = %{subver}
319     Requires: ruby(rubygems) >= %{rubygems_version}
320     BuildArch: noarch
321    
322 blino 1152 %description
323     Ruby is the interpreted scripting language for quick and
324     easy object-oriented programming. It has many features to
325     process text files and to do system management tasks (as in
326     Perl). It is simple, straight-forward, and extensible.
327    
328     %description doc
329     Ruby is the interpreted scripting language for quick and
330     easy object-oriented programming. It has many features to
331     process text files and to do system management tasks (as in
332     Perl). It is simple, straight-forward, and extensible.
333    
334     This package contains the Ruby's documentation
335    
336 fwang 291590 %description -n %{libname}
337     This package includes the libruby, necessary to run Ruby.
338    
339 blino 1152 %description devel
340     Ruby is the interpreted scripting language for quick and
341     easy object-oriented programming. It has many features to
342     process text files and to do system management tasks (as in
343     Perl). It is simple, straight-forward, and extensible.
344    
345     This package contains the Ruby's devel files.
346    
347 fwang 291551 %description RubyGems
348     RubyGems is the Ruby standard for publishing and managing third party
349     libraries.
350    
351 fwang 291552 %description rake
352     Rake is a Make-like program implemented in Ruby. Tasks and dependencies are
353     specified in standard Ruby syntax.
354    
355 fwang 291562 %description rdoc
356     RDoc produces HTML and command-line documentation for Ruby projects. RDoc
357     includes the 'rdoc' and 'ri' tools for generating and displaying online
358     documentation.
359    
360     %description json
361     This is a implementation of the JSON specification according to RFC 4627.
362     You can think of it as a low fat alternative to XML, if you want to store
363     data to disk or transmit it over a network rather than use a verbose
364     markup language.
365    
366     %description minitest
367     minitest/unit is a small and incredibly fast unit testing framework.
368    
369     minitest/spec is a functionally complete spec engine.
370    
371     minitest/benchmark is an awesome way to assert the performance of your
372     algorithms in a repeatable manner.
373    
374     minitest/mock by Steven Baker, is a beautifully tiny mock object
375     framework.
376    
377     minitest/pride shows pride in testing and adds coloring to your test
378     output.
379 pterjan 1140265
380     %description openssl
381     OpenSSL provides SSL, TLS and general purpose cryptography. It wraps the
382     OpenSSL library.
383 fwang 291562
384 pterjan 894459 %description power_assert
385     Power Assert shows each value of variables and method calls in the expression.
386     It is useful for testing, providing which value wasn't correct when the
387     condition is not satisfied.
388    
389 fwang 291590 %description irb
390     The irb is acronym for Interactive Ruby. It evaluates ruby expression
391     from the terminal.
392    
393     %description bigdecimal
394     Ruby provides built-in support for arbitrary precision integer arithmetic.
395     For example:
396    
397     42**13 -> 1265437718438866624512
398    
399     BigDecimal provides similar support for very large or very accurate floating
400     point numbers. Decimal arithmetic is also useful for general calculation,
401     because it provides the correct answers people expect–whereas normal binary
402     floating point arithmetic often introduces subtle errors because of the
403     conversion between base 10 and base 2.
404    
405 pterjan 1140265 %description did_you_mean
406     "did you mean?" experience in Ruby: the error message will tell you the right
407     one when you misspelled something.
408    
409 fwang 291590 %description io-console
410     IO/Console provides very simple and portable access to console. It doesn't
411     provide higher layer features, such like curses and readline.
412    
413 pterjan 435211 %description psych
414     Psych is a YAML parser and emitter. Psych leverages
415     libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
416     capabilities. In addition to wrapping libyaml, Psych also knows how to
417     serialize and de-serialize most Ruby objects to and from the YAML format.
418    
419 pterjan 1140265 %description net-telnet
420     Provides telnet client functionality.
421    
422     This class also has, through delegation, all the methods of a socket object
423     (by default, a TCPSocket, but can be set by the Proxy option to new()). This
424     provides methods such as close() to end the session and sysread() to read data
425     directly from the host, instead of via the waitfor() mechanism. Note that if
426     you do use sysread() directly when in telnet mode, you should probably pass
427     the output through preprocess() to extract telnet command sequences.
428    
429 pterjan 435211 %description test-unit
430     This library implements test/unit compatible API on minitest.
431     The test/unit means that test/unit which was bundled with Ruby 1.8.
432    
433 pterjan 1139983 %description xmlrpc
434     XMLRPC is a lightweight protocol that enables remote procedure calls over
435     HTTP.
436    
437 blino 1152 %prep
438 shlomif 893775 %setup -q -n ruby-%{rubyver}
439 pterjan 916671 %autopatch -p1
440 blino 1152
441     %build
442 fwang 290038 autoconf
443 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
444 pterjan 435211 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
445 shlomif 893775 --enable-multiarch \
446     --with-rubylibprefix='%{ruby_libdir}' \
447     --with-archlibdir='%{_libdir}' \
448 pterjan 435211 --with-rubyarchprefix='%{ruby_libarchdir}' \
449 shlomif 893775 --with-sitedir='%{ruby_sitelibdir}' \
450     --with-sitearchdir='%{ruby_sitearchdir}' \
451     --with-vendordir='%{ruby_vendorlibdir}' \
452     --with-vendorarchdir='%{ruby_vendorarchdir}' \
453     --with-rubyhdrdir='%{_includedir}' \
454     --with-rubyarchhdrdir='%{_includedir}' \
455 pterjan 435211 --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
456     --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
457     --with-rubygemsdir='%{rubygems_dir}' \
458     --with-ruby-pc='%{name}.pc' \
459     --enable-multiarch \
460 pterjan 1139983 --with-compress-debug-sections=no \
461 pterjan 435211 --with-ruby-version=''
462 blino 1152
463 pterjan 1139983 %make_build Q=
464    
465 blino 1152 %install
466     %makeinstall_std install-doc
467    
468 pterjan 1139983 # Version is empty if --with-ruby-version is specified.
469     # http://bugs.ruby-lang.org/issues/7807
470     sed -i 's/Version: \${ruby_version}/Version: %{ruby_version}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
471    
472     # Kill bundled certificates, as they should be part of ca-certificates.
473     for cert in \
474     rubygems.global.ssl.fastly.net/DigiCertHighAssuranceEVRootCA.pem \
475     rubygems.org/AddTrustExternalCARoot.pem \
476     index.rubygems.org/GlobalSignRootCA.pem
477     do
478     rm %{buildroot}%{rubygems_dir}/rubygems/ssl_certs/$cert
479     rm -r $(dirname %{buildroot}%{rubygems_dir}/rubygems/ssl_certs/$cert)
480     done
481    
482     # Ensure there is not forgotten any certificate.
483     test ! "$(ls -A %{buildroot}%{rubygems_dir}/rubygems/ssl_certs/ 2>/dev/null)"
484    
485     # Install emacs config
486 blino 1152 install -d %buildroot%{_datadir}/emacs/site-lisp
487     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
488    
489     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
490     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
491     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
492     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
493     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
494     EOF
495    
496 shlomif 893775 # Install the rpm macros
497 blino 1152 mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
498     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
499 fwang 289961
500 tv 673709 # Install dependency generators.
501     mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs
502     install -m 644 %{SOURCE8} %{buildroot}%{_rpmconfigdir}/fileattrs
503     install -m 755 %{SOURCE9} %{buildroot}%{_rpmconfigdir}
504     install -m 755 %{SOURCE10} %{buildroot}%{_rpmconfigdir}
505    
506 pterjan 435211 # Install custom operating_system.rb
507     mkdir -p %{buildroot}%{rubygems_dir}/rubygems/defaults
508     cp %{SOURCE1} %{buildroot}%{rubygems_dir}/rubygems/defaults
509    
510 pterjan 1140265 # Move gems root into common direcotry, out of Ruby directory structure.
511     mv %{buildroot}%{ruby_libdir}/gems %{buildroot}%{gem_dir}
512    
513     # Create folders for gem binary extensions.
514     mkdir -p %{buildroot}%{_exec_prefix}/lib{,64}/gems/%{name}
515    
516 pterjan 617250 # Version is empty if --with-ruby-version is specified.
517     # http://bugs.ruby-lang.org/issues/7807
518     sed -i 's/Version: .*/Version: %{rubyver}/' %{buildroot}%{_libdir}/pkgconfig/%{name}.pc
519    
520 pterjan 1140265 # Move the binary extensions into proper place (if no gem has binary extension,
521     # the extensions directory might be empty).
522     find %{buildroot}%{gem_dir}/extensions/*-%{_target_os}/%{ruby_version}/* -maxdepth 0 \
523     -exec mv '{}' %{buildroot}%{_libdir}/gems/%{name}/ \; \
524     || echo "No gem binary extensions to move."
525 pterjan 894459
526 pterjan 1140265 # Adjust the gemspec files so that the gems will load properly
527     sed -i '/^end$/ i\
528     s.extensions = ["json/ext/parser.so", "json/ext/generator.so"]' %{buildroot}%{gem_dir}/specifications/default/json-%{json_version}.gemspec
529 fwang 293412
530 pterjan 1140265 # Move man pages into proper location
531     mv %{buildroot}%{gem_dir}/gems/rake-%{rake_version}/doc/rake.1 %{buildroot}%{_mandir}/man1
532    
533 blino 1152 %check
534 pterjan 1140265 DISABLE_TESTS=""
535 blino 1152
536 pterjan 1140265 #make check TESTS="-v $DISABLE_TESTS"
537 pterjan 1060110
538 fwang 289961 %files
539 fwang 291551 %{_bindir}/erb
540     %{_bindir}/ruby
541 fwang 291560 %dir %{ruby_libdir}
542     %{ruby_libdir}/*.rb
543 fwang 291590 %exclude %{ruby_libdir}/irb.rb
544 pterjan 1140277 %exclude %{ruby_libdir}/json.rb
545 pterjan 1140265 %exclude %{ruby_libdir}/openssl.rb
546 fwang 291560 %{ruby_libdir}/cgi
547     %{ruby_libdir}/digest
548     %{ruby_libdir}/drb
549     %{ruby_libdir}/fiddle
550 pterjan 1140265 %{ruby_libdir}/forwardable
551 fwang 291560 %{ruby_libdir}/matrix
552     %{ruby_libdir}/net
553     %{ruby_libdir}/optparse
554 pterjan 435566 %{ruby_libdir}/psych
555 fwang 291560 %{ruby_libdir}/racc
556     %{ruby_libdir}/rbconfig
557     %{ruby_libdir}/rexml
558     %{ruby_libdir}/rinda
559     %{ruby_libdir}/ripper
560     %{ruby_libdir}/rss
561     %{ruby_libdir}/shell
562 pterjan 435211 %{ruby_libdir}/syslog
563 shlomif 893775 %{ruby_libdir}/unicode_normalize/normalize.rb
564     %{ruby_libdir}/unicode_normalize/tables.rb
565 fwang 291560 %{ruby_libdir}/uri
566     %{ruby_libdir}/webrick
567     %{ruby_libdir}/yaml
568     %dir %{ruby_libarchdir}
569 pterjan 1140265 %{ruby_libarchdir}/cgi/escape.so
570 fwang 291560 %{ruby_libarchdir}/continuation.so
571     %{ruby_libarchdir}/coverage.so
572     %{ruby_libarchdir}/date_core.so
573     %{ruby_libarchdir}/dbm.so
574     %dir %{ruby_libarchdir}/digest
575     %{ruby_libarchdir}/digest.so
576     %{ruby_libarchdir}/digest/*.so
577     %dir %{ruby_libarchdir}/enc
578     %{ruby_libarchdir}/enc/*.so
579 fwang 291562 %dir %{ruby_libarchdir}/enc/trans
580     %{ruby_libarchdir}/enc/trans/*.so
581 fwang 291560 %{ruby_libarchdir}/etc.so
582     %{ruby_libarchdir}/fcntl.so
583     %{ruby_libarchdir}/fiber.so
584     %{ruby_libarchdir}/fiddle.so
585     %{ruby_libarchdir}/gdbm.so
586     %dir %{ruby_libarchdir}/io
587     %{ruby_libarchdir}/io/nonblock.so
588     %{ruby_libarchdir}/io/wait.so
589     %dir %{ruby_libarchdir}/mathn
590 fwang 291562 %{ruby_libarchdir}/mathn/*.so
591 fwang 291560 %{ruby_libarchdir}/nkf.so
592     %{ruby_libarchdir}/objspace.so
593 pterjan 435566 %{ruby_libarchdir}/psych.so
594 fwang 291560 %{ruby_libarchdir}/pathname.so
595     %{ruby_libarchdir}/pty.so
596     %dir %{ruby_libarchdir}/racc
597     %{ruby_libarchdir}/racc/*.so
598     %{ruby_libarchdir}/rbconfig.rb
599 shlomif 893775 %{ruby_libarchdir}/rbconfig/sizeof.so
600 fwang 291560 %{ruby_libarchdir}/readline.so
601     %{ruby_libarchdir}/ripper.so
602     %{ruby_libarchdir}/sdbm.so
603     %{ruby_libarchdir}/socket.so
604     %{ruby_libarchdir}/stringio.so
605     %{ruby_libarchdir}/strscan.so
606     %{ruby_libarchdir}/syslog.so
607     %{ruby_libarchdir}/zlib.so
608 fwang 291551 %{_mandir}/man1/erb.1.*
609     %{_mandir}/man1/ruby.1.*
610 blino 1152 %{_datadir}/emacs/site-lisp/*
611     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
612     %{_sysconfdir}/rpm/macros.d/%{name}.macros
613 pterjan 1140265 #%{_datadir}/ruby/site_ruby
614     #%{_libdir}/ruby/site_ruby
615 fwang 291560 %{_datadir}/ruby/vendor_ruby
616     %{_libdir}/ruby/vendor_ruby
617 tv 674762 %{_rpmconfigdir}/fileattrs/rubygems.attr
618     %{_rpmconfigdir}/rubygems.req
619     %{_rpmconfigdir}/rubygems.prov
620 pterjan 1140265 %dir %{gem_dir}
621     %dir %{gem_dir}/build_info
622     %dir %{gem_dir}/cache
623     %dir %{gem_dir}/doc
624     %dir %{gem_dir}/extensions
625     %dir %{gem_dir}/gems
626     %dir %{gem_dir}/specifications
627     %dir %{gem_dir}/specifications/default
628     %exclude %{gem_dir}/cache/*
629 blino 1152
630     %files doc
631     %{_datadir}/ri
632 pterjan 435211 %{_datadir}/doc/ruby
633 blino 1152
634 fwang 291590 %files -n %{libname}
635     %{_libdir}/libruby.so.%{subver}
636     %{_libdir}/libruby.so.%{rubyapi}
637    
638 blino 1152 %files devel
639 fwang 290003 %{_includedir}/*
640 blino 1152 %{_libdir}/libruby.so
641 fwang 290003 %{_libdir}/pkgconfig/*.pc
642 blino 1152
643 fwang 293412 %files irb
644     %{_bindir}/irb
645     %{ruby_libdir}/irb.rb
646     %{ruby_libdir}/irb
647     %{_mandir}/man1/irb.1*
648    
649 pterjan 897269 %files power_assert
650 pterjan 1140037 %{gem_dir}/gems/power_assert-%{power_assert_version}
651     %{gem_dir}/specifications/power_assert-%{power_assert_version}.gemspec
652 pterjan 897269
653 pterjan 912571 %files io-console
654     %{ruby_libdir}/io
655     %{ruby_libarchdir}/io/console.so
656 pterjan 1140037 %{gem_dir}/specifications/default/io-console-%{io_console_version}.gemspec
657 pterjan 912571
658 pterjan 897269 %files test-unit
659 pterjan 1140037 %{gem_dir}/gems/test-unit-*
660     %{gem_dir}/specifications/test-unit-%{test_unit_version}.gemspec
661 pterjan 897269
662 fwang 291551 %files RubyGems
663     %{_bindir}/gem
664     %dir %{rubygems_dir}
665     %{rubygems_dir}/rbconfig
666     %{rubygems_dir}/rubygems
667     %{rubygems_dir}/rubygems.rb
668     %{rubygems_dir}/ubygems.rb
669    
670 fwang 291562 %files minitest
671 pterjan 1140037 %{gem_dir}/gems/minitest-%{minitest_version}
672     %{gem_dir}/specifications/minitest-%{minitest_version}.gemspec
673 fwang 291562
674 fwang 291551 %files rake
675     %{_bindir}/rake
676     %{_mandir}/man1/rake.1.*
677 pterjan 1140037 %{gem_dir}/gems/rake-%{rake_version}
678 pterjan 1140265 %{gem_dir}/specifications/rake-%{rake_version}.gemspec
679 fwang 291562
680     %files rdoc
681     %{_bindir}/rdoc
682     %{_bindir}/ri
683 pterjan 1140265 %{_mandir}/man1/ri.1.*
684 fwang 291562 %{ruby_libdir}/rdoc
685 pterjan 1140037 %{gem_dir}/gems/rdoc-%{rdoc_version}
686     %{gem_dir}/specifications/default/rdoc-%{rdoc_version}.gemspec
687 fwang 291562
688     %files json
689 pterjan 1140265 %{ruby_libarchdir}/json
690 fwang 291562 %{ruby_libdir}/json
691 pterjan 1140278 %{ruby_libdir}/json.rb
692 pterjan 1140037 %{gem_dir}/specifications/default/json-%{json_version}.gemspec
693 fwang 291590
694     %files bigdecimal
695     %{ruby_libdir}/bigdecimal
696     %{ruby_libarchdir}/bigdecimal.so
697 pterjan 1140037 %{gem_dir}/specifications/default/bigdecimal-%{bigdecimal_version}.gemspec
698 fwang 291590
699 pterjan 1140265 %files openssl
700     %{ruby_libdir}/openssl
701     %{ruby_libarchdir}/openssl.so
702     %{gem_dir}/specifications/default/openssl-%{openssl_version}.gemspec
703    
704 pterjan 435211 %files psych
705     %{ruby_libdir}/psych
706 pterjan 912333 %{ruby_libdir}/psych.rb
707 pterjan 435211 %{ruby_libarchdir}/psych.so
708 pterjan 1140037 %{gem_dir}/specifications/default/psych-%{psych_version}.gemspec
709 pterjan 1140265
710     %files did_you_mean
711     %{gem_dir}/gems/did_you_mean-%{did_you_mean_version}
712     %exclude %{gem_dir}/gems/did_you_mean-%{did_you_mean_version}/.*
713     %{gem_dir}/specifications/did_you_mean-%{did_you_mean_version}.gemspec
714    
715     %files net-telnet
716     %{gem_dir}/gems/net-telnet-%{net_telnet_version}
717     %exclude %{gem_dir}/gems/net-telnet-%{net_telnet_version}/.*
718     %{gem_dir}/specifications/net-telnet-%{net_telnet_version}.gemspec
719    
720     %files xmlrpc
721     %{gem_dir}/gems/xmlrpc-%{xmlrpc_version}
722     %{gem_dir}/specifications/xmlrpc-%{xmlrpc_version}.gemspec

  ViewVC Help
Powered by ViewVC 1.1.30