/[packages]/cauldron/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /cauldron/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 188702 - (hide annotations) (download)
Thu Dec 29 14:46:07 2011 UTC (12 years, 3 months ago) by fwang
File size: 6708 byte(s)
new version 1.8.7 p367
1 blino 1152 %define subver 1.8
2     %define rubyver 1.8.7
3 fwang 188702 %define patchversion p357
4     %define rel 1
5 blino 1152
6     Summary: Object Oriented Script Language
7     Name: ruby
8     Version: %{rubyver}.%{patchversion}
9     Release: %mkrel %rel
10     License: Ruby or GPLv2
11     Group: Development/Ruby
12     BuildRequires: autoconf
13     BuildRequires: byacc
14     BuildRequires: ncurses-devel
15     BuildRequires: readline-devel
16     BuildRequires: tcl-devel tk-devel
17     BuildRequires: db4-devel
18 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
19 blino 1152 BuildRequires: openssl-devel
20     BuildRequires: zlib-devel
21     Obsoletes: ruby-rexml
22     Provides: ruby-rexml
23     # explicit file provides (since such requires are automatically added by find-requires)
24     Provides: /usr/bin/ruby
25     Provides: ruby(abi) = %subver
26    
27     Source0: ftp://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
28     Source1: http://www.rubycentral.com/faq/rubyfaqall.html.bz2
29     Source2: http://dev.rubycentral.com/downloads/files/ProgrammingRuby-0.4.tar.bz2
30     Source3: ruby.macros
31     Patch0: ruby-lib64.patch
32     Patch1: ruby-do-not-use-system-ruby-to-generate-ri-doc.patch
33     Patch2: ruby-add-old-os-to-search-path.patch
34     Patch3: ruby-do_not_propagate_no-undefined.patch
35     URL: http://www.ruby-lang.org/
36     Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
37    
38     %define my_target_cpu %{_target_cpu}
39     %ifarch ppc
40     %define my_target_cpu powerpc
41     %endif
42     %ifarch ppc64
43     %define my_target_cpu powerpc64
44     %endif
45     %ifarch amd64
46     %define my_target_cpu x86_64
47     %endif
48    
49 rtp 25806 # we're building for eabi
50     %ifarch %arm
51     %define abi -eabi
52     %else
53     %define abi %{nil}
54     %endif
55    
56 blino 1152 %package doc
57     Summary: Documentation for the powerful language Ruby
58     Group: Development/Ruby
59    
60     %package devel
61     Summary: Development file for the powerful language Ruby
62     Group: Development/Ruby
63     Requires: %{name} = %{version}
64    
65     %package tk
66     Summary: Tk extension for the powerful language Ruby
67     Group: Development/Ruby
68     Requires: %{name} = %{version}
69    
70     %description
71     Ruby is the interpreted scripting language for quick and
72     easy object-oriented programming. It has many features to
73     process text files and to do system management tasks (as in
74     Perl). It is simple, straight-forward, and extensible.
75    
76     %description doc
77     Ruby is the interpreted scripting language for quick and
78     easy object-oriented programming. It has many features to
79     process text files and to do system management tasks (as in
80     Perl). It is simple, straight-forward, and extensible.
81    
82     This package contains the Ruby's documentation
83    
84     %description devel
85     Ruby is the interpreted scripting language for quick and
86     easy object-oriented programming. It has many features to
87     process text files and to do system management tasks (as in
88     Perl). It is simple, straight-forward, and extensible.
89    
90     This package contains the Ruby's devel files.
91    
92     %description tk
93     Ruby is the interpreted scripting language for quick and
94     easy object-oriented programming. It has many features to
95     process text files and to do system management tasks (as in
96     Perl). It is simple, straight-forward, and extensible.
97    
98     This package contains the Tk extension for Ruby.
99    
100     %prep
101     %setup -q -n ruby-%{rubyver}-%{patchversion}
102     %patch0 -p0 -b .lib64
103     %patch1 -p0 -b .ri
104     %patch2 -p2 -b .old
105     %patch3 -p2 -b .undefined
106    
107 fwang 176965 # Once fix FTBTS issue (redhat bug 716021). Remove the below
108     # when it is no longer needed.
109     sed -i.redirect -e '\@RUBY@s@\.rb >@\.rb | cat >@' ext/dl/depend
110    
111 blino 1152 autoreconf
112    
113     %build
114     echo '.text' | gcc -shared -o libdummy.so.0 -xassembler - -ltcl -ltk >& /dev/null && {
115     if %{_bindir}/ldd libdummy.so.0 | grep -q "lib\(tcl\|tk\).so"; then
116     echo "Your tcl/tk is broken, get one with versioning in the libraries."
117     exit 1
118     fi
119     rm -f libdummy.so.0
120     }
121    
122     CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
123     %configure2_5x --enable-shared --disable-rpath --enable-pthread \
124     --with-sitedir=%_prefix/lib/ruby/site_ruby \
125     --with-vendordir=%_prefix/lib/ruby/vendor_ruby \
126     --with-old-os=linux-gnu
127    
128     %make
129    
130    
131     %install
132     rm -rf %buildroot
133     %makeinstall_std install-doc
134    
135     install -d %buildroot%{_docdir}/%{name}-%{version}
136     cp -a COPYING* ChangeLog README* ToDo sample %buildroot%{_docdir}/%{name}-%{version}
137     bzcat %{SOURCE1} > %buildroot%{_docdir}/%{name}-%{version}/FAQ.html
138    
139     install -d %buildroot%{_datadir}/emacs/site-lisp
140     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
141    
142     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
143     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
144     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
145     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
146     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
147     EOF
148    
149     (cd %buildroot%{_docdir}/%{name}-%{version} ; tar xfj %{SOURCE2} ; cd Pro*; mv -f html/* . ; rm -rf html xml)
150    
151     # Make the file/dirs list, filtering out tcl/tk and devel files
152     ( cd %buildroot \
153     && find usr/lib/ruby/%{subver} \
154     \( -not -type d -printf "/%%p\n" \) \
155     -or \( -type d -printf "%%%%dir /%%p\n" \) \
156 rtp 25806 ) | egrep -v '/(tcl)?tk|(%{my_target_cpu}-%{_target_os}%{abi}/.*[ha]$)' > %{name}.list
157 blino 1152
158     # Fix scripts permissions and location
159     find %buildroot sample -type f | file -i -f - | grep text | cut -d: -f1 >text.list
160     cat text.list | xargs chmod 0644
161     # Magic grepping to get only files with '#!' in the first line
162     cat text.list | xargs grep -n '^#!' | grep ':1:#!' | cut -d: -f1 >shebang.list
163     cat shebang.list | xargs sed -i -e 's|/usr/local/bin|/usr/bin|; s|\./ruby|/usr/bin/ruby|'
164     cat shebang.list | xargs chmod 0755
165    
166    
167     # Install the rpm macros
168     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
169     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
170     %check
171     make test
172    
173     %clean
174     rm -rf %buildroot
175    
176     %files -f %{name}.list
177     %defattr(-, root, root)
178     %dir %{_docdir}/%{name}-%{version}
179     %{_docdir}/%{name}-%{version}/README
180     %{_bindir}/*
181     %dir %{_prefix}/lib/%{name}/
182     %{_libdir}/libruby.so.*
183     %{_prefix}/lib/%{name}/site_ruby
184     %{_mandir}/*/*
185     %{_datadir}/emacs/site-lisp/*
186     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
187     %{_sysconfdir}/rpm/macros.d/%{name}.macros
188    
189     %files doc
190     %defattr(-, root, root)
191     %{_datadir}/ri
192     %dir %{_docdir}/%{name}-%{version}
193     %{_docdir}/%{name}-%{version}/COPYING*
194     %{_docdir}/%{name}-%{version}/ChangeLog
195     %{_docdir}/%{name}-%{version}/README.*
196     %{_docdir}/%{name}-%{version}/FAQ.html
197     %{_docdir}/%{name}-%{version}/ToDo
198     %{_docdir}/%{name}-%{version}/sample
199     %{_docdir}/%{name}-%{version}/ProgrammingRuby*
200    
201     %files devel
202     %defattr(-, root, root)
203 rtp 25806 %{_prefix}/lib/%{name}/%{subver}/%{my_target_cpu}-%{_target_os}%{abi}/*.[ah]
204 blino 1152 %{_libdir}/libruby-static.a
205     %{_libdir}/libruby.so
206    
207     %files tk
208     %defattr(-, root, root)
209 rtp 25806 %{_prefix}/lib/%{name}/%{subver}/%{my_target_cpu}-%{_target_os}%{abi}/tcltk*
210     %{_prefix}/lib/%{name}/%{subver}/%{my_target_cpu}-%{_target_os}%{abi}/tk*
211 blino 1152 %{_prefix}/lib/%{name}/%{subver}/tcltk*
212     %{_prefix}/lib/%{name}/%{subver}/tk*
213     %{_prefix}/lib/%{name}/%{subver}/test/unit/ui/tk
214    
215    
216    

  ViewVC Help
Powered by ViewVC 1.1.30