/[packages]/cauldron/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /cauldron/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 289987 - (hide annotations) (download)
Sat Sep 8 09:10:00 2012 UTC (11 years, 6 months ago) by fwang
File size: 3654 byte(s)
add more br
1 fwang 289958 %define subver 1.9
2     %define rubyver 1.9.3
3     %define patchversion p194
4     %define rel 1
5 blino 1152
6     Summary: Object Oriented Script Language
7     Name: ruby
8     Version: %{rubyver}.%{patchversion}
9     Release: %mkrel %rel
10     License: Ruby or GPLv2
11     Group: Development/Ruby
12     BuildRequires: autoconf
13     BuildRequires: byacc
14     BuildRequires: ncurses-devel
15     BuildRequires: readline-devel
16     BuildRequires: tcl-devel tk-devel
17 fwang 276350 BuildRequires: db-devel
18 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
19 blino 1152 BuildRequires: openssl-devel
20     BuildRequires: zlib-devel
21 fwang 289987 BuildRequires: libffi-devel
22     BuildRequires: yaml-devel
23 blino 1152 Obsoletes: ruby-rexml
24     Provides: ruby-rexml
25     # explicit file provides (since such requires are automatically added by find-requires)
26     Provides: /usr/bin/ruby
27     Provides: ruby(abi) = %subver
28    
29 fwang 289958 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
30 blino 1152 Source3: ruby.macros
31     Patch0: ruby-lib64.patch
32     Patch1: ruby-do-not-use-system-ruby-to-generate-ri-doc.patch
33     Patch2: ruby-add-old-os-to-search-path.patch
34     Patch3: ruby-do_not_propagate_no-undefined.patch
35     URL: http://www.ruby-lang.org/
36    
37     %package doc
38     Summary: Documentation for the powerful language Ruby
39     Group: Development/Ruby
40 fwang 202696 BuildArch: noarch
41 blino 1152
42     %package devel
43     Summary: Development file for the powerful language Ruby
44     Group: Development/Ruby
45     Requires: %{name} = %{version}
46    
47     %package tk
48     Summary: Tk extension for the powerful language Ruby
49     Group: Development/Ruby
50     Requires: %{name} = %{version}
51    
52     %description
53     Ruby is the interpreted scripting language for quick and
54     easy object-oriented programming. It has many features to
55     process text files and to do system management tasks (as in
56     Perl). It is simple, straight-forward, and extensible.
57    
58     %description doc
59     Ruby is the interpreted scripting language for quick and
60     easy object-oriented programming. It has many features to
61     process text files and to do system management tasks (as in
62     Perl). It is simple, straight-forward, and extensible.
63    
64     This package contains the Ruby's documentation
65    
66     %description devel
67     Ruby is the interpreted scripting language for quick and
68     easy object-oriented programming. It has many features to
69     process text files and to do system management tasks (as in
70     Perl). It is simple, straight-forward, and extensible.
71    
72     This package contains the Ruby's devel files.
73    
74     %description tk
75     Ruby is the interpreted scripting language for quick and
76     easy object-oriented programming. It has many features to
77     process text files and to do system management tasks (as in
78     Perl). It is simple, straight-forward, and extensible.
79    
80     This package contains the Tk extension for Ruby.
81    
82     %prep
83     %setup -q -n ruby-%{rubyver}-%{patchversion}
84    
85     %build
86     CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
87 fwang 289958 %configure2_5x --enable-shared --disable-rpath --enable-pthread
88 blino 1152 %make
89    
90     %install
91     %makeinstall_std install-doc
92    
93     install -d %buildroot%{_datadir}/emacs/site-lisp
94     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
95    
96     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
97     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
98     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
99     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
100     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
101     EOF
102    
103     # Install the rpm macros
104     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
105     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
106 fwang 289961
107 blino 1152 %check
108     make test
109    
110 fwang 289961 %files
111 blino 1152 %{_bindir}/*
112     %{_libdir}/libruby.so.*
113 fwang 289970 %{_libdir}/ruby
114 blino 1152 %{_mandir}/*/*
115     %{_datadir}/emacs/site-lisp/*
116     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
117     %{_sysconfdir}/rpm/macros.d/%{name}.macros
118    
119     %files doc
120     %{_datadir}/ri
121    
122     %files devel
123     %{_libdir}/libruby-static.a
124     %{_libdir}/libruby.so
125    
126     %files tk

  ViewVC Help
Powered by ViewVC 1.1.30