/[packages]/cauldron/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /cauldron/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 290244 - (hide annotations) (download)
Sat Sep 8 14:27:43 2012 UTC (11 years, 7 months ago) by fwang
File size: 5745 byte(s)
update file list
1 fwang 289958 %define subver 1.9
2 fwang 290007 %define rubyapi 1.9.1
3 fwang 289958 %define rubyver 1.9.3
4     %define patchversion p194
5     %define rel 1
6 blino 1152
7 fwang 290007 # This is the local lib/arch and should not be used for packaging.
8     %define ruby_sitelibdir %{_datadir}/ruby/site_ruby/%{rubyapi}
9     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby/%{rubyapi}
10    
11     # This is the general location for libs/archs compatible with all
12     # or most of the Ruby versions available in the Fedora repositories.
13     %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby/%{rubyapi}
14     %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby/%{rubyapi}
15    
16     # The RubyGems library has to stay out of Ruby directory three, since the
17     # RubyGems should be share by all Ruby implementations.
18     %define rubygems_dir %{_datadir}/ruby/gems/%{rubyapi}
19    
20 blino 1152 Summary: Object Oriented Script Language
21     Name: ruby
22     Version: %{rubyver}.%{patchversion}
23     Release: %mkrel %rel
24     License: Ruby or GPLv2
25     Group: Development/Ruby
26     BuildRequires: autoconf
27     BuildRequires: byacc
28     BuildRequires: ncurses-devel
29     BuildRequires: readline-devel
30     BuildRequires: tcl-devel tk-devel
31 fwang 276350 BuildRequires: db-devel
32 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
33 blino 1152 BuildRequires: openssl-devel
34     BuildRequires: zlib-devel
35 fwang 289987 BuildRequires: libffi-devel
36     BuildRequires: yaml-devel
37 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
38 blino 1152 Obsoletes: ruby-rexml
39     Provides: ruby-rexml
40     # explicit file provides (since such requires are automatically added by find-requires)
41     Provides: /usr/bin/ruby
42     Provides: ruby(abi) = %subver
43    
44 fwang 289958 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
45 blino 1152 Source3: ruby.macros
46     URL: http://www.ruby-lang.org/
47    
48 fwang 290007 # == FEDORA PATCHES BEGINS ==
49     # http://redmine.ruby-lang.org/issues/5231
50     Patch0: ruby-1.9.3-disable-versioned-paths.patch
51     # TODO: Should be submitted upstream?
52     Patch1: ruby-1.9.3-arch-specific-dir.patch
53     # http://redmine.ruby-lang.org/issues/5281
54     Patch2: ruby-1.9.3-added-site-and-vendor-arch-flags.patch
55     # http://redmine.ruby-lang.org/issues/5465
56     Patch4: ruby-1.9.3-fix-s390x-build.patch
57     # Fix the uninstaller, so that it doesn't say that gem doesn't exist
58     # when it exists outside of the GEM_HOME (already fixed in the upstream)
59     Patch5: ruby-1.9.3-rubygems-1.8.11-uninstaller.patch
60     # http://redmine.ruby-lang.org/issues/5135 - see comment 29
61     Patch6: ruby-1.9.3-webrick-test-fix.patch
62     # Already fixed upstream:
63     # https://github.com/ruby/ruby/commit/f212df564a4e1025f9fb019ce727022a97bfff53
64     Patch7: ruby-1.9.3-bignum-test-fix.patch
65     # Allows to install RubyGems into custom directory, outside of Ruby's tree.
66     # http://redmine.ruby-lang.org/issues/5617
67     Patch8: ruby-1.9.3-custom-rubygems-location.patch
68     # Add support for installing binary extensions according to FHS.
69     # https://github.com/rubygems/rubygems/issues/210
70     Patch9: rubygems-1.8.11-binary-extensions.patch
71     # Make mkmf verbose by default
72     Patch12: ruby-1.9.3-mkmf-verbose.patch
73     # == FEDORA PATCHES ENDS ==
74    
75 blino 1152 %package doc
76     Summary: Documentation for the powerful language Ruby
77     Group: Development/Ruby
78 fwang 202696 BuildArch: noarch
79 blino 1152
80     %package devel
81     Summary: Development file for the powerful language Ruby
82     Group: Development/Ruby
83     Requires: %{name} = %{version}
84    
85     %package tk
86     Summary: Tk extension for the powerful language Ruby
87     Group: Development/Ruby
88     Requires: %{name} = %{version}
89    
90     %description
91     Ruby is the interpreted scripting language for quick and
92     easy object-oriented programming. It has many features to
93     process text files and to do system management tasks (as in
94     Perl). It is simple, straight-forward, and extensible.
95    
96     %description doc
97     Ruby is the interpreted scripting language for quick and
98     easy object-oriented programming. It has many features to
99     process text files and to do system management tasks (as in
100     Perl). It is simple, straight-forward, and extensible.
101    
102     This package contains the Ruby's documentation
103    
104     %description devel
105     Ruby is the interpreted scripting language for quick and
106     easy object-oriented programming. It has many features to
107     process text files and to do system management tasks (as in
108     Perl). It is simple, straight-forward, and extensible.
109    
110     This package contains the Ruby's devel files.
111    
112     %description tk
113     Ruby is the interpreted scripting language for quick and
114     easy object-oriented programming. It has many features to
115     process text files and to do system management tasks (as in
116     Perl). It is simple, straight-forward, and extensible.
117    
118     This package contains the Tk extension for Ruby.
119    
120     %prep
121     %setup -q -n ruby-%{rubyver}-%{patchversion}
122 fwang 290007 %apply_patches
123 blino 1152
124     %build
125 fwang 290038 autoconf
126 blino 1152 CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
127 fwang 290007 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
128     --with-sitedir='%{ruby_sitelibdir}' \
129     --with-sitearchdir='%{ruby_sitearchdir}' \
130     --with-vendordir='%{ruby_vendorlibdir}' \
131     --with-vendorarchdir='%{ruby_vendorarchdir}' \
132 fwang 290022 --with-rubygemsdir='%{rubygems_dir}'
133 blino 1152 %make
134    
135     %install
136     %makeinstall_std install-doc
137    
138     install -d %buildroot%{_datadir}/emacs/site-lisp
139     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
140    
141     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
142     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
143     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
144     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
145     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
146     EOF
147    
148     # Install the rpm macros
149     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
150     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
151 fwang 289961
152 blino 1152 %check
153     make test
154    
155 fwang 289961 %files
156 blino 1152 %{_bindir}/*
157     %{_libdir}/libruby.so.*
158 fwang 289970 %{_libdir}/ruby
159 fwang 290244 %{_datadir}/ruby
160 blino 1152 %{_mandir}/*/*
161     %{_datadir}/emacs/site-lisp/*
162     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
163     %{_sysconfdir}/rpm/macros.d/%{name}.macros
164    
165     %files doc
166     %{_datadir}/ri
167    
168     %files devel
169 fwang 290003 %{_includedir}/*
170 blino 1152 %{_libdir}/libruby-static.a
171     %{_libdir}/libruby.so
172 fwang 290003 %{_libdir}/pkgconfig/*.pc
173 blino 1152
174     %files tk

  ViewVC Help
Powered by ViewVC 1.1.30